Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Speakers muten niet wanneer ik koptelefoon inplug  (gelezen 3259 keer)

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Speakers muten niet wanneer ik koptelefoon inplug
« Gepost op: 2009/11/09, 12:47:39 »
Sinds ik karmic 64 bits draai worden de speakers niet meer automatisch ge-mute wanneer ik een koptelefoon plug in het front panel van mn desktop.

Ik heb er een bugmelding over gemaakt, maar er lijkt niet veel mee te gebeuren. Kan iemand me helpen? Wat zou ik allemaal kunnen doen om te zoeken naar de oorzaak? De

Ik ben niet vies van wat uitzoekwerk, maar loop nu een beetje vast...
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #1 Gepost op: 2009/11/10, 11:55:07 »
Je kan steeds eens de alsa driver van source proberen te compileren. Deze staat toch al een versienummer verder dan die van jouw.
http://www.alsa-project.org/main/index.php/Main_Page

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #2 Gepost op: 2009/11/10, 12:53:09 »
oke, dat zal ik binnenkort eens proberen
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline djdg

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #3 Gepost op: 2010/11/27, 20:17:51 »
Ik zit met hetzelfde probleem. Is de oplossing algemeen geldend voor ieder Kubuntu systeem of ligt het eraan welke hardware je hebt? (Dan weet ik in ieder geval dat ik een apart topic zou moeten openen)

https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/661327
http://www.uluga.ubuntuforums.org/showthread.php?p=9948670
http://ubuntuforums.org/showthread.php?t=1586678
« Laatst bewerkt op: 2010/11/27, 20:57:03 door w8jij17 »

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #4 Gepost op: 2010/11/28, 12:27:29 »
Hallo

@w8jij17

Toevallig net een laptopje aan het optuigen en had hetzelfde probleem,
ik heb dat hier op kunnen lossen door in de terminal de alsamixer te starten
daar de headphone van MM op 00 te zetten (gebruik de m toets en de cursortoetsen)
Aangezien de zogenaamde headphone jack sense niet in de gewone mixer opduikt, maar
wel in de alsamixer.
Ik heb standaard wel de linux-backports-modules-alsa-lucid-generic erop staan, misschien
loont het om die ook te installeren en na een reboot eens te kijken of dat werkt.
(welke versie van kubuntu draai je, kubuntu is niet de reden voor het niet muten overigens)

Als dit niet werkt, doe dan in de terminal een; aplay -l (l= kleine letter L) en post dat
hier, wellicht moet er in je /etc/modprobe.d/alsa-base.conf nog een optie worden veranderd
of toegevoegd.

Groeten Gerrit
« Laatst bewerkt op: 2010/12/01, 23:08:28 door mrGee »
-- = >  simplify if you can   -- = >

Offline djdg

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #5 Gepost op: 2010/11/28, 17:33:21 »
Bedankt mrGee!

Ik ben een stapje verder, maar ben er nog niet. De enige balk die grijs is, en waar op het eerste gezicht niets aan te wijzigen valt, is uitgerekend die van de headphone.

**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: Intel [HDA Intel], apparaat 0: VT1708S Analog [VT1708S Analog]
  Sub-apparaten: 1/2
  Sub-apparaat #0: subdevice #0
  Sub-apparaat #1: subdevice #1


Ik draai 10.10

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #6 Gepost op: 2010/11/28, 23:04:29 »
Hallo

En ook inderdaad die backports geïnstalleerd?

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline djdg

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #7 Gepost op: 2010/11/29, 22:50:18 »
Hoe doe ik dat?  ???

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #8 Gepost op: 2010/11/30, 17:06:43 »
Hallo

Pakketbeheer (synaptic) opstarten via; Systeem-Beheer
en daar als zoekopdracht backports ingeven.
Selecteer; linux-backports-modules-alsa-lucid-generic
(dus niet de verschillende kernelversies nemen)
en laat hem dat installeren, daarna de machine herstarten
en nogmaals met alsamixer wat proberen.

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #9 Gepost op: 2010/11/30, 18:50:44 »
Werkt het hierna nog niet, dan kan je het beste een bugrapport aanmaken, zodat de ontwikkelaars er iets aan kunnen doen. Doe je dat niet, dan weten de ontwikkelaars ook niet dat er een probleem is met jouw hardware en gebeurt er dus niets.

Het makkelijkste is om een terminal te openen en het volgende commando uit te voeren:
ubuntu-bug alsa-base

Meer info hier:
http://drowninginbugs.blogspot.com/2010/11/fix-bug-already-aka-long-overdue.html

Offline djdg

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #10 Gepost op: 2010/11/30, 19:33:47 »
Hallo

Pakketbeheer (synaptic) opstarten via; Systeem-Beheer
en daar als zoekopdracht backports ingeven.
Selecteer; linux-backports-modules-alsa-lucid-generic
(dus niet de verschillende kernelversies nemen)
en laat hem dat installeren, daarna de machine herstarten
en nogmaals met alsamixer wat proberen.

Groeten Gerrit

linux-backports-modules-alsa-lucid-generic staat niet in de lijst. Ik heb Kubuntu, dus de optie die er wel stond voor maverick heb ik genomen.

Ik heb een moment de headphone balk tot leven weten te wekken, maar hiermee was het probleem niet opgelost. De balk is nu weer grijs.

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #11 Gepost op: 2010/12/01, 23:20:44 »
Hallo

Aha een maverick. ik was even van een lucid uit gegaan, jammer dat dit dus
niet de oplossing is. Vervelend genoeg levert die 1708 chipset geen toe te
passen opties die je in alsa-base.conf kunt zetten (of ik kijk er overheen)

Wat voor laptop is dit eigenlijk merk/type
Misschien dat je dat en jack sense eens moet proberen als zoekopdracht
bij www.google.com/linux

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline Willemtk

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #12 Gepost op: 2010/12/01, 23:33:04 »
Hallo

Aha een maverick. ik was even van een lucid uit gegaan, jammer dat dit dus
niet de oplossing is. Vervelend genoeg levert die 1708 chipset geen toe te
passen opties die je in alsa-base.conf kunt zetten (of ik kijk er overheen)

Wat voor laptop is dit eigenlijk merk/type
Misschien dat je dat en jack sense eens moet proberen als zoekopdracht
bij www.google.com/linux

Groeten Gerrit

Van Maverick heb je die ook. Weet alleen niet of het gaat helpen bij mij, want ik heb een soortgelijk probleem. Als ik mijn koptelefoon in steek dempt hij het geluid. Ben benieuwd of het gaat helpen. Ben ze nu aan het installeren. In de vorige versie. 10.04heb ik geen last gehad. Dus ligt niet aan de laptop

Offline Willemtk

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #13 Gepost op: 2010/12/01, 23:53:47 »
Helaas pindakaas, hielp niks. Nog suggesties?

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #14 Gepost op: 2010/12/02, 10:25:24 »
Hallo

@Willemtk, ik denk dat er evt. een optie in de alsa-base.conf
moet komen. Daarvoor hebben iets meer info nodig;
in de terminal intikken;
aplay -l (l=kleine letter L)
en uitkomst hier posten.
Merk en type laptop?

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline djdg

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #15 Gepost op: 2011/05/05, 21:44:14 »
Heb nu Ubuntu (ipv Kubuntu) 11.04 en het probleem is er nog steeds. Daar waar ik het in de vorige versie maar geaccepteerd had dat het gewoon niet werkte na een lange zoektocht, hoop ik dat er inmiddels na de upgrade nieuwe ontwikkelingen zijn. Iemand advies? :)

Offline Willemtk

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #16 Gepost op: 2011/05/21, 00:01:08 »
Hallo

@w8jij17

Toevallig net een laptopje aan het optuigen en had hetzelfde probleem,
ik heb dat hier op kunnen lossen door in de terminal de alsamixer te starten
daar de headphone van MM op 00 te zetten (gebruik de m toets en de cursortoetsen)
Aangezien de zogenaamde headphone jack sense niet in de gewone mixer opduikt, maar
wel in de alsamixer.
Ik heb standaard wel de linux-backports-modules-alsa-lucid-generic erop staan, misschien
loont het om die ook te installeren en na een reboot eens te kijken of dat werkt.
(welke versie van kubuntu draai je, kubuntu is niet de reden voor het niet muten overigens)

Als dit niet werkt, doe dan in de terminal een; aplay -l (l= kleine letter L) en post dat
hier, wellicht moet er in je /etc/modprobe.d/alsa-base.conf nog een optie worden veranderd
of toegevoegd.

Groeten Gerrit


STommem vraag mss, maar hoe start je alsaplayer in de terminal?

Offline djdg

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #17 Gepost op: 2011/05/21, 00:06:34 »
Ik dacht door gewoon alsaplayer in te typen, maar toen gaf hij aan dat hij niet geïnstalleerd was. Alsnog dus gedaan, maar ook dan werkt hij bij mij niet. Zou dit dan misschien de reden zijn dat het nog niet werkt?

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #18 Gepost op: 2011/05/21, 00:07:32 »
Dit probleem heb ik al sinds Karmic (9.10). Had destijds een bugrapport aangemaakt, maar het is voor mij nog steeds niet opgelost :(.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/460654

edit: lol, ik zie nu pas dat dit mijn eigen topic was  :rolleyes:
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #19 Gepost op: 2011/05/21, 17:11:57 »
@djdg

Volgens mij is er iets "lost in translation" je moet daadwerkelijk
aplay -l
intypen en niet alsaplayer; dat wordt nl. niet bedoeld.
Met de informatie die aplay -l levert kunnen we misschien nog iets
uitzoeken.

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline djdg

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #20 Gepost op: 2011/05/21, 17:14:18 »
**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: Intel [HDA Intel], apparaat 0: VT1708S Analog [VT1708S Analog]
  Sub-apparaten: 2/2
  Sub-apparaat #0: subdevice #0
  Sub-apparaat #1: subdevice #1

Offline djdg

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #21 Gepost op: 2011/07/18, 12:40:07 »
Het is nog niet helemaal hoe ik het zou willen, maar dit is een grote stap voorwaarts:

Citaat
Thank you Benjamin. Your solution below work on my ASUS K50AB. I suggest, also, this instruction "amixer set Front 30 unmute" after restarting PC.

---------
These instructions got the headphones jacked working like I wanted: When I plug in my headphones the speakers automatically mute, and when I unplug them the speakers come back on.

1) Open gnome-volume-control
2) Click on the "Output" tab.
3) Change "Connector" to "Analog Headphones"
4) Open gnome-alsamixer
5) Turn the "Front" channel up to maximum volume.
6) Close gnome-alsamixer
7) Use gnome-volume-control to adjust volume/mute/unmute.

If you want both headphones and speakers, open gnome-alsamixer and unmute the "Front" channel.

https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/565685/comments/52

Om de ongeveer 10 minuten hoor ik een parkeerklik (in energiebeheer heb ik die optie al stopgezet) en valt in Alsamixer de 'front' balk uit. Eigenlijk valt het geluid in het algemeen uit (VLC, Firefox...).
« Laatst bewerkt op: 2011/07/18, 13:13:19 door djdg »

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Speakers muten niet wanneer ik koptelefoon inplug
« Reactie #22 Gepost op: 2011/07/18, 14:23:53 »
Het is nog niet helemaal hoe ik het zou willen, maar dit is een grote stap voorwaarts:

Citaat
Thank you Benjamin. Your solution below work on my ASUS K50AB. I suggest, also, this instruction "amixer set Front 30 unmute" after restarting PC.

---------
These instructions got the headphones jacked working like I wanted: When I plug in my headphones the speakers automatically mute, and when I unplug them the speakers come back on.

1) Open gnome-volume-control
2) Click on the "Output" tab.
3) Change "Connector" to "Analog Headphones"
4) Open gnome-alsamixer
5) Turn the "Front" channel up to maximum volume.
6) Close gnome-alsamixer
7) Use gnome-volume-control to adjust volume/mute/unmute.

If you want both headphones and speakers, open gnome-alsamixer and unmute the "Front" channel.

https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/565685/comments/52

Om de ongeveer 10 minuten hoor ik een parkeerklik (in energiebeheer heb ik die optie al stopgezet) en valt in Alsamixer de 'front' balk uit. Eigenlijk valt het geluid in het algemeen uit (VLC, Firefox...).

Voeg het volgende eens toe aan /etc/pulse/daemon.conf:
no-cpu-limit = yes
rlimit-rttime = -1