Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost] Swap-file problemen  (gelezen 3922 keer)

Offline Plotinus

  • Lid
  • Steunpunt: Nee
[opgelost] Swap-file problemen
« Gepost op: 2009/11/08, 19:56:04 »
L.S.

Bij het opstarten rolt even kort een tekstbestandje over het scherm waarin ik aantref:
"One or more of the mounts listed in /etc/fstab cannot yet be mounted. SWAP waiting for UUID...."

Als ik in GParted kijk heb ik inderdaad geen SWAP-file. De in de WIKI aangegeven manier om een SWAP-file te forceren blijkt niet te werken: GParted blijft onveranderd. Iemand een bruikbare suggestie om dit probleem op te lossen?

gegroet,
mrt
« Laatst bewerkt op: 2009/11/11, 15:48:50 door Plotinus »
Ach! Waren alle Menschen wijs, en wilden daarbij wel! De Aard waar haar een Paradijs, Nu isse meest een Hel.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Swap-file problemen
« Reactie #1 Gepost op: 2009/11/08, 20:09:23 »
Wat staat er nu in /etc/fstab?

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Swap-file problemen
« Reactie #2 Gepost op: 2009/11/08, 20:11:31 »
De swap is geen file, maar een partitie.
Normaal moet deze 4X de hoeveelheid RAM zijn, maar heb je 4 GB RAM, dan mag deze ook kleiner zijn.
Gewoon even met Gparted een partitie maken en die formatteren als swap, de rest gaat dan vanzelf.
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Swap-file problemen
« Reactie #3 Gepost op: 2009/11/08, 20:15:56 »
Ron, je kan ook een swap-bestand aanmaken. Het hoeft dus niet per se een aparte partitie te zijn.

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
Re: Swap-file problemen
« Reactie #4 Gepost op: 2009/11/08, 20:30:12 »
Als ik in GParted kijk heb ik inderdaad geen SWAP-file. De in de WIKI aangegeven manier om een SWAP-file te forceren blijkt niet te werken: GParted blijft onveranderd. Iemand een bruikbare suggestie om dit probleem op te lossen?
Als je gebruik maakt van een swap-file zie je dat inderdaad niet terug in GParted. ;)

Met een swapon opdracht kan je zien of de swap-file in gebruik is:
swapon  -s
Wiki: Veel gestelde vragen over wisselgeheugen.

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Swap-file problemen
« Reactie #5 Gepost op: 2009/11/08, 20:32:47 »
Gebruik ik Ubuntu vanaf versie 4.10 (Beatrix release) en dit wist ik niet .........
Bedank voor de terechtwijzing, nu heb ik weer wat geleerd :lol:
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger.

Offline Plotinus

  • Lid
  • Steunpunt: Nee
Re: Swap-file problemen
« Reactie #6 Gepost op: 2009/11/08, 22:26:13 »
Beste Johan,

Ik heb geen fstab; kan dat wel? Verder heb ik via Gparted inderdaad een Swap-file aangemaakt, maar bij het opstarten wordt hij toch niet opgepikt en, volgens de systeemmonitor, ook niet gebruikt, terwijl ik toch maar 512 MB aan boord heb. Rarara?

gegroet,
mrt
Ach! Waren alle Menschen wijs, en wilden daarbij wel! De Aard waar haar een Paradijs, Nu isse meest een Hel.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Swap-file problemen
« Reactie #7 Gepost op: 2009/11/09, 07:27:05 »
Ik heb geen fstab; kan dat wel?
Zonder /etc/fstab zal je systeem niet eens opstarten denk ik. Dus hoogstwaarschijnlijk zocht je op de verkeerde plek :)
Hij staat niet in je eigen map (/home/gebruiker/enz.) maar in /etc/

Citaat
Verder heb ik via Gparted inderdaad een Swap-file aangemaakt, maar bij het opstarten wordt hij toch niet opgepikt en, volgens de systeemmonitor, ook niet gebruikt, terwijl ik toch maar 512 MB aan boord heb. Rarara?
Dit is nogal onduidelijk. Gparted kan alleen partities bewerken, geen bestanden. Je kan dus niet met Gparted een swap-bestand gemaakt hebben.
Wat heb je dus precies gedaan?

Offline Progger

  • Lid
  • Steunpunt: Nee
Re: Swap-file problemen
« Reactie #8 Gepost op: 2009/11/09, 11:29:47 »
Om te weten waar je fstab staat, typ in de terminal eens locate fstab en druk op Enter, dan zie je dat die in /etc staat.
Laptop MSI U123 (160 GB) 1 GB ramMint Cinnamon 18 LTS
Laptop Toshiba Tecra  (80GB) 2 GB ram Fedora 24
Dell Latitude D600 Pentium M 1400MHz 512MB ram
Bouwjaar 2003 met Debian 8 (Jessie)

Offline Plotinus

  • Lid
  • Steunpunt: Nee
Re: Swap-file problemen
« Reactie #9 Gepost op: 2009/11/09, 21:47:22 »
Beste Johan,

De fstab heb ik gevonden (met dank aan Progger); zie de inhoud in bijgevoegd plaatje.

Ik heb inderdaad geen file, maar een partitie gemaakt; excuses voor de onduidelijkheid.

Misschien toch maar alle moed bij elkaar rapen en helemaal opnieuw installeren; zal waarschijnlijk het eenvoudigste zijn.

gegroet,
mrt
Ach! Waren alle Menschen wijs, en wilden daarbij wel! De Aard waar haar een Paradijs, Nu isse meest een Hel.

Offline Plotinus

  • Lid
  • Steunpunt: Nee
Re: Swap-file problemen
« Reactie #10 Gepost op: 2009/11/09, 21:48:38 »
nog een schermafdrukje uit GParted, om te laten zien dat het toch wel goed moet zitten denk ik...

gegroet,
mrt
Ach! Waren alle Menschen wijs, en wilden daarbij wel! De Aard waar haar een Paradijs, Nu isse meest een Hel.

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
Re: Swap-file problemen
« Reactie #11 Gepost op: 2009/11/09, 23:42:24 »
Misschien toch maar alle moed bij elkaar rapen en helemaal opnieuw installeren; zal waarschijnlijk het eenvoudigste zijn.
Kan zijn. Maar zoveel is er niet aan de hand. Als ik het goed begrijp:
 1. je hebt een swap partitie (/dev/sda6) gemaakt van 1GB.
 2. je hebt in bestand /etc/fstab opgegeven dat je een swapfile hebt.

1=prima
2=(blijkbaar) onjuist

Een eenvoudige oplossing is om /etc/fstab nog eens te wijzigen
sudo /etc/fstab
En dan deze regel toevoegen:

/dev/sda6 none  swap  sw  0  0

Als je geen swap-file hebt gemaakt kan de volgende regel worden gewist:

/mnt/512Mb.swap  none  swap  sw  0  0
Reboot, klaar.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Swap-file problemen
« Reactie #12 Gepost op: 2009/11/10, 09:30:43 »
In plaats van sudo /etc/fstab moet je gksudo gedit /etc/fstab gebruiken.
Tikfoutje van testcees, verder klopt het wel ;)

Offline Plotinus

  • Lid
  • Steunpunt: Nee
Re: Swap-file problemen
« Reactie #13 Gepost op: 2009/11/10, 23:34:47 »
Beste Johan en Testcees,

Opdrachten uitgevoerd (en plaatsing in het bestand gecontroleerd), maar de foutmelding blijft en uit de systeemmonitor blijkt inderdaad dat het gebruik van het wisselgeheugen 0% blijft, ook na het gelijktijdig in gebruik hebben van zo'n 10 programma's. Zou het kunnen dat de SWAP geformatteerd moet worden; ik kan me eigenlijk niet herinneren dat ik dat gedaan heb.

gegroet,
mrt
Ach! Waren alle Menschen wijs, en wilden daarbij wel! De Aard waar haar een Paradijs, Nu isse meest een Hel.

Offline Lexaldo

  • Lid
  • Steunpunt: Nee
Re: Swap-file problemen
« Reactie #14 Gepost op: 2009/11/11, 11:27:30 »
De swap-partitie krijgt die bruine kleur als je hem als zodanig hebt aangewezen, dus dat moet goed zijn.
Ik heb overigens ook nog nooit meer dan 0% gebruik van mijn eigen swap gezien.

Zou die foutmelding niet iets te maken kunnen hebben met de ntfs-partitie (met dat waarschuwingssymbooltje)?
« Laatst bewerkt op: 2009/11/11, 11:33:01 door Lexaldo »

Offline track

  • Lid
  • Steunpunt: Nee
Re: Swap-file problemen
« Reactie #15 Gepost op: 2009/11/11, 11:32:43 »
Plotinus:  heb je ooit met  free  (in de terminal) getest hoe veel swap hij feitelijk heeft ?
Als daar het gebruik ervan op "0" staat is dat best oke, dan heb je gewoon voldoende werkgeheugen.
Bij mij staat die ook altijd op "0":             total       used       free     shared    buffers     cached
Mem:       1295864     764952     530912          0     164704     343220
-/+ buffers/cache:     257028    1038836
Swap:      1582360          0    1582360

track

Offline Plotinus

  • Lid
  • Steunpunt: Nee
Re: Swap-file problemen
« Reactie #16 Gepost op: 2009/11/11, 15:48:17 »
Beste meedenkers,

Ik heb maar gedaan wat men hier eigenlijk altijd aanraadt en dat is een schone herinstallatie. En nu krijg ik geen foutmeldingen meer en de Swap-partitie wordt netjes gebruikt.

gegroet,
mrt
Ach! Waren alle Menschen wijs, en wilden daarbij wel! De Aard waar haar een Paradijs, Nu isse meest een Hel.

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
Re: Swap-file problemen
« Reactie #17 Gepost op: 2009/11/11, 15:51:35 »
Ik heb maar gedaan wat men hier eigenlijk altijd aanraadt en dat is een schone herinstallatie.
En zo lijkt linux steeds meer op een echte Windows computer. Daar hoor ik ook altijd opnieuw installeren als aanrader voor alle problemen.  ;)
Fijn dat het is opgelost. Suc6! :)

Offline grubuntu

  • Lid
  • Steunpunt: Nee
Re: Swap-file problemen
« Reactie #18 Gepost op: 2009/12/05, 12:32:18 »
Helaas, ik heb dit probleem ook. Het begint ineens lastig te worden, omdat ik de PPC soms meerdere keren moet opstarten om te kunnen beginnen. Opnieuw installeren vind ik geen optie na een maand werken met 9.10. Dat moet anders kunnen!

swappartitie die bij opstart gezocht wordt is 3GB groot. Ik heb er nog een bijgemaakt van 4GB. Volgens free nog helemaal vrij.
Maar hij blijft stotteren.



 

Offline track

  • Lid
  • Steunpunt: Nee
Re: [opgelost] Swap-file problemen
« Reactie #19 Gepost op: 2009/12/05, 13:01:16 »
grubuntu:  meer swap dan nodig brengt verder geen nut.
En, mits je niet met 256 MB gehegen zit is nog steeds de "formule"
van toepassing:  swap = werkgeheugen + 5 %
Dat is dan zelfs voldoende voor de slaapstand.

Jouw probleem is dit klaarblijkelijk niet.  Hoe veel werkgeheugen heb je ?
En, wat gaat precies traag ? 
Alleen i'net- dingen soms ?  Dan zou het best het IPv6- verhaal kunnen zijn.

track                              (edit: typo)
« Laatst bewerkt op: 2009/12/05, 13:36:08 door track »

Offline grubuntu

  • Lid
  • Steunpunt: Nee
Re: [opgelost] Swap-file problemen
« Reactie #20 Gepost op: 2009/12/05, 16:15:49 »
Bij opstarten verschijnt tekst die zo snel niet te lezen is, maar soms eindigt met één zin in beeld met de boodschap dat gewacht wordt op het mounten van swap. De UUID code daarachter is die van mijn swap-partitie.
In dat geval helpt alleen ctrl+alt+del.

Bij nieuw opstarten komt (als het voortgaande niet herhaald wordt) een tekst die eindigt met:
"One or more of the mounts listed in /etc/fstab cannot yet be mounted.
SWAP waiting for UUID....
press esc to enter recovery-shell" (of woorden van gelijke strekking)

Dan heb ik geluk: indrukken van esc doet de PPC gewoon opstarten en alles doet het.

Werkgeheugen: 4 GB.

Dit probleem is er sinds enkele dagen. Vanaf de schone installatie van 9.10 eind oktober zag ik wel steeds een tekst langsrollen bij het opstarten over niet uitgevoerde mounts, maar voor je die kon lezen was de zaak opgestart en functioneerde alles naar behoren.
« Laatst bewerkt op: 2009/12/05, 16:18:31 door grubuntu »

Offline track

  • Lid
  • Steunpunt: Nee
Re: [opgelost] Swap-file problemen
« Reactie #21 Gepost op: 2009/12/05, 16:30:03 »
Volgens mij is hier alleen de UUID van de swap gewijzigd.
(uiteraard, als je een nieuwe hebt aangemaakt !)

In ieder geval is het nu met die twee swap's ingewikkelder dan nodig.
Vandaar stel ik het volgende voor:
- kijk of er swap  actief is:  free  (in de terminal)
- opruimen:  de tweede swap verwijderen,
                 de eerste swap  via gparted vergroten naar 4.2 GB
                 kijken dat er alleen 1 swap  in de /etc/fstap  staat !
                 de UUID terug aanpassen met het scriptje  uuid2swap :
   (->  http://forum.ubuntu-nl.org/software-en-configuratie/swap-partitie-unmount-na-elke-heropstart/ )

track
« Laatst bewerkt op: 2009/12/05, 16:31:57 door track »

Offline grubuntu

  • Lid
  • Steunpunt: Nee
Re: [opgelost] Swap-file problemen
« Reactie #22 Gepost op: 2009/12/06, 19:59:34 »
Dank voor de suggesties.
Ik heb het volgende gedaan:

- kijk of er swap  actief is:  free  (in de terminal) Is actief
- opruimen:  de tweede swap verwijderen,                           gedaan
                 de eerste swap  via gparted vergroten naar 4.2 GB       Vergroot naar 4,5 GB
                 kijken dat er alle en 1 swap  in de /etc/fstap  staat !   Die staat er in
                 de UUID terug aanpassen met het scriptje  uuid2swap :         script gedraaid
  
Resultaat: Opstarten mondt nog steeds uit in het probleem de swap te mounten. De daarbij genoemde uuid is de uuid van de swap (volgens fstab). ESC brengt de zaak dan aan de gang in een rescue mode. Maar alles doet het wel.

ctrl-alt-del is nu niet meer nodig (lijkt het).

Wat opvalt is dat de door de snelheid nauwelijks te lezen tekst begint met "cannot read etc/udev/rules.d/z80_user.rules" (of zo).  
Dat bestandje is echter helemaal leeg..... Kan dat een reden zijn?