Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: MSI Neton geen geluid in Ubuntu  (gelezen 4337 keer)

Offline mhweb

  • Lid
  • Steunpunt: Nee
MSI Neton geen geluid in Ubuntu
« Gepost op: 2009/11/08, 09:32:04 »
Ik heb zo een all in one pc gekocht, alles zit in het scherm ingebouwd, alleen een los klavier en een muis. Dat ding is windows voorgeinstalleerd, maar heeft slechts 1 GB intern geheugen. Ik wou dus weer met ubuntu werken. Heb de installatie gedaan, met de Netbook Remix, ( de gewone versie, wilde niet lukken) Nu heb ik dus een dual-boot, en plan, eens alles werkt zoals het hoort windows er af te gooien.
Het eerste wat me opviel is dat mijn geluid niet werkt.  ( doet het in windows wel, dus zal er met de hardware zelf niets mis zijn. )

Hoe controleer ik wat er fout zit, en hoe zorg ik ervoor dat mijn geluid ( boxen en microfoon) wel werken. Ik wil skype kunnen gebruiken, en muziek afspelen.

Sorry, Heb het bericht nu hier gezet, denk dat het meer hier thuis hoort dan bij softwaren configuratie, maar weet helaas niet hoe ik het ginds moet weghalen.  ( Kan iemand dit in mijn plaats doen? )

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #1 Gepost op: 2009/11/08, 10:29:11 »
Hallo mhweb, om welke versie van Ubuntu gaat het en ben je een beetje bekend in de terminal?

Offline mhweb

  • Lid
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #2 Gepost op: 2009/11/08, 10:47:29 »
Ubuntu 9.10  de notebook remix die ik op cd had laten branden.
In hoeverre ik bekend met met de terminal,  geen expert... lol.. ik weet dat je daar commando's kan ingeven, die je informatie over je systeem bezorgen, of om dingen te installeren etc.    Ik ken zelf geen comando's, dus beperk me op dit gebied in het copy pasten van hetgeen behulpzame formumbezoekers me voorschrijven, en posten wat het resultaat ervan is.

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #3 Gepost op: 2009/11/08, 10:55:36 »
Ah mooi, zou je dan de uitkomst kunnen posten van het volgende commando in een terminal:
lspci | grep -i audio && aplay -l && cat /proc/asound/card*/codec* | grep -i codec

Offline mhweb

  • Lid
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #4 Gepost op: 2009/11/08, 11:15:58 »
mhweb@mhweb-desktop:~$ lspci | grep -i audio && aplay -l && cat /proc/asound/card*/codec* | grep -i codec
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: Intel [HDA Intel], apparaat 0: ALC888 Analog [ALC888 Analog]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
Codec: Realtek ALC888
mhweb@mhweb-desktop:~$ ^C
mhweb@mhweb-desktop:~$ ^C
mhweb@mhweb-desktop:~$

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #5 Gepost op: 2009/11/08, 11:27:50 »
Bedankt! De codec is een Realtek ALC888 en die hoort het gewoon te doen. Heb je al in je Sound Preferences gekeken? En zit er heel misschien een modem in die all-in-one PC? En misschien zou je nog 2 pakketjes willen installeren: gnome-alsamixer en paman

Offline mhweb

  • Lid
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #6 Gepost op: 2009/11/08, 11:49:05 »
Dit is hem,  http://www.laptopshop.nl/product/68351/msi-neton-ap1900-zwart.html

Ik denk dat er wel een modem in zit ja.

Heb gekeken naar instellingen, maar alleen voor microfoon is er meer dan 1 mogelijheid,   micro  1 of 2

Die twee dingen heb ik nog geinstalleerd, heb nog steeds geen geluiden..  ook geen beeps bij opstarten skype of zo

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #7 Gepost op: 2009/11/08, 12:05:48 »
Nee, die pakketjes regelen niks zelf, je kan er dingen mee regelen. Met gnome-alsamixer kun je de geluidsinstellingen van alsa checken (alsa is de 'sound-stack' van Ubuntu) en met paman (PulseAudio Manager) kun je de instellingen nalopen van PulseAudio, de sound server van Ubuntu die het mogelijk maakt dat meerdere programma's tegelijkertijd geluid kunnen maken. Staan de nodige schuifjes open in gnome-alsamixer?
En zo te zien zit er geen modem in dus die stoorzender valt af, een modem kan namelijk zichzelf tot default geluidskaart bombarderen en dan heb je dus geen geluid.

Offline mhweb

  • Lid
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #8 Gepost op: 2009/11/08, 12:33:46 »
Hoe horen die dingen ingesteld te zijn?    Effe een screenhot... 

Offline dirkalberteverts

  • Lid
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #9 Gepost op: 2009/11/08, 14:03:26 »
probeer dit eens,heeft bij mij geholpen. XD XD

https://help.ubuntu.com/community/SoundTroubleshooting
Dreamstudio 11.10

Offline mhweb

  • Lid
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #10 Gepost op: 2009/11/08, 14:52:45 »
Hehe, bestaat daar geen nederlandse beschrijving van.  
Ondertussen nog wat gegoogeld en links binnen het formum aangeklikt, maar werkt nog steeds niet.   Zoals je in de afbeelding hierboven ziet staan er in de volumeregelaar nogal wat schuifjes,  horizontale, vertikale...  en verschillende categorien.. wie kan me zeggen wat waarvoor dient, en wat ik daarvan niet nodig heb, en hoe ik dat dan eventueel kan uitzetten...

Ondertussen heb ik externe boxen aangesloten op mijn systeem, en hier blijkt wel muziek uit te komen.
Maar, de ingebouwde boxen van mijn scherm doen het blijkbaar niet.

Als iemand een idee heeft, laat het me weten,   kan die boxen niet altijd gebruiken,  horen bij een ander zijn pc.   
« Laatst bewerkt op: 2009/11/08, 15:44:09 door mhweb »

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #11 Gepost op: 2009/11/09, 09:47:42 »
Bedankt voor de screenshot! Ik zou proberen om de eerste drie schuifjes helemaal open te zetten, Dus PCM, Master en Front. Dat zijn de schuifjes voor playback, de rest, behalve Beep, zijn voor recording. Met de verticale schuifjes bedien je het volume, met de horizontale de balance. Heb zelf geen ALC888 dus weet ook niet precies welk schuifje waarvoor dient, dit kan namelijk per codec/soundchip verschillen.

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #12 Gepost op: 2009/11/09, 09:56:50 »
probeer dit eens,heeft bij mij geholpen. XD XD

https://help.ubuntu.com/community/SoundTroubleshooting
Even offtopic, maar dat dit soort dingen op de Ubuntu site staan, ik zou eens een opschoonactie houden.

Offline mhweb

  • Lid
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #13 Gepost op: 2009/11/09, 12:11:14 »
Ik ben die troubleshooting pagina gaan volgen tot aan herstart je computer, nu staat ineens mijn toetsenbord in qwerty ipv awerty

Hoe kan dit nu

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #14 Gepost op: 2009/11/09, 21:50:13 »
Geen idee. Je hebt toch niet ALSA geüpdate? Die Help pagina is leuk maar die ALSA driver Compilation paragraaf moeten ze eruit halen. En de paragrafen over OSS ook. OSS zit als het goed is niet eens meer in de Karmic repo's.

Offline mhweb

  • Lid
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #15 Gepost op: 2009/11/10, 07:24:33 »
Dat met dat toetsenbord was snel opgelost...  toen ik naar de instellingen ging kijken,  stond dat goed, maar.. er stond wel VS ( denk ik bij) heb dat verwijderd en is terug in orde.. maar, heb hier nog steeds geen geluid,    geen biepjes bij opstarten...Als ik over het icoontje van geluid ga, rechts boven in mijn scherm,  verschijnt er uitvoer 95% intern geluid analog stereo.... maar hoor niks... en als ik overga op windows werken mijn ingebouwde luidsprekers normaal.

Offline Progger

  • Lid
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #16 Gepost op: 2009/11/10, 09:49:09 »
Heb je al geprobeert door die verticale schuifjes eens één voor één helemaal naar boven te zetten, en dan telkens te testen? Zo te zien op je screenshot staat je geluid helemaal dicht dus verticale schuifjes moeten naar boven.
Laptop MSI U123 (160 GB) 1 GB ramMint Cinnamon 18 LTS
Laptop Toshiba Tecra  (80GB) 2 GB ram Fedora 24
Dell Latitude D600 Pentium M 1400MHz 512MB ram
Bouwjaar 2003 met Debian 8 (Jessie)

Offline mhweb

  • Lid
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #17 Gepost op: 2009/11/10, 11:28:00 »
Ik heb de vertikale schuifjes,   een voor een, twee per twee... allemaal verzet, terwijl Ritmebox een lijst staat af te spelen.  Ik hoor geen enkel geluid,  in geen enkele stand.
Als ik Puls audio volumeregeling open, zie ik de titel van de song, en metertjes die van links naar rechts bewegen...  maar hoor niks.

Offline Progger

  • Lid
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #18 Gepost op: 2009/11/10, 11:33:13 »
Op je toetsenbord, via de Fn-toetsen heb je toch je geluid niet gemute hoop ik, bij mij zijn dat de toetsen Fn+F7 en Fn+F8.
Laptop MSI U123 (160 GB) 1 GB ramMint Cinnamon 18 LTS
Laptop Toshiba Tecra  (80GB) 2 GB ram Fedora 24
Dell Latitude D600 Pentium M 1400MHz 512MB ram
Bouwjaar 2003 met Debian 8 (Jessie)

Offline mhweb

  • Lid
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #19 Gepost op: 2009/11/10, 12:12:59 »
Neen,   als dat het geval moest zijn,  zou ik ook in windows geen geluid hebben,    ( of met de boxen )  fn + F7 of F8 doen helemaal niks

Offline Progger

  • Lid
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #20 Gepost op: 2009/11/10, 12:15:36 »
Jammer, maar dan zou ik het ook niet meer weten, misschien iemand anders?
Laptop MSI U123 (160 GB) 1 GB ramMint Cinnamon 18 LTS
Laptop Toshiba Tecra  (80GB) 2 GB ram Fedora 24
Dell Latitude D600 Pentium M 1400MHz 512MB ram
Bouwjaar 2003 met Debian 8 (Jessie)

Offline mhweb

  • Lid
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #21 Gepost op: 2009/11/16, 13:46:10 »
Ik heb hier de hele tijd zitten spelen met de geluidsinstelling, maar nog steeds is hier niks te horen.  Als ik mijn computer bij opstarten naar windows laat gaan is alles in orde...  moet dus toch ergens aan liggen.
Misschien iemand die me kan helpen om alle dingen nog eens na te kijken?
Ik heb op het moment maar twee dingen waarvoor ik telkens weer terug moet keren naar windows, en dat is, als ik iets met geluid wil gaan doen, of, wanneer ik moet printen.
Ik zou dit graag in orde krijgen zodat ik windows van mijn systeem kan verwijderen, ( op op zijn minst niet om de haverklap ernaar terug moet keren )

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #22 Gepost op: 2009/11/16, 13:54:00 »
Er schiet me nog wat te binnen. Zou je het volgende kunnen proberen in een terminal:
pasuspender rhythmbox
En dan nagaan of je wel geluid hebt?

Offline mhweb

  • Lid
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #23 Gepost op: 2009/11/16, 14:06:08 »
mhweb@mhweb-desktop:~$ pasuspender rhythmbox

** (rhythmbox:2549): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (rhythmbox:2549): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
WARNING: Unhandled message: interface=org.freedesktop.DBus.Introspectable, path=/, member=Introspect

  Hierna Rythmbox aangezet,  song aangeklikt en die begint ( virtueel, ) niet eens af te spelen,   horen doe ik ook niks. Daarna even skype opgestart,  na het aanmelden krijg je daar meestal een geluidje,  niks dus.... en bij de opties van skype ben ik gaan kijken naar instellingen voor geluid.  Ik krijg daar alleen de keuze puls audio server, lokal  ( kan dus niks anders kiezen) en bij geluid testen krijg ik niks te horen )

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: MSI Neton geen geluid in Ubuntu
« Reactie #24 Gepost op: 2009/11/16, 15:45:56 »
Met het commando pasuspender rhythmbox zou rhythmbox ook al moeten starten. pasuspender staat voor PulseAudio suspender, oftewel, de standaard soundserver (PulseAudio) wordt zo even uitgezet zodat het programma rhytmbox zonder deze soundserver kan draaien en direct gebruik kan maken van de geluidsdrivers (de Alsa drivers). pasuspender lost verder niks op. Ik zie dat ik een typefoutje heb gemaakt, zou je het nog zo kunnen proberen:

pasuspender -- rhythmbox
Dan zou rhythmbox op moeten starten en als je dan wel geluid hebt ligt je probleem bij PulseAudio, heb je dan geen geluid dan ligt het bij Alsa.