Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST]Libcupsys2 vervangen door libcups2 (oa. Canon MP510)  (gelezen 3481 keer)

Offline Pfoeh

  • Lid
  • Steunpunt: Nee
Hoi
Ik wilde vanavond mijn Canon MP510 installeren in Karmic Koala.
Hierbij wilde ik gebruikmaken van een oude handleiding.
Helaas loopt de installatie vast vanwege het feit dat libcupsys2 vervangen is door lipcups2.
Hoe kan ik libcupsys2 installeren?
Als ik sudo apt-get install libcupsys2 probeer, krijg ik de melding dat lipcups2 de vervanger is voor het pakket dat ik nodig heb, en deze dus niet installeert.
Heeft er iemand een tip?
Morgen mag ook, want de slaap overwint momenteel de drang om de printer vandaag nog perse te installeren...  ;)

Gr.
Jeroen
« Laatst bewerkt op: 2009/11/24, 16:41:48 door Pfoeh »
Linux Registered user 485465

Beperkingen voor het vervoer van gevaarlijke stoffen, genoemd onder Tunnelcategorie E in randnummer 1.9.5.2.2. van bijlage 1, gelden voor de ArenAtunnel, gelegen onder de Amsterdam ArenA, te Amsterdam.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Libcupsys2 vervangen door libcups2
« Reactie #1 Gepost op: 2009/11/05, 18:08:17 »
En met dat ene pakket dat het andere vervangt werkt het dan of niet?

Offline Ronnie

  • Artworkteam
    • ronnie.vd.c
  • Steunpunt: Nee
Re: Libcupsys2 vervangen door libcups2
« Reactie #2 Gepost op: 2009/11/05, 19:01:11 »
Hoi
Ik wilde vanavond mijn Canon MP510 installeren in Karmic Koala.
Hierbij wilde ik gebruikmaken van een oude handleiding.
Helaas loopt de installatie vast vanwege het feit dat libcupsys2 vervangen is door lipcups2.
Hoe kan ik libcupsys2 installeren?
Als ik sudo apt-get install libcupsys2 probeer, krijg ik de melding dat lipcups2 de vervanger is voor het pakket dat ik nodig heb, en deze dus niet installeert.
Heeft er iemand een tip?
Morgen mag ook, want de slaap overwint momenteel de drang om de printer vandaag nog perse te installeren...  ;)

Gr.
Jeroen

Wellicht heeft libcups2 dezelfde functionaliteit als libcupssys2. Kun je de link naar de handleiding plaatsen. Misschien kunnen wij een manier verzinnen dat er gebruik gemaakt kan worden van lubcups2
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Documentatie Terminal

Offline Pfoeh

  • Lid
  • Steunpunt: Nee
Re: Libcupsys2 vervangen door libcups2
« Reactie #3 Gepost op: 2009/11/05, 20:00:40 »
@heir4c: het lukt niet om het laatste van de 4 deb-bestanden te installeren. In bijgaande schermprint zie je de foutmelding en de naam van het pakket waar het om gaat.
http://foto-uploaden.nl/img/5/xr2uwc2.png

@Ronnie: ik heb deze printer al diverse keren geïnstalleerd ivm installatie nieuwe versies van Ubuntu (7.10, 8.04, 9.04 en nu dan het probleempje met 9.10), waarbij ik werkt volgens: http://ubuntuforums.org/showpost.php?p=3938403&postcount=4

Nu zag ik inmiddels dat iemand anders het probleem op wist te lossen door de dependency aan te passen: http://ubuntuforums.org/archive/index.php/t-1305248.html en dit wil ik op zich wel eens uitproberen.

Wel vraag ik me af of het volgende een betrouwbaar alternatief is:
- uninstall libcups2
- install libcupsys2
- install laatste pakket en daarna installatie afronden
- install libcups2 naast libcupsys2
Ik vraag me dus af of dit niet tot conflicten gaat leiden.

Gr.
Jeroen
Linux Registered user 485465

Beperkingen voor het vervoer van gevaarlijke stoffen, genoemd onder Tunnelcategorie E in randnummer 1.9.5.2.2. van bijlage 1, gelden voor de ArenAtunnel, gelegen onder de Amsterdam ArenA, te Amsterdam.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Libcupsys2 vervangen door libcups2
« Reactie #4 Gepost op: 2009/11/06, 00:16:44 »
Je derde link lijkt mij wel iets. Daar word precies uitgelegd wat je moet doen om die .deb file aan te passen en opnieuw in te pakken. Lijkt mij wel iets.
Ten andere bedankt voor de link. Misschien heb ik dat nog wel eens nodig.

Offline Pfoeh

  • Lid
  • Steunpunt: Nee
Re: Libcupsys2 vervangen door libcups2
« Reactie #5 Gepost op: 2009/11/06, 00:40:29 »
Ik heb inmiddels de .deb aangepast en opnieuw ingepakt.
Installatie van het pakket liep ook goed.
Helaas krijg ik een foutmelding waardoor er niet geprint wordt. (iets met filters in /usr/lib/cups/filter)
Wordt nog even zoeken denk ik om dit op te lossen. Als ik eruit ben zet ik het hier even neer.

Gr.
Jeroen
Linux Registered user 485465

Beperkingen voor het vervoer van gevaarlijke stoffen, genoemd onder Tunnelcategorie E in randnummer 1.9.5.2.2. van bijlage 1, gelden voor de ArenAtunnel, gelegen onder de Amsterdam ArenA, te Amsterdam.

Offline Pfoeh

  • Lid
  • Steunpunt: Nee
Re: Libcupsys2 vervangen door libcups2
« Reactie #6 Gepost op: 2009/11/24, 16:38:26 »
Mooi, probleem opgelost!
zie: https://bugs.launchpad.net/ubuntu/+source/cups/+bug/436544
Na het geven van de printopdracht verscheen het printer-icoontje maar het printen startte niet vanwege de foutmelding: 'cups-insecure-filter'
Na het ingeven van het volgende commando werden de rechten op de map /usr/lib/cups/filter/pstocanonij aangepast:
$ sudo chown root:root /usr/lib/cups/filter/pstocanonij"pstocanonij" kan in jouw geval misschien een iets andere naam hebben. (bijv "pstocanonbj" zoals bij de persoon die het probleem op Launchpad aangekaart heeft.)
Hierna werkte de printer keurig.

Ik hoop dat het jullie van pas komt!

Jeroen
Linux Registered user 485465

Beperkingen voor het vervoer van gevaarlijke stoffen, genoemd onder Tunnelcategorie E in randnummer 1.9.5.2.2. van bijlage 1, gelden voor de ArenAtunnel, gelegen onder de Amsterdam ArenA, te Amsterdam.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: [OPGELOST]Libcupsys2 vervangen door libcups2 (oa. Canon MP510)
« Reactie #7 Gepost op: 2009/11/24, 19:22:00 »
Pfoeh, bedankt om even te melden dat het opgelost is en je oplossing erbij te zetten. Hebben anderen er dus ook iets aan zoals je zelf aangeeft.

Met vriendelijke groet,
heir4c