Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: probleem NVIDIA GeForce4 420 Go  (gelezen 3576 keer)

Calvin

  • Gast
probleem NVIDIA GeForce4 420 Go
« Gepost op: 2009/11/04, 13:53:20 »
Beste,

Ik heb ubuntu 9.10 geïnstalleerd (dual boot met WIN XP), maar ik ondervind nu enkele problemen met mijn videokaart (NVIDIA GeForce4 420 Go).
Na installatie wordt de betreffende driver ('96) voorgesteld door ubuntu. Na opnieuw opstarten, krijg ik enkel nog een wit scherm ... teken dus dat er met de driver iets mis is. Probleem is ook dat ik de installatie niet ongedaan kan maken (voor zover ik weet toch niet) en dat ik bijgevolg ubuntu opnieuw moet installeren. Bij ubuntu 9.04 kon je via de 'veilige modus' (sorry voor de windowsuitdrukking) beeldschermproblemen oplossen, bij 9.10 is dit niet voorzien.
Ik heb al vanalles geprobeerd (en bijgevolg ubuntu al meermaals opnieuw geïnstalleerd), zoals de driver rechtstreeks van NVIDIA gedownload en geïnstalleerd via het terminalvenster. Heel leerrijk, maar tot op heden zonder succes.  :rolleyes:

Ik kan wel verder zonder deze driver, maar zodra je 3D applicaties wil draaien, loop je vast, natuurlijk.

Heeft iemand een goed idee? Of, nog beter, een oplossing?

Ik heb geen ervaring met Linux of Ubuntu, dus de uitleg mag op niveau 'dummies' gegeven worden.  ;)

Thx.

Offline track

  • Lid
  • Steunpunt: Nee
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #1 Gepost op: 2009/11/04, 14:05:03 »
Hoi Calvin,

welkom op het forum !

Bij Uby 9.10 moet die herstelfunctie er wél in zitten, dan onder een andere naam:  xfix
Kijk hier:  http://sites.google.com/site/computertip/geenbeeld

track
« Laatst bewerkt op: 2009/11/04, 14:13:13 door track »

mailvanstefanie

  • Gast
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #2 Gepost op: 2009/11/04, 14:05:48 »
hahaha volgens mij hebben alle beginners hetzelfde probleem hihihi. Deze kreeg ik ook al als antwoord

Offline track

  • Lid
  • Steunpunt: Nee
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #3 Gepost op: 2009/11/04, 14:17:27 »
Nee Stefanie, sommigen hebben bij 9.10 met ernstige kinderziektes te kampen !
Jij, Calvin en nog vijf anderen hebben maar die xfix niet kunnen vinden.  =D

track

Calvin

  • Gast
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #4 Gepost op: 2009/11/04, 14:28:14 »
 :-[ Oeps, dan zal ik daar toch over gekeken hebben ... Zal ik straks eens bekijken.

Dit bespaart me al de volledige herinstallatie van ubuntu, maar lost het probleem van de driver nog niet op ...

Ik weet het, geduld is een mooie zaak ...  :)

Offline Joshua822

  • Documentatieteam
  • Steunpunt: Nee
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #5 Gepost op: 2009/11/04, 14:34:04 »
Je moet voor zo'n oude videokaart van nVidia niet de nieuwste driver ( versie 96, dus ) hebben, maar eerder het pakket nvidia-legacy ( of iets in die aard, ik heb geen nVidia videokaart die dit pakket nodig heeft ).

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #6 Gepost op: 2009/11/04, 14:35:29 »
Je moet voor zo'n oude videokaart van nVidia niet de nieuwste driver ( versie 96, dus ) hebben, maar eerder het pakket nvidia-legacy ( of iets in die aard, ik heb geen nVidia videokaart die dit pakket nodig heeft ).
Versie 96 is niet de nieuwste. Versie 190 is de nieuwste.

Calvin

  • Gast
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #7 Gepost op: 2009/11/04, 19:44:42 »
Blijkbaar heb ik toch een ander recovery menu  ???

Bij mij staat Xfix er niet in, ik kan zelfs niet naar beneden scrollen.

De enige mogelijkheden die ik heb in het recovery menu zijn: resume - clear - dpkg - grub - netroot - root
Xfix staat er dus niet tussen ... Of zit ik mss ergens verkeerd te kijken?

Wat betreft de '96 - driver van NVIDIA, in de lijst van ondersteunde modellen door deze driver staat mijn grafische kaart. Volgens mij is de '96-driver trouwens een legacy driver.
« Laatst bewerkt op: 2009/11/04, 22:31:32 door Calvin »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #8 Gepost op: 2009/11/04, 23:40:01 »
Zoals op het plaatje van Track te zien is staat deze er bij onderaan, ik denk dat je met de pijltjes toetsen even naar beneden moet scrollen, in dat scherm werkt de muis niet.
In der Beschränkung zeigt sich der Meister.

Calvin

  • Gast
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #9 Gepost op: 2009/11/05, 08:21:25 »
Zoals op het plaatje van Track te zien is staat deze er bij onderaan, ik denk dat je met de pijltjes toetsen even naar beneden moet scrollen, in dat scherm werkt de muis niet.
Heb ik geprobeerd, maar bij mij is er geen scrollbalkje te zien aan de zijkant. Als ik met de pijltjestoetsen werk, kom ik na root terug bij resume. Xfix staat er echt niet tussen of onder.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #10 Gepost op: 2009/11/05, 11:00:38 »
Apart ??? Ga nog eens in de recovery mode en kies root
Type achter de prompt sudo dpkg-reconfigure xserver-xorg Bevestig alle voorstellen met ok.
Hierna opnieuw opstarten, nu zal je de nv driver hebben. Ik zit nu niet achter mijn eigen PC, dus kan ik niet kijken welke driver je wel moet hebben of welke aanpassing je eventueel in je xorg.conf moet doen.
Eerst maar kijken of je weer normaal beeld hebt.
In der Beschränkung zeigt sich der Meister.

Calvin

  • Gast
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #11 Gepost op: 2009/11/06, 08:18:15 »
Apart ??? Ga nog eens in de recovery mode en kies root
Type achter de prompt sudo dpkg-reconfigure xserver-xorg Bevestig alle voorstellen met ok.
Hierna opnieuw opstarten, nu zal je de nv driver hebben. Ik zit nu niet achter mijn eigen PC, dus kan ik niet kijken welke driver je wel moet hebben of welke aanpassing je eventueel in je xorg.conf moet doen.
Eerst maar kijken of je weer normaal beeld hebt.
Hmm ... Het werkt niet echt ...
Ik heb het volgende gedaan: Ubuntu nogmaals volledig opnieuw geïnstalleerd (lukt ondertussen al blindelings  :)). Vervolgens heb ik de voorgestelde driver niet geïnstalleerd.
Bij ubuntu software center heb ik ook nvidia '96 driver gevonden, eens geprobeerd om deze te installeren, dit lukte. Vervolgens bij 'apparaatbeheer' (denk toch dat dit zo heet) gekeken, hier stond dat ik een andere versie van de driver dan de voorgestelde gebruikte. Met jouw 'toverformule' in het achterhoofd toch maar ff de voorgestelde driver geïnstalleerd, reboot en ... een wit scherm. (Nog) geen paniek, opnieuw opgestart en via recovery mode in root 'sudo dpkg-reconfigure xserver-xorg' ingetikt. En toen gebeurde er ... niets. Wat gekraak van de HD en een seconde later stond de cursor weer vrolijk te pinken. Even een aantal krachttermen geuit ... wat uiteraard niet hielp.

Het irriteert mij verschrikkelijk dat die driver niet deftig geïnstalleerd raakt, maar ik zal niet rusten voor ik een oplossing heb ...  ;)

Iemand een goed idee? Liefst een ander idee dan ubuntu opnieuw te moeten installeren (da's eerder een work-around :)).

Offline track

  • Lid
  • Steunpunt: Nee
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #12 Gepost op: 2009/11/06, 10:23:28 »
Wat mij nu verbast is hoe het "recovery"- menu verminkt kan geraken.

Je hebt een gewone Uby 9.10 live-CD van deze site: http://www.ubuntu.com/getubuntu/download   binnengehaald toch ?
En het is geen "beta" of zoiets ?   
Kun je misschien de checksom van de CD nog een keer testen:  https://help.ubuntu.com/community/HowToMD5SUM
Eerlijk gezegd vind het toch wat raar.

track

Calvin

  • Gast
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #13 Gepost op: 2009/11/06, 12:25:40 »
Ik heb inderdaad via de vermelde site ubuntu gedownload en achteraf op cd gebrand. Zal vanavond eens cd testen.
Dit kan toch niet veroorzaakt worden door de dual-boot?

Offline track

  • Lid
  • Steunpunt: Nee
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #14 Gepost op: 2009/11/06, 13:08:57 »
Nee, "dual-boot" wordt beheerd door grub / grub2, de rest is ervan onafhankelijk.
Dus, het zit zeker ergens in de Uby 9.10- installatie.

track

Offline bms230

  • Lid
  • Steunpunt: Nee
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #15 Gepost op: 2009/11/07, 13:37:59 »
Beste Calvin,

Hier hetzelfde probleem.
Ik ben benieuwd naar de uitkomst van de installatie met de nieuwe cd.

Frederik

  • Gast
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #16 Gepost op: 2009/11/08, 11:11:54 »
Zit hier met hetzelfde probleem. Ubuntu 9.10 nu voor de derde keer geïnstalleerd vanwege Nvidia drivers waarvan Ubuntu denkt dat er betere voorhanden zijn. Als ik akkoord ga met het updaten van de drivers (er is overigens helemaal niks mis met het scherm of de resolutie) is het beeldscherm totaal niet meer te benaderen. De resolutie is zo klein dat er geen knop (en dus geen instelling) meer is om een en ander te corrigeren. Waarom die drivers aangeboden worden met zulke drastische gevolgen, mij is t een raadsel,

Calvin

  • Gast
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #17 Gepost op: 2009/11/09, 08:34:01 »
Ik heb dit weekend even md5sum gebruikt om mijn installatie-cd te controleren. De originele gedownloade iso-file had ik al met de grote schoonmaak van mijn pc verwijderd, dus deze kan ik niet meer controleren.
Als ik de cd nakijk, krijg ik volgende melding:

[..allemaal cijfers ...] Buffer I/O error on device sr0, logical block ...(weer allemaal cijfertjes, wsch het blockadres)

Ik krijg een 8-tal van deze meldingen, de laatste regel van het md5sum-rapportje zegt:

Input/output error

Wil dit nu zeggen dat de gebrande cd corrupt is?

Offline track

  • Lid
  • Steunpunt: Nee
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #18 Gepost op: 2009/11/09, 09:38:15 »
Ja Calvin, een aantal sporen of sectoren zijn botweg niet leesbaar.
Dat betekent die IO-error.  Misschien is het voldoende om de speler op te schonen,
anders wordt het een "nieuwe" CD.

Dan het best op een CD-RW, die hoef je niet weg te mikken als er fouten zijn.
(dat doe ik trouwens ook, er is immers na ½ jaar sowieso weer een nieuwe ...)

En als ook dat niet lukt kun je nog steeds met een usb-staaf installeren.
( http://wiki.ubuntu-nl.org/community/UNetbootin )

track

Calvin

  • Gast
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #19 Gepost op: 2009/11/09, 10:23:18 »
Dus, kort samengevat, ik download nogmaals ubuntu (deze keer zal ik dit niet meer verwijderen, een ezel ...  :)), vervolgens op een cd-rw'tje branden en dan duimen dat het wel lukt ...

Momenteel stond ubuntu al op een rw'tje, zal voor de zekerheid maar een nieuw nemen.

Offline maarth

  • Lid
  • Steunpunt: Nee
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #20 Gepost op: 2009/11/09, 11:08:52 »
als je de driver geinstalleerd hebt moet je even in de terminal sudo nvidia-xconfig typen
en dan pas opnieuw opstarten .
(password blijft blank als je het intikt in de terminal)

Calvin

  • Gast
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #21 Gepost op: 2009/11/10, 08:14:41 »
Gisterenavond weer een beetje aan het experimenteren geweest. Ik heb ubuntu opnieuw gedownload van de website. Vervolgens op een nieuw cd'tje gebrand en md5sum uitgevoerd, resultaat: weer I/O errors.
Om de cd te branden gebruikte ik Nero. Ik heb infrarecorder gedownload en hiermee een nieuwe image gebrand. Dit werkt blijkbaar wel!  :D
Na md5sum uitgevoerd te hebben als controle op de cd-rom helemaal geen errors. Nu dit probleempje opgelost is, heb ik er weer een nieuw bij ...
Er wordt immers een hash gegenereerd. Deze moet je controleren met deze op https://help.ubuntu.com/community/UbuntuHashes
De bij mij gegenereerde  Hash staat niet in het lijstje op bovenvermelde website. Is dit een probleem?

Offline track

  • Lid
  • Steunpunt: Nee
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #22 Gepost op: 2009/11/10, 10:21:15 »
Ja, die "hash" is maar een heel grondige checksom.  En als die niet klopt zou ik denken
dat er iets mis is.
Klopt de hash van jouw  .iso bestand dan ?  (dat is maar de eerste voorwaarde ..)

En, wat gebeurt eigenlijk als je probeert met de nieuwe CD te installeren ?

track

Calvin

  • Gast
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #23 Gepost op: 2009/11/10, 13:23:36 »
De hash van mijn .iso bestand heb ik niet gecontroleerd, ik heb direct het cd'tje gebrand.
Ik heb nog geen tijd gehad voor een nieuwe installatie.
Vanavond zal ik de iso-file eens controleren en als die ok is, zal ik eens trachten een installatie uit te voeren. Ik veronderstel dat ik best de partitie waarop ik ga installeren, eerst laat formatteren via ubuntu?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: probleem NVIDIA GeForce4 420 Go
« Reactie #24 Gepost op: 2009/11/10, 13:31:19 »
Dat kan tijdens de installatie. Mocht je wel de juiste Hash hebben en het installeren lukt weer niet, download dan de Alternate versie, staat op de zelfde site een beetje naar beneden. Dit is een tekst installatie cd, installeert direct dus geen Live cd, lijkt een beetje op hoe Windows de installatie doet.
« Laatst bewerkt op: 2009/11/10, 14:03:15 door Gijsbert »
In der Beschränkung zeigt sich der Meister.