Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu 9.10 & ATI drivers?  (gelezen 6059 keer)

Offline kilian

  • Lid
  • Steunpunt: Nee
Ubuntu 9.10 & ATI drivers?
« Gepost op: 2009/11/03, 13:31:16 »
De ATI drivers voor Ubuntu 9.04 waren gewoon slecht, dat was bekend. Ik vroeg me nu af of dit ook bij de nieuwe, 9.10, zo is.
De 3D ondersteuning van de standaard drivers is niet echt goed, dus het zou fijn zijn als ik terug met de ATI drivers kan werken, maar of dit nu gaat?

Alvast bedankt
Kilian

Offline pasiwik

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.10 & ATI drivers?
« Reactie #1 Gepost op: 2009/11/03, 13:43:32 »
Ik heb een ATI Radeon HD 2400. Bij Ubuntu 9.04 kreeg ik altijd problemen als ik de visuele effecten aanzette, zeker als er een video afspeelde. Deze problemen heb ik nu nog niet ondervonden. Dus naar mijn gevoel werken de drivers nu beter. Dit gezegd zijnde blijven die visuele effecten meestal wel afstaan bij mij, maar het gesloten stuurprogramma heb ik nog niet terug afgezet (iets wat ik in 9.04 wel had gedaan)

Offline dirkalberteverts

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.10 & ATI drivers?
« Reactie #2 Gepost op: 2009/11/04, 17:21:56 »
naar amd site gaan en de driver voor jou kaart downloaden.Er staat op de site wel hoe je hem moet installeren.Werkte voor mij nog steeds goed met elke ubuntuversie. XD XD
Dreamstudio 11.10

Offline driesv

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.10 & ATI drivers?
« Reactie #3 Gepost op: 2009/11/06, 19:52:13 »
Al iemand ervaring met ATI drivers te installeren op Ubuntu 9.10.
Ik zou graag mijn TV Out gebruiken en naar't schijnt raden ze aan om de ati drivers te gebruiken.

Het gaat om een Radeon X700.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Ubuntu 9.10 & ATI drivers?
« Reactie #4 Gepost op: 2009/11/06, 20:20:08 »
Ik heb een ATI Mobility Radeon™ HD 4570 Graphics en de driver werkt goed :) Ik kon hem alleen niet activeren via Hardware Drivers, ik moest envyng gebruiken. Maar na envyng te gebruiken doet ie het goed :)

Offline driesv

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.10 & ATI drivers?
« Reactie #5 Gepost op: 2009/11/06, 21:02:17 »
Hoe werkt envyng? Want ik heb daar geen ervaring mee.
Is dat moeilijk en houdt dat een risico in?

(Heb op dat gebied niet veel ervaring)

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Ubuntu 9.10 & ATI drivers?
« Reactie #6 Gepost op: 2009/11/06, 21:12:49 »
Het houdt in principe geen risico in. envyng installeer je via Synaptic: envyng-core en envyng-gtk

Dan doe je Alt+F2 en typ je envyng

Kies de juiste ATI-driver (meestal de "recommended") en installeer deze.
Herstart je computer et voila :)

Offline driesv

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.10 & ATI drivers?
« Reactie #7 Gepost op: 2009/11/07, 00:21:14 »
Oei, ik vind geen compatibele driver, toch niet met envyng.

Wat met de officiele ati-drivers via amd?

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.10 & ATI drivers?
« Reactie #8 Gepost op: 2009/11/07, 10:22:14 »
Ati ondersteund niet meer alle ati kaarten(vooral oude kaarten). Dus zoek of die van jouw ondersteund worden.

Zelf heb ik een ati 9600, die niet ondersteund wordt, maar bij mij wordt, denk ik, de open source driver geinstalleerd. Ik heb dus niks moeten installeren, 3d/compiz werkte, dit heb ik wel uitgezet ivm snelheid.

Offline driesv

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.10 & ATI drivers?
« Reactie #9 Gepost op: 2009/11/07, 10:35:38 »
http://support.amd.com/us/gpudownload/linux/Legacy/Pages/radeon_linux.aspx?type=2.4.1&product=2.4.1.3.18&lang=English
De laatste update is van 29 maart 2009.

Citaat van: ATI
System Requirements
        Before attempting to install the ATI CatalystTM Linux software suite, the following
        software must be installed:
            XOrg 6.8, 6.9, 7.0, 7.1, 7.2, 7.3 or 7.4
            Linux kernel 2.6 or above
            glibc version 2.2 or 2.3
            POSIX Shared Memory (/dev/shm) support is required for 3D applications
        The ATI CatalystTM Linux software suite no longer provides precompiled Kernel
        Modules; all installations require GCC compiler and kernel-headers or kernel-source in
        order to enable 2D and 3D acceleration.

For best performance and ease of use, ATI recommends the following:
    Kernel module build environment
    o Kernel source code include either the Kernel Source or Kernel Headers packages
    The RPM utility should be installed and configured correctly on your system, if you
    intend to install via RPM packages
The following packages must be installed in order for the CatalystTM Linux driver to
install and work properly:
    XFree86-Mesa-libGL
    libstdc++
    libgcc
    XFree86-libs
    fontconfig
    freetype
    zlib
    gcc

Ik gebruik momenteel de (standaard)drivers van Ubuntu en ik ben er zeer tevreden van, ik wil alleen dat mijn tv out ook werkt.
Als dat op een andere manier gaat, graag.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.10 & ATI drivers?
« Reactie #10 Gepost op: 2009/11/08, 01:08:35 »
Ik gebruik momenteel de (standaard)drivers van Ubuntu en ik ben er zeer tevreden van, ik wil alleen dat mijn tv out ook werkt.
Als dat op een andere manier gaat, graag.

Misschien ben je hier iets mee:
http://forum.ubuntu-nl.org/software-en-configuratie/kan-resolutie-niet-wijzigen/msg505434/#msg505434

En in Synaptic is er nog een pakketje: atitvout

Citaat
ATI TV Out Support Program

This utility program may be used for executing several configuration
commands for the TV Out connector of ATI Rage Mobility P/M
and some Radeon graphics boards under GNU/Linux on i386.
Primarily it is intended to enable TV Out support after bootup and
for switching the used TV standard from NTSC to PAL.
It works either on console or X.


Open een terminal en tik in: sudo apt-get install atitvout
Na install kan je in de terminal intikken: atitvout
Dan krijg je deze info te zien (lees dit eerst even voor je installeert):

gerolf@Duxie:~$ atitvout
atitvout 0.4 :: ATI Rage/Radeon TV Out configuration program
    Lennart Poettering <mz617469@poettering.de> 2001,2002
    http://www.stud.uni-hamburg.de/users/lennart/projects/atitvout/
    Licensed under the GNU General Public License,
         http://www.gnu.org/licenses/gpl.html#SEC1

Supported commands:
    help: Shows this help.
    vbe: Show some information about the VESA BIOS Extension (VBE).
    tvout: Shows some information about the TV Out connector.
    standard: Shows some information about the used TV standard.
    pal*: Sets PAL mode.
    ntsc*: Sets NTSC mode.
    detect: Shows a list of attached displays.
    active: Shows a list of all active displays.
    auto: Activates all attached displays, deactivates all others.
    off: Deactives all displays.
    l,c,t,lc,lt,ct,lct: Activates the specified display, deactivates all
                        others. (l = LCD; c = CRT; t = TV)

Use the flags -f and -r for forcing Rage Mobility/Rage LT resp. Radeon/R128 mode.
* Not available on Radeon/Rage 128.

You may specifiy more than one command on the command line. An example:

    atitvout pal auto

This command line automatically enables an attached TV and sets it to PAL mode.

PLEASE NOTE: When using the ati driver of XFree 4.1 you should rerun this
utility always after having changed the screen resolution with C-A-+ or C-A--.
Otherwise the displays may go nuts.

PLEASE NOTE: Not all ATI adapters support all of these commands. Please try them
all before complaining.

PLEASE NOTE: Most cards do not allow to activate non attached displays. All calls
to atitvout will fail if you try to enable displays which do not show up in
'atitvout detect'.

PLEASE NOTE: Not all adapters seem to support simultaneously using TV and LCD from
within Linux. Thus 'lt' may fail, while 'l' and 't' succeed. In this case 'auto'
will fail too. In fact 'auto' works only on very few adapters.

Offline driesv

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.10 & ATI drivers?
« Reactie #11 Gepost op: 2009/11/08, 13:55:02 »
Ik vrees ervoor dat Atitvout bij mij niet werkt.

Vorige week werkte ik nog in Ubuntu 9.04 (ext3-filesystem) en had ik dat geinstalleerd en mijn grafische kaart werkte niet meer onder Ubuntu. (na opstarten)
Dus had ik maar ineens beslist om Ubuntu 9.10 te installeren op een ext4-filsystem.

Dus ik vrees dat dat nu weer mijn grafische instellingen om zeep kan helpen.