Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST]Geluid: ALC1200 aan de praat krijgen  (gelezen 1852 keer)

Offline r3inhout

  • Lid
  • Steunpunt: Nee
[OPGELOST]Geluid: ALC1200 aan de praat krijgen
« Gepost op: 2009/11/02, 19:21:38 »
Hey,

Ik heb een geluidskaart met een Realtek ALC1200. Ik heb een linux driver gevonden (http://www.realtek.com.tw/downloads/downloadsview.aspx?langid=1&pfid=24&level=4&conn=3&downtypeid=3) Maar hoe zorg ik er in ubuntu voor dat het werkt? Hoe ga ik verder?

mvg,
Reinhout
« Laatst bewerkt op: 2009/11/04, 10:28:25 door r3inhout »

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Geluid: ALC1200 aan de praat krijgen
« Reactie #1 Gepost op: 2009/11/02, 19:46:05 »
Hallo Reinhout, deze geluidschip moet het gewoon doen. Welke versie van Ubuntu gebruik je? Ik zou de driver niet proberen te installeren, Ubuntu heeft deze driver al aan boord, waarschijnlijk gaat er iets anders mis. Ben je een beetje bekend met de terminal onder Ubuntu?

Offline r3inhout

  • Lid
  • Steunpunt: Nee
Re: Geluid: ALC1200 aan de praat krijgen
« Reactie #2 Gepost op: 2009/11/02, 20:31:22 »
Ik heb Karmic staan in een dual boot met vista. Ik heb geluid door 1 enkele jack van mijn kaartje. Het probleem is dat ik achteraan 5 jack's en een digitale uitgang heb en voorraan mijn pc een micro en earphone jack. Ik heb al alle opties in geluidsvoorkeuren al doorlopen maar er helpt niets.
Ik ben redelijk nieuw in ubuntu maar ik ken een kleine basis ivm de terminal.

Alvast bedankt voor je hulp

edit:
Als ik kijk in het volgende lijstje (http://www.alsa-project.org/main/index.php/Matrix:Vendor-Intel) dan staat ICH9 er niet tussen of is die lijst outdated?

info over mijn kaartje:
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
        Subsystem: Micro-Star International Co., Ltd. Device 7502
        Flags: bus master, fast devsel, latency 0, IRQ 22
        Memory at fdff4000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

« Laatst bewerkt op: 2009/11/02, 20:35:16 door r3inhout »

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Geluid: ALC1200 aan de praat krijgen
« Reactie #3 Gepost op: 2009/11/02, 20:44:53 »
Kun je dan ook de uitkomst posten van aplay -l en cat /proc/asound/card*/codec* | grep -i codec ?
Hoogstwaarschijnlijk moet je een optie toevoegen aan het bestand /etc/modprobe.d/alsa-base.conf, nu nog even uitzoeken welke.

Offline r3inhout

  • Lid
  • Steunpunt: Nee
Re: Geluid: ALC1200 aan de praat krijgen
« Reactie #4 Gepost op: 2009/11/02, 23:21:03 »
reinhout@reinhout-desktop:~$ aplay -l
**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: Intel [HDA Intel], apparaat 0: ALC1200 Analog [ALC1200 Analog]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
kaart 0: Intel [HDA Intel], apparaat 1: ALC1200 Digital [ALC1200 Digital]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0

*************************************************

reinhout@reinhout-desktop:~$ cat /proc/asound/card*/codec* | grep -i codec
Codec: Realtek ALC1200

Sorry voor het late antwoord ik was gaan trainen ;)

Offline Thomas de Graaff

  • Lid
  • Steunpunt: Nee
Re: Geluid: ALC1200 aan de praat krijgen
« Reactie #5 Gepost op: 2009/11/02, 23:28:36 »
Wat ik ervan begrepen heb is dat de driver voor deze geluidskaart niet genoeg is.. Iedere fabrikant maakt weer zijn eigen configuratie van de hardware. Bij mijn laptop is het nodig om bij deze kaart in /etc/modprobe.d/alsa-base of /etc/modprobe.d/alsa.cfg aan het einde de lijn
options snd-hda-intel model=targa-digtoe te voegen.

Voor verschillende modellen computers is dit weer anders. Meer info hierover is te vinden in het bestand:

ALSA-Configuration.txt.gz

te vinden door in een terminal te typen:
locate ALSA-Configuration.txt.gz
meer info:

https://help.ubuntu.com/community/HdaIntelSoundHowto

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Geluid: ALC1200 aan de praat krijgen
« Reactie #6 Gepost op: 2009/11/02, 23:55:02 »
Voor de ALC1200 zou je kunnen proberen de volgende regel toe te voegen aan /etc/modprobe.d/alsa-base.conf:
options snd-hda-intel probe_mask=1
Dit kun je het beste als volgt doen:
sudo cp /etc/modprobe.d/alsa-base.conf /etc/modprobe.d/alsa-base.conf.orig (kopietje maken, je weet maar nooit)
sudo gedit /etc/modprobe.d/alsa-base.conf en dan op het eind de regel erbij zetten, opslaan en afsluiten.
sudo alsa force-reload herstart de soundstack en hopelijk werkt het dan.

Bron: http://ubuntuforums.org/showthread.php?t=843012&highlight=alc1200
« Laatst bewerkt op: 2009/11/02, 23:59:23 door AutoStatic »

Offline r3inhout

  • Lid
  • Steunpunt: Nee
Re: Geluid: ALC1200 aan de praat krijgen
« Reactie #7 Gepost op: 2009/11/03, 00:10:35 »
Voor de ALC1200 zou je kunnen proberen de volgende regel toe te voegen aan /etc/modprobe.d/alsa-base.conf:
options snd-hda-intel probe_mask=1
Dit kun je het beste als volgt doen:
sudo cp /etc/modprobe.d/alsa-base.conf /etc/modprobe.d/alsa-base.conf.orig (kopietje maken, je weet maar nooit)
sudo gedit /etc/modprobe.d/alsa-base.conf en dan op het eind de regel erbij zetten, opslaan en afsluiten.
sudo alsa force-reload herstart de soundstack en hopelijk werkt het dan.

Bron: http://ubuntuforums.org/showthread.php?t=843012&highlight=alc1200

Ik krijg nu af en toe (zomaar opeens plopjes door mijn speakers :s) alsof er iemand de jack uittrekt ofzo...

Edit:
Ik heb de jack's eens losgetrokken en even andere gaatjes geprobeerd. Het geluid is nu ok :)
SSout (sides?), CSout (centrum?) en RSout (rear, achter?) werken als geluidsbron. Dan heb ik nog een digitaal gaatje, en SPDIF. Dan zijn er nog 2 andere jacks met een tekentje naast, iets als: (((->))) waarvan ik absoluut niet kan raden wat ze betekenen :s
De plopjes zijn er ook nog altijd :s
« Laatst bewerkt op: 2009/11/03, 01:02:10 door r3inhout »

Offline r3inhout

  • Lid
  • Steunpunt: Nee
Re: Geluid: ALC1200 aan de praat krijgen
« Reactie #8 Gepost op: 2009/11/03, 11:59:48 »
Wat ik ervan begrepen heb is dat de driver voor deze geluidskaart niet genoeg is.. Iedere fabrikant maakt weer zijn eigen configuratie van de hardware. Bij mijn laptop is het nodig om bij deze kaart in /etc/modprobe.d/alsa-base of /etc/modprobe.d/alsa.cfg aan het einde de lijn
options snd-hda-intel model=targa-digtoe te voegen.

Voor verschillende modellen computers is dit weer anders. Meer info hierover is te vinden in het bestand:

ALSA-Configuration.txt.gz

te vinden door in een terminal te typen:
locate ALSA-Configuration.txt.gz
meer info:

https://help.ubuntu.com/community/HdaIntelSoundHowto

Deze heb ik al eens doorlopen maar er staat geen model tussen die overeenkomt met de ALC1200. Moet ik ze dan gewoon 1 voor een allemaal proberen tot alles werkt?

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Geluid: ALC1200 aan de praat krijgen
« Reactie #9 Gepost op: 2009/11/03, 12:41:41 »
Nee, er is geen specifieke codec instelling voor de ALC1200 dus dat heeft niet zo veel zin.
Die plopjes worden misschien veroorzaakt door PulseAudio. Als je in je Sound Properties alles op Alsa zet ipv Autodetect, maakt dat wat uit?

Offline Thomas de Graaff

  • Lid
  • Steunpunt: Nee
Re: Geluid: ALC1200 aan de praat krijgen
« Reactie #10 Gepost op: 2009/11/03, 17:15:16 »

Deze heb ik al eens doorlopen maar er staat geen model tussen die overeenkomt met de ALC1200. Moet ik ze dan gewoon 1 voor een allemaal proberen tot alles werkt?

Kijk eens bij de opties bij ALC888 deze wordt volgens mij gebruikt voor ALC1200 op het moment. (Ik weet niet meer precies waar ik dat vandaan had, maar het werkt bij mij in ieder geval).

Offline r3inhout

  • Lid
  • Steunpunt: Nee
Re: Geluid: ALC1200 aan de praat krijgen
« Reactie #11 Gepost op: 2009/11/04, 10:27:05 »
Bedankt beide :D Mijn geluid gaat nu zonder morren, enkel mijn earphone plug gaat niet maar daar kan ik mee leven ;)
Een dikke merci :)

mvg,
Reinhout