Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: opgelost:plopgeluidjes  (gelezen 3319 keer)

Offline maarth

  • Lid
  • Steunpunt: Nee
opgelost:plopgeluidjes
« Gepost op: 2009/11/02, 11:31:38 »
als ik op mijn medion laptop werkt en ik start totem of mplayer op en dan hoor je
zo,n pok geluid.
op de desktop helemaal geen last van alleen met uitschakelen .
mijn vraag is ,is hier nog wat aan te doen en of er meer mensen last van hebben .
alvast bedankt voor de reakties.
« Laatst bewerkt op: 2009/11/08, 09:51:04 door maarth »

Offline ubby

  • Lid
  • Steunpunt: Nee
Re: plopgeluidjes
« Reactie #1 Gepost op: 2009/11/02, 12:11:21 »
Dat viel mij gister ook op :)
Wat de oorzaak is weet ik.

Offline Dave

  • Lid
  • Steunpunt: Nee
Re: plopgeluidjes
« Reactie #2 Gepost op: 2009/11/02, 18:24:58 »
kabouter plop in de buurt?





ubbie je verteld nog wel verder toch na dit antwoord?

Offline Robb987

  • Lid
  • Steunpunt: Nee
Re: plopgeluidjes
« Reactie #3 Gepost op: 2009/11/02, 19:02:09 »
Helaas heb ik sinds de update van 9.04 naar 9.10 exact dezelfde hinderlijke tikken in de speakers bij starten en stoppen van geluid afspelen. Nooit eerder meegemaakt sinds Ubuntu 7.04. Geluid speelt verder in prima kwaliteit af.

Het gebeurd bij alle programma's en internetpagina's met geluid (youtube) waarbij geluid gebruikt wordt. Ook bij het opstarten van de laptop (een HP Pavilion dv6361eu) en het weer afsluiten.

lspci -vvv

00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
   Subsystem: Hewlett-Packard Company Device 30b7
   Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
   Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 0 (500ns min, 1250ns max)
   Interrupt: pin B routed to IRQ 21
   Region 0: Memory at c0000000 (32-bit, non-prefetchable) [size=16K]
   Capabilities: [44] Power Management version 2
      Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot+,D3cold+)
      Status: D0 PME-Enable- DSel=0 DScale=0 PME-
   Capabilities: [50] Message Signalled Interrupts: Mask+ 64bit+ Queue=0/0 Enable-
      Address: 0000000000000000  Data: 0000
      Masking: 00000000  Pending: 00000000
   Capabilities: [6c] HyperTransport: MSI Mapping Enable- Fixed+
   Kernel driver in use: HDA Intel
   Kernel modules: snd-hda-intel

Bijlagen en meer informatie op verzoek beschikbaar.

Hopelijk weet iemand een oplossing want het is niet echt gaaf.

Offline pasiwik

  • Lid
  • Steunpunt: Nee
Re: plopgeluidjes
« Reactie #4 Gepost op: 2009/11/02, 19:54:50 »
zelfde probleem hier

Offline Jan E.

  • Lid
  • Steunpunt: Nee
Re: plopgeluidjes
« Reactie #5 Gepost op: 2009/11/02, 19:59:46 »
Idem hier. Dit is overigens het enige minpuntje wat ik tot nu toe heb kunnen ontdekken...

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
   Subsystem: Hewlett-Packard Company Device 30c3
   Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
   Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 0, Cache Line Size: 64 bytes
   Interrupt: pin A routed to IRQ 17
   Region 0: Memory at e8044000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: HDA Intel
   Kernel modules: snd-hda-intel



Samsung NP300E7A
Ubuntu 14.04

Offline Robertos

  • Lid
  • Steunpunt: Nee
Re: plopgeluidjes
« Reactie #6 Gepost op: 2009/11/02, 23:14:47 »
Ik kan me ook bij deze rij aansluiten.
Het geluid is verder prima op het plop/tik geluidje in het begin na, het betreft een iiyama scherm met ingebouwde speakers.
Erg hard hoor je dat niet, maar een oplossing zou uiteraard fijn zijn.

Hier staat een mogelijke oplossing (voor mij jammer genoeg niet): http://ubuntuforums.org/showthread.php?t=1309846


Offline Dave

  • Lid
  • Steunpunt: Nee
Re: plopgeluidjes
« Reactie #7 Gepost op: 2009/11/02, 23:19:35 »
nog niet gehoord. toch maar eens op letten dan.

Offline Robb987

  • Lid
  • Steunpunt: Nee
Re: plopgeluidjes
« Reactie #8 Gepost op: 2009/11/02, 23:40:27 »
Ik ben er denk ik wel achter wat er gebeurd. O0

Let op: uitvoeren van de beschreven acties is geheel op eigen risico. Zorg voor een goede back-up!!

Via https://help.ubuntu.com/community/SoundTroubleshooting#Having%20sound%20issues%20with%20HP%20dvx%20laptop deze link kwam ik onder het kopje "Is ALSA using the correct model?" de stappen tegen die me naar de oplossing hielpen.

Ik heb het script uitgevoerd en opgestuurd, dat laatste is niet echt nodig, als je de uitvoer kunt opslaan is voldoende. Ik heb de stappen gevolgt voor mijn geluidskaart. Uiteindelijk bleek module snd-hda-intel gebruikt te worden in "/etc/modprobe.d/alsa-base.conf" In dit bestand staat een powersave option helemaal onderaan.

Dit bracht mij op het idee dat de oorzaak wel eens deze powersave functie kan zijn. Het document op deze http://git.alsa-project.org/?p=alsa-kmirror.git;a=blob;f=Documentation/powersave.txt;h=9657e8099228ddf128fcca227324633faa919835;hb=96628985cf737e8c96412609eba4fbcd142aceb4 alsawebsite bevestigd dit in theorie.

volgens
# cat /sys/module/snd_hda_intel/parameters/power_savewas de waarde bij mij initieel 10 (let op: snd_hda_intel geldt voor mijn geluidskaart, bij u kan deze module afwijken).

Ik heb getest of the timeout inderdaad wordt beinvloed door:
# echo 5 > /sys/module/snd_hda_intel/parameters/power_saveDit blijkt het geval (de tijd tussen einde muziekbestand tot click was ervoor 14s en 9s na deze aanpassing).

Ik heb het volgende commando in de terminal gebruikt om het muziekbestand test.wav te spelen:  
$ aplay -vv test.wav
Wil je dus energie besparen, de standaard instelling, dan blijven de klikgeluiden. Wil je er echt van af dan kun je de waarde op 0 seconden instellen. Ik heb dat niet getest.

<edit> Robertos was me net voor terwijl ik aan het typen was.
« Laatst bewerkt op: 2009/11/02, 23:43:02 door Robb987 »

Offline maarth

  • Lid
  • Steunpunt: Nee
Re: plopgeluidjes
« Reactie #9 Gepost op: 2009/11/03, 02:13:52 »
bedankt voor alle berichten ben toch niet de enige dus, dan gaan ze er wel aan werken.

Offline colapunk

  • Lid
  • Steunpunt: Nee
Re: plopgeluidjes
« Reactie #10 Gepost op: 2009/11/07, 13:18:17 »
yeah! robbs tip deed voor mij de trick!

heerlijk, hoe bewerkbaar linux keer op keer blijkt :D

Offline Dave

  • Lid
  • Steunpunt: Nee
Re: plopgeluidjes
« Reactie #11 Gepost op: 2009/11/07, 17:40:04 »
nog niet gehoord. toch maar eens op letten dan.


Heb het echt niet kunnen ontdekken maar gelukkig heb je een oplossing gekregen

Offline maarth

  • Lid
  • Steunpunt: Nee
Re: opgelost:plopgeluidjes
« Reactie #12 Gepost op: 2009/11/08, 11:58:27 »
op de desktop had ik ook geen enkele last,en op de medionflaptop is het ook opgelost.
ik heb in de terminal sudo gedit /etc/modprobe.d/alsa-base.conf ingetikt onderop bij powersave=10 veranderd in een 0
op opslaan drukken opnieuw opstarten en het is weg.
nog bedankt voor alle reakties en je kan toch zien dat het opensource model werkt want foutjes worden echt snel opgelost
als het mogelijk is. :D :D :D

Offline midas

  • Lid
  • Steunpunt: Nee
Re: opgelost:plopgeluidjes
« Reactie #13 Gepost op: 2009/11/08, 12:29:16 »
Héhé...bij mij ook eindelijk onder Kubuntu Karmic opgelost. Het betreft precies hetzelfde document waarvan de laatste regel moet worden geblacklisted. Bedankt!
Linux Mint 18.3 Cinnamon (64-bits)