Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] 9.10 en NVidia-settings  (gelezen 3770 keer)

Offline MKe

  • Lid
  • Steunpunt: Nee
[OPGELOST] 9.10 en NVidia-settings
« Gepost op: 2009/10/30, 08:28:13 »
Hoi,

Ik heb net de final van 9.10 geïnstalleerd. Werkt prima tot nu toe. Om mijn Geforce 7600 aan te sturen heb ik ook de gesloten drivers van NVidia geïnstalleerd (versie 185), net zoals ik voorheen op 8.04 en 9.04 heb gedaan. De driver lijkt goed te werken. Hierbij komt ook het programma nvidia-settings, waarmee je grafisch de instellingen kunt wijzigen.  Nu wordt de beeldscherm verversing standaard op 60hz gezet en dat geeft een beetje wazig beeld. Ik wil dat daarom veranderen in 75 hz. Dit gaat wel, maar ik kan de instellingen niet opslaan. Ik krijg de melding: "Failed to parse existing X config file '/etc/X11/xorg.conf'!". Het is geen rechten kwestie, aangezien ik nvidia-settings heb opgestart met sudo.
Is dit een bug in de nvidia software? Hoe kan ik alsnog de refreshrate op 75Hz instellen?

Ik heb een LG Flatron L1919S beeldscherm en een GF 7600 GS kaart.
« Laatst bewerkt op: 2009/10/30, 15:15:36 door MKe »
Mijn blokkendoos blog: http://mke21.wordpress.com/

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: 9.10 en NVidia-settings
« Reactie #1 Gepost op: 2009/10/30, 08:57:47 »
Blijvende instellingen. Alt F2 >   Of Terminalvenster 
gksudo nvidia-settings

grj

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: 9.10 en NVidia-settings
« Reactie #2 Gepost op: 2009/10/30, 09:04:43 »
Blijvende instellingen. Alt F2 >   Of Terminalvenster 
gksudo nvidia-settings

grj
Joop, de topicstarter zegt toch juist dat hij dat al doet ???

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: 9.10 en NVidia-settings
« Reactie #3 Gepost op: 2009/10/30, 09:10:01 »
Cumulus007 , de topicstarter zegt ook

Blijvende instellingen. Alt F2 >   Of Terminalvenster 
gksudo nvidia-settings

grj
Joop, de topicstarter zegt toch juist dat hij dat al doet ???


aangezien ik nvidia-settings heb opgestart met sudo.
« Laatst bewerkt op: 2009/10/30, 09:12:51 door joop905 »

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: 9.10 en NVidia-settings
« Reactie #4 Gepost op: 2009/10/30, 09:12:22 »
Dus hij heeft het programma al opgestart via root... wat wil je er dan mee zeggen?

Offline MKe

  • Lid
  • Steunpunt: Nee
Re: 9.10 en NVidia-settings
« Reactie #5 Gepost op: 2009/10/30, 10:26:54 »
Blijvende instellingen. Alt F2 >   Of Terminalvenster  
gksudo nvidia-settings

grj

Dat had ik inderdaad ook al verzonnen.
Met de hand dingen in de config file toevoegen zou dan kunnen werken (al blijft het jammer van de grafische interface). Wat zet je er dan in (ik ben nog steeds een newbie :) )?
« Laatst bewerkt op: 2009/10/30, 11:48:42 door MKe »
Mijn blokkendoos blog: http://mke21.wordpress.com/

Offline Wybren

  • Lid
  • Steunpunt: Nee
Re: 9.10 en NVidia-settings
« Reactie #6 Gepost op: 2009/10/30, 11:20:27 »
Ik heb precies hetzelfde probleem, alleen probeer ik 2 beeldschermen te installeren.

VALIDATION ERROR:  Data incomplete in file /etc/X11/xorg.conf.
Undefined Device "(null)" referenced by Screen "Default Screen".

Segmentatiefout

Ook al van alles geprobeerd, alle effecten op 0, zoveel mogelijk programma's gesloten etc. maar nog geen resultaat.

Offline pietermeurs

  • Lid
  • Steunpunt: Nee
Re: 9.10 en NVidia-settings
« Reactie #7 Gepost op: 2009/10/30, 11:58:54 »
Ik heb ook een probleem met mijn Nvidia. Bij 9.04 geen enkel probleem, gaf ie na de installatie gewoon aan dat er besturingsprogrammas waren, maar bij clean install van 9.10 helemaal niks. Bovendien geeft ie, nadat ik nvidia-setting heb geïnstalleerd via synaptic en wil starten (voor m'n dual-screen instellingen), volgende foutmelding: "you do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run 'nvidia-xconfig' as root), and restart the X server".

Wanneer ik in een terminal nvidia-xconfig wil doen, geeft ie:
Het programma 'nvidia-xconfig' kan gevonden worden in de volgende pakketten:
 * nvidia-glx-173
 * nvidia-glx-185
 * nvidia-glx-96
Probeer: sudo apt-get install <geselecteerd pakket>
nvidia-xconfig: command not found

Wat moet ik doen? Ik werk op een laptop, Lenovo 3000 n200, met geloof ik een geforce 7300

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: 9.10 en NVidia-settings
« Reactie #8 Gepost op: 2009/10/30, 12:06:43 »
Dan kun je de 185 installeren.

Offline tabasco

  • Lid
  • Steunpunt: Nee
Re: 9.10 en NVidia-settings
« Reactie #9 Gepost op: 2009/10/30, 13:06:36 »
[...]
Ik krijg de melding: "Failed to parse existing X config file '/etc/X11/xorg.conf'!". Het is geen rechten kwestie, aangezien ik nvidia-settings heb opgestart met sudo.
Is dit een bug in de nvidia software? Hoe kan ik alsnog de refreshrate op 75Hz instellen?
[...]
hoi, ik kon ook na een nieuwe installatie mijn resolutie niet wijzigen vanwege een zelfde soort fout. dit heb ik opgelost door zelf mijn xorg.conf aan te passen (al vaker gedaan)

Hier heb ik overigens een oplossing gevonden voor dit probleem mocht je het via nvidia-settings (grafisch) willen doen.
Voer deze drie stappen eerst uit in een terminal:
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
sudo nvidia-xconfig
sudo nvidia-settings
Stap 1 maakt een backup
Stap 2 maakt een leesbare xorg.conf voor het nvidia-settings programma
Stap 3 maak de juiste instelling en sla deze op

Offline Wybren

  • Lid
  • Steunpunt: Nee
Re: 9.10 en NVidia-settings
« Reactie #10 Gepost op: 2009/10/30, 13:33:32 »
[...]
Ik krijg de melding: "Failed to parse existing X config file '/etc/X11/xorg.conf'!". Het is geen rechten kwestie, aangezien ik nvidia-settings heb opgestart met sudo.
Is dit een bug in de nvidia software? Hoe kan ik alsnog de refreshrate op 75Hz instellen?
[...]
hoi, ik kon ook na een nieuwe installatie mijn resolutie niet wijzigen vanwege een zelfde soort fout. dit heb ik opgelost door zelf mijn xorg.conf aan te passen (al vaker gedaan)

Hier heb ik overigens een oplossing gevonden voor dit probleem mocht je het via nvidia-settings (grafisch) willen doen.
Voer deze drie stappen eerst uit in een terminal:
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
sudo nvidia-xconfig
sudo nvidia-settings
Stap 1 maakt een backup
Stap 2 maakt een leesbare xorg.conf voor het nvidia-settings programma
Stap 3 maak de juiste instelling en sla deze op


Oke, dit werkt. Juiste configuratie gekozen, instellingen opslaan lukte.

Maar: als ik reboot kom ik niet in de GUI terecht. Ik kom in een commandline terecht. Ziet er hetzelfde uit als ctrl alt f2. (Sorry ben een beginneling, weet niet hoe dat heet)

Hoe krijg ik nu mn backup terug?

Offline tabasco

  • Lid
  • Steunpunt: Nee
Re: 9.10 en NVidia-settings
« Reactie #11 Gepost op: 2009/10/30, 13:39:16 »
@Wybren,
Jij hebt een heel andere fout dan waar ik op reageerde!

Je kunt je back-up terug zetten door in te loggen en het volgende commando uit te voeren:
sudo cp /etc/X11/xorg.conf.bak /etc/X11/xorg.conf

Offline Wybren

  • Lid
  • Steunpunt: Nee
Re: 9.10 en NVidia-settings
« Reactie #12 Gepost op: 2009/10/30, 15:09:48 »
@Wybren,
Jij hebt een heel andere fout dan waar ik op reageerde!

Je kunt je back-up terug zetten door in te loggen en het volgende commando uit te voeren:
sudo cp /etc/X11/xorg.conf.bak /etc/X11/xorg.conf

Oké, ik dacht het werkt misschien ook voor mij.. Maar ik het is weer hersteld.

Offline MKe

  • Lid
  • Steunpunt: Nee
Re: 9.10 en NVidia-settings
« Reactie #13 Gepost op: 2009/10/30, 15:15:09 »
hoi, ik kon ook na een nieuwe installatie mijn resolutie niet wijzigen vanwege een zelfde soort fout. dit heb ik opgelost door zelf mijn xorg.conf aan te passen (al vaker gedaan)

Hier heb ik overigens een oplossing gevonden voor dit probleem mocht je het via nvidia-settings (grafisch) willen doen.
Voer deze drie stappen eerst uit in een terminal:
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
sudo nvidia-xconfig
sudo nvidia-settings
Stap 1 maakt een backup
Stap 2 maakt een leesbare xorg.conf voor het nvidia-settings programma
Stap 3 maak de juiste instelling en sla deze op


Werkte uitstekend, bedankt!

Offline Wybren

  • Lid
  • Steunpunt: Nee
Re: [OPGELOST] 9.10 en NVidia-settings
« Reactie #14 Gepost op: 2009/10/30, 16:04:18 »
Iemand een oplossing voor mijn probleem of kan ik beter een nieuw topic openen?

Offline tabasco

  • Lid
  • Steunpunt: Nee
Re: [OPGELOST] 9.10 en NVidia-settings
« Reactie #15 Gepost op: 2009/10/30, 17:03:06 »
@femke98: druk wat vaker op F5 ;) (deze pagina stond volgens mij al een tijdje opgelost)

Offline MKe

  • Lid
  • Steunpunt: Nee
Re: [OPGELOST] 9.10 en NVidia-settings
« Reactie #16 Gepost op: 2009/10/31, 12:03:16 »
@femke98: druk wat vaker op F5 ;) (deze pagina stond volgens mij al een tijdje opgelost)
Toen ik deze las, nog niet hoor!

Toch had ik dat al een uur voordat je reageerde [OPGELOST] ervoor gezet  ??? Nou ja, het is opgelost in ieder geval.