Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Extra grafische effecten en games werken niet meer na upgrade naar 9.10 (Radeon)  (gelezen 1272 keer)

Maikel Steneker

  • Gast
Goedemiddag,

Ik heb gisteren mijn installatie van Ubuntu 9.04 geupgrade naar de release candidate van 9.10 via "update-manager -d". Het is niet de eerste keer dat ik dat doe (deze installatie was oorspronkelijk versie 8.04) en het is tot nu toe altijd bijna vlekkeloos verlopen.

Gisteren was ik erg tevreden met mijn upgrade; alles werkte nog zoals het hoort. Omdat ik een aantal extra repositries had (van o.a. Wine) liet ik het installatieprogramma mijn computer niet opschonen; in plaats daarvan heb ik dat achteraf gedaan via "apt-get autoremove".

Vandaag bleken echter ineens de grafische effecten van mijn installatie uitgezet te zijn (opnieuw aanzetten werkt niet) en kon ik mijn enige geïnstalleerde game (World of Goo) slechts op een fractie van de snelheid draaien! Ik heb daarom in Synaptic gekeken, waar ineens de fglrx-drivers ontbraken (die ik, als ik het me goed herinner, wel geïnstalleerd had).

Mijn videokaart is trouwens een ATI Radeon 9250. Ik heb nooit veel hoeven te doen om 'm aan de praat te krijgen; ik meen dat ik gevraagd werd om de drivers te installeren en toen werkte alles prima, ook na alle upgrades.

Wie kan mij op weg helpen?


Edit: ik heb zojuist xorg.conf vervangen door xorg.conf.dist-upgrade-200910231557 (de backup die gisteren automatisch gemaakt is) en alles werkt nu weer perfect :)
« Laatst bewerkt op: 2009/10/24, 14:49:51 door Maikel Steneker »

Offline shinger

  • Lid
    • shingeri
  • Steunpunt: Nee
Maar jij hebt een legacy ati kaartje toch. dus niet de HD series. Als goed is zouden die drivers niet werken op 9.04 en verder.

Maikel Steneker

  • Gast
Maar jij hebt een legacy ati kaartje toch. dus niet de HD series. Als goed is zouden die drivers niet werken op 9.04 en verder.
't Is geen HD kaartje inderdaad, maar vreemd genoeg werkt het perfect. Ik heb alleen geen idee welke drivers ik nu gebruik.

Offline shinger

  • Lid
    • shingeri
  • Steunpunt: Nee
Als je bij hardware drivers kijkt zie je dan dat hij ati drivers heeft geinstalleerd en welke als ik vragen mag? misschien een screen?

Offline heir4c

  • Lid
  • Steunpunt: Nee
Maikel, jij hebt jouw ati 9250 kunnen doen werken met de fglrx? Dat is de eerste keer dat ik dat hier zie. Heb zelf een ASUS A9250 (ati-kaart maar uitgebracht door ASUS) maar de fglrx werkt hier niet. Voor deze kaart werd er ook nooit een voorstel gedaan onder Systeem>Beheer>HardwareDrivers. Dus altijd gewerkt met de OpenDrivers.
Vreemd. Maar misschien kon dit wel onder 8.04 en is die blijven staan met je upgrade naar 9.04.
Sowieso onder 9.10 werkt mijn kaart beter maar nog altijd met de OpenDrivers.
Geen voorstel in HardwareDrivers.

Maikel Steneker

  • Gast
Als je bij hardware drivers kijkt zie je dan dat hij ati drivers heeft geinstalleerd en welke als ik vragen mag? misschien een screen?
De ATI drivers staan er niet bij.

Maikel, jij hebt jouw ati 9250 kunnen doen werken met de fglrx? Dat is de eerste keer dat ik dat hier zie. Heb zelf een ASUS A9250 (ati-kaart maar uitgebracht door ASUS) maar de fglrx werkt hier niet. Voor deze kaart werd er ook nooit een voorstel gedaan onder Systeem>Beheer>HardwareDrivers. Dus altijd gewerkt met de OpenDrivers.
Vreemd. Maar misschien kon dit wel onder 8.04 en is die blijven staan met je upgrade naar 9.04.
Sowieso onder 9.10 werkt mijn kaart beter maar nog altijd met de OpenDrivers.
Geen voorstel in HardwareDrivers.

Zal ik maar eerlijk zeggen dat ik geen idee heb? :-[ Het enige wat ik zeker weet is dat hij World of Goo kan draaien en dat de speciale desktopeffecten werken op de hoogste stand. Als de open source drivers dat ook kunnen kan het goed zijn dat ik die gebruik.

Heeft iemand misschien een consolecommando waarmee ik snel kan controleren welke drivers geladen zijn?

Offline heir4c

  • Lid
  • Steunpunt: Nee
Er is zo'n commando maar kan niet direct zeggen hoe dat eruit ziet.
Je kan wel via Synaptic zoeken op fglrx (uiterste zoekfunctie, dus niet het invulveld dat je ziet) en dan zou je moeten zien of de fglrx-driver geïnstalleerd staat.

Ik zit nu in 9.10 en mijn visuele effecten staan op extra (met de OpenDrivers) Dat kon ik niet in vroegere versies.
Maar als je de compiz effecten instelt en daarna naar Systeem>Voorkeuren>Uiterlijk>VisueleEffecten gaat gaan kijken, zal je zien dat de drie cirkeltjes leeg zijn. Klik die niet weer aan anders ben je weer compiz-effecten kwijt.
Dat is blijkbaar zo bij sommige ati en zeker bij de 9250 zoals de mijne.

Hier staan compiz uit omdat ik met een oude cpu zit (een Pen ll) en dat gaat dan heel traag die cube enzo.

Maikel Steneker

  • Gast
Er is zo'n commando maar kan niet direct zeggen hoe dat eruit ziet.
Je kan wel via Synaptic zoeken op fglrx (uiterste zoekfunctie, dus niet het invulveld dat je ziet) en dan zou je moeten zien of de fglrx-driver geïnstalleerd staat.
xserver-xorg-video-radeon staat geïnstalleerd. Ik zie nu wel iets interessants in de omschrijving staan:
Citaat
Note that this is not the same as the ATI-provided, binary-only, 'fglrx'
driver, which provides additional 3D functionality for some newer Radeon
cards, but is not supported.
Ik zit nu in 9.10 en mijn visuele effecten staan op extra (met de OpenDrivers) Dat kon ik niet in vroegere versies.
Maar als je de compiz effecten instelt en daarna naar Systeem>Voorkeuren>Uiterlijk>VisueleEffecten gaat gaan kijken, zal je zien dat de drie cirkeltjes leeg zijn. Klik die niet weer aan anders ben je weer compiz-effecten kwijt.
Dat is blijkbaar zo bij sommige ati en zeker bij de 9250 zoals de mijne.

Hier staan compiz uit omdat ik met een oude cpu zit (een Pen ll) en dat gaat dan heel traag die cube enzo.
Is dat niet precies zoals het hoort? Zoals ik het begrijp zijn die drie cirkeltjes vooraf ingestelde profielen. Als je compiz handmatig gaat instellen wordt een vierde cirkeltje geactiveerd (Aangepast).
Ik heb zelf een Pentium 4, dus Compiz draait hier goed met de standaard "Extra" instellingen.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Nee, ik krijg dan geen vierde cirkeltje met aangepast. De drie zijn gewoon leeg en als ik er één terug aanvinkt dan verdwijnen mijn compiz instellingen, zoals jij aangeeft.
Nou, ja, het werkt en dat is al heel goed.