Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Xine  (gelezen 925 keer)

Nieuwux

  • Gast
Xine
« Gepost op: 2006/10/31, 17:41:50 »
Hoi,

Ik wil de 'Xine' installeren. Moet ik Xine-ui hebben of gxine... what is the differents? Of is er nog een andere betere dvd-player?

  en nu staan er wel introducties voor instructie op de site, maar daar kan ik niet echt iets uit wijs worden. Kan iemand me bij den hand nemen?
Deze twee bestanden heb ik gedownloaded:

xine-lib-1.1.1.tar.gz
xine-ui-0.99.4.tar.gz

Instructions:

 Download the latest xine-lib and gxine/xine-ui tarballs, then follow these instruction. To unpack a tarball, use:

   tar xfvz tarballname.tar.gz

The following instructions will install xine in /usr/local where it will be visible for all users. You need root privileges to do this on most systems.

After unpacking xine-lib, issue:

   ./configure
   make install

Make sure your /etc/ld.so.conf contains /usr/local/lib and continue with:

   ldconfig

Now unpack your frontend (gxine or xine-ui or ...), then:

   ./configure
   make install

Complete build instructions

The build process is the same for all of the xine modules.

You have to start with xine-lib. If built and installed successfully, you can continue with the frontend(s).

If you have installed xine-lib to a non-standard prefix, make sure that you have $prefix/bin in your PATH and that your linker finds libs in $prefix/lib - otherwise trying to build modules that rely on xine-lib will fail with configure complaining about not finding certain parts of libxine. Using bash you can do something like:

   export PATH="$prefix/bin:$PATH"
   export LD_LIBRARY_PATH="$prefix/lib:$LD_LIBRARY_PATH"

to make sure libxine can be found by the frontend(s).

Last but not least. Here the build instructions. As stated earlier, those are the same for every xine module.

   ./autogen.sh [-> *only* if you checked your sources out of CVS]
   ./configure
   make
   make install

Alvast bedankt.

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
Xine
« Reactie #1 Gepost op: 2006/10/31, 17:47:55 »
Niet via de site downloaden!
Of via System> Administration>Synaptic package manager de pakket gxine installeren.
Of in Applications>Accessories>Terminal hetvolgende commando intikken:
sudo apt-get install gxine

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Xine
« Reactie #2 Gepost op: 2006/10/31, 17:48:37 »
die xine-ui: User Interface
die xine-lib: library
Je hebt ze bijde nodig.

Waarom doe je ze moeilijk?
Kijk eens ff in Synaptic pakketbeheer. Ze staan er gewoon in hoor.
Gebruik maar ff de zoek-knop en 't woord xine
Er staan nog leuke players in zoals codeine en gxine (met een look die beter bij gnome past)
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Xine
« Reactie #3 Gepost op: 2006/10/31, 17:49:30 »
dedju, Kiwinote is me voor ...
Nu ja, hij geeft de Terminal manier aan, ik de grafische ;)
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
Xine
« Reactie #4 Gepost op: 2006/10/31, 17:59:17 »
Citaat van: bartek
die xine-ui: User Interface
die xine-lib: library
Je hebt ze beide nodig.
Als je gxine installeert worden gelijk alle dependencies opgelost.
Gxine is zelf al een ui en je hebt als ik me niet vergis geen xine-ui nodig.
Xine-lib komt niet voor, deze heet libxine1, maar wordt automatisch geinstalleerd bij het installeren van gxine.
Zie eerdere post voor installatie mogelijkheden.

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Xine
« Reactie #5 Gepost op: 2006/10/31, 18:04:11 »
klopt, ik gaf de betekenis van de woorden die hij zelf gaf.
Ik ben daarna begonnen over synaptic maar dat staat los van mijn verklarende woordenlijst.
Sorry als er daar verwarring ontstaat.
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
Xine
« Reactie #6 Gepost op: 2006/10/31, 18:11:12 »
Maakt niet uit, ik dacht misschien dat Nieuwux in verwarring zou raken door pakketen die niet geinstalleerd hoefden te worden en die niet bestonden, vandaar dat ik het even uitlegde, was meer voor hem bedoeld.

Nieuwux

  • Gast
Xine
« Reactie #7 Gepost op: 2006/11/01, 16:18:47 »
Citaat van: Kiwinote
Citaat van: bartek
die xine-ui: User Interface
die xine-lib: library
Je hebt ze beide nodig.
Als je gxine installeert worden gelijk alle dependencies opgelost.
Gxine is zelf al een ui en je hebt als ik me niet vergis geen xine-ui nodig.
Xine-lib komt niet voor, deze heet libxine1, maar wordt automatisch geinstalleerd bij het installeren van gxine.
Zie eerdere post voor installatie mogelijkheden.
Bedankt allebei!