Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: F-spot: compile hulp gezocht  (gelezen 1406 keer)

Offline blokkendoos

  • Lid
  • Steunpunt: Nee
F-spot: compile hulp gezocht
« Gepost op: 2009/10/15, 13:02:08 »
Ik wil graag de laatste versie van F-Spot installeren op mijn HH versie, maar de ./configure opdracht kreunt met
o.a. de volgende fouten:
checking for F... configure: error: Package requirements (libgnome-2.0 >= 2.2 libgnomeui-2.0 >= 2.2 libexif >= 0.5.7 libexif < 0.7.0 gtk-sharp-2.0 >= 2.12.2 glib-sharp-2.0 >= 2.12.2 glade-sharp-2.0 >= 2.12.2 gnome-vfs-sharp-2.0 >= 2.12.2 gtk+-2.0 >= 2.14 mono >= 2.0.0 mono-cairo >= 1.2.4) were not met:

Requested 'gtk-sharp-2.0 >= 2.12.2' but version of Gtk is 2.12.0
Requested 'glib-sharp-2.0 >= 2.12.2' but version of GLib is 2.12.0
Requested 'glade-sharp-2.0 >= 2.12.2' but version of Glade is 2.12.0
Requested 'gtk+-2.0 >= 2.14' but version of GTK+ is 2.12.9
Requested 'mono >= 2.0.0' but version of Mono is 1.2.6

Nu volg ik de handleiding van de website van F-spot onder het kopje:
 How to Build F-Spot from a released version, subkop: Prerequisites.

Maar met Synaptic kom ik met bijv. gtk-sharp niet verder dan versie 2.12 terwijl het volgens de F-spotters 2.12.2 moet zijn.

Hoe kan ik e.e.a. oplossen?
Liefst zonder een complete upgrade naar II of JJ?

bvd
pablo k




Offline Double12

  • Webteam
  • Steunpunt: Nee
Re: F-spot: compile hulp gezocht
« Reactie #1 Gepost op: 2009/10/15, 14:35:31 »
Kijk, dat is dus het nadeel van een niet rolling-release distro (zoals Ubuntu) en dan een oude release gebruiken: je zit dan met een hele collectie verouderde pakketten die je niet zomaar kunt upgraden.
Als je er toch niet zo mee zit om met oude pakketten te werken, is het misschien een idee om gewoon een wat oudere versie van F-Spot te gebruiken. Die heeft namelijk ook wat oudere dependencies nodig.

Wil je wel met de nieuwste versie van F-Spot werken, dan is het denk ik onvermijdelijk om een nieuwere release van Ubuntu te installeren.

Je kunt natuurlijk proberen de nieuwste versies van de libraries zelf te compileren, of bijv. een backports-repository gebruiken, maar dat zou ik je sterk afraden. Alle andere programma's op je Hardy Heron-systeem rekenen nog op een oudere versie van Gtk. Ik heb eens geprobeerd een nieuwere versie van Gtk te installeren (overigens onder een andere distributie), toen deden al mijn programma's het niet meer. :P
« Laatst bewerkt op: 2009/10/15, 14:37:03 door Double12 »

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: F-spot: compile hulp gezocht
« Reactie #2 Gepost op: 2009/10/15, 18:16:39 »
Als je 32-bits gebruikt: https://launchpad.net/~michelinux/+archive/ppa

Op eigen risico uiteraard, maar grote voordeel is wel dat je naderhand de pakketjes weer kan deïnstalleren.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: F-spot: compile hulp gezocht
« Reactie #3 Gepost op: 2009/10/15, 20:16:29 »
Als je 32-bits gebruikt: https://launchpad.net/~michelinux/+archive/ppa

Op eigen risico uiteraard, maar grote voordeel is wel dat je naderhand de pakketjes weer kan deïnstalleren.

Plus dat veel programma's best om kunnen gaan met een nieuwere GTK-versie.

Offline Double12

  • Webteam
  • Steunpunt: Nee
Re: F-spot: compile hulp gezocht
« Reactie #4 Gepost op: 2009/10/15, 22:36:55 »
Plus dat veel programma's best om kunnen gaan met een nieuwere GTK-versie.
GTK+ staat er wel bekend om backward compatible te willen zijn, door ook verouderde functies in de API te laten staan. Maar mijn ervaringen op Suse Linux Enterprise Desktop zijn anders: na installatie van een nieuwe GTK+ uit een aparte repository konden mijn programma's een bepaalde functie van GTK+ niet meer vinden.