Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Apache2 File does not exist: /htdocs  (gelezen 922 keer)

Corno

  • Gast
Apache2 File does not exist: /htdocs
« Gepost op: 2009/10/12, 16:41:50 »
Hallo,

Onlangs ben ik overgestapt van Windows naar Ubuntu. Toen ook gelijk maar een servertje geïnstalleerd met samba, gedeelte printer/scanner, enz.

Alles heeft perfect gedraaid. Echter zaterdag kwam ik er achter dat ik niet meer kon scannen. (werkt via een webinterface). een test leerde dat ook de index.html uit /var/www het niet meer doet. Ik krijg dan een 404 pagina voor mijn kiezen. het bestand staat nog wel in de /var/www map. Ik kan mij niet herinneren dat ik wat gewijzigd heb.

de webinterface van Crups, om te printen, kan ik nog wel bij. Die gaat echter over een andere poort dan 80, nl. 631. (Na de installatie van Crups heb ik de scanner geïnstalleerd dus het kan niet zo zijn dat dit de instellingen gesloopt heeft).
als ik kijk bij /var/logs/apache2/error.log dan zie ik sinds zaterdag de melding  File does not exist: /htdocs voorbijkomen. Typich natuurlijk omdat naar mijn idee de web bestanden in /var/www staan.

Wat is er loos? iemand een idee?

Bedankt alvast!

(Heb op mijn opleiding (ICT Beheerder) gewerkt met Suse, nu een aantal weken ubuntu. Heb dus wel het e.a. aan ervaring, maar lang niet genoeg om voor dit probleem zelf een oplossing te bedenken.) 

Offline Scormen

  • Lid
    • LinuxOntdekt.Be
  • Steunpunt: Nee
Re: Apache2 File does not exist: /htdocs
« Reactie #1 Gepost op: 2009/10/12, 18:21:37 »
Welkom op het forum, Corno.

Kijk eens naar het bestand /etc/apache2/sites-available/default
Hierin wordt een link gelegd naar de DocumentRoot en Directory van de default website.

Mogelijk dat deze fout staat?
Ubuntu gebruiker #18341 | Linux gebruiker #456955
· Mijn persoonlijke Linux blog

Corno

  • Gast
Re: Apache2 File does not exist: /htdocs
« Reactie #2 Gepost op: 2009/10/12, 18:48:17 »
Scormen, bedankt voor je antwoord.

De bestanden
/etc/apache2/sites-available/default
en
/etc/apache2/sites-enabled/000-default

zijn allebei leeg. Tenminste als ik het volgende comando gebruik:

sudo nano default

Dan krijg ik een leeg venster maar zie niet de melding staan van een nieuw bestand.

zelfde geld voor 000-default.

Enig idee hoe ik dit weer gevuld krijg?