Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: (opgelost) Strepen op scherm  (gelezen 3659 keer)

Offline bms230

  • Lid
  • Steunpunt: Nee
(opgelost) Strepen op scherm
« Gepost op: 2009/10/10, 22:42:42 »
Beste allemaal,

Ik draai nu een aantal maanden ubuntu op mijn computer (dual boot met windows).
Sinds vandaag heb ik een probleem. Ik kwam in mijn kamer en zag dat er allemaal rare strepen op het beeldscherm stonden(zie ook bijlage). Deze strepen veranderen van kleur, afhankelijk van de achtergrond.
Ik dacht aan een probleem met mijn beeldscherm of videokaart. Ik heb toen windows opgestart , maar hierbij doet het probleem zich niet voor.
Ik kan me herinneren dat ik gister een update heb doorgevoerd.
Heeft iemand een oplossing voor dit probleem? Ik kom er namelijk niet uit.
Alvast bedankt!
Gr.
« Laatst bewerkt op: 2010/02/24, 22:08:44 door bms230 »

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #1 Gepost op: 2009/10/10, 23:04:08 »
Hallo bms230, om wat voor grafische kaart gaat het? En welke versie van Ubuntu?

Offline track

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #2 Gepost op: 2009/10/10, 23:13:27 »
Hoi Bastiaan,

welkom op het forum !

Dergelijke verschijnselen heb ik alleen gehad toen de driver van mijn Intel-kaart het slecht deed.
Het is dus een probleem met de (fabrieks-) driver.  Welke grafische kaart heb je eigenlijk ?
Als je dat niet weet helpt een  lshw -C display  in de terminal verder.

Vind je soms iets onder  [systeem] - beheer - Hardware Drivers  dat er meerdere mogelijkheden zijn ?

track

p.s.: AutoStatic was me voor ...

Offline bms230

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #3 Gepost op: 2009/10/11, 18:40:31 »
Bedankt voor de snelle reacties;
als ik de code in de terminal invoer krijg ik de volgende output:

WARNING: you should run this program as super-user.
PCI (sysfs) 
  *-display:0 UNCLAIMED   
       description: VGA compatible controller
       product: RV280 [Radeon 9200 SE]
       vendor: ATI Technologies Inc
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 01
       width: 32 bits
       clock: 66MHz
       capabilities: bus_master cap_list
       configuration: latency=32 mingnt=8
  *-display:1 UNCLAIMED
       description: Display controller
       product: RV280 [Radeon 9200 SE] (Secondary)
       vendor: ATI Technologies Inc
       physical id: 0.1
       bus info: pci@0000:02:00.1
       version: 01
       width: 32 bits
       clock: 66MHz
       capabilities: cap_list
       configuration: latency=32 mingnt=8

Bij systeem - beheer - hardwarestuurprogramma's staat er dat er geen stuurprogramma's in gebruik zijn op deze computer.

Ik gebruik de volgende versie van ubuntu:  Ubuntu 9.04 - de Jaunty Jackalope - uitgebracht in April 2009,

Hopelijk weten jullie raad.



Offline track

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #4 Gepost op: 2009/10/11, 20:18:12 »
Dat blijkt het verhaal met de nieuwe ATI-drivers te zijn.  Die worden officiëel pas voor Karmic (9.10)
uitgegeven, maar ze zijn nu al redelijk bruikbaar.
Een Howto vind je hier:  http://webupd8.blogspot.com/2009/05/graphic-video-drivers-ubuntu-repository.html
En iets over de achtergrond lezen kun je het best hier:  http://forum.ubuntu-nl.org/test-forum/open-source-ati-driver-3d-komt-eraan!/

Er is een risico dat het niet goed werkt, maar het is in ieder geval een poging waard.
En, als het niet lukt kun je het altijd netjes weer verwijderen.  Het is immers via synaptic geïnstalleerd.

track

Offline bms230

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #5 Gepost op: 2009/10/12, 10:50:53 »
Dank voor de reactie!
Ik heb geprobeerd de howto te volgen. Het viel me dat ik al een aantal van deze softwarebronnen had staan.
Als ik bij software bronnen alles aanvink (ook de toevoegde bronnen) krijg ik deze foutmelding:

W: GPG-fout: http://ppa.launchpad.net jaunty Release: De volgende ondertekeningen konden niet geverifieerd worden omdat de publieke sleutel niet beschikbaar is: NO_PUBKEY 4F191A5A8844C542

heeft dat met dit stukje te maken? "Then go to this link, save that code in a file and on the "Authentication" tab, click "Import Key File" and select the file you saved with the code from that link. Now click close and then the "Reload" button so that software sources will be updated."
Het lukte namelijk niet om de link te openen. Dan krijg ik een foutmelding.

Ik heb alles geïnstalleerd en de computer opnieuw opgestart. Helaas blijft het probleem zich voordoen. Het kan zijn dat ik iets verkeerd heb gedaan. Hoe deïnstalleer ik wat ik geïnstalleerd heb in synaptic (sorry maar hiervoor gebruik ik ubuntu te kort)?

Wat ik mij afvraag. Hoe kan het dat voor kort alles normaal werkte en dat het systeem (de drivers) nu ineens hun werk niet meer doen? In theorie zou het toch mogelijk moeten zijn dit probleem op te lossen als het probleem er ook ooit niet is geweest?
Veel vragen...hopelijk kunnen jullie mij verder helpen aangezien ik behoorlijk 'groen' ben in de linuxomgeving.
Alvast bedankt!


Offline bms230

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #6 Gepost op: 2009/10/12, 21:44:45 »
Kleine update.
Ik heb de foutmelding bij het installeren weten op te lossen. Het bleek dat ik de code van de website (waarvan ik dacht dat deze niet werkte) moest kopieëren in een leeg bestand. Daarna Kon ik de codes invoeren bij software van derden en werd alles keurig geladen.
Als ik vervolgens naar synaptic pakketbeheer ga zie ik de functie 'mark all updates niet'. Ik denk dat deze al door zijn gevoerd. Als ik de computer opnieuw opstart heb ik nog geen resultaat. Is er een manier om een schone start te maken in dit proces?
ALvast bedankt!

PS Ik heb mijn vorige bericht maar even laten staan om te laten zien wat ik fout doe.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #7 Gepost op: 2009/10/13, 01:45:35 »
Ik heb hier een ASUS A9250. Dit is eigenlijk een ATI 9200. Hier heb ik geen problemen met deze kaart. Ik denk dat dat een verkeerde herkenning is van de monitor.
Wat de driver betreft. Als je via "HardwareDrivers" geen driver aangeboden krijgt dan geen installeren.
De fglrx driver werkt hier sowieso niet.
Wat je eventueel wel kan doen is een dualboot met 8.04.3 (of een triple als windows er ook op staat) Door dit te doen kan je nagaan of je het probleem ook krijgt met een andere versie. Je kan dan ook de xorg.conf van de 8.04.3 gebruiken en die in de 9.04 plaatsen.

Over enkele dagen komt ook de 9.10 uit. Hier werkt dit heel goed samen met mijn grafische kaart.
Dus nog even geduld.
En probeer zeker de 8.04.3 (LTS) eens uit. In die versie is er een andere (oudere) kernel en zal dit beter werken. Proberen kan nooit kwaad, en vergt enkel wat tijd.

Succes, en laat iets weten, thx.

Met vriendelijke groet,
heir4c

Offline bms230

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #8 Gepost op: 2009/10/13, 21:02:58 »
Bedankt voor je antwoord!
Ik denk dat ik voor de laatste optie ga en wacht op versie 9.10.
Tijd is nu namelijk iets wat ik niet veel heb, en ik denk dat er voor mij wel wat tijd gaat inzitten om uit te zoeken hoe ik een dual boot maak met windows.
Ik heb gelezen dat de 29e 9.10 uitkomt. (http://www.ubuntulinux.org/testing/karmic/alpha1).
Je kan 9.04 upgraden, maar is dat verstandig gezien mijn huidige problemen? Is een fresh install beter of moet dat niet uitmaken?
In ieder geval ik ben blij dat ik over zo'n 2 weken ubuntu weer kan gebruiken. Ik vind het zoveel fijner (stabieler) werken dan een ander niet nader te noemen o.s.

Hopelijk kan iemand nog een antwoord geven op bovenstaande vraag.
In ieder geval wil ik iedereen bedanken voor de moeite die ze hebben genomen om mij te helpen.
Hopelijk is het probleem opgelost met 9.10!

Groet,

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #9 Gepost op: 2009/10/14, 19:42:00 »
Je kan updaten, maar vind zelf dat een 'verse' install beter is.
Het is namelijk zo dat bij een upgrade 'oudere' instellingen/progjes blijven staan.
Een voorbeeld: in 8.04.3 is een progje: displayconfig-gtk
Dit progje zit enkel in 8.04 en niet meer in latere versies. Maar heb eens een upgrade gedaan vanuit 8.04 naar 8.10 en toen bleef dat progje erin. (Ga dit tenandere eens uitproberen met een upgrade naar 9.04 of 9.10 om te zien of die dan ook in blijft. Maar dit betwijfel ik omdat het een andere kernel is)

Nu, de 8.04.3 is de LTS versie: Long Term Support, 3jaar ondersteuning, terwijl de tussentijdse versies maar 1,5 jaar ondersteuning krijgen en minder stabiel zijn en ook een soort van 'test/uitprobeer' versies zijn.

Het werkt eigenlijk hetzelfde, het verschil is dat in de LTS versies de progjes hun versie behouden die ze hadden bij de release en dus enkel updates krijgen en veiligheidsupdates natuurlijk. voorbeeld: FireFox 3.0.14 in 8.04.3 blijft die versie en veranderd dus niet naar de FireFox versie 3.5 die nu in 9.10 zit.
Maar die 3.5 is dan ook nog heel nieuw en toch nog niet stabiel genoeg.
Als je dus echt stabiel systeem wil is de 8.04.3 aangewezen. Die je dan na 2 jaar eventueel kunt upgraden naar de volgende LTS of wachten tot de Support stopt en dan pas upgraden of een verse install doen met de nieuwe LTS.

De werking gaat ook vanaf 9.10 veranderen. Ik bedoel daarmee dat er een geheel nieuwe kernel versie word gebruikt en ook de bestanden/instellen ervan veranderd er een heleboel. Kijk maar eens naar het topic over 9.10 in de Test Forum Categorie. (Veel leesvoer): Geen xorg.conf meer, een andere grub, enz...
Een grote aanpassing dus, ook voor de meer ervaren gebruikers hier op het forum.

Dus, backup je /home en doe een verse install.

Een dualboot is niet zo moeilijk. Je moet wel rekening houden met een 'foutje' in de 9.10 (ook in 9.04) namelijk: Er word maar 2,5 GB toegekend aan ubuntu. Dat moet je even aanpassen (naar min. 10GB) om ubuntu wat ruimte te geven.
Zie ook: http://sites.google.com/site/computertip/installeren



Offline bms230

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #10 Gepost op: 2009/10/30, 19:30:41 »
Beste allemaal;

Vandaag Ubuntu 9.10 geïnstalleerd. Bij de installatie zag ik dat het probleem zich helaas weer voordeed.
Teleurgesteld begon ik met het installeren van Mandriva. Hopelijk zou dit wel werken. Echter bij de installatie, zelfde probleem! Toen dacht ik bij mijzelf. Misschien moet Ubuntu 9.10 eerst daadwerkelijk geïnstalleerd worden. Helaas bleef het probleem zich voordoen na de installatie. Toen installeerde ik via het ubuntu software centrum ATI binary X.Org driver. Ik start de computer opnieuw op en.....hij doet t!!!
Nu is er nog een klein probleempje. rondom de muisaanwijzer zit nog zo'n blokje met lijntjes. Dit blok blijft om het pijltje heen zitten.
Weet iemand hier de oplossing voor? Ik denk zelf dat de oplossing misschien bij synaptic pakketbeheer zit; snel zoeken 'ati'. Daar staan driver gerelateerde installaties. Ik heb er echter geen kaas van gegeten welke ik dan eventueel zou moeten installeren.

Hopelijk kunnen jullie mij hierbij helpen.
Ik ben in ieder geval heel blij dat de toekomst er waarschijnlijk weer windows-loos uit zal zien!

Groetjes,




Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #11 Gepost op: 2009/10/31, 02:56:45 »
Dat zal waarschijnlijk dus nog altijd aan de driver liggen. Maar je kan misschien eens proberen een andere muisaanwijzer te kiezen, misschien lost het daarmee wel op.
Ga naar Systeem>Voorkeuren>Uiterlijk. Dan het tabblad: "Thema" en daarin het laatste tabblad: "Muisaanwijzer".
Kies daar een andere om te kijken of je dan nog dat 'blokje' hebt.


Voor wat de pakketten in Synaptic betreft: ?  Daarmee kan ik je niet direct helpen. Mijn kaart werkt oob, dus ja...
Nog wat wachten op andere forum-leden.

Met vriendelijke groet,
heir4c

Offline bms230

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #12 Gepost op: 2009/10/31, 11:00:35 »
en..... het probleem is opgelost!!!!!!!

Niet te geloven!

Eerst probeerde ik een andere muisaanwijzer. Dat werkte helaas niet.
Toen installeerde ik in synaptic pakketbeheer (zoekterm ati) xserver - xorg-video-ati dbg.
toen installeerde ik envyng core en envy qt.
Ik probeerde vervolgens bij envyNG de eerste nvidia driver te installeren. Ik vertrouwde het niet helemaal omdat er aangeraden werd om zeker te weten wat je doet voordat je veranderingen maakt. Dat weet ik niet dus kapte ik het proces af. Vervolgens deselecteerde ik mijn ati driver en startte de computer opnieuw op. Hoop gerommel uit de computer en vervolgens werkt alles perfect! Ook het bewegende scherm van de geluidsspeler werkt nu zonder rare strepen.
Bedankt voor al jullie berichten!

Gr.
« Laatst bewerkt op: 2009/10/31, 11:04:21 door bms230 »

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #13 Gepost op: 2009/10/31, 16:43:12 »
Graag gedaan.
Nog een vraagje: Heb je dat pakket: xserver ..... dbg (debugging) ook laten staan of heb je dat alsnog verwijderd?

En zet even in je eerste bericht naast de titel: [Opgelost]
Zo weten de anderen dat ook.
ThanX

Offline bms230

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #14 Gepost op: 2009/11/06, 21:42:43 »
Ik dacht dat ik die had laten staan.
Helaas kan ik dat niet meer controleren.
Ik vond vandaag uit dat de driver toch niet helemaal ok is. Ik installeerde compiz fusion. Helaas werkte dat niet. Door middel van Compiz-check (http://forlong.blogage.de/entries/pages/Compiz-Check)  kwam ik erachter dat het probleem aan de driver ligt. Heb toen wat lopen rommelen met info van help.ubuntu.com, maar daar kwam ik niet uit.
Ik probeerde de ati driver nogmaals uit en aan te vinken. Toen ik de computer opnieuw opstartte bleef hij knipperen bij naam-desktop login. Dit stond in het beeld:
ubuntu 9:10 NAAM-Desktop tty1
NAAM-desktop login.
Herstarten of herstel had geen zin. Heb ubuntu toen even opnieuw geïnstalleerd.
Vervolgens meteen de drivers geïnstalleerd via ENVYNG. Weer hetzelfde probleem. 
Er klopt dus iets nog niet helemaal. Waarschijnlijk mis ik nog een 'stukje driver' - als ik logisch nadenk. Heeft iemand enig idee?
Moet ik hierover een nieuw topic openen? Het probleem met de strepen in het beeldscherm is immers feitelijk opgelost.
Gr.
« Laatst bewerkt op: 2009/11/06, 23:22:15 door bms230 »

Offline track

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #15 Gepost op: 2009/11/06, 23:20:47 »
Volgens mij is dat nog steeds het zelfde onderwerp, het is immers dezelfde graka.

Alleen dat je nu bij de ongelukkige 20% van de Uby-9.10-upgraders hoort die een probleem
met het grafische scherm heeft.

Heb je trouwens een keer in de "recovery mode" opgestart en de "xfix - repair Xorg" uitgevoerd ?
(het telkens herinstalleren is volgens mij nog steeds een ondeugd vanuit het Win..- tijdstip...)

track

Offline bms230

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #16 Gepost op: 2009/11/06, 23:32:20 »
hmm dat is balen. Het draait nu zonder de grafische extra's goed. Werkt nog altijd fijner dan windows.
Dat herinstalleren stamt inderdaad uit mijn windows-tijdperk :$

"xfix - repair Xorg" heb ik nog niet uitgevoerd. Slaat dat op het herinstalleren of is dat een mogelijke oplossing voor het probleem met mijn grafische kaart?
Dank voor je antwoord!

Offline track

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #17 Gepost op: 2009/11/06, 23:38:11 »
De 9.10 maakt uitbundig gebruik van die automatische toestanden.  Feitelijk udev dus.
En om een probleem met de driver te herstellen is er extra de "xfix" in het recovery-menu.
Was er voeger ook al, maar nu is het des te essentiëler.
Heeft ook niets met herinstallatie te maken, het stelt alleen alles (omtrent Xorg) opnieuw in.

Probeer het gewoon, misschien haalt het nog iets uit. 
Je begrijpt:  in het grub-menu opstarten met een "recovery" !

track

Offline bms230

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #18 Gepost op: 2009/11/07, 09:55:39 »
Bedankt track,
Ik startte de computer via het grub menu op in een recovery mode. Dan krijg ik het volgende menu. Resume to normal boot / clean / dpkg / grub / netroot / root. Ik heb de eerste optie gekozen en ingelogd. Vervolgens kent het systeem de code 'xfix' niet. (De ati driver staat uitgevinkt in envyng). Ik heb het idee dat ik helemaal verkeerd zit. Ik kom er helaas niet uit met google. Weet iemand misschien waar ik een online handleiding kan vinden?
Alvast bedankt.

Offline track

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #19 Gepost op: 2009/11/07, 10:07:25 »
Het was iets anders bedoeld:
Start naar de  "recovery"  op  (dat deed je al)  maar in het menu moet helemaal beneden een punt "xfix   Try to autorapair graphic" staan,
zoals op het plaatje in de bijlage.  Die moet je hebben.  (evtl. scrollen met [↓] )

track
« Laatst bewerkt op: 2009/11/07, 10:11:03 door track »

Offline bms230

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #20 Gepost op: 2009/11/07, 13:36:00 »
Beste track,

Vreemd genoeg staat xfix niet in het lijstje van recovery mode.
Ik zie dat hier al een topic over gaat...http://forum.ubuntu-nl.org/hardware-en-drivers/probleem-nvidia-geforce4-420-go/msg505217/
Als ik mijn computer opstart zie ik volgens mij ook nvidia staan. Als ik envyng open staat er onder ati ook 3 driver voor nvidia.
185.18.36-0ubuntu9
173.14.20-0ubuntu5
96.43.13-0ubuntu6
Toen ik (week terug) de eerste probeerde kreeg ik een geheel wit scherm...
Opgelost door...tja...opnieuw installeren.
Het probleem komt dus in ieder geval vaker voor.

Nog wat extra info.
de grub duurt best lang (in vergelijking met de vorige versie van ubuntu) om te laden; zo'n 25 seconden. Er staat ook bij: grub version 1.97~beta 4.


« Laatst bewerkt op: 2009/11/07, 13:47:41 door bms230 »

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Strepen op scherm
« Reactie #21 Gepost op: 2009/11/07, 21:14:57 »
Yep, grub 1.97-beta4 is grub2 en die start inderdaad wat trager. Komt wel goed.

Citaat
.....Toen ik (week terug) de eerste probeerde kreeg ik een geheel wit scherm.....
Dat wit scherm heeft te maken met compiz. De visuele effecten uitschakelen zou dat probleem moeten oplossen.