Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: XP computer in netwerk mounten  (gelezen 4891 keer)

Offline grafcom

  • Lid
  • Steunpunt: Nee
XP computer in netwerk mounten
« Gepost op: 2009/10/05, 19:45:17 »
Ik heb een probleem met het programma Grsync (eigenlijk rsync).

Wanneer ik bestanden van mijn XP computer in het netwerk wil synchroniseren met Grsync blijkt dit niet goed te werken.
De XP computer kan ik als map selecteren door te gaan naar /gebruiker/.gvfs
Dit lijkt te werken alleen het synchroniseren gaat steeds fout. Ik krijg allerhande foutmeldingen maar alle bestanden worden toch gekopieerd. Echter de file attributen kloppen dan niet meer, de datum en tijd wordt omgezet naar het moment van kopieren.

Op het forum van Grsync werd me dit aangeraden:

Citaat
I think the problem is related to the limitations of gnome's virtual file system.
Rsync doesn't know about gnome, so I think the solution could be mounting the filesystems at "kernel" level, instead of by gnome, i.e. using "fstab".

Hoe kan ik een computer in mijn netwerk "mounten"?

Welke code moet ik in het bestand "fstab" zetten zodat ik dit kan oproepen met: sudo mount -a "computernaam" ?

Bij voorbaat dank.
« Laatst bewerkt op: 2009/10/05, 19:46:53 door grafcom »

Offline track

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #1 Gepost op: 2009/10/05, 22:26:54 »
Hoi Grafcom,

de tip van dat forum (en vooral de uitleg erbij !) lijkt mij nogal twijfelachtig.
Maar in ieder geval werkt een standaard-mount van een smb-share via fstab via cifs uitstekend.

Ik heb dit in mijn fstab staan:
//192.168.1.30/fs1  /media/fs1  cifs users,exec,credentials=/home/track/.smbcredentials  0  0Het mountpunt /media/fs1 moet bij voorbaat al bestaan uiteraard.  En er moet een bestand /home/track/.smbcredentials
zijn met deze inhoud:
username=track
password=datweetikzelfnieteens
Alle namen zal je aanpassen uiteraard ...
Maar in ieder geval werkt het goed, bij het opstarten wordt de share automatisch gemount.
Om achteraf te mounten moet ik wél root-rechten hebben, dus een  sudo mount -a doen.

track

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #2 Gepost op: 2009/10/05, 22:46:38 »
Dan nog zal rsync sowieso foutmeldingen blijven geven aangezien Windows en GNU/Linux een andere rechtenstructuur hebben. Welke flags/instelling van rsync gebruik je nu?

Offline grafcom

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #3 Gepost op: 2009/10/06, 09:59:44 »

Maar in ieder geval werkt een standaard-mount van een smb-share via fstab via cifs uitstekend.

Ik heb dit in mijn fstab staan:
//192.168.1.30/fs1  /media/fs1  cifs users,exec,credentials=/home/track/.smbcredentials  0  0Het mountpunt /media/fs1 moet bij voorbaat al bestaan uiteraard.  En er moet een bestand /home/track/.smbcredentials
zijn met deze inhoud:
username=track
password=datweetikzelfnieteens


track

Hallo Track,

oeps.... hoe stel ik dit allemaal in? Dit is voor mij nieuw. Waar te beginnen?

Offline grafcom

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #4 Gepost op: 2009/10/06, 10:07:07 »
Dan nog zal rsync sowieso foutmeldingen blijven geven aangezien Windows en GNU/Linux een andere rechtenstructuur hebben. Welke flags/instelling van rsync gebruik je nu?

Hallo AutoStatic,

aangezien in Grsync gebruik neem ik aan dat je wil weten welke opties hier zijn aangevinkt (?)
Tijd bewaren - Verwijderen op doel - Windows compatibility - Laat overdrachtsgegevens zien - Veel informatie geven -

Alle overige opties staan uit

Offline track

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #5 Gepost op: 2009/10/06, 10:18:04 »
Het eerste code-blok moet je in het bestand  /etc/fstab  van jouw eigen bak zetten,
het makkelijkst via een  gksu gedit /etc/fstab .  (want die heeft de eigenaar "root")

Je moet wél de gegevens aanpassen.  Het eerste is het IP-adres en de map op de andere computer
die de share aanbiedt. (dat krijg je in ieder geval daar via een  ifconfig ,  ook onder win..)

Het tweede is de map waar die share gemount moet worden, op je eigen bak.
Verder zal je "cifs" en de opties het best eerst overnemen.
En het pad voor de "credentials" kun je zelf kiezen, alleen in de fstab moet ook het goede pad staan.
Let vooral ook op de spaties !  (anders werkt het niet in de fstab)

En het tweede code-blok is dan de inhoud van dit "credentials"-bestand. 
Uiteraard met jouw echte inlog-gegevens op die bak met de share.

Probeer het gewoon, en als het niet lukt zou ik graag zien wat dan in jouw "fstab" staat.

track
« Laatst bewerkt op: 2009/10/06, 10:20:02 door track »

Offline grafcom

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #6 Gepost op: 2009/10/06, 11:12:15 »
het werkt nog niet, krijg de melding na sudo mount -a 192.168.0.1
mount: kan 192.168.0.1 niet vinden in /etc/fstab noch in etc.mtab

Hier is de inhoud van mijn fstab

# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda5 during installation
UUID=c1fa9a9f-fab5-4c86-af4e-140e81ee0a33 /               ext3    relatime,errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
UUID=a05af32f-1cad-4a3b-b61e-0fe04a0c8456 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
//192.168.0.1/fs1  /media/compu2  cifs users,exec,credentials=/home/gebruiker/.smbcredentials  0  0

heb het bestand .smbcredentials aangemaakt in de map /home/gebruiker
In de map media een map aangemaakt met de naam compu2

Achter het ipnummer staat /fs1 - welke naam zou hier exact moeten staan, de naam die ik aan de schijf heb gegeven?

Offline grafcom

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #7 Gepost op: 2009/10/06, 11:32:18 »
Toevoeging op voorgaande:

Ik heb een keer "sudo mount -a" gedaan en krijg dan:

mount: onjuiste bestandssysteemsoort, ongeldige optie, ontbrekende codepagina, ontbrekend hulpprogramma, slecht superblok op //192.168.01./fs1 of een andere fout

In het syteemlog (dmesg | tail) staat:

CIFS VFS: No username specified
CIFS VFS: cifs_mount failed w/return code = -22
« Laatst bewerkt op: 2009/10/06, 11:42:02 door grafcom »

Offline track

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #8 Gepost op: 2009/10/06, 12:00:40 »
Zit bij jou de gesharede map ook op   /fs1  zoals bij mij ??  Dat zou mij eigenlijk verbazen.
Je moet er precies die map inzetten die je wilt aanspreken.
En, die "192.168.0.1" is meestal de router toch ?  Of is dat bij jou anders ?

Als die gegevens niet kloppen zal hij uiteraard niets vinden.

track

Offline grafcom

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #9 Gepost op: 2009/10/06, 12:42:07 »
Ik heb inmiddels de schijf van de XP computer handmatig kunnen mounten met:

sudo mount -t cifs //192.168.0.1/"werkschijf4" /media/compu2 -o username=
Bedoel je deze naam (werkschijf4) i.p.v. fs1?

ik heb dit aangepast maar dan werkt het nog steeds niet.

192.168.0.1 is bij mij de XP computer.


Offline grafcom

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #10 Gepost op: 2009/10/06, 12:44:44 »
Dan nog zal rsync sowieso foutmeldingen blijven geven aangezien Windows en GNU/Linux een andere rechtenstructuur hebben.

Hallo AutoStatic,

inmiddels Grsync geprobeerd nadat ik de schijf van de XP computer handmatig had gemount en je hebt gelijk. De foutmeldingen blijven en de file attributen datum en tijd worden niet mee overgenomen.
Enig idee hoe ik dit op kan lossen?

Overigens gaat alles wel goed wanneer ik de map handmatig naar de XP computer kopieer, alleen via Grsync gaat het fout.

Offline track

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #11 Gepost op: 2009/10/06, 14:09:37 »
Als je handmatig met dat commando had kunnen mounten moet het eigenlijk ook via fstab lukken.
komt er een foutmelding na de  sudo mount -a dan ?

Uiteraard is jouw adres dan "//192.168.0.1/"werkschijf4" , ook in de fstab.
De foutmelding "CIFS VFS: No username specified" wijst meer op een probleem met de smbcredentials.
Heb je in de "smbcredentials" te toegangsdata van jouw XP ingezet ?  Die horen daar te staan.
Tikfout soms ?

track

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #12 Gepost op: 2009/10/06, 14:16:03 »
Track, waar ik wel benieuwd naar ben is het volgende:
er zijn zat computeraars die geen wachtwoord hebben ingesteld, bijvoorbeeld omdat ze de enige gebruiker van hun Windows-pc zijn. Wat moeten die dan in .smbcredentials zetten, of is in geval van 'geen Windows-wachtwoord' helemaal geen sprake van .smbcredentials?

Offline grafcom

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #13 Gepost op: 2009/10/06, 14:22:48 »
Tja, ik blijf dezelfde fout krijgen

Citaat
mount: onjuiste bestandssysteemsoort, ongeldige optie, ontbrekende codepagina, ontbrekend hulpprogramma, slecht superblok op //192.168.01./werkschijf4 of een andere fout

In het syteemlog (dmesg | tail) staat:

CIFS VFS: No username specified
CIFS VFS: cifs_mount failed w/return code = -22

In het bestand .smbcredentials staat als username de naam van mijn account en als password hetgeen ik gebruik om in te loggen.

Omdat het handmatig mounten wel lukte en ik daar geen gebruikersnaam en wachtwoord voor gebruikt hebt,
kan ik dat dan ook niet doen in de fstab?

Offline track

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #14 Gepost op: 2009/10/06, 14:34:22 »
Ik lees hier weer:
Citaat
...
//192.168.01./werkschijf4 of een andere fout
Is dat echt de foutmelding, geknipt en geplakt ?  Want die "192.168.01."  is er inderdaad niet !
Heb je de tikfout op het forum of in de fstab ?

Je kunt de gebruikergegevens ook meteen in die fstab- regel zetten.  Maar dat maakt eigenlijk niet uit.
Als je maar de toegangsdata van XP inzet.

track

Offline grafcom

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #15 Gepost op: 2009/10/06, 14:44:54 »

//192.168.01./werkschijf4 of een andere fout
Is dat echt de foutmelding, geknipt en geplakt ?  Want die "192.168.01."  is er inderdaad niet !
Heb je de tikfout op het forum of in de fstab ?
[/quote]

Nee, dat staat hier fout. ;/ In de fstab staat de goede 192.168.0.1

Offline track

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #16 Gepost op: 2009/10/06, 15:00:52 »
Wat levert een  cat /home/gebruiker/.smbcredentials op dan ?
De inloggegevens of een foutmelding ?   Let er ook op het puntje.
(dat behoort bij de bestandsnaam en maakt het bestand "verborgen")

track

Offline grafcom

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #17 Gepost op: 2009/10/06, 15:28:11 »
username=Mijn naam
password=wachtwoord

Geen foutmelding

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #18 Gepost op: 2009/10/06, 16:16:59 »
Hallo grafcom, heb alles nog even doorgelezen maar wat wil je precies synchroniseren? Wil je een directory van je XP machine synchroniseren met een map op je Ubuntu machine?

Offline grafcom

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #19 Gepost op: 2009/10/06, 17:13:52 »
Hallo AutoStatic,

het doel van dit alles was om m.b.v. dit programma (Grsync) via mijn Ubuntu computer verschillende synchronisaties te doen van een aantal mappen.

Map op XP computer naar backup schijf
Map van Ubuntu comuter naar backup schijf
Map van een NAS naar backup schijf
Map van USB schijf naar backup schijf
Map van USB schijf naar NAS
etc.

Handmatig is dit allemaal prima te doen vanaf Ubuntu.

Wat me wel is opgevallen dat alles goed werkt als ik van een Ubuntu map op een gedeelde computer (dual boot) naar een XP map (op dezelfde computer) kopieer...

Ik las overigens dit nog maar kan dat dan niet rijmen met de dual boot.
Citaat
Another common cause involves sending files to an Microsoft filesystem: if the file's modified time is an odd value but the receiving filesystem can only store even values, then rsync will re-transfer too many files. You can avoid this by specifying the --modify-window=1 option.

Misschien toch maar eens uitzoeken hoe ik dit aan de gang krijg my Rsync i.p.v. Grsync?

Offline grafcom

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #20 Gepost op: 2009/10/06, 19:55:49 »
Hallo AutoStatic,

ik heb nu geprobeerd het met rsync i.p.v. Grsync en het volgende commando geprobeerd:

rsync -av --delete-after /media/compu2/test/ /media/compu2/test2/
Waarbij compu2 de XP computer is en? Yep, dan werkt het wel.....

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #21 Gepost op: 2009/10/07, 12:38:00 »
Dan zou ik het lekker zo doen, zelf scripten. Is veel leerzamer en krijg je ook meer inzicht in wat het programmaatje precies doet :)

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #22 Gepost op: 2009/10/07, 15:09:59 »
Track, heb jij nog een antwoord op mijn vraag in bericht #12? Ik kwam dit namelijk tegen toen ik een tijdje terug bezig was met een probleem met het netwerk hier. Ik heb in XP geen wachtwoord ingesteld. Dat blanco laten in .smbcredentials werkt dus niet. Inmiddels is het probleem opgelost m.b.v. autofs, maar ik vraag me dus nog steeds af hoe je te werk zou moeten gaan wanneer je in Windows geen wachtwoord gebruikt, maar wél cifs wilt gebruiken.

Track, waar ik wel benieuwd naar ben is het volgende:
er zijn zat computeraars die geen wachtwoord hebben ingesteld, bijvoorbeeld omdat ze de enige gebruiker van hun Windows-pc zijn. Wat moeten die dan in .smbcredentials zetten, of is in geval van 'geen Windows-wachtwoord' helemaal geen sprake van .smbcredentials?

Offline track

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #23 Gepost op: 2009/10/07, 15:51:28 »
Mikkel:  ik heb er geen antwoord.  Ik zou ook eerst proberen dat "password=" òf leeg te laten of weg te laten.
Als dat ook niet lukt zou ik verder in de man- pages zoeken. ( http://linux.die.net/man/ )
Anders ook geen idee.

track

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: XP computer in netwerk mounten
« Reactie #24 Gepost op: 2009/10/07, 16:06:26 »
Mikkel:  ik heb er geen antwoord.

Jij en dan geen antwoord hebben? Valt me van je tegen, track. =D =D =D
Nou ja, kan ook gebeuren. ;)  Ik heb het opgelost door iets anders te gebruiken dan cifs, maar de vraag 'wat nou als je onder Windows geen wachtwoord gebruikt' bleef wel sluimeren.
In ieder geval bedankt voor dít antwoord. :)