Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Canon Pixma MP610 installeren; snap manual niet.  (gelezen 5871 keer)

Offline John K

  • Lid
  • Steunpunt: Nee
Canon Pixma MP610 installeren; snap manual niet.
« Gepost op: 2009/10/04, 19:31:48 »
Wie kan hier iets van bakken?

http://www.ubuntugeek.com/how-to-get-a-canon-all-in-one-printer-working-with-ubuntu.html


Ik heb i.p.v de beschreven Canon MP160 een Canon MP610. Ik heb de deb. files geinstalleerd voor de Canon 610 en geinstalleerd zoals de beschrijving, maar verschillende commando's gaan verkeerd, zoals:

cd /usr/share/cups/model/
bash: cd: /usr/share/cups/model/: No such file or directory


sudo lpadmin -p MP160 -P canonmp160.ppd -v cnij_usb:/dev/usblp0 -E  
lpadmin: No such file or directory


cd mp150-0.13.1
bash: cd: mp150-0.13.1: No such file or directory


Groeten John K

Offline peter10

  • Lid
    • Mijn Hyve
  • Steunpunt: Nee
Re: Canon Pixma MP610 installeren; snap manual niet.
« Reactie #1 Gepost op: 2009/10/04, 22:33:19 »
Maar hij deed het dus niet gewoon met automatische herkenning? Dus dat bij eerste keer aanzetten, hij een lijstje van geschikte stuurprogramma's gaf?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Canon Pixma MP610 installeren; snap manual niet.
« Reactie #2 Gepost op: 2009/10/04, 22:50:39 »
Open een terminal en kopier de volgende regel en plak deze in de terminal
sudo aptitude install libgtk2.0-dev libxml2-dev gettext libnss-dev libnspr-dev libgtkspell alien
Ik heb alien erachter gezet, deze heb je nodig om een rpm om te zetten.
Download hier http://canon.com.au/products/all_in_one_printers/all_in_one_printers/mp160_support.aspx de volgende drivers in je Home map, dan hoef je niet te navigeren met de terminal. :):
cnijfilter-common-2.80-1.i386.rpm

cnifjilter-mp160-2.70-1.i386.rpm

scangearmp-common-1.00-1.i386.rpm

scangearmp-mp160-1.00-1.i386.rpm

In de terminal sudo alien -d *.rpm dit zet alle rpm files in een keer om naar deb files.
In de terminal  sudo dpkg -i cnij*.deb dit installeert de printer drivers
In de terminal sudo dpkg -i scan*.deb dit installeert de scanner drivers
Nu een voor een de regels in de terminal:
sudo aptitude install libpng3

sudo ln -s /usr/lib/libtiff.so.4 /usr/lib/libtiff.so.3

sudo /etc/init.d/cupsys restart

cd /usr/share/cups/model/        <-- Deze map bestaat niet, eerst aanmaken?

sudo lpadmin -p MP160 -P canonmp160.ppd -v cnij_usb:/dev/usblp0 -E

sudo apt-get install libxml1
Nu is de printer/scanner geinstalleerd, nu dit nog
Download the sane scanner back-end from here. Save it to your home directory. Op here klikken in de orginele website. Dan download je het bestand wat nu zo geïnstalleerd wordt, regels een voor een uitvoeren:
tar -xvjf mp150-0.13.1.tar.bz2

cd mp150-0.13.1

make

sudo make install


(if asked to overwrite any files, choose Yes) Als er gevraagd wordt om te overschrijven, Yes
Printer aanzetten, computer herstarten en probeer de Scanner uit met Xsanne.  :P

Hier nog een link, http://mp610.blogspot.com/2008/04/give-your-scanner-new-freshly-sane.html
« Laatst bewerkt op: 2009/10/04, 22:59:35 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline John K

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma MP610 installeren; snap manual niet.
« Reactie #3 Gepost op: 2009/10/05, 12:50:15 »
Beste Gijsbert,

Heb jij zelf een MP610 geinstalleerd? Werkt het?


Jij antwoord; 'cd /usr/share/cups/model/        <-- Deze map bestaat niet, eerst aanmaken?'

Hoe maak ik de map aan?

John K

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Canon Pixma MP610 installeren; snap manual niet.
« Reactie #4 Gepost op: 2009/10/05, 16:39:51 »
Ik heb deze printer niet, ik heb wel de installatie beschrijving door gelezen en de betreffende map gecontrolleerd. Deze is er niet, dan lijkt mij het proberen waard om deze map aan te maken en te kijken of de installatie wel goed gaat.
De map aanmaken cd /usr/share/cups dan sudo mkdir model
In der Beschränkung zeigt sich der Meister.

Offline John K

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma MP610 installeren; snap manual niet.
« Reactie #5 Gepost op: 2009/10/05, 17:13:54 »
Letterlijk 'model' ?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Canon Pixma MP610 installeren; snap manual niet.
« Reactie #6 Gepost op: 2009/10/05, 17:47:00 »
Ja, deze map wordt bedoeld.
In der Beschränkung zeigt sich der Meister.

Offline John K

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma MP610 installeren; snap manual niet.
« Reactie #7 Gepost op: 2009/10/05, 18:19:37 »
Ik heb het volgende gedaan, maar errors;

$ cd /usr/share/cups/model/

user@comp1:/usr/share/cups/model$ sudo lpadmin -p MP160 -P canonmp160.ppd -v cnij_usb:/dev/usblp0 -E

lpadmin: No such file or directory

user@comp1:/usr/share/cups/model$

user@comp1:/usr/share/cups/model$ sudo apt-get install libxml1

Reading package lists... Done

Building dependency tree       

Reading state information... Done

libxml1 is already the newest version.

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

user@comp1:/usr/share/cups/model$ tar -xvjf mp150-0.14.4.tar.bz2

tar: mp150-0.13.1.tar.bz2: Cannot open: No such file or directory

tar: Error is not recoverable: exiting now

tar: Child returned status 2

tar: Error exit delayed from previous errors

user@:comp1/usr/share/cups/model$ cd mp150-0.13.1

bash: cd: mp150-0.13.1: No such file or directory

user@comp1:/usr/share/cups/model$ sudo lpadmin -p MP610 -P canonmp610.ppd -v cnij_usb:/dev/usblp0 -E

lpadmin: Bad device-uri "cnij_usb:/dev/usblp0"!

user@comp1:/usr/share/cups/model$




Vervolgens heb ik van deze site; http://ubuntuforums.org/archive/index.php/t-556980.html

het commando in terminal; scangearmp

en tot mijn verbazing, ondanks alle errors in terminal (zie output) scant de MP610!!!

Ik heb ook dit gevonden en uitgeprobeerd, maar ook errors; http://mp610.blogspot.com/2007_11_01_archive.html

wanneer ik volgens deze link ' Get the full new package that includes MP610: mp150-0.14.0u.tar.bz2, and untar it :
$ tar xvjf mp150-0.14.0u.tar.bz2' uitvoer krijg ik als output;

$ tar xvjf mp150-0.14.0u.tar.bz2
tar: mp150-0.14.0u.tar.bz2: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors

Weet jij of iemnad anders wat er fout gat?

Groeten John K

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Canon Pixma MP610 installeren; snap manual niet.
« Reactie #8 Gepost op: 2009/10/05, 19:11:15 »
Ik denk dat je beter de debs voor jouw printer/scanner kan downloaden http://support-au.canon.com.au/EN/search?v%3aproject=ABS-EN&binning-state=model%3d%3dPIXMA%20MP610%0Amenu%3d%3dDownload%0Aos%3d%3dLinux& Als je deze hebt geinstalleerd, dan kan je in Cups je printer terug vinden, zo kom je in Cups: Open je web browser en typ in de adresbalk http://localhost:631/
In der Beschränkung zeigt sich der Meister.

Offline John K

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma MP610 installeren; snap manual niet.
« Reactie #9 Gepost op: 2009/10/05, 19:37:23 »
Daar heb ik de printer en scannerdriver ook vandaan. De printer werkt en de scanner ook, maar alleen via terminal- scanarmp. Alleen in Xsane image scanner krijg ik de scanner niet te zien en ik denk dat ik dat moet installeren middels;

Get the full new package that includes MP610: mp150-0.14.0u.tar.bz2, and untar it :
$ tar xvjf mp150-0.14.0u.tar.bz2' (zie http://mp610.blogspot.com/2007_11_01_archive.html)

Deze heb ik in /home gedownload, maar vervolgens krijg ik als ik in terminal invoer; $ tar xvjf mp150-0.14.0u.tar.bz2
dan krijg ik deze output;

$ tar xvjf mp150-0.14.0u.tar.bz2
tar: mp150-0.14.0u.tar.bz2: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors

Ik snap niet wat er fout gaat? Hoe installeer ik xsane zodat deze de Canon Pixma MP 610 wel herkent. Scannen via de terminal lukt mij wel maar mijn vrouw denk ik niet. Mijn  oude HP scanner komt wel tevoorschijn. Volgens de site http://mp610.blogspot.com/2007_11_01_archive.html zou ik zelfs via het netwerk kunnen scannen.......

John K

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Canon Pixma MP610 installeren; snap manual niet.
« Reactie #10 Gepost op: 2009/10/05, 20:27:16 »
Je moet er nog sudo voor zetten dus sudo tar xvjf mp150-0.14.0u.tar.bz2
Zorg er ook voor dat je in de directory staat, waar je de tarball hebt gedownload, bijv. cd Downloads. Controleer met het commando dir of de tarball inderdaad in de directory staat. vervolgens het commando typen, dan de eerste drie letters van de tarball typen, klik op de TAB toets dan wordt de rest van de naam aangevuld.
Je kan ook met nautilus naar de map gaan en dan rechtsklik op het bestand kiezen Hier uitpakken, dan krijg je een mapje met de zelfde naam in de directory van de tarball.
« Laatst bewerkt op: 2009/10/05, 20:32:08 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline John K

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma MP610 installeren; snap manual niet.
« Reactie #11 Gepost op: 2009/10/05, 22:22:01 »
Bedankt voor je antwoord, ik ga weer aan de slag!

Groeten John K

Offline John K

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma MP610 installeren; snap manual niet.
« Reactie #12 Gepost op: 2009/10/06, 17:50:51 »
Het uitpakken is d.m.v nautilus wel gelukt, maar ik zie nog steeds geen Canon in mijn Xsane verschijnen. Heeft iemand enig idee wat er moet gebeuren? Wel mijn oude HP Scanjet.

Kan ik Xsane updaten of de-instaleren en dan weer een verse install?

Groeten John K