Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Creative WebCam Go of Logitech Quickcam Pro 5000  (gelezen 5665 keer)

gosh

  • Gast
Creative WebCam Go of Logitech Quickcam Pro 5000
« Gepost op: 2006/01/07, 20:21:55 »
Hoi,

Ik heb het internet al afgezocht maar geen nuttige info vinden over het installeren van een van de webcams die ik heb onder linux.

Ik heb er twee:
een oude Creative WebCam Go
en een nieuwe Logitech Quickcam Pro 5000

Iemand ervaring hiermee?

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Creative WebCam Go of Logitech Quickcam Pro 5000
« Reactie #1 Gepost op: 2006/01/08, 13:43:48 »
logitech -> half closed source driver dus klieren met module-assistant
creative -> geen idee

Op grote broer ubuntuforums.org heb ik wel eens mensen gezien die ze aan de praat kregen, probeer de zoekfunctie daar eens.

jpjacobs

  • Gast
Creative WebCam Go of Logitech Quickcam Pro 5000
« Reactie #2 Gepost op: 2006/01/08, 18:45:55 »
heb hier ook een oude logitech: gewoon pluggen en gebruiken (test met bv camstream of gqcam)
moet eens kijken in dmesg output na pluggen, of dat er iets van /dev/videoX staat. dan weet je zeker dat ie herkend is :)

gosh

  • Gast
Creative WebCam Go of Logitech Quickcam Pro 5000
« Reactie #3 Gepost op: 2006/01/09, 13:12:52 »
Citaat van: Dennis
logitech -> half closed source driver dus klieren met module-assistant
creative -> geen idee

Op grote broer ubuntuforums.org heb ik wel eens mensen gezien die ze aan de praat kregen, probeer de zoekfunctie daar eens.
Wat bedoel je met "half closed source driver dus klieren met module-assistant"?

Op ubuntuforums zijn wel verschillende andere logitech webcams die werken, maar de mijne is geloof ik te nieuw, want die howto's werkten bij mij niet....

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Creative WebCam Go of Logitech Quickcam Pro 5000
« Reactie #4 Gepost op: 2006/01/09, 14:01:42 »
Kernel hacken, maar dan iets makkelijker ;) Als de forum howtos daar niet helpen zul je nog even moeten wachten op de volgende update van de driver.

`GooZ

  • Gast
Creative WebCam Go of Logitech Quickcam Pro 5000
« Reactie #5 Gepost op: 2006/01/09, 16:54:49 »
Dit hielp bij mijn webcam:
http://ubuntuforums.org/showthread.php?t=75284&highlight=howto+webcam+chipset

Wel even kijken of je webcam gelist staat op deze site. Zorg dat je zeker weet wat je doet! Bij mij werkte het prima :)

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
Creative WebCam Go of Logitech Quickcam Pro 5000
« Reactie #6 Gepost op: 2006/01/09, 18:40:10 »
Mijn el-chipo webcam die ik "kreeg" op

gosh

  • Gast
Creative WebCam Go of Logitech Quickcam Pro 5000
« Reactie #7 Gepost op: 2006/01/11, 16:20:38 »
Citaat van: kennywest
Mijn el-chipo webcam die ik "kreeg" op

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Creative WebCam Go of Logitech Quickcam Pro 5000
« Reactie #8 Gepost op: 2006/01/11, 22:10:55 »
Dat lijkt erop alsof-ie gewoon werkt. Bestaat /dev/video*?

gosh

  • Gast
Creative WebCam Go of Logitech Quickcam Pro 5000
« Reactie #9 Gepost op: 2006/01/14, 21:43:50 »
Citaat van: Dennis
Dat lijkt erop alsof-ie gewoon werkt. Bestaat /dev/video*?
/dev/video0 en /dev/video1 bestaan.

Als ik camstreams opstart en de webcam selecteer krijg ik de foutmelding:
The device experienced an error -14 (bad adress)

gosh

  • Gast
Creative WebCam Go of Logitech Quickcam Pro 5000
« Reactie #10 Gepost op: 2006/01/17, 16:53:17 »
Met die Creative kom ik niet verder.

Ik heb nog wat rondgezocht voor die Logitech Quickcam Pro 5000 en kwam op een driver, uvcvideo, die het wel zou moeten doen: http://linux-uvc.berlios.de/

Volgens mij heb ik 'm goed gecompileerd en geinstallerd.

output van dmesg:

[4294709.623000] Linux video capture interface: v1.00
[4294709.648000] usbvideo: Probing device 3
[4294709.648000] Format MJPEG found
[4294709.648000] Format Uncompressed found
[4294709.648000] usbvideo: Found a Status endpoint (addr 87).
[4294709.648000] usbvideo: Found UVC device (1.00)
[4294709.648000] usbvideo: Scanning UVC chain: OT 5 <- Unit 4 <- Unit 3 <- Unit 2 <- IT 1
[4294709.648000] usbvideo: Found a valid video chain (1 -> 5).
[4294709.703000] usbvideo: UVC device initialized.
[4294709.703000] usbcore: registered new driver usbvideo
[4294709.703000] USB Video Class driver (v0.1.0)

en

[4294778.695000] usbvideo: uvc_v4l2_open
[4294778.695000] usbvideo: Unknown ioctl 0x803c7601
[4294781.113000] usbvideo: > uvc_v4l2_release
[4294781.115000] usbvideo: < uvc_v4l2_release
[4294806.172000] usbvideo: uvc_v4l2_open
[4294806.173000] usbvideo: Unknown ioctl 0x803c7601
[4294808.385000] usbvideo: > uvc_v4l2_release
[4294808.393000] usbvideo: < uvc_v4l2_release

Als ik camorama start krijg ik de fout:
Could not connect to video device (/dev/video0)
Please check the connection

Als ik xawtv start dan gaat het lichtje op de webcam heel even aan en daarna sluit xawtv automatisch.

Enig idee?

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Creative WebCam Go of Logitech Quickcam Pro 5000
« Reactie #11 Gepost op: 2006/01/17, 19:28:56 »
Wat is de uitvoer van:
ls -al /dev/video*
id

Ik denk dat je te weinig rechten hebt als normale user, dat moet dus veranderen :)

gosh

  • Gast
Creative WebCam Go of Logitech Quickcam Pro 5000
« Reactie #12 Gepost op: 2006/01/17, 21:15:47 »
ls /dev/video*
ls: /dev/video*: No such file or directory

 id
uid=1000(jos) gid=1000(jos) groups=4(adm),20(dialout),21(fax),24(cdrom),25(floppy),26(tape),29(audio),30(dip),44(video),46(plugdev),104(lpadmin),105(scanner),106(admin),1000(jos)

helpt dat?

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Creative WebCam Go of Logitech Quickcam Pro 5000
« Reactie #13 Gepost op: 2006/01/17, 21:18:23 »
Hee, bestaan je /dev/video0 en video1 ineens niet meer?

Haal die nieuwe driver eens weg, en doe 'sudo adduser jos video', dat zou een hoop moeten schelen.

gosh

  • Gast
Creative WebCam Go of Logitech Quickcam Pro 5000
« Reactie #14 Gepost op: 2006/01/17, 21:31:10 »
Ik zal het morgen eens proberen.
Dan kan ik weer bij die PC (m'n kids slapen nu... :))

Voor de volledigheid, hoe verwijder ik die driver?
Gewoon webcam uitpluggen?

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Creative WebCam Go of Logitech Quickcam Pro 5000
« Reactie #15 Gepost op: 2006/01/17, 21:39:23 »
Geen idee, ligt eraan hoe je hem installeerde :)

gosh

  • Gast
Creative WebCam Go of Logitech Quickcam Pro 5000
« Reactie #16 Gepost op: 2006/01/18, 21:49:56 »
Ik heb het opgegeven met deze twee webcams.
Voor een prikkie heb ik Logitech Quickcam Messenger aangeschaft.
Deze was zo te installeren volgens een howto op ubuntuforums.

Ik zal nog wel wat verder zoeken en proberen om ze toch aan de praat te krijgen, maar voorlopig hebben we weer een webcam :)

Bedankt voor het meedenken.
Mocht het toch lukken met die andere twee webcams, dan post ik wel een howto.