Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: OPGELOST mount error 111  (gelezen 5177 keer)

Offline BaukeP

  • Lid
  • Steunpunt: Nee
OPGELOST mount error 111
« Gepost op: 2009/09/28, 13:58:16 »
Hallo,

Omdat ik zo tevreden ben over Ubuntu (op een laptop 32bits) , heb ik ook m'n desktop (64b) overgezet naar Ubuntu.
Het meeste gaat goed. Nog een paar kleine dingetjes en ook deze werkt prima (hoop ik).

1:
De volgende regel werkte altijd, maar nu krijg ik een error 111 (Connection refused). Map op TB (=laptop) is gedeeld en mountpoint bestaat.
//Ubuntu-TB/Data-TB   /media/Data-TB   cifs   credentials=/root/.smbcredentials,uid=bauke,iocharset=utf8,file_mode=0777,dir_mode=0777   0 0

Van de laptop naar de desktop gaat wel met deze regel (iets andere mappen uiteraard)

2:
In nautilus werkt het kopiëren en plakken naar andere tabbladen niet meer. Naar het zijvenster, ingesteld als Boom, gaat het wel

Graag wat hulp met bovenstaande puntjes

Bij voorbaat dank

Bauke
« Laatst bewerkt op: 2009/09/29, 23:32:29 door BaukeP »

Offline joeri_damian

  • Lid
    • undergroundlinux.webs.com
  • Steunpunt: Nee
Re: mount error 111
« Reactie #1 Gepost op: 2009/09/28, 15:34:59 »
Kom je Ubuntu in?
Zo ja open een terminal Venster en typ dan FSCK (even uit me hoofd)

Anders even op starten met dat anderen normaal weet ik uit me hoofd vandaag even niet.
En het zelfde verhaal.

Als het goed is geeft die aan Broken File system Want too repair blocks Y/N

Natuurlijk Y vind die een aantal kapotten blocks en aantal keer Y invoeren.

Onieuw opstarten en klaar.

Offline track

  • Lid
  • Steunpunt: Nee
Re: mount error 111
« Reactie #2 Gepost op: 2009/09/28, 16:42:29 »
Hoi Bauke,

en je hebt ook op beide bakken in de  /root/.credentials  hetzelfde staan ?
Want daar haal je je toegangsdata af.

track

Offline BaukeP

  • Lid
  • Steunpunt: Nee
Re: mount error 111
« Reactie #3 Gepost op: 2009/09/28, 18:37:24 »
Joeri

Kan tot zware beschadigingen leiden zegt ie! Dus niet gedaan.
Heb wel autofsck draaien. Dus  na een reboot zouden fouten opgelost moeten zijn.......toch?

Track

Jazeker, allebei gelijk (inlognaam en wachtwoord zijn ook gelijk op beide PC's)

Bauke
« Laatst bewerkt op: 2009/09/28, 18:40:05 door BaukeP »

Offline track

  • Lid
  • Steunpunt: Nee
Re: mount error 111
« Reactie #4 Gepost op: 2009/09/28, 18:52:22 »
Die  fsck  mag je alleen op afgekoppelde partities draaien.
Als het om de root-partitie gaat dus alleen vanaf een live-CD.
Dat was het enige probleem.

Maar nog een andere vraag: er draaien op beide bakken ook samba-servers ?

track
« Laatst bewerkt op: 2009/09/28, 18:53:56 door track »

Offline BaukeP

  • Lid
  • Steunpunt: Nee
Re: mount error 111
« Reactie #5 Gepost op: 2009/09/28, 19:03:23 »
Samba is op allebei geïnstalleerd. Automatisch, ik heb daar verder ook niets mee gedaan.
Wat heb ik daar eventueel vergeten?

Bauke

Offline joeri_damian

  • Lid
    • undergroundlinux.webs.com
  • Steunpunt: Nee
Re: mount error 111
« Reactie #6 Gepost op: 2009/09/28, 19:13:56 »
Joeri

Kan tot zware beschadigingen leiden zegt ie! Dus niet gedaan.
Heb wel autofsck draaien. Dus  na een reboot zouden fouten opgelost moeten zijn.......toch?

Track

Jazeker, allebei gelijk (inlognaam en wachtwoord zijn ook gelijk op beide PC's)

Bauke
klopt maar een niet werkend systeem is toch al beschadigt
Teminste dat is meestal mijn gedachtengang en bedrijven hebben vaak iets wat particuliere niet hebben back-upps dus meschien zou het daarom een wat groter risco kunnen zijn.

Je kan altijd alle paketten na kijken met dpkg.
Maar hou dan rekening met dat dat niet direct zegt dat je paketten vergeten ben.
Meschien wel met synphatic.


Maar gaat dit eigenlijk om een 64 bits server of gewoon 64 bits desktop?
« Laatst bewerkt op: 2009/09/28, 19:19:05 door joeri_damian »

Offline track

  • Lid
  • Steunpunt: Nee
Re: mount error 111
« Reactie #7 Gepost op: 2009/09/28, 20:17:57 »
Samba is op allebei geïnstalleerd. Automatisch, ik heb daar verder ook niets mee gedaan.
...
Dat geldt alleen voor de samba-client !!

Ik vrees dat je op een bak de samba-server  niet hebt geïnstalleerd !!
Die is nodig om iets te kunnen delen.  En dat was ook mijn vorige vraag.

track

Offline BaukeP

  • Lid
  • Steunpunt: Nee
Re: mount error 111
« Reactie #8 Gepost op: 2009/09/28, 21:01:55 »
Track,

Ik begreep je een beetje verkeerd. Bij samba (in synaptic) staat server. Dacht dat dat genoeg was.
Maar hoe breng ik die samba server op gang? Is daar een tooltje voor?

Misschien draait ie wel? Hoe zie ik dat?

Sorry voor de vele vragen, maar bedankt voor alle antwoorden!

Bauke

Offline track

  • Lid
  • Steunpunt: Nee
Re: mount error 111
« Reactie #9 Gepost op: 2009/09/28, 21:09:19 »
Hoe heb je het op jouw eerste bak gedaan dan ?   Want daar werkt die blijkbaar.
Als je  samba-server via  synaptic gewoon installeert wordt hij
(mogelijk na een reboot)  ook automatisch opgestart.
Als er nog iets mis gaat, zal je het achteraf configureren:
https://help.ubuntu.com/community/SettingUpSamba

track

Offline BaukeP

  • Lid
  • Steunpunt: Nee
Re: mount error 111
« Reactie #10 Gepost op: 2009/09/28, 21:17:07 »
hallo,

Ik wordt ouder gelukkig, maar ik weet niet meer hoe ik het op die andere abk heb gedaan. Heb zoveel gedaan in het begin!

Samba-server staat bij mij niet in synaptic! Dat heeft toch niks met de 64b versie te maken?

Ik heb in Synaptic alle bronnen open (behalve sources en de proposed and backports worden niet geupdate)

Bauke

Offline track

  • Lid
  • Steunpunt: Nee
Re: mount error 111
« Reactie #11 Gepost op: 2009/09/28, 21:22:08 »
Eeehm, juist.  De server heet gewoon "samba"  en de client heet "samba-client"....
En je moet beiden hebben.

track

Offline BaukeP

  • Lid
  • Steunpunt: Nee
Re: mount error 111
« Reactie #12 Gepost op: 2009/09/28, 22:09:41 »
En die heb ik beide.

Nu even voor mijn begrip:
Op de laptop zie ik de gedeelde mappen van de desktop. Het server gedeelte van de desktop is dus goed.
Op de desktop krijg ik niet de mappen van de laptop. De fout ligt dus op de laptop (het server gedeelte).

Nu heb ik op de laptop GADMIN-SAMBA geinstalleerd en die veroorzaakt de ellende misschien wel. Kan ik de GADMIN-SAMBA en samba en de samba client eraf gooien en opnieuw installeren?

Ja, dat kan ;). Maar zou het ook helpen?

Als je een map deelt en de samba software is niet geinstalleerd, dan krijg je een venster om het alsnog te installeren. Dat heb ik ook op de laptop gehad!?!
Dan zou je bijna zeggen dat dat goed moet zijn.

Al met al ben ik behoorlijk los nu :(

Bauke

PS Op de laptop krijg ik als ik op netwerk -- Windows-netwerk klik de melding 'Kon de locatie niet aankoppelen'. Op de desktop kan ik het windows-netwerk wel zien, maar de laptop (uiteraard) niet.
« Laatst bewerkt op: 2009/09/28, 22:25:15 door BaukeP »

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: mount error 111
« Reactie #13 Gepost op: 2009/09/29, 10:56:36 »
Kom je Ubuntu in?
Zo ja open een terminal Venster en typ dan FSCK (even uit me hoofd)

Anders even op starten met dat anderen normaal weet ik uit me hoofd vandaag even niet.
En het zelfde verhaal.

Als het goed is geeft die aan Broken File system Want too repair blocks Y/N

Natuurlijk Y vind die een aantal kapotten blocks en aantal keer Y invoeren.

Onieuw opstarten en klaar.
Hallo joeri_damian, een dergelijke mount error heeft helemaal niks met beschadigde bestandssystemen te maken.

En Bauke, wat is de gehele foutmelding? Een 111 error heeft meestal iets met hostnames te maken die niet gevonden kunnen worden oid.

Offline track

  • Lid
  • Steunpunt: Nee
Re: mount error 111
« Reactie #14 Gepost op: 2009/09/29, 13:54:58 »
Hoi Bauke,

die  gadmin  kan problemen opleveren, met name wanneer je alles een beejte door elkaar installeert
en gebruikt.  Maar dat is op zich niet erg, want je kunt nog steeds het bestand   smb.conf
handmatig bekijken.  Want daar staat uiteindelijk alles opgeslagen.

Zou jij dus die  smb.conf  van jouw kleptop even opzoeken ?
En het best hier (links onder het schrijfhokje) in de  Extra opties... - Bijlage  zetten ?

Dan kunnen wij rechtstreeks kijken.

track

Offline BaukeP

  • Lid
  • Steunpunt: Nee
Re: mount error 111
« Reactie #15 Gepost op: 2009/09/29, 14:23:55 »
AutoStatic,

Dit is de melding in de terminal:

bauke@Ubuntu-BB:~$ sudo mount -t cifs //Ubuntu-TB/Data-TB /media/Data-TB -o username=bauke,password=xxxx,iocharset=utf8,file_mode=0777,dir_mode=0777[sudo] password for bauke:
mount error(111): Connection refused
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
bauke@Ubuntu-BB:~$

Offline BaukeP

  • Lid
  • Steunpunt: Nee
Re: mount error 111
« Reactie #16 Gepost op: 2009/09/29, 14:27:43 »
Track,

Bijgaand het laptop bestandje.

Ik heb gadmin eraf gegooid. Smbfs en samba geherinstalleerd.

Bauke
« Laatst bewerkt op: 2009/09/29, 14:30:14 door BaukeP »

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: mount error 111
« Reactie #17 Gepost op: 2009/09/29, 16:58:17 »
Geen idee of dát het probleem is, maar ik zie in jouw bestandje dit staan:
[Data-TB]
path = /mnt/Data
comment = No comment
read only = no
available = yes
browseable = yes
writable = no
guest ok = no
public = no
printable = no
share modes = no
locking = no

Nu kan ik me vergissen, maar daar staat immers dat er op Data-TB niet geschreven en niets gedeeld mag worden...........

En verder staat bovenin het bestandje de naam van de werkgroep met kleine letters, terwijl die (dacht ik) altijd met hoofdletters geschreven moet worden.

Maar nogmaals.......... ik kan me vergissen. ;)

Offline track

  • Lid
  • Steunpunt: Nee
Re: mount error 111
« Reactie #18 Gepost op: 2009/09/29, 21:05:10 »
Bauke, jouw  smb.conf bevat dit:
Citaat
hosts allow = 127. 192.168.0.
Heb je dat achteraf zelf veranderd of staat dat echt zo bij jou ?
Want die regel is een beetje verminkt ...
Zoiets zou het moeten zijn:       hosts allow = 192.168.0.4 127.0.0.1

track

Offline BaukeP

  • Lid
  • Steunpunt: Nee
Re: mount error 111
« Reactie #19 Gepost op: 2009/09/29, 23:31:25 »
Heren,

Ik heb maar gewoon het desktop bestand (smb.conf) gekopieerd naar de laptop. Paar dingetjes aangepast.
En nu loopt het allemaal weer als een zonnetje!

Track,

Nee, ik heb niks aangepast. Dat Gadmin gedoe heeft mij en jullie veel tijd gekost (ik ga er tenminste vanuit dat daardoor het bestand verminkt was)

Maar, eind goed, al goed!

Bedankt!!

Bauke

Offline track

  • Lid
  • Steunpunt: Nee
Re: OPGELOST mount error 111
« Reactie #20 Gepost op: 2009/09/29, 23:38:42 »
Volgens mij was echt alleen die regel verminkt die ik in mijn laatste post aantoonde.  En kleine fout eigenlijk,
die volgens mij door een maar half uitgevoerde wijziging veroorzaakt werd ...

En als hij geen geldige "hosts" meer heeft gaat hij natuurlijk staken.

track
« Laatst bewerkt op: 2009/09/30, 03:44:43 door track »