Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Opgelost: Sabnzbplus in Linux Mint wil niet juist opstarten  (gelezen 4528 keer)

Offline Kakysan

  • Lid
    • Het computermannetje
  • Steunpunt: Nee
Opgelost: Sabnzbplus in Linux Mint wil niet juist opstarten
« Gepost op: 2009/09/27, 20:48:06 »
Ik heb via pakketbeheer (synaptic) in Linux mint sabnzbplus geinstalleerd. Na het starten van dit programma krijg je normaal de web gebaseerde interface. Maar ik krijg deze melding:

Fout bij verbinden

Firefox kan geen verbinding maken met de server op localhost:8080.

Hoewel de website lijkt te bestaan is het de browser niet gelukt ermee te verbinden.

    * Misschien is de website tijdelijk niet beschikbaar? Probeer het later opnieuw.
    * Kunt u ook geen andere websites bezoeken? Controleer de netwerkverbinding van de computer.
    * Wordt uw computer of netwerk beschermd door een firewall of proxy? Onjuiste instellingen kunnen een goede werking tijdens het webbrowsen verstoren.

Weet iemand of Linux mint poort 8080 gebruikt ? Lijkt me wel sterk, maar je weet het niet. Ook toen ik hem naar 8081 zette, krijg ik dezelfde melding.

Ik hoor het wel !

Gr karel,
      
« Laatst bewerkt op: 2010/02/08, 18:53:58 door Kakysan »
Ik gebruik Linux Ubuntu 12.04 Unity & Windows 8.1

Mijn overstap weblogs zijn: http://overstappen2ubuntu.wordpress.com & http://overstappen2linuxmint.wordpress.com

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Sabnzbplus in Linux Mint wil niet juist opstarten
« Reactie #1 Gepost op: 2009/09/27, 20:50:36 »
Heb je /etc/default/sabnzbdplus wel aangepast?

Krijg je een foutmelding als je sudo /etc/init.d/sabnzbdplus restart uitvoert?

Offline Kakysan

  • Lid
    • Het computermannetje
  • Steunpunt: Nee
Re: Sabnzbplus in Linux Mint wil niet juist opstarten
« Reactie #2 Gepost op: 2009/09/27, 21:24:00 »
Johan, als ik jou commando uitvoer krijg ik dit:

SABnzbd+ binary newsgrabber: not configured, aborting. See /etc/default/sabnzbdplus

Wat zou er dan 'not configured' moeten zijn ?

Ik heb het bestand ook even geopend en het volgende staat erin: Zegt jou dit wat ?

Gr Karel,



#!/bin/sh
#
# Copyright (C) 2008 by JCF Ploemen <linux@jp.pp.ru>
# released under GPL, version 2 or later

### BEGIN INIT INFO
# Provides:          sabnzbdplus
# Required-Start:    $local_fs $network
# Required-Stop:     $local_fs $network
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: SABnzbd+ binary newsgrabber
### END INIT INFO

DAEMON=/usr/bin/sabnzbdplus

[ -x $DAEMON ] || exit 0

NAME=$(basename $DAEMON)
DESC="SABnzbd+ binary newsgrabber"
SETTINGS=/etc/default/sabnzbdplus
OPTIONS="--daemon"
PYTHONEXEC="$(readlink -f $(sed -n -e "1s/^#\!\([a-z0-9\.\/]\+\).*/\1/p" $DAEMON))"

. /lib/lsb/init-functions

check_retval() {
   if [ $? -eq 0 ]; then
      log_end_msg 0
      return 0
   else
      log_end_msg 1
      exit 1
   fi
}

is_running() {
   # returns 0 when running, 1 otherwise
   start-stop-daemon --quiet --stop --test --user $USER --exec $PYTHONEXEC --name $NAME || return 1
}

load_settings() {
   [ -r $SETTINGS ] || exit 0
   . $SETTINGS

   [ -z "$USER" ] && {
      log_warning_msg "$DESC: not configured, aborting. See $SETTINGS";
      exit 0; }

   [ -n "$CONFIG" ] && OPTIONS="$OPTIONS --config-file $CONFIG"
   [ -n "$HOST" -a -n "$PORT" ] && OPTIONS="$OPTIONS --server $HOST:$PORT"
   [ -n "$EXTRAOPTS" ] && OPTIONS="$OPTIONS $EXTRAOPTS"
}

case "$1" in
   start)
      load_settings
      if ! is_running; then
         log_daemon_msg "Starting $DESC"
         start-stop-daemon --quiet --chuid $USER --start --exec $DAEMON -- $OPTIONS
         check_retval
      else
         log_success_msg "$DESC: already running"
      fi
   ;;
   stop)
      load_settings
      if is_running; then
         log_daemon_msg "Stopping $DESC"
         start-stop-daemon --quiet --stop --signal 15 --retry 30 --exec $PYTHONEXEC --name $NAME --user $USER
         check_retval
      else
         log_success_msg "$DESC: not running"
      fi
   ;;
   reload|force-reload|restart)
      $0 stop
      $0 start
   ;;
   *)
      log_failure_msg "Usage: $0 {start|stop|restart|reload|force-reload}"
   ;;
esac

exit 0
Ik gebruik Linux Ubuntu 12.04 Unity & Windows 8.1

Mijn overstap weblogs zijn: http://overstappen2ubuntu.wordpress.com & http://overstappen2linuxmint.wordpress.com

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Sabnzbplus in Linux Mint wil niet juist opstarten
« Reactie #3 Gepost op: 2009/09/27, 21:27:55 »
Je moet /etc/default/sabnzbdplus bewerken.
Het enige wat je in principe moet doen is je naam invullen achter USER=
In mijn geval:
USER=johan

Hierna kan je het starten via het eerder genoemde commando.

Offline Kakysan

  • Lid
    • Het computermannetje
  • Steunpunt: Nee
Re: Sabnzbplus in Linux Mint wil niet juist opstarten
« Reactie #4 Gepost op: 2009/09/27, 21:40:33 »
Ik heb het in dit regeltje veranderd, maar mocht niet werken:

is_running() {
   # returns 0 when running, 1 otherwise
   start-stop-daemon --quiet --stop --test --user=karel $USER --exec $PYTHONEXEC --name $NAME || return 1

of moet $user nog weg ? is dat niet een commando dat hij automatisch je gebruikersnaam invul ? Ik snap niet waarom in normale ubuntu dit gewoon werkt zonder deze aanpassingen.

Gr karel,
Ik gebruik Linux Ubuntu 12.04 Unity & Windows 8.1

Mijn overstap weblogs zijn: http://overstappen2ubuntu.wordpress.com & http://overstappen2linuxmint.wordpress.com

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Sabnzbplus in Linux Mint wil niet juist opstarten
« Reactie #5 Gepost op: 2009/09/27, 21:44:51 »
/etc/default/sabnzbdplus
/etc/init.d/sabnzbdplus

De bovenste moet je bewerken.
De 2e gebruik je alleen als je hem handmatig op wil starten of afsluiten.

Offline Kakysan

  • Lid
    • Het computermannetje
  • Steunpunt: Nee
Re: Sabnzbplus in Linux Mint wil niet juist opstarten
« Reactie #6 Gepost op: 2009/09/27, 22:03:01 »
Nou, het gaat niet lukken. Als ik mijn naam invul krijg ik een foutmelding dat het niet goed is. ook het volledig path etc is niet goed.
Ik heb hetzelfde bestand bekeken in mijn normale ubuntu, en daar staat ook geen gebruikersnaam. En daar werkt het prima.

Het maakt ook verder niet uit (wel jammer natuurlijk), maar vreemd is het wel dat het niet wil werken in Linux Mint.

gr Karel,

Ik gebruik Linux Ubuntu 12.04 Unity & Windows 8.1

Mijn overstap weblogs zijn: http://overstappen2ubuntu.wordpress.com & http://overstappen2linuxmint.wordpress.com

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Sabnzbplus in Linux Mint wil niet juist opstarten
« Reactie #7 Gepost op: 2009/09/27, 22:10:59 »
De bewerking die je in antwoord #4 geeft klopt in ieder geval niet.

Even voor de duidelijkheid: is /etc/init.d/sabnzbdplus nu weer zoals die standaard hoort te zijn?
Daar moet je niks in veranderen.

De configuratie pas je aan in /etc/default/sabnzbdplus
Voor de duidelijkheid mijn configuratie:
# This file is sourced by /etc/init.d/sabnzbdplus
#
# When SABnzbd+ is started using the init script, the
# --daemon option is always used, and the program is
# started under the account of $USER, as set below.
#
# Each setting is marked either "required" or "optional";
# leaving any required setting unconfigured will cause
# the service to not start.

# [required] user or uid of account to run the program as:
USER=johan

# [optional] full path to the configuration file of your choice;
#            otherwise, the default location (in $USER's home
#            directory) is used:
CONFIG=

# [optional] hostname/ip and port number to listen on:
HOST=
PORT=

# [optional] extra command line options, if any:
EXTRAOPTS=
Ik heb alleen USER= veranderd. That's it.

Nu zou Sabnzbdplus automatisch moeten starten als je Ubuntu start.
Wil je dit niet, dan zou je het configuratiebestand weer origineel kunnen maken.

Je kan sabnzbdplus ook handmatig starten via het commando sabnzbdplus.
GEEN sudo gebruiken.

In de verborgen .sabnzbd map in je home map staan de logbestanden. Misschien dat je daar wat meer informatie uit kan halen?

Offline Kakysan

  • Lid
    • Het computermannetje
  • Steunpunt: Nee
Re: Sabnzbplus in Linux Mint wil niet juist opstarten
« Reactie #8 Gepost op: 2009/09/28, 15:52:24 »
De bewerking die je in antwoord #4 geeft klopt in ieder geval niet.

Even voor de duidelijkheid: is /etc/init.d/sabnzbdplus nu weer zoals die standaard hoort te zijn?
Daar moet je niks in veranderen. Ik heb het weer orgineel gemaakt.

De configuratie pas je aan in /etc/default/sabnzbdplus
Voor de duidelijkheid mijn configuratie:
# This file is sourced by /etc/init.d/sabnzbdplus
#
# When SABnzbd+ is started using the init script, the
# --daemon option is always used, and the program is
# started under the account of $USER, as set below.
#
# Each setting is marked either "required" or "optional";
# leaving any required setting unconfigured will cause
# the service to not start.

# [required] user or uid of account to run the program as:
USER=johan

# [optional] full path to the configuration file of your choice;
#            otherwise, the default location (in $USER's home
#            directory) is used:
CONFIG=

# [optional] hostname/ip and port number to listen on:
HOST=
PORT=

# [optional] extra command line options, if any:
EXTRAOPTS=
Ik heb alleen USER= veranderd. That's it. Dat had ik ook gedaan, maar dan krijg ik dus de foutmelding dat ik verkeerde gebruiker ben.

Nu zou Sabnzbdplus automatisch moeten starten als je Ubuntu start. Tja, en dat doet hij dus niet. Ik blijf hetzelfde melding krijgen als in post 1
Wil je dit niet, dan zou je het configuratiebestand weer origineel kunnen maken. Hij is nu weer orgineel !

Je kan sabnzbdplus ook handmatig starten via het commando sabnzbdplus. Dit geeft dezelfde foutmelding. Raar maar waar. Ik start sabnzb altijd al handmatig via een snelkoppeling.
GEEN sudo gebruiken.

In de verborgen .sabnzbd map in je home map staan de logbestanden. Misschien dat je daar wat meer informatie uit kan halen? Ik zal eens een kijkje nemen hierin. Bedankt in ieder geval bedankt voor je moeite.

Gr Karel,

« Laatst bewerkt op: 2009/09/28, 15:55:21 door Kakysan »
Ik gebruik Linux Ubuntu 12.04 Unity & Windows 8.1

Mijn overstap weblogs zijn: http://overstappen2ubuntu.wordpress.com & http://overstappen2linuxmint.wordpress.com

Offline dirkalberteverts

  • Lid
  • Steunpunt: Nee
Re: Sabnzbplus in Linux Mint wil niet juist opstarten
« Reactie #9 Gepost op: 2009/10/03, 20:24:41 »
ik gebruik sabnzbplus ook en na de installatie hoefde ik niets aan te passen,wat je wel kunt aanpassen wil dus ook via de webinterface.Misschien het beste om alles te deinstalleren en weer opnieuw installeren. XD XD
Dreamstudio 11.10

Offline Kakysan

  • Lid
    • Het computermannetje
  • Steunpunt: Nee
Re: Sabnzbplus in Linux Mint wil niet juist opstarten
« Reactie #10 Gepost op: 2010/02/08, 18:53:39 »
Ik heb laatst Linux mint 8 geinstalleerd en kwam dus weer met hetzelfde probleem dat Sabnzbplus niet wilde opstarten. Maar na een simpele google zoektocht kwam ik met de oplossing:

Edit: Deze regels moest ik ook in Kubuntu 9.10 veranderen en het werkte perfect.

Verander de volgende twee zinnetjes.

# [optional] hostname/ip and port number to listen on:
HOST=0.0.0.0
PORT=8888

Kennelijk zit bij Linux mint iets anders op die poort 8080 (standaard in sabnzb).

Engelse link: http://forums.sabnzbd.org/index.php?topic=3114.0

Gr Karel,

« Laatst bewerkt op: 2010/02/26, 09:24:05 door Kakysan »
Ik gebruik Linux Ubuntu 12.04 Unity & Windows 8.1

Mijn overstap weblogs zijn: http://overstappen2ubuntu.wordpress.com & http://overstappen2linuxmint.wordpress.com