Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] Problemen bij instellen muis scrollwheel in xorg.conf  (gelezen 1626 keer)

Offline StudioCascade

  • Lid
  • Steunpunt: Nee
Hallo,

Een maand of 2 geleden ben ik overgestapt naar Ubuntu en ik ben er nog altijd zeer enthousiast over.
Er is echter één ding die ik maar niet goed ingesteld krijg: mijn muis.

Ik ben in het bezit van een Microsoft Comfort Optical 3000.
Dit is een muis met zowel horizontale als verticale scroll en een 'programmeerbare' knop bij de duim.

De muis werkt op zich prima, alleen het scrollwieltje reageert niet zoals het hoort.
Het scrollwieltje horizontaal bewegen, resulteert in een verticale scroll
en de verticale scrollbeweging lijkt de forward en backward buttons van de browser te bedienen.

Kortom niet echt een gewenste situatie.
Ik heb de xorg.conf aangepast, maar het lijkt erop alsof deze instellingen totaal geen invloed hebben.
Hoe ik de button remapping ook instel, de knoppen blijven allemaal hetzelfde reageren (ook na een herstart van X) alsof mijn systeem helemaal niet naar xorg.conf kijkt.

Overigens, dit is wat er in mijn xorg.conf staat:

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ExplorerPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
 Option "Buttons" "8"
 Option "ButtonMapping" "1 2 3 8 6 7"
EndSection

Heeft iemand nog suggesties?
Ik ben er al een behoorlijke tijd mee bezig en heb ook op internet al een hoop gezocht,
maar ik krijg het niet opgelost.
« Laatst bewerkt op: 2009/09/23, 21:36:33 door StudioCascade »

Offline track

  • Lid
  • Steunpunt: Nee
Re: Problemen bij instellen muis scrollwheel in xorg.conf
« Reactie #1 Gepost op: 2009/09/23, 21:08:07 »
Hoi,

en welkom op het forum !

Kun je even uitleggen waarom je deze opties hebt ingesteld, een voor een ?
Of waar je die instellingen vandaan hebt ?

Zomaar begrijp ik het verhaal nog niet goed.

track

p.s.:  en heb je van  https://launchpad.net/ubuntu/+source/xorg/+bug/52288 
het antwoord # 11 al uitgeprobeerd ?
« Laatst bewerkt op: 2009/09/23, 21:21:52 door track »

Offline StudioCascade

  • Lid
  • Steunpunt: Nee
Re: Problemen bij instellen muis scrollwheel in xorg.conf
« Reactie #2 Gepost op: 2009/09/23, 21:20:55 »
Hoi,

Dank je voor je reactie.
En excuses voor mijn onvolledigheid.

Ik heb deze instellingen op internet gevonden, om precies te zijn op:
https://launchpad.net/ubuntu/+source/xorg/+bug/52288

Ik geef toe, bij deze instellingen staat dat deze gebruiker dit onder Ubuntu Hardy doet
en ik maak gebruik van Jaunty, maar ik mag aannemen dat dit onder Jaunty dezelfde settings zijn.
Of is dit een gevaarlijke uitspraak?

Overigens, als ik in xorg.conf ButtonMapping en ZAxisMapping aanpas, verandert er helemaal niets na een herstart.
Kortom, het lijkt gewoon alsof die settings geen invloed hebben.

Offline track

  • Lid
  • Steunpunt: Nee
Re: Problemen bij instellen muis scrollwheel in xorg.conf
« Reactie #3 Gepost op: 2009/09/23, 21:25:18 »
Het een en ander is anders bij Jaunty, dat is waar.
Maar ik dacht dat de xorg.conf  nog steeds werkt als vanouds.
En volgens mij zit er ook nog steeds de "xev" als hoofd- driver in.

Dus zal het eigenlijk nog steeds moeten werken.
Even bij jouw bron:  heb je het voorstel van antwoord # 11
al uitgeprobeerd ?  Dat was daar ook uiteindelijk de oplossing...
(het scriptje moet je "uitvoerbaar" maken uiteraard !)

track
« Laatst bewerkt op: 2009/09/23, 21:27:56 door track »

Offline StudioCascade

  • Lid
  • Steunpunt: Nee
Re: [OPGELOST] Problemen bij instellen muis scrollwheel in xorg.conf
« Reactie #4 Gepost op: 2009/09/23, 21:38:30 »
Ja en nee dus...

Ik zat me min of meer blind te staren op de settings in xorg.conf.
Het scriptje had ik er dus niet neergezet.
Heel stom van mij dat ik daar overheen gelezen heb.

Hartelijk dank in elk geval dat je me erop attent hebt gemaakt!
Nu werkt mijn muis zoals 't hoort!