Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Probleem met afspelen van diverse video formaten  (gelezen 12926 keer)

Offline fotooog

  • Lid
    • FOTOOOG
  • Steunpunt: Nee
Probleem met afspelen van diverse video formaten
« Gepost op: 2009/09/18, 09:47:56 »
Hallo,

Mijn eerste post op dit forum, ik ben Wilfred en een tevreden Ubuntu gebruiker.
Voor foto- en videobewerking, echter gebruik ik windows. :|

Mijn vraag is deze:

Video bestanden worden door mijn mediaplayer (conceptronic CM3H500) niet gezien als ik ze onder linux heb binnen gehaald, AVI, VOB etc en kopieer ik na downloaden naar mijn mediaplayer.
De video_TS map lijkt leeg wanneer ik deze met de mediaplayer open, terwijl de bestanden wel degelijk aanwezig zijn, Avi wordt ook niet gezien.
Wanneer ik exact hetzelfde bestand met windows binnen haal en kopieer naar mijn mediaplayer werkt alles wel goed.
Ik kan de bestanden wel zonder plobleem lokaal ( op de pc dus ) met VLC player afspelen, Ubuntu en Windows.

Gebruikte programma's zijn met Windows: Grabit
En met Ubuntu: Klibido ( ook met Pan geen succes )

Als ik het probleem zelf inschat denk ik dat het probleem in de mediaplayer zit, kan het zijn dat er met linux een soort van ident signaal aan een bestand wordt meegegeven waardoor de mediaplayer er geen raad mee weet.
Als ik beide bestanden vergelijk lijkt er geen verschil te zijn, bit grootte, bestandsnamen ed.

Ik hoop zo duidelijk te zijn en ben benieuwd of er mensen zijn met dezelfde ervaring.

Alvast bedankt voor de reactie.

Groeten,
Wilfred



Offline Paul Matthijsse

  • Lid
  • Steunpunt: Ja
Re: Probleem met afspelen van diverse video formaten
« Reactie #1 Gepost op: 2009/09/18, 10:20:55 »
Hallo,

Mijn eerste post op dit forum, ik ben Wilfred en een tevreden Ubuntu gebruiker.
Welkom, etc!

De video_TS map lijkt leeg wanneer ik deze met de mediaplayer open, terwijl de bestanden wel degelijk aanwezig zijn
Ja dit heb ik onlangs ook geconstateerd met de mediaplayer van mijn dochter. Een (legaal) gedownload videofilmpje was nergens op die speler te bekennen, terwijl het in Nautilus wel degelijk zichtbaar was. Geen idee hoe dit op te lossen. DRM-ongein misschien?

Offline Meneer Jansen

  • Lid
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #2 Gepost op: 2009/09/18, 13:58:48 »
Ik denk dat er codecs geïnstalleerd moeten worden. Voor usenet gebruik ik OpenFTD en SABNzbD+.

Succes. :)
http://forum.nedlinux.nl | http://www.alleslinux.com/forum
Linux interesse gebieden: mulitmedia en configuratie.

Offline n00buntu

  • Lid
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #3 Gepost op: 2009/09/18, 14:08:47 »
DRM-ongein misschien?
Misschien heeft het wel iets met rechten te maken, maar (hopelijk) dan niet zozeer met DRM.

Als je op zo'n map rechts-klikt (in Nautilus) en kiest voor Eigenschappen heb je een tabje 'Delen'. Daarin kun je aangeven/instellen dat de map gedeeld moet kunnen worden, wellicht dat je de bestanden onder Windows dan wel kunt zien?

Offline fotooog

  • Lid
    • FOTOOOG
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #4 Gepost op: 2009/09/18, 23:31:07 »
Hallo,

Dank voor de reacties, ik ga verder puzzelen.

Als andere mensen suggesties hebben, dan graag.

Wilfred

Offline fotooog

  • Lid
    • FOTOOOG
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #5 Gepost op: 2009/09/19, 08:18:52 »
Hallo,

Het probleem is nog niet opgelost, maar ik heb wel iets ontdekt:

Het blijkt dat als ik een linux video bestand vanuit windows op de mediaplayer kopieer het wel werkt.
Als ik een videobestand vanuit Ubuntu op de mediaplayer kopieer werkt het niet, ook al is deze origineel via windows gedownloaded.

De harde schijf van de mediaplayer is volgens FAT32 geformateerd, wat voor de functie van mediaplayer noodzakelijk is (volgens de gebruiksaanwijzing) EXT3 enz wordt niet ondersteund, NTFS wel.

Wat ik dan wel wil weten is wat er met het videobestand gebeurt als het vanuit een linux hardeschijf afkomt.

Ik zal me erin moeten berusten dat ik voorlopig hier windows voor moet gebruiken. :o

Reacties welkom !

Wilfred

Offline Meneer Jansen

  • Lid
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #6 Gepost op: 2009/09/19, 15:05:04 »
Ik had je posts niet goed gelezen, wist niet dat het om een conceptronic CM3H500 ging. Biek ding man (= jaren '80 taal, excuses)!  O0 Als ik het goed begrijp zijn de videobestanden (waar geloof ik niets mee aan de hand is) niet op je mediaplayer te lezen indien gekopieerd vanuit Linux, maar wel indien gekopieerd vanuit Windows. Toch?

Allereerst zou ik controleren of de bestanden überhaupt zijn overgekopieerd naar de USB harde schijf media player. Als je de player aansluit via USB, zie je het apparaat dan verschijnen in een filebrowser (zoals de Explorer onder Win of Nautilus onder Linux?). Hoogstwaarschijnlijk wel, anders krijg je de video's er niet op natuurlijk. Probeer na het kopiëren eens het volgende commando in te geven:

sync
Verklaring: Als er iets wordt gekopieerd door een besturingssysteem (Win of Lin) dan wordt niet altijd meteen alles over gezonden via USB. Dat is om je usbstick of schijf een beetje te "sparen". Sommige (oude) usb sticks zijn wel vaak te beschrijven (een stuk of 10.000 keer ofzo), maar niet oneindig vaak. Dus je besturingssysteem schrijft je bestanden pas weg als jij dat wilt. In een keer en niet in een stuk of tien keer als je tien bestanden of een heel groot bestand (lees: DVD) naar USB wegschrijft. Onder Windows heet dit "safely remove hardware", onder Linux doe je dit met het commando sync.

Succes :)
http://forum.nedlinux.nl | http://www.alleslinux.com/forum
Linux interesse gebieden: mulitmedia en configuratie.

Offline fotooog

  • Lid
    • FOTOOOG
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #7 Gepost op: 2009/09/20, 10:51:03 »
Hallo,

De bestanden zijn inderdaad wel goed overgezet naar de player, alleen niet zichtbaar door de player zelf.
Ik heb het sync commando na een andere kopieer actie gegeven ( via terminal ) maar dat haalt niets uit.
Of misschien begrijp ik je niet goed.

Ik blijf zoeken en proberen en meld het als ik iets ontdekt heb.

Dank je en groeten,

Wilfred

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Probleem met afspelen van diverse video formaten
« Reactie #8 Gepost op: 2009/09/20, 12:24:16 »
Zou het een rechten probleem kunnen zijn ?
Kan je de player benaderen als "USB-Stick" en dan met de rechtermuistoets eens kijken bij eigenschappen/rechten.
Mogelijk dat daar iets fout gaat, maar dan kan je dan ook weer simpel aanpassen.
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger.

Offline Tom

  • Lid
    • Wanda´s Blog Linux Xubuntu. ♥
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #9 Gepost op: 2009/09/20, 13:24:06 »
En als U nu eens niet Windows mediaplayer gebruikte maar bv VLCplayer ?.
http://www.videolan.org/
Ook deze gebruikte ik veel in Windows.
http://codecpack.nl/klcodec.htm
Misschien gebruikt WMPlayer andere codecs.
« Laatst bewerkt op: 2009/09/20, 13:32:51 door Wanda »
1 x Xuby 14.04.5 Lts 64 bits.1 x 16.04.5 Lts. 2 x Xuby 18.04.1 Lts 64 bits. ♥
https://sites.google.com/site/wandabloglinuxxubuntu/pc-s-installeren-configureren.

Offline fotooog

  • Lid
    • FOTOOOG
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #10 Gepost op: 2009/09/20, 13:59:35 »
Hoi,

Zolang het filmbestand op de pc staat en daar afgespeeld maakt het niet uit wat je gebruikt, VLC en / of Windows media player.
Zowel op de linux als windows PC.

De problemen beginnen na het kopieren naar de mediaplayer.

Groeten,

Wilfred

Offline Meneer Jansen

  • Lid
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #11 Gepost op: 2009/09/20, 15:29:41 »
Ik heb het sync commando na een andere kopieer actie gegeven ( via terminal ) maar dat haalt niets uit.
Of misschien begrijp ik je niet goed.
Je hebt mij perfect begrepen. ;) Ik type altijd op de commandline 'sync' in, dan verdwijnt de commando prompt een tijdje, en als de synchroniseer actie succesvol verlopen is komt de prompt weer terug in de terminal.
Naar mijn mening kan het geen rechten probleem zijn, want de USB harde schijf media player waar we het over hebben is FAT32 geformatteerd en dat bestandsysteem heeft nauwelijks 'rechten'. Alleen 'hidden', 'system' etc... Je zou daar naar kunnen kijken, maar het lijkt mij sterk dat Linux die media bestanden als 'hidden' of 'system' markeert.

Dit is een heel vreemd probleem aan het worden. Linux kan prima overweg met fat32. Misschien zou je een andere Filebrowser kunnen proberen om de bestanden over te zetten. Voor Linux zijn bekende filebrowsers:
- Konqueror (van KDE)
- Nautilus (van Gnome)
- Midnight Commander (mc, voor de terminal)
- XFE (geprogrammeerd in Fox)

Misschien dat dat helpt... Succes in ieder geval! :)

« Laatst bewerkt op: 2009/09/20, 15:32:04 door Meneer Jansen »
http://forum.nedlinux.nl | http://www.alleslinux.com/forum
Linux interesse gebieden: mulitmedia en configuratie.

Offline fotooog

  • Lid
    • FOTOOOG
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #12 Gepost op: 2009/09/20, 16:05:47 »
Citaat
Je hebt mij perfect begrepen. ;) Ik type altijd op de commandline 'sync' in, dan verdwijnt de commando prompt een tijdje, en als de synchroniseer actie succesvol verlopen is komt de prompt weer terug in de terminal.

Ik heb niet gewacht tot de commando prompt weer terug was, oeps, te vroeg de terminal afgesloten  =D
Ik doe een tweede poging.

Wilfred

Offline track

  • Lid
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #13 Gepost op: 2009/09/20, 21:40:19 »
Hoi Wilfred,

ik vraag mij af wat het verschil tussen de bestanden vanuit Win.. en vanuit Uby
zou kunnen zijn.  Is er misschien iets met hoofdletters in de bestandsnamen ?
als je een bestand vanuit Win.. haalt naar Uby, en hem pas daarna naar de player
verplaatst, maakt dat een verschil ?

En, zie je een verschil tussen een Uby- bestand en een vanuit Win.. als je hen naast elkaar
in een map zet en een  ls -l in de terminal doet ?  (ik denk hier aan het rechtenpatroon)

track

p.s.: wordt de doelmap op de player zowel onder Uby als onder win.. hetzelfde gezien ?
     (ook qua naam en rechten ?)
     Is er enig verschil tussen een bestand vanuit win.. en vanuit Uby als jet in de
     gemountte player-map een  ls -l  doet ?
« Laatst bewerkt op: 2009/09/20, 21:44:43 door track »

Offline fotooog

  • Lid
    • FOTOOOG
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #14 Gepost op: 2009/09/20, 22:07:27 »
Hoi,

Nee, als ik bv een AVI bestand op Windows heb staan (mijn pc heeft 2 maal een HHD, 1 met Windows en de ander met  Ubuntu) en ik kopieer deze naar de player heb ik geen probleem.
Als ik dit exact hetzelfde AVI bestand vanuit de Windows HDD naar de Ubuntu HDD kopieer en dan naar de player heb ik het probleem zoals eerder beschreven.
Dus ik hang de player met een usb kabel aan slechts 1 PC.
Er zit dus geen verschil tussen de bestanden cq mappen, deze zijn dezelfde.
Tenzij de rechten opeens veranderen als de map op Ubuntu staat.

Wederom dank voor het mee denken en groeten,

Wilfred

Offline track

  • Lid
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #15 Gepost op: 2009/09/21, 00:10:23 »
Dan is het inderdaad duidelijk:
Het bestand  "mijnfilmpje.avi"  van Win.. rechtstreeks naar de player:  lukt.
Hetzelfde bestand eerst naar Uby, daaarna naar de player: lukt niet.

Dus zit het probleem niet in het bestand zelf maar in de manier hoe het naar de player
over gebracht wordt.  Eenduidig, als ik het goed begrijp. 
Nu mijn vrag:  wat is het resultaat als ik dit ene bestand als "mijnfilmpje1.avi" rechtstreeks
vanuit Win.. op de player zet en dan als "mijnfilmpje2.avi" via Uby op de player zet.

Uiteraard zal "mijnfilmpje1.avi" draaien en "mijnfilmpje2.avi" niet.  Maar wat is het verschil
in een listing van de map (die op de player zit),  dus een  ls -l  /media/player/filmpjesmap/*.avi
(of hoe die map op de player op jouw Uby-bak nu heet)  Iets anders, de eigenaar of wat dan ook ?
(met welk bestandsysteem is de player eigenlijk gemount ?)
Is er maar enig verschil zichtbaar tussen die twee "mijnfilmpje"s ?  Dan vinden wij misschien een aanpak.

track
« Laatst bewerkt op: 2009/09/21, 00:12:49 door track »

Offline fotooog

  • Lid
    • FOTOOOG
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #16 Gepost op: 2009/09/21, 08:32:38 »
Hoi,

Ik denk dat je spijker op zijn kop slaat.
Als ik het bestandje via Ubuntu op de player zet wordt de player gemount door Ubuntu, natuurlijk.
(Hoewel ik steeds meer de player ga verdenken, ik heb naar Conceptronics een mail met een omschrijving van het probleem gestuurd)

Ik heb pas vanavond weer tijd om te experimenteren, tot die tijd zal ik het even laten pruttelen en bezinken.

Dank weer en groeten,

Wilfred

« Laatst bewerkt op: 2009/09/21, 08:46:53 door fotooog »

Offline track

  • Lid
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #17 Gepost op: 2009/09/21, 13:03:18 »
Dat is misschien het punt:
bij het mounten van een extern toestel kun je verschillende parameters instellen en meegeven.
Als daar iets vreemd gaat heb je soms rare instellingen.  Maar dat moet je even precies nagaan. 
Bij Linux kun je het dan heel goed instellen.

track

Offline fotooog

  • Lid
    • FOTOOOG
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #18 Gepost op: 2009/09/21, 23:48:57 »
Hoi,

Het wordt inderdaad een heel vreemd probleem.
Ik heb nog een klein experiment gedaan, maar laat het voorlopig voor wat het is, denk ik.

Als ik de mediaplayer via usb op mijn pc aansluit en een bestand binnen deze player kopieer en plak (ik heb er dan twee natuurlijk) en ik doe dat met de windows pc en nog een keer met de linux pc, vervolgens de player weer op de tv aansluit.......................

Juist, ik zie dan alleen de kopie gemaakt met de windows pc

( hier staan wat woorden niet voor iedereen geschikt)

nil volentubus arduum.

 :o

Welterusten.




Offline track

  • Lid
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #19 Gepost op: 2009/09/22, 10:19:47 »
... nil solvere volentibus arduum.
Atque, patientia vincit omnia.  (Quin etiam Fenestras Redmondienses ;))

Dus, wij zullen een aanpak vinden.  Mijn vraag is:
wat verklapt een  mount  en wat een  cat  /etc/mtab  in de terminal,
met die speler aangeprikt ?

Mits hij "ro" gemount zou zijn kun je uiteraard niets naar de speler schrijven.
Ergens in die richting gaat mijn verdenking.

track
« Laatst bewerkt op: 2009/09/22, 10:38:41 door track »

Offline fotooog

  • Lid
    • FOTOOOG
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #20 Gepost op: 2009/09/22, 10:37:35 »
Hoi,

Bedoel je dat ik eerst een " mount commando"  in de terminal moet geven alvorens te beginnen met wegschrijven ?

Ik ga dat vanavond uitproberen, hier heb ik helaas geen LINUX pc tot mijn beschikking.

Groet,

Wilfred

Offline track

  • Lid
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #21 Gepost op: 2009/09/22, 10:40:46 »
Nee, als je alleen een naakte  mount  geeft verklapt hij gewoon
wat hij waar en hoe gemount heeft.  En dat wil ik eigenlijk maar weten.

track

Offline fotooog

  • Lid
    • FOTOOOG
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #22 Gepost op: 2009/09/22, 10:50:22 »
Een pure logging dus,

Je krijgt de info zsm

Groet,

Wilfred

Offline Meneer Jansen

  • Lid
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #23 Gepost op: 2009/09/22, 12:25:05 »
Niet om vervelend te doen: maar heb je sync iedere keer ingegeven en gewacht tot sync klaar was?
http://forum.nedlinux.nl | http://www.alleslinux.com/forum
Linux interesse gebieden: mulitmedia en configuratie.

Offline fotooog

  • Lid
    • FOTOOOG
  • Steunpunt: Nee
Re: Probleem met afspelen van diverse video formaten
« Reactie #24 Gepost op: 2009/09/22, 13:08:20 »
Jazeker, netjes gewacht tot de prompt terug was

Wilfred