Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geluid uit koptelefoon én luidsprekers.  (gelezen 28050 keer)

Offline ilseroen

  • Lid
  • Steunpunt: Nee
Geluid uit koptelefoon én luidsprekers.
« Gepost op: 2009/09/13, 11:49:43 »
Goedemiddag, ik heb het volgende probleem:
als ik mijn koptelefoon aansluit, heb ik geluid uit mijn luidsprekers én mijn koptelefoon, wat niet zo handig is.
Koptelefoon aangesloten op de juiste aansluiting (Acer Aspire heeft een zwarte, ipv groene aansluiting).

Welke instellingen moet ik hebben om er voor te zorgen dat als ik mijn koptelefoon aansluit, dat ik dan alleen daar geluid doorheen heb?

Ik heb al het één en ander geprobeerd, maar kwam er niet uit.

Alvast bedankt voor de hulp.

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #1 Gepost op: 2009/09/13, 11:52:03 »
Heb je al een keer met een rechterklik op het luidspreker-icoontje  in de alsa-mixer gekeken of er niet misschien iets afgevinkt is ?
Of dat er een schuif omlaag staat ?

Offline ilseroen

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #2 Gepost op: 2009/09/13, 12:16:20 »
Ja, ik heb alle knoppen geprobeerd, maar het helpt niets.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #3 Gepost op: 2009/09/13, 14:39:50 »
Deze vraag is nog voorgekomen hier op het forum. Normaal is dat helemaal geen softwareaangelegenheid: het is het contactje van je koptelefoon dat normaliter de aansluiting met de interne luidspreker onderbreekt op het ogenblik dat de stekker van de koptelefoon erin gaat. Als dat niet werkt, lijkt mij dat een defect van dat stopcontactje.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #4 Gepost op: 2009/09/13, 19:21:11 »
asoundconf-gtk
gnome-alsamixer
alsamixergui

Probeer eens met en van deze, misschien moet je het nog installeren.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #5 Gepost op: 2009/09/13, 20:35:10 »
Goedemiddag, ik heb het volgende probleem:
als ik mijn koptelefoon aansluit, heb ik geluid uit mijn luidsprekers én mijn koptelefoon, wat niet zo handig is.
Koptelefoon aangesloten op de juiste aansluiting (Acer Aspire heeft een zwarte, ipv groene aansluiting).

Welke instellingen moet ik hebben om er voor te zorgen dat als ik mijn koptelefoon aansluit, dat ik dan alleen daar geluid doorheen heb?

Ik heb al het één en ander geprobeerd, maar kwam er niet uit.

Alvast bedankt voor de hulp.
Is de zwarte aansluiting niet voor extra speakers t.b.v. surround geluid?
Je hebt geen hoofdtelefoonaansluiting aan de voorzijde?
In der Beschränkung zeigt sich der Meister.

Offline ilseroen

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #6 Gepost op: 2009/09/13, 23:10:15 »
Citaat
Is de zwarte aansluiting niet voor extra speakers t.b.v. surround geluid?
Je hebt geen hoofdtelefoonaansluiting aan de voorzijde?

Nee, geen aansluiting aan de voorzijde. En die zwarte aansluiting is ook voor de hoofdtelefoon, volgens de gebruiksaanwijzing.

@Jan11000, ik heb alle drie geïnstalleerd, moet ik dan nog iets speciaals doen?

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #7 Gepost op: 2009/09/14, 18:52:39 »
Hallo

Kijk ook even hier;
http://forum.ubuntu-nl.org/hardware-en-drivers/geluid-doet-raar-met-headset/msg388862/#msg388862

ik neem aan dat je ubuntu 9.04 gebruikt? dan heet de file in bovengenoemde draad niet meer
alsa-base maar; alsa-base.conf

Misschien kun je hier wat meer mee, of ga op zoek met de zoekwoorden; jack sense
of; jack sensing

Groeten Gerrit
 
« Laatst bewerkt op: 2009/12/03, 16:14:18 door mrGee »
-- = >  simplify if you can   -- = >

Offline ilseroen

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #8 Gepost op: 2009/09/14, 19:07:16 »
@mrGee, ik heb de link aangeklikt en even wat in het terminal venster getypt. Dit kwam er uit:

jodokus@ubuntu:~$ cat /proc/asound/* 2>/dev/null
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xc8000000 irq 22
  2:        : timer
  3:        : sequencer
  4: [ 0- 3]: digital audio playback
  5: [ 0- 4]: digital audio capture
  6: [ 0- 0]: digital audio playback
  7: [ 0- 0]: digital audio capture
  8: [ 0]   : control
 0 snd_hda_intel
00-00: ALC888 Analog : ALC888 Analog : playback 1 : capture 1
00-03: NVIDIA HDMI : NVIDIA HDMI : playback 1
00-04: ALC888 Analog : ALC888 Analog : capture 1
G0: system timer : 4000.000us (10000000 ticks)
  Client sequencer queue 0 : stopped
P0-0-0: PCM playback 0-0-0 : SLAVE
P0-0-1: PCM capture 0-0-1 : SLAVE
P0-3-0: PCM playback 0-3-0 : SLAVE
P0-4-1: PCM capture 0-4-1 : SLAVE
Advanced Linux Sound Architecture Driver Version 1.0.18rc3.
jodokus@ubuntu:~$ lspci|grep -i audio
00:07.0 Audio device: nVidia Corporation MCP78S [GeForce 8200] High Definition Audio (rev a1)
jodokus@ubuntu:~$ aplay -l cat /etc/modprobe/alsa-base
**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: NVidia [HDA NVidia], apparaat 0: ALC888 Analog [ALC888 Analog]
  Sub-apparaten: 0/1
  Sub-apparaat #0: subdevice #0
kaart 0: NVidia [HDA NVidia], apparaat 3: NVIDIA HDMI [NVIDIA HDMI]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0

Citaat
Hallo

Inderdaad eerst even je mixer openen
Kijk of je bij de tab; schakelaars zoiets als Headphone jack sense
hebt staan en vink die aan.
Staat ie er niet bij; toevoegen via de voorkeuren knop

Werkt het alsnog niet ? even melden, waarschijnlijk moet er dan even aan een
optie in je alsa-base gesleuteld worden.
Daarbij willen we dan wel
wat gegevens meer; bijv. Versie ubuntu, model laptop en met deze commando's
in de terminal;
cat /proc/asound/* 2>/dev/null
lspci|grep -i audio
aplay -l

en evt. een;
cat /etc/modprobe/alsa-base
om te kijken wat je er nu hebt staan

Bij mijn oude laptop lost de interne schakelaar in de jack socket dat zelf voor mij op
dus beide opties worden niet door mij gebruikt.

Voor iemand op dit forum was met name de toevoeging position_fix=1 de oplossing
voorbeeldje; options snd-hda-intel position_fix=1 model=lenovo in zijn alsa-base

Groeten Gerrit


En waar moet ik die veranderingen dan aanbrengen? Dit is voor mij niet duidelijk, aangezien ik niet thuis ben in deze materie.

Offline jerry_80

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #9 Gepost op: 2009/09/15, 16:08:40 »
Ik heb hier idd ook eens een draad over gestart, zie:
http://forum.ubuntu-nl.org/software-en-configuratie/geluid-enkel-via-line-out/

Ik heb tot op heden nog geen werkende oplossing, maar ik denk eraan om een usb koptelefoon aan te schaffen om het probleem te omzeilen.


Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #10 Gepost op: 2009/09/16, 17:19:02 »
Hallo

Sorry dat ik niet meer zo vlot reageer als vroeger, maar druk druk tot zeer druk.

Geen kant en klare oplossing, maar wat opmerkingen en ook vragen,
De ALC888 is een wat moeilijkere chipset, zoek maar eens op dit forum, maar weinig kant
en klaar oplossingen.
Wat is het exacte type acer laptop? , het loont vaak de moeite om even bij
http://www.linux-laptop.net/ en http://tuxmobil.org/
te kijken voor een mogelijke oplossing, ipv. het wiel twee keer uit te vinden.
En welke ubuntu versie?

laatste regel die je intikte:
jodokus@ubuntu:~$ aplay -l cat /etc/modprobe/alsa-base
**** Lijst van PLAYBACK hardware-apparaten ****
etc.
etc.

klopt niet helemaal, dat zijn 2 opdrachten door elkaar, die
cat /etc/modprobe/alsa-base
is nl. een aparte opdracht en werkt alleen voor 8.10 en ouder
Voor versies vanaf 9.04;  cat /etc/modprobe/alsa-base.conf
Dat is tevens de file waar evt. wat in veranderd zou moeten/kunnen worden.
Vandaar dat we output even willen zien of daar al wat valt te ontdekken.

Maar sommige mensen die totaal geen geluid kregen met 9.04 icm. met de
alc888 hebben zelfs een nieuwere versie van alsa erop moeten zetten en ik kan
zo niet bepalen of je headphone/speaker probleem ermee opgelost gaat worden.
Er zijn wat tutorials te vinden, ik heb zo de linkjes niet; liggen op mijn andere bak,
oa. beschrijving voor een dell met alc888 zonder geluid.

Hopelijk heb je hier wat meer aan of kan iemand met het model laptop iets meer.

Groeten Gerrit




-- = >  simplify if you can   -- = >

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #11 Gepost op: 2009/09/16, 17:25:53 »
Dit hielp bij mij:

Open de geluidsmixer (het geluidspictogram in je systeemvak) en druk vervolgens op Voorkeuren om de te tonen kanalen te wijzigen. Zoek nu in de lijst naar "jack sense" of "jack detection" (iets in die trant) en zet er een vinkje voor. Nu moet het desbetreffende kanaal in je mixer staan. Zet het aan en het geluid zou automatisch moeten dempen als je iets aansluit ;)

Offline ilseroen

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #12 Gepost op: 2009/09/17, 18:48:59 »
Citaat
Wat is het exacte type acer laptop? , het loont vaak de moeite om even bij
http://www.linux-laptop.net/ en http://tuxmobil.org/
te kijken voor een mogelijke oplossing, ipv. het wiel twee keer uit te vinden.
En welke ubuntu versie?

Acer Aspire 7530, met daarop 9.04.
Deze staat niet in de lijst van de 2 linkjes.


Citaat
klopt niet helemaal, dat zijn 2 opdrachten door elkaar, die
cat /etc/modprobe/alsa-base
is nl. een aparte opdracht en werkt alleen voor 8.10 en ouder
jodokus@ubuntu:~$ cat /etc/modprobe/alsa-base
cat: /etc/modprobe/alsa-base: Bestand of map bestaat niet


Hier gaat dus iets niet goed.


@Cumulus007:

Citaat
Open de geluidsmixer (het geluidspictogram in je systeemvak) en druk vervolgens op Voorkeuren om de te tonen kanalen te wijzigen. Zoek nu in de lijst naar "jack sense" of "jack detection" (iets in die trant) en zet er een vinkje voor. Nu moet het desbetreffende kanaal in je mixer staan. Zet het aan en het geluid zou automatisch moeten dempen als je iets aansluit

Ik kan het nergens vinden, dus dit gaat helaas niet werken.  :(



Offline Maik

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #13 Gepost op: 2009/09/17, 19:05:37 »
Wacht in dat geval op de aankomende Ubuntu 9.10 Karmic Koala. Met de nieuwere kernels vanaf 2.6.30-xx en hoger worden de HDA geluidkaarten beter ondersteund. ;)
Ik heb zelf ook zulke problemen met mijn HDA geluidskaart en weet dat het in de nieuwe versie in oktober "out of the box" gaat werken. Nog een klein maandje geduld dus.


Overigens in 9.04 moet het alsa-base.conf zijn en niet alsa-base. :)
« Laatst bewerkt op: 2009/09/17, 19:07:28 door DarkEra »

Offline ilseroen

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #14 Gepost op: 2009/09/17, 19:11:16 »
Citaat
Overigens in 9.04 moet het alsa-base.conf zijn en niet alsa-base.

jodokus@ubuntu:~$ cat /etc/modprobe/alsa-base.conf
cat: /etc/modprobe/alsa-base.conf: Bestand of map bestaat niet

Helaas, dit werkt ook niet.

Citaat
Wacht in dat geval op de aankomende Ubuntu 9.10 Karmic Koala. Met de nieuwere kernels vanaf 2.6.30-xx en hoger worden de HDA geluidkaarten beter ondersteund. Wink
Ik heb zelf ook zulke problemen met mijn HDA geluidskaart en weet dat het in de nieuwe versie in oktober "out of the box" gaat werken. Nog een klein maandje geduld dus.

Klein maandje? Dat gaat lukken...  :)

Offline Maik

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #15 Gepost op: 2009/09/17, 19:21:48 »
Op 29 Oktober komt Ubuntu 9.10 uit in ieder geval, iets meer dan een maand nog bedoelde ik eigenlijk. ;)

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #16 Gepost op: 2009/09/17, 21:25:12 »
Even voor de volledigheid, door een slordigheidje overgenomen uit
de doorlink het moet;

cat /etc/modprobe.d/alsa-base.conf
zijn.

Je kunt natuurlijk ook even een 9.10 alpha alvast proberen in live modus,
als je geen maandje meer kunt wachten  ;)
Het is niet alleen de nieuwere kernel maar evt. ook de nieuwe alsa base paketten
die de doorlag kunnen geven.

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline ilseroen

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #17 Gepost op: 2009/09/20, 20:03:57 »
Ik kwam er net achter dat het probleem zich niet voor doet onder windows.
Ergens zal ik dan de instellingen niet goed hebben, maar geen flauw idee wat.

Offline jerry_80

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #18 Gepost op: 2009/10/29, 21:59:11 »
Bij mij is het alvast opgelost met de 9.10!
:-D

Offline ilseroen

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #19 Gepost op: 2009/12/03, 13:36:14 »
Opgelost: 9.10 heeft dit probleem niet.

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #20 Gepost op: 2009/12/03, 16:20:39 »
Hallo

Mooi, zal waarschijnlijk wel de nieuwere kernel annex alsaversie zijn,

wat staat er nu trouwens in je alsa-base.conf ?
cat /etc/modprobe.d/alsa-base.conf

als er niets expliciet werd toegevoegd door het systeem, in een regel
als; options snd-hda-intel model=bladiebla

dan heeft ie het op automagisch geregeld.

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline ilseroen

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #21 Gepost op: 2009/12/03, 18:27:37 »
Dit staat er:

jodokus@jodokus:~$ cat /etc/modprobe.d/alsa-base.conf
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Power down HDA controllers after 10 idle seconds
options snd-hda-intel power_save=10 power_save_controller=N
jodokus@jodokus:~$


Geen idee wat het allemaal inhoudt, maar alles werkt.

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #22 Gepost op: 2009/12/03, 20:43:53 »
Lijkt me geheel automagisch ingesteld. Trouwens, heb je gezien dat er powersave options
in staan, die willen nog wel eens zorgen voor klikkende bijgeluiden/danwel ruis. Dat is
niet bij iedere kaart zo en misschien na een update van het één en ander misschien ook
wel weg. Sommige gebruikers moesten dat uitzetten, ben er zelf nog niet over gestruikeld.

Bedankt voor je terugmelding overigens.

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline petervs

  • Lid
  • Steunpunt: Nee
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #23 Gepost op: 2009/12/03, 21:40:24 »
Zo vaak gebruik ik de koptelefoon niet, maar onder 8.04 moest ik dit toevoegen aan /etc/modprobe.d/alsa-base :
options snd-hda-intel model=stack3
 position_fix=0 single_cmd=0

maar kom erachter dat het inderdaad onder 9.10 meteen werkt (9.10 tot nu toe de beste versie bij mij)
Ubuntu MATE 16.04

TwoM

  • Gast
Re: Geluid uit koptelefoon én luidsprekers.
« Reactie #24 Gepost op: 2010/03/25, 19:18:19 »
Hey.

Ik gebruik sinds kort Ubuntu 9.10 en ik heb nu hetzelfde probleem als de topicstarter  :(
Mijn laptop: HP Pavilion dv7-3160eb Entertainment Notebook PC
met als audio driver in Windows: IDT High Definition Audio CODEC Driver

Eerst had ik enkel geluid uit de subwoofer onderaan de laptop, toen heb ik linux-backports-modules-alsa-2.6.31-20-generic-pae geïnstalleerd.
Nu werken mijn interne boxen en ook mijn 2 audio uitgangen, maar de interne boxen slaan niet af wanneer ik mijn koptelefoon en/of surround system aansluit.
(For the record: In windows 7 lukt dat wel en mijn laptop is een week oud, dus het ligt niet aan de hardware)

Ik heb hier al verscheidene topics geraadpleegd en ik heb één oplossing gevonden die werkt, maar die vind ik toch niet optimaal.
Ik heb GNOME Alsa Mixer geïnstalleerd en wanneer ik die open kan ik via de laatste regelaar de speakers afzetten en gebruik ik enkel de audio uitgangen.
Maar dan moet ik alles doen via die Mixer en kan ik dus het icoontje in het systeemvak niet langer gebruiken...
Want wanneer ik die gebruik springen mijn speakers terug aan.

Iemand een oplossing voor dit probleem? Of wacht ik ook best op een volgende versie van Ubuntu?


Dank bij voorbaat!