Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Wireless werkt niet (Ubuntu 9.04, Intel wifi 5100)  (gelezen 2773 keer)

mph

  • Gast
Wireless werkt niet (Ubuntu 9.04, Intel wifi 5100)
« Gepost op: 2009/09/08, 20:27:39 »
Dag allen,

Na een hele tijd gewerkt te hebben met een vorige versie van Ubuntu op een desktop, was het voor mij een logische stap om op mijn nieuwe laptop (met helaas enkel Vista geïnstalleerd) de nieuwste Ubuntu te installeren. Heel wat dingen werkten gelukkig meteen (ook oa. wired internet), maar wireless doet het niet. Ik heb al heel wat zoekwerk gedaan, maar ik raakte de weg wat kwijt tussen alle adviezen die niet op mij van toepassing waren of die niet voldoende waren uitgewerkt om mij te helpen. Vandaar, reluctantly, toch maar hier eens posten.

In short:
Ubuntu versie: 9.04. Net geïnstalleerd, dus geen conflicterende programma's ofzo.
Wifi: Intel Wireless Wifi link 5100  (waarvan ik toch had gevonden dat die "out of the box" zou moeten werken)?

Geen idee wat voor gegevens ik nog moet leveren zodat hulpvaardige zielen me de juiste tips zouden kunnen geven...?

Alvast bedankt voor jullie tijd en moeite!

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
In der Beschränkung zeigt sich der Meister.

mph

  • Gast
Re: Wireless werkt niet (Ubuntu 9.04, Intel wifi 5100)
« Reactie #2 Gepost op: 2009/09/08, 21:04:58 »
Heb je hier wat aan? http://sites.google.com/site/computertip/geendraadloosinternet
Dat was een van de dingen die ik gevonden had ja :)
stap 1) Alle updates binnenhalen: gedaan.
Hardware drivers: die geeft enkel een ATI-driver... en ik zie niet meteen hoe ik "andere drivers" zou moeten oproepen?

stap 2) lspci gedaan, Resultaat, zoals gezegd: een Intel wifi 5100.
Stappen 3-8 zijn dus niet van toepassing, en ndiswrapper doe ik liever niet, voorlopig (had gelezen dat dat niet meteen goed was?)

Hopelijk is de oplossing eigenlijk maar iets kleins, en moet ik niet direct "windows gaan binnenhalen onder linux"?

groeten,
Maarten

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Wireless werkt niet (Ubuntu 9.04, Intel wifi 5100)
« Reactie #3 Gepost op: 2009/09/08, 22:21:25 »
Is het een wifi die in de laptop zit? Of een USB-wifi
In het eerste geval open een terminal en type lspci en kan je de uitkomst hier plaatsen, via copy/paste
In het tweede geval open een terminal en type lsusb en kan je de uitkomst hier plaatsen, via copy/paste
Graag tussen code tags, deze krijg je door op de knop # te drukken , deze staat boven het bericht wat je typt.
In der Beschränkung zeigt sich der Meister.

Offline quick30

  • Lid
  • Steunpunt: Nee
Re: Wireless werkt niet (Ubuntu 9.04, Intel wifi 5100)
« Reactie #4 Gepost op: 2009/09/08, 22:29:38 »
Ik heb even wat gegoogled. Er kwam een bug naar boven:
https://bugs.launchpad.net/ubuntu/+source/linux-backports-modules-2.6.28/+bug/350370
Hier ook iemand met een laptop die Jaunty installeerde en het niet werkt.  >:(

Het lijkt wel te zijn opgelost want even verder op de pagina staat:
https://bugs.launchpad.net/ubuntu/+source/linux-backports-modules-2.6.28/+bug/350370/comments/18
..dat het
Citaat
The fix described there is to install linux-backports-modules-jaunty-generic from backports, it has a new iwlagn module which fixed WPA2 auth for me and at least a few others so far.

Ik heb niet gekeken hoe dat moet. Daarvoor gaat het me even te ver. [Ik ga nu douchen en naar bed.] =D

mph

  • Gast
Re: Wireless werkt niet (Ubuntu 9.04, Intel wifi 5100)
« Reactie #5 Gepost op: 2009/09/08, 22:58:09 »
Met de lspci kwam ik uit op dit:

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3650
01:00.1 Audio device: ATI Technologies Inc RV635 Audio device [Radeon HD 3600 Series]
02:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040T PCI-E Fast Ethernet Controller (rev 12)
0a:01.0 FireWire (IEEE 1394): O2 Micro, Inc. Firewire (IEEE 1394) (rev 02)
0a:01.2 SD Host controller: O2 Micro, Inc. Integrated MMC/SD Controller (rev 02)
0a:01.3 Mass storage controller: O2 Micro, Inc. Integrated MS/xD Controller (rev 01)


Ik moet helaas toegeven dat ik van de link van quick30 niet zoveel snap  :-[

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Wireless werkt niet (Ubuntu 9.04, Intel wifi 5100)
« Reactie #6 Gepost op: 2009/09/08, 23:18:11 »
   1. Download "iwlwifi-5000-ucode-5.4.A.11.tar.gz" from "http://intellinuxwireless.org/?n=Downloads".
   2. Unzip it to a folder, and copy the "iwlwifi-5000-1.ucode" file to "/lib/firmware"
   3. And then reboot the machine
Van deze site http://www.linuxquestions.org/questions/linux-networking-3/intel-wifi-link-5100-cannot-work-on-linux-678588/ antwoord #3 Als je het niet helemaal volgt, post dan weer bij welke stap je vast zit.
In der Beschränkung zeigt sich der Meister.

mph

  • Gast
Re: Wireless werkt niet (Ubuntu 9.04, Intel wifi 5100)
« Reactie #7 Gepost op: 2009/09/09, 00:55:59 »
   1. Download "iwlwifi-5000-ucode-5.4.A.11.tar.gz" from "http://intellinuxwireless.org/?n=Downloads".
   2. Unzip it to a folder, and copy the "iwlwifi-5000-1.ucode" file to "/lib/firmware"
   3. And then reboot the machine
Van deze site http://www.linuxquestions.org/questions/linux-networking-3/intel-wifi-link-5100-cannot-work-on-linux-678588/ antwoord #3 Als je het niet helemaal volgt, post dan weer bij welke stap je vast zit.

Die file stond er al mooi tussen, vrees ik... zelfs een nieuwere versie dan die van die site... of gaat het er net om dat de nieuwste versie niet werkt?  ???

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Wireless werkt niet (Ubuntu 9.04, Intel wifi 5100)
« Reactie #8 Gepost op: 2009/09/09, 08:40:28 »
De file staat al uitgepakt in /lib/firmware? Dat de file nieuwer is kan natuurlijk heel goed kloppen aangezien de link van vorig jaar is. Je kan het nog proberen met de oudere driver. Als dit niet de oplossing is dan toch de post van quick30 doorlopen, stap voor stap met behulp van ons.
In der Beschränkung zeigt sich der Meister.

mph

  • Gast
Re: Wireless werkt niet (Ubuntu 9.04, Intel wifi 5100)
« Reactie #9 Gepost op: 2009/09/15, 19:31:10 »
Geen idee waarom, maar opeens werkt het, na de router even af- en terug aangezet te hebben...

(met excuses voor de vertraging, ik ben even (on)behoorlijk ziek geweest. bedankt voor de reacties!)
« Laatst bewerkt op: 2009/09/17, 03:29:46 door mph »