Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: local domein meilding kort na het opstarten.  (gelezen 6294 keer)

Offline force317

  • Lid
  • Steunpunt: Nee
local domein meilding kort na het opstarten.
« Gepost op: 2009/09/03, 18:07:48 »
Ik krijg kort nadat ik ben opgestart de volgende melding :

'Netwerkservicedetectie uitgeschakeld : Uw huidige netwerk heeft een .local domein. Dat wordt niet aanbevolen en is niet bruikbaar met
de Avahi netwerkservicedetector. De service is daarom uitgeschakeld.'

Hoe kan ik deze melding verhelpen ? Ik krijg die nog maar enkele dagen, vroeger nooit. Mogelijk veroorzaakt door een installeren/deinstalleren van software of gewoon door een update ?

Momenteel in gebruik op mijn hardware : Ubuntu 13.10, Kubuntu 13.10, Windows 7 Home, Windows 8.1 Home.

Offline Maik

  • Lid
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #1 Gepost op: 2009/09/03, 18:15:38 »
Dat is nou echt toevallig. Ik heb dit ook precies hetzelfde, na het laden van de desktop en dat er connectie is gemaakt met internet. Ben er ook nog niet achter waar dit nu zo 123 vandaan komt.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #2 Gepost op: 2009/09/03, 18:43:33 »
Dat komt door je router waarschijnlijk.
Die geeft de computers bij het opstarten hun netwerkinstellingen, waaronder het IP-adres en het domein van het netwerk.

Als je router aan je computer meedeelt dat het "domein" van het netwerk ".local" is, dan werkt Avahi niet, omdat die zelf alle .local-adressen wil beheren.

Je moet dus in je router het domein veranderen in bijvoorbeeld .lan

Het kan ook nog zo zijn dat je zelf in de netwerkmanager/instellingen dat hebt opgegeven.

Offline force317

  • Lid
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #3 Gepost op: 2009/09/04, 01:47:05 »
En waar pas je die instelling aan op je ubuntu notebook in de menu's ? Vermits ik niks in de router manueel ben gaan aanpassen kan het toch niet daaraan liggen ?

Sinds verleden zondag is er een asus eee pc 1000 he in het netwerk die draait op XP Home. Kan dit een rol spelen ? Het is geloof ik van rond die tijd dat de melding op de ubuntu notebook is opgedoken ?

Momenteel in gebruik op mijn hardware : Ubuntu 13.10, Kubuntu 13.10, Windows 7 Home, Windows 8.1 Home.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #4 Gepost op: 2009/09/04, 02:15:35 »
Volgens deze pagina ligt het aan je DNS server.
Dat betekent in de meeste thuissituaties dus je modem/router. Je zal dus in je modem iets aan moeten passen, niet in Ubuntu of Windows.

Zie voor een voorbeeld dit screenshot:

Het gaat hier om de domain name en je moet hier lan of .lan invoeren. Of iets anders wat niet bestaat en niet .local is.

Of hier:

Niet de rode pijl, maar weer "domain name".

Bij jouw modem of router kan dat er anders uitzien, dat verschilt per merk en type.

Offline Maik

  • Lid
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #5 Gepost op: 2009/09/04, 14:27:20 »
Ik snap er niets van in ieder geval. Ik zelf heb niks aangepast, dus ik vraag me af hoe dat kan dat hij gebruik maakt van .local domain. Of ik nu de draadloze router pak of gewoon de kabel die aan de telenet kast is aangesloten, maakt niks uit. Wat me ook opvalt is dat m'n IP steeds veranderd op het eind na bijvoorbeeld een nieuwe installatie.

Zou het kunnen zijn dat misschien de telenet kast die hier geinstalleert is van slag is na een stroomuitval van laatst? Ik weet niet of dat er iets me te maken kan hebben.

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #6 Gepost op: 2009/09/06, 13:09:44 »
...................
Zou het kunnen zijn dat misschien de telenet kast die hier geinstalleert is van slag is na een stroomuitval van laatst? Ik weet niet of dat er iets me te maken kan hebben.

Dat denk ik niet,  want sinds een paar dagen heb ik precies hetzelfde.
Kan het iets te maken hebben met een update ?
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: LinuxMInt18.2.  Radio Amateur callsign: PA2HO

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #7 Gepost op: 2009/09/06, 14:10:12 »
Misschien is er aan de kant van Telenet wel iets veranderd?
Het probleem zit in de DNS server, en als je de DNS server van Telenet gebruikt zou daar best wel wat veranderd kunnen zijn.

Wat staat er in /etc/resolv.conf ?

Wat zegt dit commando?
host -v -t SOA local.Let op de punt aan het einde

En dit commando?
route -n

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #8 Gepost op: 2009/09/06, 14:12:59 »
Hier ook een telenet gebruiker met hetzelfde probleem.

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #9 Gepost op: 2009/09/06, 18:22:01 »
anyway even gedaan wat johan voorstelde.
siegie@lapdell:~$ host -v -t SOA local.
Trying "local"
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 97
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;local.                         IN      SOA

;; ANSWER SECTION:
local.                  18000   IN      SOA     ns.telenet-ops.be. systemgroup.telenet-ops.be. 2008082501 10800 3600 604800 3600

;; AUTHORITY SECTION:
local.                  18000   IN      NS      dnscache.telenet-ops.be.

Received 111 bytes from 195.130.131.4#53 in 17 ms
Zover ik het begrijp is er dus duidelijk iets veranderd bij telenet.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #10 Gepost op: 2009/09/06, 18:27:38 »
Als je de dns servers verandert naar OpenDNS zou het probleem met Avahi opgelost worden.
https://www.opendns.com/start/device/ubuntu

Maar eigenlijk zou Telenet hun DNS servers aan moeten passen zodat het .local domein genegeerd wordt.

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #11 Gepost op: 2009/09/06, 19:10:06 »
Kan je naam van .local ook niet gewoon veranderen?
Ik heb even gezocht onder /etc/avahi/avahi-daemon en domeinname veranderd in iets simpel als .thuis .
Maar dit heeft geen effect.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #12 Gepost op: 2009/09/06, 19:25:02 »
Nee dat kan niet.
 .local is specifiek bedoeld voor Avahi, Bonjour, mdns en alles wat volgens dezelfde standaarden werkt.

Daarom vind ik het zo vreemd dat een ISP dit domein op zijn eigen DNS servers inzet.
Het is immers een domein dat op internet niet gebruikt wordt. In een thuissituatie zou je wel .local kunnen kiezen voor je besloten netwerkje, maar het gevolg is dan dat Avahi niet meer werkt.

En Avahi is nou juist zo makkelijk: automatisch een computer op je lan opzoeken als je die over wil nemen via VNC, lokaal chatten via Pidgin, Ekiga enz., automatisch netwerkprinters vinden, geen IP-adressen meer hoeven te onthouden, enz.

Dit probleem is ook niet specifiek voor Linux, ook Apple computers kunnen problemen krijgen. En Windows als de Bonjour plugin geïnstalleerd is.

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #13 Gepost op: 2009/09/06, 19:36:13 »
Ik heb dit ondertussen ook even het forum van tik gezet.
De telecom en internet klanten vereniging, normaal hebben zij om de zoveel tijd een vergadering met telenet.
http://www.tik.be/forum/viewtopic.php?f=5&t=11840&p=149086#p149086

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #14 Gepost op: 2009/09/06, 20:09:52 »
Hier gebruik ik OpenDNS en zie ik dit:
johan@desktop:~$ host -v -t SOA local.
Trying "local"
Received 23 bytes from 208.67.222.222#53 in 31 ms
Trying "local"
Host local. not found: 3(NXDOMAIN)
Received 23 bytes from 208.67.222.222#53 in 32 ms

Mijn router gebruikt wel de DNS server van mijn provider, Telfort.
Als ik die opgeef zie ik dit:

johan@desktop:~$ host -v -t SOA local. 192.168.1.254
Trying "local"
Received 98 bytes from 192.168.1.254#53 in 25 ms
Trying "local"
Using domain server:
Name: 192.168.1.254
Address: 192.168.1.254#53
Aliases:

Host local. not found: 3(NXDOMAIN)
Received 98 bytes from 192.168.1.254#53 in 24 ms

Zo zou het dus moeten.

Offline Scormen

  • Lid
    • LinuxOntdekt.Be
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #15 Gepost op: 2009/09/06, 20:44:10 »
Zelfde foutmelding hier ... Ook telenet.
Ubuntu gebruiker #18341 | Linux gebruiker #456955
· Mijn persoonlijke Linux blog

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #16 Gepost op: 2009/09/06, 21:23:49 »
Het schijnt vaker voor te komen dat providers het niet helemaal goed doen.
Zie de release notes voor Jaunty: https://wiki.ubuntu.com/JauntyJackalope/ReleaseNotes#Avahi%20will%20not%20start%20if%20a%20.local%20domain%20is%20present

En het bugrapport: https://bugs.launchpad.net/ubuntu/+source/avahi/+bug/327362

Er is dus wel een oplossing, zoals in de eerste link staat, maar eigenlijk zou Telenet hun DNS servers anders in moeten stellen.

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #17 Gepost op: 2009/09/08, 10:05:34 »
Voorlopig heb ik het opgelost zoals het in de release notes beschreven staat.
http://www.ubuntu.com/getubuntu/releasenotes/904
Werkt prima, maar opzich wel stom om die detectie te moeten uitschakelen.

Offline Scormen

  • Lid
    • LinuxOntdekt.Be
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #18 Gepost op: 2009/09/08, 19:05:26 »
Ik heb de Telenet helpdesk gecontacteerd, maar die hebben blijkbaar tijd genoeg, ik krijg geen reactie ...
Ubuntu gebruiker #18341 | Linux gebruiker #456955
· Mijn persoonlijke Linux blog

Offline force317

  • Lid
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #19 Gepost op: 2009/09/12, 16:30:22 »
Vreemd genoeg krijg ik de melding voor het moment niet meer ...
Waarom ? Geen idee.  ???
Momenteel in gebruik op mijn hardware : Ubuntu 13.10, Kubuntu 13.10, Windows 7 Home, Windows 8.1 Home.

Offline Scormen

  • Lid
    • LinuxOntdekt.Be
  • Steunpunt: Nee
Re: local domein meilding kort na het opstarten.
« Reactie #20 Gepost op: 2009/09/17, 18:06:28 »
Nu je het zegt, ik ook niet ...
De host local. is hier ook verdwenen, blijkbaar heeft Telenet z'n nameservers toch aangepast?

Telenet helpdesk heeft nog altijd niet gereageerd ...

Kris
Ubuntu gebruiker #18341 | Linux gebruiker #456955
· Mijn persoonlijke Linux blog