Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: 2 beeldschermen  (gelezen 606 keer)

Smetje

  • Gast
2 beeldschermen
« Gepost op: 2009/09/01, 07:42:54 »
hallo,
tot en met 8.04 werkte volgende configuratie:
- Nividia Gforce 6200
- 2 aparte X-screens
- één via VGA op 1366x768
- één via DVI op 1440x900
sinds de nieuwe install met 9.04 had ik het probleem dat wanneer ik een programma opende op het bovenste scherm (screen 1, geloof ik) dat werd gezet op het onderste (screen 0). Dan ben ik van alles aan het uitproberen geweest maar zonder succes, tot het moment dat ik geen beeld meer had. Ik kon dan met dpkg-reconfigure ...  weer de vesa driver installeren maar dat is uiteraard niet de bedoeling.
Gisterenavond heb ik alles dan opgegeven en 9.04 nog eens geinstalleerd. ik heb/had 3 partities op mij HD: een /, een /home en een swap. Bij de installatie (waarbij ik een prima beeld had op 1440*900 via DVI, dus hardware goed herkend?) heb ik ervoor gekozen om enkel de / te laten formateren omdat ik op de /home nogal wat data heb. Soit, na een geslaagde re-instal en een herstart krijg ik een, hoe moet ik het omschrijven, paarse sterrenhemel. Het scherm geeft wel de melding op 1440*900/60Hz te zitten, wat goed is. Staat op de /home nog iets dat met de Xserver te maken heeft?

thanks,
Tom.

Offline Willem_D

  • Lid
  • Steunpunt: Nee
Re: 2 beeldschermen
« Reactie #1 Gepost op: 2009/09/01, 12:02:12 »
Smetje, welkom op het forum!

Of er op de /home configuratie-data voor de Xserver staan durf ik niet te zeggen (ik zou het niet verwachten).

Je zou eens kunnen proberen om via recovery-mode een 'xfix (Try to auto repair graphic problems)' te starten, en vervolgens opnieuw de nVidia fabrieksdriver te installeren.

(xfix zal de opvolger zijn van 'dpkg-reconfigure' .)
Acer 5930G laptop met nVidia 9600M GT


"Je verschijnt niet in je lichaam, maar je lichaam verschijnt in Jou."
Francis Lucille

Offline Willem_D

  • Lid
  • Steunpunt: Nee
Re: 2 beeldschermen
« Reactie #2 Gepost op: 2009/09/01, 12:09:43 »
sinds de nieuwe install met 9.04 had ik het probleem dat wanneer ik een programma opende op het bovenste scherm (screen 1, geloof ik) dat werd gezet op het onderste (screen 0). Dan ben ik van alles aan het uitproberen geweest maar zonder succes, tot het moment dat ik geen beeld meer had.

Zodra je weer beeld hebt, kun je beide schermen misschien weer perfect werkend krijgen door je xorg.conf te editen; het vereist wel enige studie.

Zie: https://wiki.ubuntu.com/X/Config/Resolution .

Het volgende draadje zou je hierbij kunnen helpen:
http://forum.ubuntu-nl.org/hardware-en-drivers/start-niet-op-met-2e-videokaart/msg459377/#msg459377
Acer 5930G laptop met nVidia 9600M GT


"Je verschijnt niet in je lichaam, maar je lichaam verschijnt in Jou."
Francis Lucille

Smetje

  • Gast
Re: 2 beeldschermen
« Reactie #3 Gepost op: 2009/09/01, 13:23:32 »
thanks!

- die xfix zal ik vanavond eens proberen.
- het stuk uit de ubuntu wiki heb ik uitgeprint...

gr,
Tom.

Smetje

  • Gast
Re: 2 beeldschermen
« Reactie #4 Gepost op: 2009/09/01, 22:24:40 »
topic opgelost.

heb met vim de lijn driver "vesa" toegevoegd. Vervolgens grafisch met 'hardware drivers' de nvidia 180 driver geïnstalleerd. de xorg.conf nog voor het herstarten gecontroleerd: de vesa driver was eruit en er was nog het één en ander toegevoegd. Dus ik vertrouwde erop en deed de herstart. Met succes.
Ik had goed beeld op de VGA uitput - niets op de DVI. Met nvidia-settings het tweede beeldscherm toevoegd, de resoluties konden op auto blijven staan.

Nu heb ik wel een ander probleem, ook sinds ubuntu 9.04, maar ik den daarvoor een ander topic te openen.

gr en thx,
Tom.