Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu 9.04 / kan schermresolutie niet opslaan NVIDIA GeForce Go 7950 GTX  (gelezen 5357 keer)

Offline xxmkkl

  • Lid
  • Steunpunt: Nee
DELL XPS M1710
INTEL CORE 2 DUO 2,33 Ghz
4 GB RAM
NVIDIA Geforce Go 7950 GTX 512 MB
Ubuntu 9.04


Hallo,

Ben sinds kort overgestapt van VISTA naar Linux, en ben blij met de grotere vrijheid. Probleem is dat ik de schermresolutie niet kan opslaan, en moet ik dit iedere reboot manueel op de gewenste resolutie zetten.

Heb eerst de laatste nieuwe drivers geïnstalleerd met system - administration - hardware drivers (Nvidia drivers 180)
Ook heb ik geprobeerd om via de terminal als root de nvidia-instellingen te benaderen op verschillende wijzes: (gksudo nvidia-drivers / sudo nvidia-drivers)
Tevens heb ik geprobeerd om het xorg.conf bestand te bekijken, en dingen aan te passen mbv internetsites, maar mijn kennis reikt niet ver genoeg om dit met vol vertrouwen te doen, dus heb het na vergeefse pogingen weer in de oude configuratie teruggezet (had backups gemaakt).

Wat ik ook probeer, wanneer ik de laptop opnieuw opstart, start het bootscherm in de gewenste resolutie (1920x1200), maar Ubuntu start op in 800x600.
Ik houd best van puzzelen, maar ik kom er niet meer uit! Het is voor mij allemaal nieuw, en ik moet nog veel leren, maar ik ben al weken bezig en begin nu te twijfelen of ik wel Linux wil, aangezien ik zelfs zo'n ogenschijnlijk simpel probleem maar niet opgelost krijg.

Wie kan mij helpen?

« Laatst bewerkt op: 2013/01/10, 00:41:35 door xxmkkl »

Offline Johan Velthuizen

  • Lid
    • http://www.velthuizen.nl
  • Steunpunt: Nee
Bij het opslaan geeft hij waarschijnlijk de melding dat hij een file niet kan opslaan. Noteer de naam van die file en in welke map deze file staat.

Open nu de terminal en type sudo nautilus
geef je wachtwoord

Zoek via nautilus naar de juiste map klik er met rechter muise knop  klik op eigenschappen en zet de rechten van de map oplezen en schrijven

Probeer daarna nogmaals de instelling op te slaan.

Offline joop905

  • Lid
  • Steunpunt: Nee
Welkom,
kijk eens naar Nvidia-settings

Blijvende instellingen. Alt F2 >   Of Terminalvenster  
gksudo nvidia-settings

GrJ.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Ik sluit me aan bij het advies van joop905.  :)

Nadat je gksudo nvidia-settings hebt gedaan in de terminal, kun je als volgt de resolutie instellen via het menu van dat instelprogje (dat is namelijk ook nog even zoeken):
http://sites.google.com/site/computertip/geenbeeld
(punt 2 c, tekstblok rechts onderaan de pagina).

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
Hallo, probeer de hardware-driver voor NVidia te activeren, ga naar Systeem, Beheer, Hardwaredrivers (of zoiets, heb even geen Nederlandse Ubuntu bij de hand) en klik op de laatste. Als het goed is volgt er een vraag of u de gesloten (niet opensource) drivers van Nvidia wilt gebruiken, klik op yes, waarna eea. wordt gedownlöädet, waarnaar de boel, eventueel na een herstart van X, werkt, in theorie & principe. In mijn (beperkte) ervaring werken nvidia-kaarten goed met deze gesloten drivers.
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...

Offline heir4c

  • Lid
  • Steunpunt: Nee
Welkom op het forum,

Als het bovenstaande niet werkt kan je nog altijd je xorg.conf aanpassen:(enkel indien de rest dus niet werkt)

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
SubSection "Display"
Depth    24
Virtual  1024  768
                Modes "1024x768@70" "1024x768@60"
EndSubSection
EndSection


De resoluties en refresh rate kan je zelf nog aanpassen. De "Virtual" is de resolutie voor je inlogscherm.


xxmkkl, Als je die tekst onderaan je bericht er vast op wil zetten (dus als "handtekening") Klik je op je nickname om in je profiel te gaan (of bovenaan op "Profiel") Daar kies je links voor 'Forumprofielinformatie'.
Scrol iets naar beneden en daar zie je dan 'Handtekening' staan. Daar kan je het één en ander typen/plaatsen en dat verschijnt dan automatisch mee als je een bericht typt.

Offline xxmkkl

  • Lid
  • Steunpunt: Nee
DELL XPS M1710
INTEL CORE 2 DUO 2,33 Ghz
4 GB RAM
NVIDIA Geforce Go 7950 GTX 512 MB
Ubuntu 9.04


Hallo, bedankt voor de snelle reacties.
Had al verschillende manieren die genoemd waren geprobeerd:

manier 1:

sudo nvidia-settings / gksudo nvidia-settings
Dan vervolgens opslaan in het programma van nvidia

Dit werkt helaas niet, wanneer ik reboot, zelfde probleem

manier 2:

vanuit terminal: sudo gedit /etc/X11/xorg.conf

Het volgende is zichtbaar:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce Go 7950 GTX"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Configured Video Device"
    Monitor        "Configured Monitor"
    DefaultDepth    24
EndSection

Section "Screen"

# Removed Option "metamodes" "1920x1200_60 +0+0"
# Removed Option "metamodes" "1920x1200_60 +0+0; 1920x1200 +0+0"
# Removed Option "metamodes" "1920x1200 +0+0; 1920x1200_60 +0+0"
# Removed Option "metamodes" "nvidia-auto-select +0+0; 1920x1200 +0+0; 1920x1200_60 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1920x1200 +0+0; nvidia-auto-select +0+0; 1920x1200_60 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


ik weet niet goed wat ik hier zou moeten aanpassen, het ziet eruit alsof alles goed is, toch?
er staat overigens wél 4x
# Removed Option "metamodes" "1920x1200_60 +0+0"

heeft dat er iets mee te maken?
« Laatst bewerkt op: 2009/08/29, 13:24:08 door xxmkkl »

Offline heir4c

  • Lid
  • Steunpunt: Nee
Blijkbaar slaat de nvidia-settings wel iets op, anders krijg je zo geen xorg.conf. Normaal gezien staat er bijna niets in.
Dus mijn berichtje niet volgen.
Even wachten op anderen met advies.

Edit: Misschien wel die Virtual erbij zetten. (dus enkel virtual en resolutie, niet de "modes")

Offline xxmkkl

  • Lid
  • Steunpunt: Nee
DELL XPS M1710
INTEL CORE 2 DUO 2,33 Ghz
4 GB RAM
NVIDIA Geforce Go 7950 GTX 512 MB
Ubuntu 9.04


@heir4c:

Sorry, ik ben een n00b wat Ubuntu/Linux betreft. Wat bedoel je met Virtual?

Mike

Offline heir4c

  • Lid
  • Steunpunt: Nee
In mijn eerste bericht staat een wit kader met daarin één van mijn xorg.conf
Daarin vind je het woordje: Virtual  met daarnaast een resolutie. Die kan je dus op dezelfde plaats toevoegen in jouw xorg.conf maar de resolutie kan je aanpassen.
Om de xorg.conf te bewerken moet je wel root rechten hebben dus in terminal of via Alt+F2 en dan intikken:
gksudo gedit /etc/X11/xorg.confLet op de X Dit moet een hoofdletter zijn.

Maar het is raar dat de nvidia-settings wel je xorg.conf aanpassen maar dat het toch niet werkt. Heb je al eens herstart?

Offline xxmkkl

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.04 / kan schermresolutie niet opslaan NVIDIA GeForce Go 7950 GTX
« Reactie #10 Gepost op: 2009/08/30, 11:45:08 »
Citaat
Maar het is raar dat de nvidia-settings wel je xorg.conf aanpassen maar dat het toch niet werkt. Heb je al eens herstart?

Uiteraard, want het probleem is dat wanneer ik opnieuw opstart, de resolutie niet bewaard blijft. Misschien is het een bug in Ubuntu, met specifiek deze driver?



Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.04 / kan schermresolutie niet opslaan NVIDIA GeForce Go 7950 GTX
« Reactie #11 Gepost op: 2009/08/30, 13:21:32 »
Ga eens naar Systeem>Voorkeuren>Scherm (in engelse versie: Display)
Kan je daar je resolutie aanpassen en tot hoe hoog?

Offline sandermans15

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.04 / kan schermresolutie niet opslaan NVIDIA GeForce Go 7950 GTX
« Reactie #12 Gepost op: 2009/08/30, 14:23:35 »
hmm toen ik begon had ik ook moeite met het opslaan van mijn x server settings
in /etc/.... zijn er geen rechten om te schrijven dus wat ik had gedaan is:
klik op save to x configuration file en klik ipv op 'save' op 'show preview' en kopieer de text die daar in staat (crtl + a (alles selecteren) en dan crtl + c (kopieren))
alt+f2>terminal
sudo kate of gedit /etc/x11/xorg.conf
gebruik dan ctrl + a (alles selecteren) en dan crtl + v (plakken) en klik op opstaan en herstart je computer

dit heeft bij mij gewerkt ik hoop dat het voor jouw ook zo is

dit is de mijne nu (de grafische kaart is een oudje :p )
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@palmer)  Sun Feb  1 20:21:04 UTC 2009


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Philips FTV"
    HorizSync       15.0 - 70.0
    VertRefresh     48.0 - 62.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce FX 5200"
EndSection

Section "Screen"

# Removed Option "metamodes" "1280x720_60 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1280x720 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
« Laatst bewerkt op: 2009/08/30, 15:13:33 door sandermans15 »

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.04 / kan schermresolutie niet opslaan NVIDIA GeForce Go 7950 GTX
« Reactie #13 Gepost op: 2009/08/30, 14:58:24 »
Leuke Tip, goed dat je het zo kon oplossen. Hopelijk werkt dit ook voor xxmkkl.
Thx om dit te delen met anderen.

Offline sandermans15

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.04 / kan schermresolutie niet opslaan NVIDIA GeForce Go 7950 GTX
« Reactie #14 Gepost op: 2009/08/30, 15:11:26 »
Leuke Tip, goed dat je het zo kon oplossen. Hopelijk werkt dit ook voor xxmkkl.
Thx om dit te delen met anderen.

geen probleem ik doe het graag ;) :D en idd nu hope dat het werkt 
« Laatst bewerkt op: 2009/08/30, 15:14:31 door sandermans15 »

Offline xxmkkl

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.04 / kan schermresolutie niet opslaan NVIDIA GeForce Go 7950 GTX
« Reactie #15 Gepost op: 2009/08/30, 22:05:22 »
DELL XPS M1710
INTEL CORE 2 DUO 2,33 Ghz
4 GB RAM
NVIDIA Geforce Go 7950 GTX 512 MB
Ubuntu 9.04


Bedankt voor de goede tip, die mij als zeer logisch in de oren klonk.


Opende het programma van NVIDIA en klikte de gewenste resolutie aan en deed de preview. Een scherm met preview van het xorg.conf opende en ik kopieërde de gegevens (CTRL A + CTRL C)
Heb het xorg.conf bestand geopend als root via de terminal: sudo gedit /etc/X11/xorg.conf
Verving de gegevens met de gegevens van de 'PREVIEW' en klikte op save. Hierna alles afgesloten en reboot.

Helaas, werkt niet, start weer op in verkeerde resolutie.
Om de één of andere reden slaat hij mijn resolutie niet op, ik snap er niets van

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.04 / kan schermresolutie niet opslaan NVIDIA GeForce Go 7950 GTX
« Reactie #16 Gepost op: 2009/08/30, 23:16:24 »
Maak eerst een backup/kopie van je xorg.conf (bijv. -> "xorg-conf-30-08-2009") en plaats de onderstaande coderegels in je device/screen-sectie van xorg.conf

Ik heb geen idee of dat bij je werkt, maar ik zag dat er verschillende benamingen in xorg.conf staan waardoor conflicten kunnen ontstaan.
De namen zoals "Device0" heb ik overal gelijk gemaakt in de onderstaande code.

Section "Device"
   Identifier "Device0"
   Driver "nvidia"
   VendorName "NVIDIA Corporation"
   BoardName "GeForce Go 7950 GTX"
EndSection

Section "Screen"
   Identifier "Default Screen"
   Device "Device0"
   Monitor "Configured Monitor"
   DefaultDepth 24
EndSection

Section "Screen"
   Identifier "Default Screen"
   Device "Device0"
   Monitor "Configured Monitor"
   DefaultDepth 24
   Option "TwinView" "0"
   Option "metamodes" "1920x1200 +0+0; nvidia-auto-select +0+0; 1920x1200_60 +0+0"
   SubSection "Display"
   Depth 24
   EndSubSection
EndSection
Xubuntu 18.04-rc; siduction-15.1.0 Xfce

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.04 / kan schermresolutie niet opslaan NVIDIA GeForce Go 7950 GTX
« Reactie #17 Gepost op: 2009/08/30, 23:21:32 »
Maak altijd eerst een kopie voordat je gaat lopen veranderen:
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf-backup
wil je de back-up terug zetten ??
sudo cp /etc/X11/xorg.conf-backup /etc/X11/xorg.conf

Offline sandermans15

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.04 / kan schermresolutie niet opslaan NVIDIA GeForce Go 7950 GTX
« Reactie #18 Gepost op: 2009/08/31, 10:51:11 »
als je kubuntu hebt hoef je niet perse een backup te maken:
gebruik je ipv gedit kate en ik weet niet of kate dit doet of dat kubuntu dit doet
maar zodra je een bestand opent met kate en wijzigt en slaat hem op op hetzelfde bestand crieert deze automatisch een backup bestandje met dezelfde naam maar dan met een ~ erbij en als het fout ging kan je weer terug zetten door de backup in kate te openen en dan die text te kopieren en in het echte bestand te zetten.

maar jammer dat het niet heeft gewerkt
ik ga nog ever verder denken en kijken misschien vind ik nog eens wat ;)

Offline sandermans15

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.04 / kan schermresolutie niet opslaan NVIDIA GeForce Go 7950 GTX
« Reactie #19 Gepost op: 2009/08/31, 10:53:20 »
kan je je hele xorg.config hier even neerzetten?

Offline xxmkkl

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.04 / kan schermresolutie niet opslaan NVIDIA GeForce Go 7950 GTX
« Reactie #20 Gepost op: 2009/09/05, 20:56:35 »
Sorry voor het wachten..

bedankt voor alle hulp.
ik zat even in het buitenland de afgelopen week. Heb geprobeerd om de xorg.conf aan te passen en te vervangen (uiteraard mét backup) met die van Joop905 maar geen veranderingen.

Voor de duidelijkheid zal ik hier mijn xorg.conf bestand even zetten:


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@palmer)  Sun Feb  1 20:21:04 UTC 2009

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Mon Mar 23 15:33:27 PST 2009
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Configured Monitor"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LPL"
    HorizSync       30.0 - 75.0
    VertRefresh     60.0
EndSection

Section "Device"
    Identifier     "Configured Video Device"
    Driver         "nvidia"
    Option         "NoLogo" "True"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce Go 7950 GTX"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Configured Video Device"
    Monitor        "Configured Monitor"
    DefaultDepth    24
EndSection

Section "Screen"

# Removed Option "metamodes" "1920x1200_60 +0+0"
# Removed Option "metamodes" "1920x1200_60 +0+0; 1920x1200 +0+0"
# Removed Option "metamodes" "1920x1200 +0+0; 1920x1200_60 +0+0"
# Removed Option "metamodes" "nvidia-auto-select +0+0; 1920x1200 +0+0; 1920x1200_60 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1920x1200 +0+0; nvidia-auto-select +0+0; 1920x1200_60 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection




Offline sandermans15

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.04 / kan schermresolutie niet opslaan NVIDIA GeForce Go 7950 GTX
« Reactie #21 Gepost op: 2009/09/08, 10:36:20 »
ik zie hier nou niet echt een bug in zitten en hij staat gewoon ingestelt op 1920x1200 op 60 hertz

ik denk dat de xorg wel goed staad en dat daar niks mis mee is maar ik denk dat het xorg bestand niet eens word geopend
en daardoor steeds terug gaat in 800x600 (dat is standaard geloof ik)
maar ik heb echter geen idee hoe je dat kan oplossen als dat al het probleem is

sorry

Offline xxmkkl

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.04 / kan schermresolutie niet opslaan NVIDIA GeForce Go 7950 GTX
« Reactie #22 Gepost op: 2009/09/12, 10:35:30 »
Dat vind ik nou zo jammer van Linux.. Ik ben een beginner met Linux, maar ik word wel verplicht om te gaan editen in gedeeltes van de computer, waar een kleine fout grote gevolgen heeft. Ik vind het leuk om bezig te zijn met computers, maar ik ben nu al weken bezig met een klein probleem, dat op de een of andere manier niet op te lossen is.

Een groot voordeel is dat er veel ondersteuning is, weinig virus/spyware problemen kent en dat het gratis is, maar ik heb geen tijd om (ondertussen meer dan 20 uur) zoveel te investeren in een probleempje als dit.

In ieder geval iedereen hartstikke bedankt voor de moeite allemaal, bedankt voor alle goede tips!

Het wordt toch Windows 7 ben ik bang... jammer


Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.04 / kan schermresolutie niet opslaan NVIDIA GeForce Go 7950 GTX
« Reactie #23 Gepost op: 2009/09/12, 10:42:46 »
En via Systeem -> Beheer -> Nvidia X Server Settings kun je de resolutie niet wijzigen? Ook niet als je het start via gksu nvidia-settings (in alt+f2), je de resolutie wijzigt en vervolgens op "Save to X configuration file" klikt?

Tja, je moet begrijpen dat de driver van Nvidia van Nvidia zelf komt en niet kan worden verbeterd door Ubuntu of andere ontwikkelaars. Dat is een groot nadeel aan closed source drivers.

Offline xxmkkl

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 9.04 / kan schermresolutie niet opslaan NVIDIA GeForce Go 7950 GTX
« Reactie #24 Gepost op: 2009/09/12, 12:01:09 »
@ Cumulus007

nope.. die oplossing kon worden gevonden via google en had ik al geprobeerd. werkt ook niet.
vreemd he, ik weet echt niet wat nu het probleem is..

Heeft iemand een idee?
« Laatst bewerkt op: 2009/09/14, 08:32:19 door xxmkkl »