Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: (Opgelost) Automatisch koppelen via fstab werkt niet goed.  (gelezen 4772 keer)

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Hier draaien twee pc's in een NFS-netwerkje. Op beide is fstab aangepast, zodat de gedeelde map op de 'andere' pc automatisch wordt gekoppeld bij het opstarten. Echter, er wordt niet automatisch gekoppeld bij de pc die als eerste aangaat. En dat is 99 van de 100 keer mijn pc. :(
Wanneer de andere pc later is aangezet, en ik klik op mijn pc op de Bladwijzer onder Locaties, dan zie ik een lege gedeelde map van de andere pc, terwijl daar wél iets in staat. Onder 'Verwisselbare media' en in 'Computer' is ie niet te bekennen en bij openen in /media verschijnt er ook een lege map. Er komen geen foutmeldingen over 'niet kunnen bereiken' o.i.d.  

Een sudo mount -a in de terminal is voldoende om die gedeelde map aan te koppelen en in 'Verwisselbare media' en 'Computer' te laten verschijnen, maar ik kan me niet voorstellen dat dit de normale gang van zaken is. Want wat heeft die regel in fstab van mijn pc dan voor nut?
Behalve fstab zijn ook de bestanden exports, hosts en hosts.allow aangepast. Heb ik nog iets over het hoofd gezien?
« Laatst bewerkt op: 2009/08/23, 18:15:43 door Mikkel »

Offline track

  • Lid
  • Steunpunt: Nee
Re: Automatisch koppelen via fstab werkt niet goed.
« Reactie #1 Gepost op: 2009/08/22, 16:08:24 »
Hoi Mikkel,

hij kan maar een map of drive (via fstab) aankoppelen die er is.  Als je de eerste computer aanzet is er dus geen andere map
om aan te koppelen.  Dat is volgens mij zover dus in orde.

Als ik een netwerkmap achteraf moet aankoppelen doe ik het ook met  sudo mount -a .
Dat is een beetje ruw maar het werkt. 
Er is in principe ook een methode dat je het via een klik op de knop kunt doen door de rechten van  /sbin/mount.cifs  aan te passen, maar dat heb ik tot nu toe niet aan de praat gekregen.

Als jij dat op een rij zou krijgen is dat ook voor mij dus interessant.

Vriendelijke groet,

track

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: Automatisch koppelen via fstab werkt niet goed.
« Reactie #2 Gepost op: 2009/08/22, 17:23:05 »
Er is in principe ook een methode dat je het via een klik op de knop kunt doen door de rechten van  /sbin/mount.cifs  aan te passen, maar dat heb ik tot nu toe niet aan de praat gekregen.

Als jij dat op een rij zou krijgen is dat ook voor mij dus interessant.

Hahaha......... nou, als jij dat al niet voor elkaar kunt krijgen........ dan ik al helemaal niet. =D =D =D

Als alleen mijn pc aanstaat valt er uiteraard niets te zien in de gedeelde map op de andere pc, dat weet ik, maar dat zou dus betekenen dat een aanpassing in fstab op de pc die over het algemeen als eerste aanstaat, compleet overbodig is. Ik begrijp uit jouw reactie dat (op dit moment) sudo mount -a de enige oplossing is. 
Ben dit trouwens in geen van de handleidingen om een NFS-netwerk op te zetten tegengekomen, terwijl het toch voor veel mensen verhelderend zou werken als dat erbij zou staan.

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: Automatisch koppelen via fstab werkt niet goed.
« Reactie #3 Gepost op: 2009/08/22, 17:50:33 »
Er is in principe ook een methode dat je het via een klik op de knop kunt doen door de rechten van  /sbin/mount.cifs  aan te passen, maar dat heb ik tot nu toe niet aan de praat gekregen.

Als jij dat op een rij zou krijgen is dat ook voor mij dus interessant.

Waarschijnlijk ken jij deze handleiding: http://ubuntuforums.org/showpost.php?p=2243984
allang want hij is al ruim anderhalf jaar oud, maar is dit iets, track? De schrijver heeft hem niet getest op een NFS-netwerk, dus aan jou dan de eer. XD

Offline track

  • Lid
  • Steunpunt: Nee
Re: Automatisch koppelen via fstab werkt niet goed.
« Reactie #4 Gepost op: 2009/08/22, 18:11:05 »
...
Hahaha......... nou, als jij dat al niet voor elkaar kunt krijgen........ dan ik al helemaal niet. =D =D =D
- je moet mij ook niet overschatten.  Ik ben thuis in CL toestanden sinds ALGOL 60, maar ik heb ook mijn zwakke kanten.  Netwerken is er een van.
Als alleen mijn pc aanstaat valt er uiteraard niets te zien in de gedeelde map op de andere pc, dat weet ik, maar dat zou dus betekenen dat een aanpassing in fstab op de pc die over het algemeen als eerste aanstaat, compleet overbodig is. Ik begrijp uit jouw reactie dat (op dit moment) sudo mount -a de enige oplossing is. 
- misschien is er nog een andere, maar ik heb met de gauwte de makkelijkste manier gebruikt die ik wist. En jij blijkbaar ook.   ;)
Ben dit trouwens in geen van de handleidingen om een NFS-netwerk op te zetten tegengekomen, terwijl het toch voor veel mensen verhelderend zou werken als dat erbij zou staan.
- ik heb trouwens ook alleen win..- shares (rsp.samba) op mijn netwerk.  Ik weet niet of er voor NFS nog ander trucs zijn.
Waarschijnlijk ken jij deze handleiding: http://ubuntuforums.org/showpost.php?p=2243984
Yep, dat was zoiets. (ik dacht een andere site maar dezelfde truc).

Sja, we hebben een nieuw idee nodig, hè ?

track

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: Automatisch koppelen via fstab werkt niet goed.
« Reactie #5 Gepost op: 2009/08/22, 18:42:47 »
Waarschijnlijk ken jij deze handleiding: http://ubuntuforums.org/showpost.php?p=2243984
Yep, dat was zoiets. (ik dacht een andere site maar dezelfde truc).

Sja, we hebben een nieuw idee nodig, hè ?

Nou jongens en meisjes, wie heeft er een nieuw idee? =D  Kan me niet voorstellen dat wij de enigen zijn die tegen dit 'probleem' aanlopen.

Offline Wiley

  • Lid
  • Steunpunt: Nee
Re: Automatisch koppelen via fstab werkt niet goed.
« Reactie #6 Gepost op: 2009/08/22, 21:59:12 »
Ik gebruik autofs en dat werkt heel goed. Zie hier voor een tutorial:
http://ubuntuforums.org/showthread.php?t=249889&highlight=umount+nfs&page=20

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
Re: Automatisch koppelen via fstab werkt niet goed.
« Reactie #7 Gepost op: 2009/08/22, 22:24:30 »
hij kan maar een map of drive (via fstab) aankoppelen die er is.  Als je de eerste computer aanzet is er dus geen andere map
om aan te koppelen.  Dat is volgens mij zover dus in orde.

Als ik een netwerkmap achteraf moet aankoppelen doe ik het ook met  sudo mount -a .
Dat is een beetje ruw maar het werkt. 
Er is in principe ook een methode dat je het via een klik op de knop kunt doen door de rechten van  /sbin/mount.cifs  aan te passen, maar dat heb ik tot nu toe niet aan de praat gekregen.

Het ging toch over nfs? Wat heeft dat te maken met cifs?

Je zou denken dat hiervoor de _netdev optie bestemd is. Zie de wiki.
`Wie wil de Nederlandstalige Ubuntu documentatie wiki onderhouden? https://wiki.ubuntu-nl.org

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: Automatisch koppelen via fstab werkt niet goed.
« Reactie #8 Gepost op: 2009/08/22, 23:27:06 »
Ik zet die _netdev-optie gewoon in m'n fstab. ^-^  Morgen ervoor zorgen dat mijn pc als eerste aanstaat en dan eens kijken of de andere pc 'gezien' wordt als die aangezet wordt.

Er staat in de Wiki trouwens een typfoutje in de regel:
_netdev - Geef aan dat dit een netwerkopslag is dit gekoppeld moet worden na het opbrengen van de netwerkverbinding. Deze optie is alleen van toepassing voor het type bestandssysteem nfs.

Offline Wiley

  • Lid
  • Steunpunt: Nee
Re: Automatisch koppelen via fstab werkt niet goed.
« Reactie #9 Gepost op: 2009/08/23, 00:58:04 »
@testcees en mikkel

Als ik in de man page van mount over _netdev lees dan begrijp ik eruit dat er gewacht wordt met mounten totdat de netwerkverbinding van de computer gemaakt/opgestart is. Dus niet persé de netwerkverbinding náár de juiste nfs server, zeker niet al die helemaal niet up is, maar gewoon het netwerkgebeuren op de machine zelf. Ik denk dus dat die optie alleen gedurende het booten wacht op netwerk. Als dat er is, maar nog steeds geen server (omdat die niet opgestart is) heb je nog geen mount. En die komt er ook niet omdat na het booten niets meer 'wacht' op die mount.

Daarvoor is autofs, dat ik voor jullie laatste 2 posts noemde. Kijk er nou even in, het is m.i. een oplossing voor je probleem en makkelijk te configureren: het mount namelijk je nfs alleen en zolang als je er toegang naar zoekt (bijv. via nautilus). Als de server dus pas na de client up komt, krijg je toch toegang.

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: Automatisch koppelen via fstab werkt niet goed.
« Reactie #10 Gepost op: 2009/08/23, 02:03:35 »
Ik had al vluchtig op de site onder jouw link gekeken, Wiley, maar _netdev toevoegen aan fstab ging even sneller. Ik beloof je dat ik morgen 'jouw' handleiding zal volgen, mocht de gewijzigde fstab niets uithalen. ;)

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: Automatisch koppelen via fstab werkt niet goed.
« Reactie #11 Gepost op: 2009/08/23, 14:39:26 »
_netdev in fstab maakt geen enkel verschil, dus ik ga 'jouw' handleiding volgen, Wiley. ^-^

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: Automatisch koppelen via fstab werkt niet goed.
« Reactie #12 Gepost op: 2009/08/23, 17:26:31 »
Bedankt voor de tip, Wiley, maar ik houd het wel bij sudo mount -a Die handleiding is van vóór Hardy, dus óf hij klopt niet (meer), óf ik begrijp hem niet. XD
De man opent het bestand /etc/auto.ubuntumini, dat in Hardy niet bestaat, en toont de inhoud van zijn auto.ubuntumini, wat opvallende gelijkenissen vertoont met het bestand auto.misc, dat ik wél heb.
Ik haal er nergens uit of ie dat auto.misc nou heeft gekopieerd, er zelf wat regels aan heeft toegevoegd en het daarna heeft opgeslagen als auto.ubuntumini, maar het lijkt er verdacht veel op.
In ieder geval, na het restarten van autofs is er hier niets veranderd. Gedeelde map op de andere pc was 'leeg'.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Automatisch koppelen via fstab werkt niet goed.
« Reactie #13 Gepost op: 2009/08/23, 18:00:23 »
Je zou ook nog de "user" optie op kunnen geven in fstab. Dan heb je geen sudo meer nodig.
Verder zou je een klein scriptje kunnen maken op je bureaublad, dat de NFS share koppelt.

Dit zou er dan bijvoorbeeld in kunnen staan:
#!/bin/bash
mount /pad/naar/NFS/map
Even dat bestand uitvoerbaar maken en vervolgens hoef je alleen maar te dubbelklikken :)

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: Automatisch koppelen via fstab werkt niet goed.
« Reactie #14 Gepost op: 2009/08/23, 18:15:11 »
Nog sneller dan een terminalcommando. ;) Bedankt, Johan. :)

Offline Wiley

  • Lid
  • Steunpunt: Nee
Re: (Opgelost) Automatisch koppelen via fstab werkt niet goed.
« Reactie #15 Gepost op: 2009/08/23, 19:21:44 »
hey Mikkel,

Tsja, je moet er even goed voor zitten, zijn uitleg is soms een beetje apart qua volgorde.
Maar het is een handig en mooi principe, dus zonde van het geklik op links of elke keer mount -a doen, vind ik.
Uiteraard je eigen keuze, maar ik probeer het toch nog eens:

Om te beginnen, je zegt dat de gedeelde map op de andere pc leeg was: autofs is voor je client (dus de pc waarop je gaat mounten), niet voor de server!

/etc/auto.ubuntumini bestaat ook niet, hij maakt 'm aan en kiest zelf de naam (kopie van auto.misc).

Citaat
/etc/auto.ubuntumini is where we keep another file listing our NFS mounts. It can be any file name in any directory actually. But the default is /etc/auto.misc which I leave for later examination. We're going to create this /etc/auto.ubuntumini file in a moment. What matters is that the file matches this entry in /etc/auto.master.

Ik heb 'm zelf anders genoemd en een kopie gemaakt van auto.misc:  /etc/auto.nfs:
#
# $Id: auto.misc,v 1.2 2003/09/29 08:22:35 raven Exp $
#
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# Details may be found in the autofs(5) manpage

#cd -fstype=iso9660,ro,nosuid,nodev :/dev/cdrom

# the following entries are samples to pique your imagination
#linux -ro,soft,intr ftp.example.org:/pub/linux
#boot -fstype=ext2 :/dev/hda1
#floppy -fstype=auto :/dev/fd0
#floppy -fstype=ext2 :/dev/fd0
#e2floppy -fstype=ext2 :/dev/fd0
#jaz -fstype=ext2 :/dev/sdc1
#removable -fstype=ext2 :/dev/hdd
nfs          -fstype=nfs,rw,hard,intr 192.168.2.9:/srv/nfs

De laatste regel is van mij: nfs protocol, ip adres van de server en de nfs export.

Een verwijzing naar die /etc/auto.nfs staat dan weer in /etc/auto.master:
#
# $Id: auto.master,v 1.4 2005/01/04 14:36:54 raven Exp $
#
# Sample auto.master file
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# For details of the format look at autofs(5).
#/misc /etc/auto.misc --timeout=60
#/smb /etc/auto.smb
#/misc /etc/auto.misc
#/net /etc/auto.net
/mnt/nfsShare /etc/auto.nfs --timeout=300 --ghost

Ofwel: mount op je client in /mnt/nfsShare de configuratie zoals 'ie in /etc/auto.nfs staat.

Een belangrijke tip van JRicard:
Citaat
One element of note. BOTH the AUTO.MASTER and AUTO.UBUNTUMINI files require a blank line with line feed after the last entry. Just an anomaly as to the way the software reads lines until it reaches an end of file. But don't forget them.

Tot slot, als je beide bestanden netjes opgeslagen hebt:
sudo /etc/init.d/autofs restart
en de boel moet in /mnt/nfsShare zichtbaar zijn. (NB: de map nfsShare onder /mnt moet je wel zelf aanmaken vóórdat je er een fs in mount)

Da's alles.
« Laatst bewerkt op: 2009/08/23, 19:25:40 door Wiley »

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: (Opgelost) Automatisch koppelen via fstab werkt niet goed.
« Reactie #16 Gepost op: 2009/08/23, 21:24:39 »
Om te beginnen, je zegt dat de gedeelde map op de andere pc leeg was: autofs is voor je client (dus de pc waarop je gaat mounten), niet voor de server!
Op beide pc's hier staat op het Bureaublad een map die gedeeld is, dus ze zijn beide zowel server als client. In dit geval is mijn pc de client, dus de handleiding heb ik alleen maar uitgevoerd op mijn pc.
 
Citaat
/etc/auto.ubuntumini bestaat ook niet, hij maakt 'm aan en kiest zelf de naam (kopie van auto.misc).
Ik snap dat die map niet bestaat (omdat ik hem niet kon vinden), maar hij is daar niet bepaald duidelijk over.
Hij rept wel van auto.misc, maar zegt daarbij dat ie daar later op terugkomt. 'k Lees alleen niet wáár.

Citaat
Ik heb 'm zelf anders genoemd en een kopie gemaakt van auto.misc
Omdat de inhoud van mijn auto.misc zo ontzettend overeen kwam met zijn 'auto.ubuntumini', had ik hier auto.misc aangepast door het toevoegen van een regel zoals hij in auto.ubuntumini had gezet. 't Had alleen niet het gewenste resultaat.

Citaat
Een belangrijke tip van JRicard:
One element of note. BOTH the AUTO.MASTER and AUTO.UBUNTUMINI files require a blank line with line feed after the last entry.
Had ik opgevolgd. ;)

Citaat
Tot slot, als je beide bestanden netjes opgeslagen hebt:
sudo /etc/init.d/autofs restart
Ook gedaan. ;)

Citaat
en de boel moet in /mnt/nfsShare zichtbaar zijn. (NB: de map nfsShare onder /mnt moet je wel zelf aanmaken vóórdat je er een fs in mount)

Da's alles.
Sja......... ik wilde dat het waar was. :D
Wiley, als dit bij jou werkt, dan probeer ik het ook nog wel een keer. Moet toch lukken, nietwaar? :rolleyes:
« Laatst bewerkt op: 2009/08/23, 21:26:38 door Mikkel »