Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Internet problemen na installatie windows  (gelezen 2876 keer)

piratenaapje

  • Gast
Internet problemen na installatie windows
« Gepost op: 2006/10/26, 18:43:17 »
Ik heb een heel vreemd probleem: ik krijg het internet onder ubuntu niet meer aan de praat sinds de installatie van windows, onder windows kan ik echter wel op internet. Zelfs via een ubuntu live cd kan ik niet op internet.

Weet iemand waaraan dit kan liggen?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Internet problemen na installatie windows
« Reactie #1 Gepost op: 2006/10/26, 23:29:47 »
Als het zelfs met de LiveCD niet lukt, dan kan het onmogelijk aan Windows liggen. Is er iets veranderd aan de harde waar?

Groet, Pjotr.

piratenaapje

  • Gast
Internet problemen na installatie windows
« Reactie #2 Gepost op: 2006/10/27, 10:07:30 »
Het enige wat aan de hardware is veranderd, is het tijdelijk uitschakelen van de harde schijf waarop ubuntu staat. Na windows te installeren en deze harde schijf terug in te schakelen, werkte internet onder ubuntu niet meer.

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Internet problemen na installatie windows
« Reactie #3 Gepost op: 2006/10/27, 11:09:20 »
Er zijn in dit geval een paar commandootjes die je even voor ons in een terminal venster moet uitvoeren en de output hier plaatsen:

ifconfig -a
cat /etc/resolv.conf
netstat -rn
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

piratenaapje

  • Gast
Internet problemen na installatie windows
« Reactie #4 Gepost op: 2006/10/27, 17:05:29 »
Bedankt voor de hulp, maar vreemd genoeg toen ik mijn pc vanmiddag opstartte ging internet wel.
Dit is vreemd omdat na zo'n 10 reboots gisteren, internet nog steeds niet ging...

piratenaapje

  • Gast
Internet problemen na installatie windows
« Reactie #5 Gepost op: 2006/10/27, 18:27:02 »
Na nog een reboot is het terug naar af: internet werkt niet meer.
Output van terminal:

kristof@piratenaapje:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:10:DC:0F:7C:A9
          inet6 addr: fe80::210:dcff:fe0f:7ca9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:24 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1880 (1.8 KiB)  TX bytes:2520 (2.4 KiB)
          Interrupt:201

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:100 (100.0 b)  TX bytes:100 (100.0 b)

sit0      Link encap:IPv6-in-IPv4
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

kristof@piratenaapje:~$ cat /etc/resolv.conf
search telenet.be
nameserver 195.130.130.163
nameserver 195.130.130.3
kristof@piratenaapje:~$ netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
kristof@piratenaapje:~$

piratenaapje

  • Gast
Internet problemen na installatie windows
« Reactie #6 Gepost op: 2006/10/28, 11:24:15 »
Bring
Up
My
Post
Kan iemand me helpen?

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Internet problemen na installatie windows
« Reactie #7 Gepost op: 2006/10/30, 08:47:26 »
Ben ik weer ...

Het probleem is dat je eth0 geen IP adres heeft, zoals te zien is in de output van ifconfig - a. Jij hebt:

eth0      Link encap:Ethernet  HWaddr 00:10:DC:0F:7C:A9
          inet6 addr: fe80::210:dcff:fe0f:7ca9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

Maar moet zijn:
eth0      Link encap:Ethernet  HWaddr 00:10:DC:0F:7C:A9
          inet addr:xxx.xxx.xxx.xxx  Bcast:xxx.xxx.xxx.xxx  Mask:255.255.255.x
          inet6 addr: fe80::210:dcff:fe0f:7ca9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

Ik heb op dit forum wel eens gelezen dat wanneer je systeem direct aan de ADSL router hangt, dat het dan af en toe problemen heeft om een IP adres via het DHCP protocol te verkrijgen. We kunnen twee dingen doen: OF je geeft als het niet lukt het volgende commando:

sudo dhclient eth0

OF we geven je systeem een vast IP adres zodat-ie daar nooit meer om hoeft te vragen. Probeer eerst het commandootje maar even!
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

piratenaapje

  • Gast
Internet problemen na installatie windows
« Reactie #8 Gepost op: 2006/10/31, 14:40:27 »
sudo dhclient eth0
kristof@piratenaapje:~$ sudo dhclient eth0
There is already a pid file /var/run/dhclient.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:10:dc:0f:7c:a9
Sending on   LPF/eth0/00:10:dc:0f:7c:a9
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
kristof@piratenaapje:~$
kristof@piratenaapje:~$ ping -c1 google.com
ping: unknown host google.com
kristof@piratenaapje:~$ ping -c1 72.14.207.99
connect: Network is unreachable
kristof@piratenaapje:~$
Na het uitschakelen van IPv6 en rebooten:
kristof@piratenaapje:~$ sudo lspci -v
00:00.0 Host bridge: Intel Corporation 82845 845 (Brookdale) Chipset Host Bridge (rev 03)
        Subsystem: Intel Corporation 82845 845 (Brookdale) Chipset Host Bridge
        Flags: bus master, fast devsel, latency 0
        Memory at d0000000 (32-bit, prefetchable) [size=128M]
        Capabilities: [e4] Vendor Specific Information
        Capabilities: [a0] AGP version 2.0

00:01.0 PCI bridge: Intel Corporation 82845 845 (Brookdale) Chipset AGP Bridge (rev 03) (prog-if 00 [Normal decode])
        Flags: bus master, 66MHz, fast devsel, latency 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
        Memory behind bridge: e0000000-e1ffffff
        Prefetchable memory behind bridge: d8000000-dfffffff

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 12) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=32
        I/O behind bridge: 0000c000-0000cfff
        Memory behind bridge: e2000000-e3ffffff
        Prefetchable memory behind bridge: 20000000-200fffff

00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (LPC) (rev 12)
        Flags: bus master, medium devsel, latency 0

00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 (rev 12) (prog-if 80 [Master])
        Subsystem: Micro-Star International Co., Ltd. Unknown device 3990
        Flags: bus master, medium devsel, latency 0
        I/O ports at f000 [size=16]

00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #1) (rev 12) (prog-if 00 [UHCI])
        Subsystem: Micro-Star International Co., Ltd. Unknown device 3990
        Flags: bus master, medium devsel, latency 0, IRQ 177
        I/O ports at d000 [size=32]

00:1f.3 SMBus: Intel Corporation 82801BA/BAM SMBus (rev 12)
        Subsystem: Micro-Star International Co., Ltd. Unknown device 3990
        Flags: medium devsel, IRQ 11
        I/O ports at 5000 [size=16]

00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #2) (rev 12) (prog-if 00 [UHCI])
        Subsystem: Micro-Star International Co., Ltd. Unknown device 3990
        Flags: bus master, medium devsel, latency 0, IRQ 185
        I/O ports at d800 [size=32]

01:00.0 VGA compatible controller: nVidia Corporation NV20 [GeForce3 Ti 200] (rev a3) (prog-if 00 [VGA])
        Subsystem: Micro-Star International Co., Ltd. Unknown device 8838
        Flags: bus master, 66MHz, medium devsel, latency 248, IRQ 193
        Memory at e0000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d8000000 (32-bit, prefetchable) [size=64M]
        Memory at dc000000 (32-bit, prefetchable) [size=512K]
        [virtual] Expansion ROM at dc080000 [disabled] [size=64K]
        Capabilities: [60] Power Management version 2
        Capabilities: [44] AGP version 2.0

02:02.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 43) (prog-if 10 [OHCI])
        Subsystem: VIA Technologies, Inc. IEEE 1394 Host Controller
        Flags: bus master, medium devsel, latency 32, IRQ 169
        Memory at e3002000 (32-bit, non-prefetchable) [size=2K]
        I/O ports at c000 [size=128]
        Capabilities: [50] Power Management version 2

02:03.0 Communication controller: Ambient Technologies Inc HaM controllerless modem (rev 02)
        Subsystem: Creatix Polymedia GmbH Unknown device 0002
        Flags: medium devsel, IRQ 5
        Memory at e3000000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at c400 [size=256]
        Capabilities: [60] Power Management version 2

02:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
        Subsystem: Realtek Semiconductor Co., Ltd. RT8139
        Flags: bus master, medium devsel, latency 32, IRQ 201
        I/O ports at c800 [size=256]
        Memory at e3001000 (32-bit, non-prefetchable) [size=256]
        [virtual] Expansion ROM at 20000000 [disabled] [size=64K]
        Capabilities: [50] Power Management version 2

02:07.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
        Subsystem: Micro-Star International Co., Ltd. Unknown device 3990
        Flags: bus master, medium devsel, latency 32, IRQ 209
        I/O ports at cc00 [size=256]
        Capabilities: [c0] Power Management version 2

kristof@piratenaapje:~$
Een statisch ip is volgens mij niet mogelijk:  als ik een statisch ip wil moet ik bij mijn provider (telenet) meer betalen...
Als ik het nog niet eerder heb gezegd: ik zit NIET achter een router

NLsandman

  • Gast
Internet problemen na installatie windows
« Reactie #9 Gepost op: 2006/10/31, 15:35:39 »
Vreemd dat je dhcp request in eens niet meer beantwoord wordt.

sandman@dromeland:~$ sudo dhclient eth0
Password:
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:50:8d:48:12:7a
Sending on   LPF/eth0/00:50:8d:48:12:7a
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPOFFER from 192.168.1.254
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.254
bound to 192.168.1.65 -- renewal in 37860 seconds.

wat me wel opvalt met alle dhcp problemen is dat het om dualboot gaat met windows xp.
Zou het kunnen dat tijdens uitschakelen van windows xp er op 1 of andere manier geen vrijgave aan de dhcp server wordt gegeven?

Piraten aapje, zou je als je in windows zit in de command box daarvan (cmd) het commando ipconfig /release kunnen ingeven en daarna op te starten naar linux, ben wel benieuwd wat dit oplevert.

piratenaapje

  • Gast
Internet problemen na installatie windows
« Reactie #10 Gepost op: 2006/10/31, 15:46:37 »
Dank je wel NLsandman, nu werkt internet onder ubuntu wel! Mijn eeuwige dank is de jouwe.
Ook bedankt aan al de rest die heeft proberen te helpen.
Nu nog eens proberen of het internet onder windows nu nog werkt

piratenaapje

  • Gast
Internet problemen na installatie windows
« Reactie #11 Gepost op: 2006/10/31, 15:56:00 »
Hmm, na windows opnieuw te hebben opgestart, en terug in ubuntu te gaan werkt internet opnieuw niet meer. Met andere woorden: ik moet elke keer dat ik windows afsluit ipconfig /release ingeven in de command prompt. Aangezien deze pc door mijn hele familie wordt gebruikt is dit niet zo handig. Dus is er een manier om deze taak te automatiseren (door elke keer dat windows afsluit dit commando te laten uitvoeren bijvoorbeeld) of deze taak overbodig te maken?

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Internet problemen na installatie windows
« Reactie #12 Gepost op: 2006/10/31, 16:04:06 »
Ja, in dit geval is een vast IP adres de oplossing. Wat je kunt doen is de zaak onder DHCP aan de praat krijgen en met behulp van de commando's die ik je al eerder gaf de parameters noteren (behalve /etc/resolv.conf, die is al goed).

Bij de output van "netstat -rn noteer je het IP adres van de regel die gemarkeerd is met UG (Universal Gateway) - dit is dus de "default router" - en bij je "ifconfig eth0" je IP adres en netmask.

Nu weet ik in Ubuntu niet uit m'n hoofd waar je dat instelt, maar er is vast wel iets onder Systeem en dan Netwerk-instellingen of iets dergelijks.
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

piratenaapje

  • Gast
Internet problemen na installatie windows
« Reactie #13 Gepost op: 2006/10/31, 17:31:16 »
Het probleem is dat een statisch ip adres niet tot de opties behoord: daarvoor moet ik bijbetalen.

NLsandman

  • Gast
Internet problemen na installatie windows
« Reactie #14 Gepost op: 2006/11/01, 23:28:04 »
Citaat van: piratenaapje
Hmm, na windows opnieuw te hebben opgestart, en terug in ubuntu te gaan werkt internet opnieuw niet meer. Met andere woorden: ik moet elke keer dat ik windows afsluit ipconfig /release ingeven in de command prompt. Aangezien deze pc door mijn hele familie wordt gebruikt is dit niet zo handig. Dus is er een manier om deze taak te automatiseren (door elke keer dat windows afsluit dit commando te laten uitvoeren bijvoorbeeld) of deze taak overbodig te maken?
Normaal hoort windows dat zelf te doen maarja windows he ;)

je moet in het register een sleutel bij maken zodat bij het afsluiten de lease wordt vrij gegeven.

Op de volgende link staat hoe je dat moet doen maar is wel in het engels.
Indien dit lukt zou je mischien voor kunnen stellen aan dit forum om er een sticky van te laten maken of opnemen in een wiki want er zijn heel veel mensen met lease problemen in ubuntu bij dual boot xp.

http://www.windowsitpro.com/Article/ArticleID/47131/47131.html

Let op er staat windows 2000 maar dit is ook voor xp van toepassing.

Succes!

Ps bij statisch instellen heb je geen vast ip adres nodig, bij adsl zijn dynamische ip's vaak semi statisch cq ze veranderen bijna niet.

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Internet problemen na installatie windows
« Reactie #15 Gepost op: 2006/11/02, 08:41:47 »
Citaat van: piratenaapje
Het probleem is dat een statisch ip adres niet tot de opties behoord: daarvoor moet ik bijbetalen.
Nee, ik bedoel dat JOUW PC een vast IP adres gaat krijgen, NIET je ADSL modem. Volgens mij werkt het nu zo (correct me if I'm wrong): Je modem haalt zijn adres op bij de provider (een dynamisch adres dis, ook al is het vaak dezelfde, en doet DHCP voor de clients (jouw PC dus) die aan hem verbinden.

Het adres van je eigen PC kun je in dat geval gerust vast instellen.
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

`GooZ

  • Gast
Internet problemen na installatie windows
« Reactie #16 Gepost op: 2006/11/02, 15:30:16 »
Hmm... hij heeft telenet lees ik in zijn post, dus heeft hij geen ADSL modem (moet niet inloggen ofzo). Als je een router hebt werkt dit natuurlijk wel zoals tukcedo zegt. Dan is het gewoon een kwestie van je IP statisch te maken op je router, maar bij mijn weten doet nagenoeg elke router dit standaard.

NLsandman

  • Gast
Internet problemen na installatie windows
« Reactie #17 Gepost op: 2006/11/02, 15:42:04 »
oeps ik dacht dat hij tele2 had maar dat is dus telenet.

Maar met statisch instellen is zijn probleem niet over, het is een lapmiddel maar de fout zit hem toch echt in windows xp en daar moet hij die aanpassing voor doen in het register.

piratenaapje

  • Gast
Internet problemen na installatie windows
« Reactie #18 Gepost op: 2006/11/02, 17:45:16 »
Het eerste deel van de aanpassingen in het register lukken me wel, het tweede deel is echter veel moeilijker terug te vinden: ik heb dit tot dusver nog niet gevonden.

NLsandman

  • Gast
Internet problemen na installatie windows
« Reactie #19 Gepost op: 2006/11/04, 20:33:15 »
vergeet dat hele gebeuren wat ik jouw heb gezegt, haal ook die regel weer weg uit het register.

Ik vond dit op handboek linux belgie:

Dual boot: LET OP: Indien je in een dualboot zit met een Windows-machine kan het zijn dat je geen ip-adres van telenet krijgt.
Dit heeft de volgende oorzaak: Elke netwerkkaart heeft een uniek MAC adres. Dit adres is in je hardware ingebakken.
De dns-server houdt dit MAC adres bij. Indien je nu eerst via Windows op het internet gaat en daarna boot naar Linux, krijg je in vele gevallen geen ip-adres van de dns-server.
Deze server herinnert immers dat het reeds een ip-adres voor dat MAC-adres gaf en geeft bij gevolg geen nieuw.
Je kunt dit oplossen door het ip-adres onder Windows vrij te geven alvorens je de PC reboot.

 Om dit te automatiseren heb je 2 opties:

   1. Via snelkoppeling: Geef in notepad het volgende in:
            ipconfig /release
      Save dit als ip_vrijgave.bat
      Maak een snelkoppeling op je desktop dat naar ip_vrijgave.bat verwijst.
      Kwestie van klikken voor je afsluit
   2. Via Group Policy Editor: Automatisch ip vrijgeven bij afsluiten van Win XP:
      Open notepad en voeg in:
            ipconfig /release
      save als: ip_vrijgave.cmd
      Type in de run box gpedit.msc
      Onder "Computer Configuration" kies je "Windows Settings" vervolgens "Scripts"(startup/shutdown) vervolgens "Shutdown" rechts kliken, properties "Add"
      bij "Script Name" geef je het adres naar de batch file


Beetje dom om het wiel nog eens opnieuw uit te vinden ;)

piratenaapje

  • Gast
Internet problemen na installatie windows
« Reactie #20 Gepost op: 2006/11/04, 22:32:24 »
Citaat van: NLsandman
vergeet dat hele gebeuren wat ik jouw heb gezegt, haal ook die regel weer weg uit het register.

Ik vond dit op handboek linux belgie:

Dual boot: LET OP: Indien je in een dualboot zit met een Windows-machine kan het zijn dat je geen ip-adres van telenet krijgt.
Dit heeft de volgende oorzaak: Elke netwerkkaart heeft een uniek MAC adres. Dit adres is in je hardware ingebakken.
De dns-server houdt dit MAC adres bij. Indien je nu eerst via Windows op het internet gaat en daarna boot naar Linux, krijg je in vele gevallen geen ip-adres van de dns-server.
Deze server herinnert immers dat het reeds een ip-adres voor dat MAC-adres gaf en geeft bij gevolg geen nieuw.
Je kunt dit oplossen door het ip-adres onder Windows vrij te geven alvorens je de PC reboot.

 Om dit te automatiseren heb je 2 opties:

   1. Via snelkoppeling: Geef in notepad het volgende in:
            ipconfig /release
      Save dit als ip_vrijgave.bat
      Maak een snelkoppeling op je desktop dat naar ip_vrijgave.bat verwijst.
      Kwestie van klikken voor je afsluit
   2. Via Group Policy Editor: Automatisch ip vrijgeven bij afsluiten van Win XP:
      Open notepad en voeg in:
            ipconfig /release
      save als: ip_vrijgave.cmd
      Type in de run box gpedit.msc
      Onder "Computer Configuration" kies je "Windows Settings" vervolgens "Scripts"(startup/shutdown) vervolgens "Shutdown" rechts kliken, properties "Add"
      bij "Script Name" geef je het adres naar de batch file


Beetje dom om het wiel nog eens opnieuw uit te vinden ;)
1. Dit is wat ik nu doe
2. Dit probeerde ik oorspronkelijk te doen, maar om dit te doen heb je xp pro nodig, en ik heb jammer genoeg home...
Toch bedankt voor al de moeite :P