Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Virus!? CPU blijft steeds 100% ..  (gelezen 4147 keer)

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
Virus!? CPU blijft steeds 100% ..
« Gepost op: 2006/10/26, 12:32:07 »
Nouw ik start vanmorgen Ubuntu op, maar ik merk dat ie heel langzaam loopt. Ik ga dus even kijken in de System Monitor en wat zie ik, CPU zit de hele tijd op 100% :S Toen natuurlijk ff gekeken of er niet een programma aan stond wat deze hoeveelheid CPU gebruikt, maar nee het hoogste cpu gebruik door een programma is steeds maar 8-10 % ..
restarten heb ik al tich keer gedaan en heb al alle sessies geprobeert (Xgl, Gnome, Failsafe) maar de CPU blijft steeds 100%
wtf Heb ik nu een virus!? (bij windows hoor je dit wel eens vaker en dan is het een virus)
Open Source = Freedom = Power !!

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Virus!? CPU blijft steeds 100% ..
« Reactie #1 Gepost op: 2006/10/26, 12:34:13 »
kijk bij procesbeheer welk proces dat cpu misbruik veroorzaakt.
ps selecteer wel ff --alle processen-- :)

budster

  • Gast
Virus!? CPU blijft steeds 100% ..
« Reactie #2 Gepost op: 2006/10/26, 12:37:39 »
doe eens top (in terminal). ik denk eerder dat je iets hebt geinstalleert dat nogal hongerig is en continu op de achtergrond loopt.

Offline woteb

  • Lid
  • Steunpunt: Nee
Virus!? CPU blijft steeds 100% ..
« Reactie #3 Gepost op: 2006/10/26, 13:37:33 »
Start een terminal op en geef dan het commando: top

Rapporteer dan wat je allemaal ziet.
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Virus!? CPU blijft steeds 100% ..
« Reactie #4 Gepost op: 2006/10/26, 15:40:22 »
ik zat net te denken: open de terminal en typ --top--.

Offline Dave

  • Lid
  • Steunpunt: Nee
Virus!? CPU blijft steeds 100% ..
« Reactie #5 Gepost op: 2006/10/26, 17:14:04 »
Citaat
(bij windows hoor je dit wel eens vaker en dan is het een virus
kan,... maar is vaker de dooddoener als het simpelweg niet geweten wordt.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Virus!? CPU blijft steeds 100% ..
« Reactie #6 Gepost op: 2006/10/26, 17:20:07 »
@dave
precies. problemen=virus......

Offline Arvid Van Essche

  • Lid
  • Steunpunt: Nee
Virus!? CPU blijft steeds 100% ..
« Reactie #7 Gepost op: 2006/10/26, 17:22:50 »
ik heb het ook eens gehad. Maar dat was toen ik mijn systeem om zeep geholpen had door met XGL te prutsen.
Nu heb ik voor jou wel geen tips. Want toen ben ik ook opnieuw begonnen met dapper. En heb een full format gedaan.
Voor jou denk ik is dat iets te drastisch.

Arvid

ifokkema

  • Gast
Virus!? CPU blijft steeds 100% ..
« Reactie #8 Gepost op: 2006/10/26, 20:08:38 »
Mensen; het is Linux, hoor. CPU 100% kan gebeuren; check `top` (zoals al twee keer gesuggereerd) om meer te weten te komen. In die jaren dat ik met Linux heb gewerkt, heb ik nog nooit een virus onder linux gezien. Trouwens, zou een virus niet root rechten moeten hebben om zichzelf automatisch op te starten? Volgens mij wel... :)

Paretje

  • Gast
Virus!? CPU blijft steeds 100% ..
« Reactie #9 Gepost op: 2006/10/26, 23:27:48 »
Als ik een hoog percentage krijg is dat gewoon omdat wine niet goed is fagesloten. Als je het niet vind is de gemakelijkeste manier ... computer herstarten ;)

Azalin

  • Gast
Virus!? CPU blijft steeds 100% ..
« Reactie #10 Gepost op: 2006/10/26, 23:31:02 »
Wine moet je altijd kunnen vinden. Als dat niet zo is, dan goed kijken onder naam van het programma dat je opstartte, onder Wine, onder Wineserver en zorgen dat je -alle processen- laat zien in het Procesbeheer. Een hele handige tool waarme je processen ook kunt beeindigen.

Paretje

  • Gast
Virus!? CPU blijft steeds 100% ..
« Reactie #11 Gepost op: 2006/10/26, 23:37:16 »
Zelfde mening :P

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
Virus!? CPU blijft steeds 100% ..
« Reactie #12 Gepost op: 2006/10/26, 23:38:54 »
commando top:

darell@bora:~$ top

top - 23:31:05 up 4 min,  2 users,  load average: 3.84, 2.25, 0.92
Tasks:  95 total,   3 running,  92 sleeping,   0 stopped,   0 zombie
Cpu(s): 92.0% us,  8.0% sy,  0.0% ni,  0.0% id,  0.0% wa,  0.0% hi,  0.0% si
Mem:   1033892k total,   676836k used,   357056k free,    10980k buffers
Swap:   891568k total,        0k used,   891568k free,   508472k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 5040 darell    15   0 37040  23m  10m S  8.3  2.3   0:14.39 python
 4315 root      15   0 45884  22m  10m S  7.3  2.2   0:10.93 Xorg
 6110 darell    17   0 11196 4660 3660 R  2.3  0.5   0:00.07 emerald
 5226 darell    15   0 14620 2776 1852 S  1.0  0.3   0:00.61 gnome-screensav
 5354 darell    15   0 32336  13m 8236 S  0.7  1.3   0:00.63 gnome-terminal
 4900 darell    15   0 27404 9244 6956 S  0.3  0.9   0:00.70 gnome-settings-
 4915 darell    15   0 59228  16m  10m S  0.3  1.7   0:00.61 gnome-panel
 4955 darell    15   0 17692 5380 3900 S  0.3  0.5   0:00.06 gnome-power-man
 5127 darell    15   0 23052  10m 7648 S  0.3  1.0   0:00.19 clock-applet
 5632 darell    16   0  2200 1108  856 R  0.3  0.1   0:00.03 top
 6111 darell    16   0 10776 3240 2624 S  0.3  0.3   0:00.01 emerald
    1 root      16   0  1564  528  460 S  0.0  0.1   0:00.90 init
    2 root      RT   0     0    0    0 S  0.0  0.0   0:00.00 migration/0
    3 root      34  19     0    0    0 S  0.0  0.0   0:00.00 ksoftirqd/0
    4 root      RT   0     0    0    0 S  0.0  0.0   0:00.00 watchdog/0
    5 root      10  -5     0    0    0 S  0.0  0.0   0:00.06 events/0
    6 root      12  -5     0    0    0 S  0.0  0.0   0:00.01 khelper
Dit is van een Gnome sessie, in XGL kan ik niks meer doen dan (windows borders blijven hangen enzo) Zoals je ziet gebruikt geen een programma op de lijst zoveel CPU, maar toch is ie 100% ..
Uitloggen doet Ubuntu ook bijna niet meer (je klikt op Log out en vervolgens hangt ie vast) dus ik moet hem steeds restarten. Na een stuk of 4-5 keer restarten is de CPU opeens weer normaal.
Ik heb niet aan mn systeem geklooit of wat dan ook, ik had gister alleen ge-reboot naar Windows en toen ik vanmorgen Ubuntu weer opstartte kreeg ik dit ..
iemand enig idee wat het probleem kan zijn?
Open Source = Freedom = Power !!

Azalin

  • Gast
Virus!? CPU blijft steeds 100% ..
« Reactie #13 Gepost op: 2006/10/26, 23:42:37 »
Tja, toch is het een programma dat je CPU maximaal belast. Zoals al een aantal keren is geadviseerd, open Procesbeheer en onder Beeld selecteer je Alle Processen. Dan krijg je alle processen te zien en DAN weet je meer.

Maar dat er iets niet lekker zit lijkt me wel duidelijk. Zit me net bedenken, het ZOU natuurlijk ook iets met je grafische kaart drivers te maken kunnen hebben... maarja, het kan met zoveel te maken hebben :)

Offline woteb

  • Lid
  • Steunpunt: Nee
Virus!? CPU blijft steeds 100% ..
« Reactie #14 Gepost op: 2006/10/27, 00:00:04 »
Je schrijft dat na 4-5 keer herstarten de zaak normaal werk. En na 6 keer? Dan weer 100% CPU?

Wat je zou kunnen doen is het volgende: in /boot/grub/menu.lst achter je kernel het woordje splash verwijderen (dit moet je evne als root doen). Hierdoor zie je bij het opstarten wat er allemaal netjes en niet-netjes opstart. Misschien kom je dan iets tegen wat niet goed werkt.

Voorbeeld van mijn menu.lst:

title      Ubuntu, kernel 2.6.15-27-686
root      (hd0,3)
kernel      /boot/vmlinuz-2.6.15-27-686 root=/dev/hda4 ro quiet
initrd      /boot/initrd.img-2.6.15-27-686
savedefault
boot

Editen via sudo gedit /boot/grub/menu.lst
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Virus!? CPU blijft steeds 100% ..
« Reactie #15 Gepost op: 2006/10/27, 01:18:02 »
100% cpu gebruik kan ook voorkomen bij hoge IO load (input/output) op je harde schijven.
Overigens verbruikt Python zo te zien wel best veel CPU?

Je kan eens proberen om dat Python proces daar te stoppen (killen) en kijken wat dat geeft.
Het is wel handig als je weet welk Python proces dat precies is... Top geeft hier zo te zien niet genoeg info, dus kan je zo ook ff kijken welk proces dat precies is volgens mij:

cat /proc/5040/cmdline

waar 5040 dus het PID is (cijfer in eerste kolom bij Top) van het Python proces

En als je dat proces afsluit, werkt alles dan weer normaal?

sudo kill -9 5040
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Virus!? CPU blijft steeds 100% ..
« Reactie #16 Gepost op: 2006/10/27, 09:33:30 »
Citaat van: Azalin
Tja, toch is het een programma dat je CPU maximaal belast. Zoals al een aantal keren is geadviseerd, open Procesbeheer en onder Beeld selecteer je Alle Processen. Dan krijg je alle processen te zien en DAN weet je meer.
@darell
geef daar nu eerst een "analyse" van. een analyse van ALLE processen. iets moet op de achtergrond aan je cpu knagen!

Offline woteb

  • Lid
  • Steunpunt: Nee
Virus!? CPU blijft steeds 100% ..
« Reactie #17 Gepost op: 2006/10/27, 10:27:00 »
En als je dan op CPU klikt, zie je de cpuvreter bovenaan staan......
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

ifokkema

  • Gast
Virus!? CPU blijft steeds 100% ..
« Reactie #18 Gepost op: 2006/10/27, 10:34:52 »
Citaat van: woteb
En als je dan op CPU klikt, zie je de cpuvreter bovenaan staan......
Top laat ook alle processen zien, en zou dus hetzelfde moeten doen. Maar zoals eerder gesuggeerd zou het een IO/Wait kunnen zijn van de CPU. Als je naar zijn load kijkt (bovenaan de top output) lijkt het er inderdaad op dat hij goed gestresst wordt. Om te zien welke files er geopend zijn door een proces, gebruik je lsof. Om dus te zien of het inderdaad dat Python proces was:

lsof -p 5040
(het PID nummer is dus inmiddels weer anders, maar het staat links in de output van top).

Je krijgt dan een lijst. Veel files? Veel keer dezelfde file? Grote files? Kijk daar eens naar.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Virus!? CPU blijft steeds 100% ..
« Reactie #19 Gepost op: 2006/10/27, 21:37:42 »
darrell ben je er al uit? :)

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
Virus!? CPU blijft steeds 100% ..
« Reactie #20 Gepost op: 2006/10/29, 14:27:26 »
pf net weer mn computer moeten rebooten en het probleem is er nog steeds. Ik kan maar nergens het programma vinden wat de cpu gebruikt! Heb het in Gnome en XGL sessie.

in XGL is dit mn top:

top - 13:21:10 up 9 min,  2 users,  load average: 8.46, 5.57, 2.52
Tasks: 107 total,   8 running,  99 sleeping,   0 stopped,   0 zombie
Cpu(s): 91.8% us,  8.2% sy,  0.0% ni,  0.0% id,  0.0% wa,  0.0% hi,  0.0% si
Mem:   1033892k total,   760000k used,   273892k free,    11676k buffers
Swap:   891568k total,        0k used,   891568k free,   515052k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 4870 darell    16   0  243m  90m 9264 R 32.0  9.0   1:59.45 Xgl
 4999 darell    15   0 14268 9024 3196 S  6.2  0.9   0:09.61 beryl-xgl
 5401 darell    15   0 55192  14m  10m S  4.9  1.5   0:15.45 gnome-system-mo
 7012 darell    18   0     0    0    0 R  4.6  0.0   0:00.14 emerald
 7013 darell    16   0 12156 5784 4216 S  3.9  0.6   0:00.12 emerald
 6416 darell    15   0 32444  13m 8240 S  1.3  1.3   0:00.42 gnome-terminal
 5170 darell    15   0 14620 2792 1864 S  1.0  0.3   0:03.46 gnome-screensav
 4905 darell    15   0 37628 5536 4428 S  0.7  0.5   0:00.61 beryl-manager
 5074 darell    15   0 54196  11m 8348 S  0.3  1.1   0:00.34 mixer_applet2
 6801 darell    16   0  2196 1112  856 R  0.3  0.1   0:00.05 top
    1 root      16   0  1568  532  460 S  0.0  0.1   0:00.91 init
    2 root      RT   0     0    0    0 S  0.0  0.0   0:00.00 migration/0
    3 root      34  19     0    0    0 S  0.0  0.0   0:00.00 ksoftirqd/0
    4 root      RT   0     0    0    0 S  0.0  0.0   0:00.00 watchdog/0
    5 root      10  -5     0    0    0 S  0.0  0.0   0:00.06 events/0
    6 root      11  -5     0    0    0 S  0.0  0.0   0:00.00 khelper
    7 root      12  -5     0    0    0 S  0.0  0.0   0:00.00 kthread
hier verbruikt XGL dus best veel CPU, maar het kan denk ik niet aan XGL liggen want in Gnome heb ik exact hetzelfde!
echt heel vervelend :(
Open Source = Freedom = Power !!

ifokkema

  • Gast
Virus!? CPU blijft steeds 100% ..
« Reactie #21 Gepost op: 2006/10/29, 15:06:20 »
Hmmm.... ik heb op zich wel eens gehoord van mensen (en volgens mij zelf ook een keertje gehad) dat een proces dat heel veel CPU innam, niet te vinden was via top. Zoeken via Google heeft alleen maar andere mensen gevonden met hetzelfde probleem, maar geen oplossingen.

Je load is gigantisch hoog. Zo hoog krijg je het niet zomaar. De PC wordt echt gestressed.

- Hoe is je harde schijf activiteit?
- Probeer dit eens: reboot, NIET inloggen via de GUI, maar Ctrl-Alt-F1 en inloggen op de terminal. Draai dan top weer eens. Er zijn nu een stuk minder processen aan de gang, en misschien helpt dat.
- Geen rare dingen? Dan Ctrl-Alt-F7 en probeer in te loggen op failsafe Gnome. In de terminal of de console top draaien. Nu?
- Uitloggen, Gnome in. Nu?
- Etc...

PieterStel

  • Gast
Virus!? CPU blijft steeds 100% ..
« Reactie #22 Gepost op: 2006/10/29, 15:08:51 »
Ik heb na de upgrade naar edgy iets soortgelijks gehad!
Bij mij bleek de gnome system-monitor de boosdoener, die heb ik toen
in synaptec gemarkeerd voor herinstalllatie ( en dus laten herinstalleren)
en nu geen problemen meer!

Misschien eens proberen?

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
Virus!? CPU blijft steeds 100% ..
« Reactie #23 Gepost op: 2006/10/30, 13:15:45 »
volgens mij heb ik het opgelost!
heb de system monitor zoals PieterStel voorstelde opnieuw geinstalleerd en ook zo'n Gnome Keyring ofzoiets (die gaf soms wel eens foutmeldingen) en nu heb ik er (tot nu toe) geen last meer van! :D
nu maar hopen dat het niet terug komt haha
Open Source = Freedom = Power !!

PieterStel

  • Gast
Virus!? CPU blijft steeds 100% ..
« Reactie #24 Gepost op: 2006/10/30, 20:38:51 »
Mooi dat het opgelost is!