Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] Start niet op met 2e videokaart  (gelezen 2691 keer)

Offline Kogacarlo

  • Lid
  • Steunpunt: Nee
[OPGELOST] Start niet op met 2e videokaart
« Gepost op: 2009/08/14, 15:46:07 »
Ik heb naast mijn Ati radeon x700 pro nog een Ati radeon x 550 gezet.
Win XP pakt de kaart zonder problemen maar Ubuntu wil niet starten, alleen in een soort DOS omgeving. Dus alleen zwart scherm met text.
Ik heb "try to fix xserver" geprobeerd in recovery mode tijdens opstarten maar dat werkt niet.
Heeft iemand een oplossing?
« Laatst bewerkt op: 2009/09/01, 23:44:46 door Kogacarlo »
Ubuntu op een stickie

Offline Miki

  • Lid
  • Steunpunt: Nee
Re: Start niet op met 2e videokaart
« Reactie #1 Gepost op: 2009/08/14, 16:15:39 »
Ik neem aan dat het om de installatie van 9.04 gaat. Er zijn heel veel
problemen met de ati kaarten, deze krijgen op het moment geen
ondersteuning voor oudere kaarten. Ik heb er zelf ook mee geworsteld en geen oplossing gevonden.

http://forum.ubuntu-nl.org/software-en-configuratie/ubuntu-8-10-vastlopers-zwart-scherm/15/

Offline Willem_D

  • Lid
  • Steunpunt: Nee
Re: Start niet op met 2e videokaart
« Reactie #2 Gepost op: 2009/08/14, 16:35:56 »
Ik heb naast mijn Ati radeon x700 pro nog een Ati radeon x 550 gezet.
Win XP pakt de kaart zonder problemen maar Ubuntu wil niet starten, alleen in een soort DOS omgeving. Dus alleen zwart scherm met text.
Ik heb "try to fix xserver" geprobeerd in recovery mode tijdens opstarten maar dat werkt niet.
Heeft iemand een oplossing?
Wat is precies je bedoeling? Kunnen beide kaarten als een gecombineerde kaart gebruikt worden onder XP? Wil je twee monitoren kunnen aansluiten onder XP en/of Ubuntu?

Is het een optie voor je / is het mogelijk om in je BIOS één van de twee kaarten te disabelen?
Acer 5930G laptop met nVidia 9600M GT


"Je verschijnt niet in je lichaam, maar je lichaam verschijnt in Jou."
Francis Lucille

Offline Miki

  • Lid
  • Steunpunt: Nee
Re: Start niet op met 2e videokaart
« Reactie #3 Gepost op: 2009/08/14, 16:36:33 »
Het meest uitgebreide informatie heb ik in de onderstaand thread gevonden. Sommigen
lukt het een bapaalde kaart aan de praat te krijgen.

http://ubuntuforums.org/showthread.php?t=1133931

Offline Willem_D

  • Lid
  • Steunpunt: Nee
Re: Start niet op met 2e videokaart
« Reactie #4 Gepost op: 2009/08/14, 16:45:51 »
Door handmatig je xorg.conf te wijzigen, is veel mogelijk:
 zie http://forum.ubuntu-nl.org/hardware-en-drivers/2-videokaarten-3-schermen-hoe-in-te-stellen/

Maar je zult er wel even in moeten duiken.
Acer 5930G laptop met nVidia 9600M GT


"Je verschijnt niet in je lichaam, maar je lichaam verschijnt in Jou."
Francis Lucille

Offline Kogacarlo

  • Lid
  • Steunpunt: Nee
Re: Start niet op met 2e videokaart
« Reactie #5 Gepost op: 2009/08/17, 18:38:57 »
@Miki; nee het gaat over 8.10 (staat in mijn onderschrift).
@Willem_D; Ik heb XP omdat ik Flight Simulator speel op 3 schermen. In de BIOS kan ik geen kaarten disabelen  :(
Bedankt voor de antwoorden. Ik ga er in duiken  XD

« Laatst bewerkt op: 2009/08/17, 18:51:09 door Kogacarlo »
Ubuntu op een stickie

Offline Willem_D

  • Lid
  • Steunpunt: Nee
Re: Start niet op met 2e videokaart
« Reactie #6 Gepost op: 2009/08/17, 20:36:21 »
Indrukwekkend plaatje!

Kun je onder Ubuntu met slechts één scherm toe?
Acer 5930G laptop met nVidia 9600M GT


"Je verschijnt niet in je lichaam, maar je lichaam verschijnt in Jou."
Francis Lucille

Offline Kogacarlo

  • Lid
  • Steunpunt: Nee
Re: Start niet op met 2e videokaart
« Reactie #7 Gepost op: 2009/08/18, 19:20:41 »
Dat zou kunnen maar ik heb er liever twee.
Ik heb 8.10 nog eens geinstalleerd op een andere partitie. Alle gaat goed tot ik de proprietary driver van Ati installeer. Daarna kan ik niet booten met fatsoenlijk beeld.
Ik werk nu vanaf een live USB-stick; kan ik vanaf hier de Ati driver op de harde schijf uitzetten/disabelen/terugdraaien of zoiets?
Ubuntu op een stickie

Offline Willem_D

  • Lid
  • Steunpunt: Nee
Re: Start niet op met 2e videokaart
« Reactie #8 Gepost op: 2009/08/19, 10:32:41 »
Dat zou kunnen maar ik heb er liever twee.
Ik heb 8.10 nog eens geinstalleerd op een andere partitie. Alle gaat goed tot ik de proprietary driver van Ati installeer. Daarna kan ik niet booten met fatsoenlijk beeld.
Ik werk nu vanaf een live USB-stick; kan ik vanaf hier de Ati driver op de harde schijf uitzetten/disabelen/terugdraaien of zoiets?

Geef de xorg.conf van je harddisk-install eens een andere naam. (Het is even zoeken: de systeem-partitie zal in de live-USBstick-sessie gemount staan onder /media of /mnt .)  Mogelijk dat Ubuntu bij het opstarten dan een maagdelijke xorg.conf aanmaakt (zonder verwijzing naar de ATI-fabrieksdriver).
Ik heb het zelf nooit geprobeerd of dit werkt, maar je kunt de wijziging gemakkelijk weer ongedaan maken.
« Laatst bewerkt op: 2009/08/19, 10:39:27 door Willem_D »
Acer 5930G laptop met nVidia 9600M GT


"Je verschijnt niet in je lichaam, maar je lichaam verschijnt in Jou."
Francis Lucille

Offline Kogacarlo

  • Lid
  • Steunpunt: Nee
Re: Start niet op met 2e videokaart
« Reactie #9 Gepost op: 2009/08/19, 19:37:43 »
Ik had al eens de xorg.conf van de livesessie in de /etc/x11 van de hd gezet maar dat werkte niet.
Nu dus de xorg.conf een andere naam gegeven (en de xorg.conf.failsafe verwijderd) maar dat werkt ook niet.
Ik wil graag Ubuntu opnieuw installeren.
Probleem is dat er documenten op mijn oude bureaublad staan die ik niet mag copieren (geen permissie).
gksu nautilus werkt niet en sudo nautilus ook niet. Grrrr
haha wat nu  ???
 :rolleyes:
Ubuntu op een stickie

Offline Kogacarlo

  • Lid
  • Steunpunt: Nee
Re: Start niet op met 2e videokaart
« Reactie #10 Gepost op: 2009/08/19, 20:08:35 »
OK ik heb een kersverse install op een andere partitie.
Het copieren gaat nu wel.
Hierna zal ik weer een verse install doen op de eerste partitie. Ik denk dat ik dan de proprietary driver niet meer installeer.
Jammergenoeg heb ik dan minder scherp beeld omdat ik dan de schermresolutie niet haal.
Bedankt voor het meedenken  :-*
Ubuntu op een stickie

Offline Kogacarlo

  • Lid
  • Steunpunt: Nee
Re: Start niet op met 2e videokaart
« Reactie #11 Gepost op: 2009/08/23, 21:19:55 »
De resolutie is ook weer geregeld.
Ik heb de oorspronkelijke xorg.conf verandert als volgt:
Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
        SubSection "Display"
                Virtual 2704 1050
        EndSubSection

EndSection
De regels SubSection t/m EndSubSection heb ik toegevoegd.
Ik kan nu op allebei mijn monitors de goede resolutie selecteren. (ik gebruik 2 monitors, 1024*768 en 1680*1050)
1024+1680=2704 vandaar dat getal.
Het hele verhaal staat hier.
« Laatst bewerkt op: 2009/08/23, 21:29:43 door Kogacarlo »
Ubuntu op een stickie

Offline Willem_D

  • Lid
  • Steunpunt: Nee
Re: Start niet op met 2e videokaart
« Reactie #12 Gepost op: 2009/08/24, 18:21:16 »
Kogacarlo, mijn complimenten dat je dit gefixt hebt!

De link die je hebt gevonden, lijkt me voor veel mensen interessant (met name voor gebruikers van ATI-GPU's).

Groet, Willem_D.

(Wil je svp even 'OPGELOST' voor de topic-titel zetten?)
Acer 5930G laptop met nVidia 9600M GT


"Je verschijnt niet in je lichaam, maar je lichaam verschijnt in Jou."
Francis Lucille

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Start niet op met 2e videokaart
« Reactie #13 Gepost op: 2009/08/24, 19:49:27 »
@Kogacarlo:
gksu en sudo niet gebruiken voor nautilus. Beste: gksudo  Ja, net iets anders. En gebruik gewoon de Alt+F2 en dan gksudo nautilus.