Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Probleem met Qt Creator  (gelezen 1257 keer)

Offline JV.com

  • Lid
  • Steunpunt: Nee
Probleem met Qt Creator
« Gepost op: 2009/08/11, 18:12:07 »
goedendag,

ik zag toennet een review over Qt Creator en een filmpje. wat ik zag beviel mij wel alles zag er goed en strak uit.Nu heb ik Qt Creator geinstalleerd. en ik wou het even testen door een helloworld console project te maken. ik een nieuw console project starten. wil ik deze builden en runnen krijg ik deze foutmelding:

Running build steps for project HelloWorld...
Creating gdb macros library...
No valid Qt version set. Set one in Tools/Options
Error while building project HelloWorld
When executing build step 'QMake'
Canceled build.

nu heb ik gekeken in tools -> Qt. daar moet je blijkbaar iets gebeuren een versie setten of dergelijke maar ik snap er niks van. dus ik googlen: kom ik hierop uit:

Go to Tools > Options > QT4 > QT Version
- Press the add button and in the field "Path" fill with /opt/qtsdk-2009.03/qt
- In the field default qt version select the "qt"

dit gedaan help niks. alleen deze versie regel /opt/qtsdk-2009.03/qt stond er ook al.

wie weet hoe ik dit kan oplossen.


Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Probleem met Qt Creator
« Reactie #1 Gepost op: 2009/08/11, 18:40:56 »
Heb je de qt-ontwikkelingsbestanden wel geïnstalleerd? libqt4-dev is dat.

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Re: Probleem met Qt Creator
« Reactie #2 Gepost op: 2009/08/11, 18:48:41 »
Indien je Qt SDK gebruikt (wat ik persoonlijk steeds aanbeveel omdat de packages van Qt in Ubuntu soms wat achterlopen of onvolledig zijn) dan heb je zelf gekozen waar Qt geïnstalleerd moest worden. Indien je met "sudo" de installatie hebt gestart is het standaardpad /opt/qtsdk-2009.03/qt inderdaad.

Indien je libqt4-dev gebruikt uit de Ubuntu packages, dan bevinden al die zaken zich op een andere locatie... maar ik gebruik al heel lang de SDK, dus ik weet niet precies hoe je het moet instellen om de standaard Ubuntu Qt libs te gebruiken ipv degene van Qt SDK.

PS: Qt SDK kan je hier vinden -  http://qt.nokia.com/downloads

edit: nuja, als je toch ervoor kiest om de Qt packages van Ubuntu te gebruiken, waarom dan ook niet het Qt Creator package van Ubuntu? of heb je dan nog steeds problemen?
« Laatst bewerkt op: 2009/08/11, 18:50:47 door profoX »
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline JV.com

  • Lid
  • Steunpunt: Nee
Re: Probleem met Qt Creator
« Reactie #3 Gepost op: 2009/08/11, 18:56:58 »
ik heb libqt4-dev net geïnstalleerd via synaptic alleen dit mocht niet baten.

ook heb ik geprobeerd het via de terminal te installeren dit wou allemaal hetzelfde maar de compile fouten bleven.

nee ik draai niet "bewust" SDK, hiermee wil ik zeggend dat ik hiervan geen flauw idee heb als ik dit draai.

« Laatst bewerkt op: 2009/08/11, 19:11:08 door JV.com »

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Re: Probleem met Qt Creator
« Reactie #4 Gepost op: 2009/08/11, 19:11:39 »
ik heb libqt4-dev net genstalleerd via synaptic alleen dit mocht niet baten.
Heb het even geprobeerd - als je Qt SDK niet wil gebruiken (noch de Qt libs van de Qt website) - dan kan je Qt Creator na het installeren van libqt4 en libqt4-dev als volgt instellen:
Tools - Options - Qt4 - Qt Versions - Default Qt Version: Auto-detected Qt
in de lijst van Qt versies zou naast Auto-detected Qt Path /usr moeten staan, Debugging Helper zal wellicht echter niet ingeschakeld zijn, maar dat is niet zo van belang
Als ook dat niet werkt, kan je nog handmatig proberen een Qt versie toe te voegen en als Path /usr meegeven.

Maar, ik raad toch echt wel de SDK aan in plaats van de Ubuntu pakketjes 8)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Re: Probleem met Qt Creator
« Reactie #5 Gepost op: 2009/08/11, 19:27:18 »
Indien je stapsgewijze instructies wil om Qt SDK te installeren:
http://vidiqatch.org/qt4gids/install.php
Ik zou dan vooraf wel best je huidige Qt Creator deïnstalleren zodat die geen conflicten kan veroorzaken met de versie uit het SDK.
Kan zijn dat je na installatie nog wel het pad van de Qt libs (bv. /home/jouwnaam/qtsdk-2009.03/qt) moet toevoegen aan de lijst in Qt Creator (Tools - Options - Qt4 - Qt Versions)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)