Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Mijn samba netwerk doet het niet  (gelezen 2160 keer)

Offline eekie1

  • Lid
  • Steunpunt: Nee
Mijn samba netwerk doet het niet
« Gepost op: 2009/08/07, 22:14:28 »
Ik draai o.a. ubuntu 9.04 x64 op een raid 0 partitie, naast windows 7 testversie. Het meeste functioneert goed, maar mijn windows-netwerk krijg ik niet aan de praat. Ik heb het een en ander op aanwijzing van andere forum threads gewijzigd aan smb.conf. De originele versie heb ik gebackupt. De i.p. adressen van het modum en de i.p. range voor de clients waren niet goed ingevuld. De werkgroepnaam Workgroup heb ik in kapitalen gezet.
Als ik naar locaties, netwerk ga krijg ik netjes het windows netwerk icoon. Als ik het icoon aanklik verschijnt de waarschuwing:Kon de locatie niet aankoppelen en Kon lijst van gedeelde mappen niet van server opvragen.
Smb.config ziet er als volgt uit:

[global]
netbios name = Samba24
server string = Samba file and print server
workgroup = WORKGROUP
security = user
hosts allow = 127. 192.168.1.
interfaces = 127.0.0.1/8 192.168.1.0/80
bind interfaces only = yes
remote announce = 192.168.1.255
remote browse sync = 192.168.1.255
printcap name = cups
load printers = yes
cups options = raw
printing = cups
guest account = smbguest
log file = /var/log/samba/samba.log
max log size = 1000
null passwords = no
username level = 6
password level = 6
encrypt passwords = yes
unix password sync = yes
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
local master = no
domain master = no
preferred master = no
domain logons = no
os level = 33
logon drive = m:
logon home = \\%L\homes\%u
logon path = \\%L\profiles\%u
logon script = %G.bat
time server = no
name resolve order = lmhosts hosts wins bcast
wins support = no
wins proxy = no
dns proxy = no
preserve case = yes
short preserve case = yes
client use spnego = no
client signing = no
client schannel = no
server signing = no
server schannel = no
nt pipe support = yes
nt status support = yes
allow trusted domains = no
obey pam restrictions = yes
enable spoolss = yes
client plaintext auth = no
disable netbios = no
follow symlinks = no
update encrypted = yes
pam password change = no
passwd chat timeout = 120
hostname lookups = no
username map = /etc/samba/smbusers
smb passwd file = /etc/samba/smbpasswd
passwd program = /usr/bin/passwd '%u'
passwd chat = *New*password* %n\n *ReType*new*password* %n\n *passwd*changed*\n
add user script = /usr/sbin/useradd -d /dev/null -c 'Samba User Account' -s /dev/null '%u'
add user to group script = /usr/sbin/useradd -d /dev/null -c 'Samba User Account' -s /dev/null -g '%g' '%u'
add group script = /usr/sbin/groupadd '%g'
delete user script = /usr/sbin/userdel '%u'
delete user from group script = /usr/sbin/userdel '%u' '%g'
delete group script = /usr/sbin/groupdel '%g'
add machine script = /usr/sbin/useradd -d /dev/null -g sambamachines -c 'Samba Machine Account' -s /dev/null -M '%u'
machine password timeout = 120
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431
template shell = /dev/null
winbind use default domain = yes
winbind separator = @
winbind cache time = 360
winbind trusted domains only = yes
winbind nested groups = no
winbind nss info = no
winbind refresh tickets = no
winbind offline logon = no

[homes]
comment = Home Directories
path = /home
read only = no
available = yes
browseable = yes
writable = yes
guest ok = no
public = no
printable = no
share modes = no
locking = no

[netlogon]
comment = Network Logon Service
path = /home/netlogon
read only = no
available = yes
browseable = yes
writable = no
guest ok = no
public = no
printable = no
share modes = no
locking = no

[profiles]
comment = User Profiles
path = /var/samba/profiles
read only = no
available = yes
browseable = no
writable = yes
guest ok = no
public = no
printable = no
locking = no
create mode = 0600
directory mask = 0700

[printers]
comment = All Printers
path = /var/spool/samba
browseable = yes
writable = no
guest ok = no
public = no
printable = yes
share modes = no
locking = no

[pdf-documents]
path = /home/pdf-documents
comment = Converted PDF Documents
available = yes
browseable = yes
writeable = yes
guest ok = yes

[pdf-printer]
path = /tmp
comment = PDF Printer Service
printable = yes
guest ok = yes
use client driver = yes
printing = bsd
print command = /usr/bin/gadmin-samba-pdf %s %u
lpq command =
lprm command =

[test]
path = /home/USERNAME/test
available = yes
valid users = USERNAME
read only = no
browsable = yes
public = yes
writable = yes
[code/]

Ik kan wel gewoon naar de client machines pingen (ping 192.162.1.73/74). Volgens gadmin-samba is het netwerk geactiveerd en aanvankelijk kreeg ik bij het windows netwerkicoon wel contact met windows 7 op dezelfde computer. Bij controle van smb.config geen foutmeldingen alleen de waarschuwing: The "share modes"option is deprecated.
Kent iemand het probleem en belangrijker kent iemand de oplossing?
« Laatst bewerkt op: 2009/08/09, 21:09:31 door chris. »

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: Mijn samba netwerk doet het niet
« Reactie #1 Gepost op: 2009/08/08, 00:08:16 »
Even een paar puntjes.
1)
hosts allow = 127. 192.168.1
Dit lijkt me een rare uitdrukking
Bedoel je het volgende misschien?
127.0.0.0/24 en 192.168.1.0/8

2)
Lijkt me een raar adres 'ping 192.162.1.73/74' Als je een volledig ipadres neemt 8*4 dan heb je toch maar 32 bits? Hoe kom jij dan aan 74

Ik heb de indruk dat je de configuratie gewoon veel te moeilijk maakt, en daardoor fouten insluipen. Gebruik gewoon de standaardconfiguratie, deze werkt goed.

Offline eekie1

  • Lid
  • Steunpunt: Nee
Re: Mijn samba netwerk doet het niet
« Reactie #2 Gepost op: 2009/08/08, 09:48:21 »
Hallo Siegi,
Voor de goede orde met de oorspronkelijke smb.conf werkte het ook niet. Aan de regel hosts allow heb ik niets veranderd. Het lijkt me dus een verkorte notatie van wat je volledig aangeeft. Met de ping i.p. bedoelde ik natuurlijk twee adressen 192.168.1.73, 192.168.1.74.
Het lijkt me het beste om samba helemaal opnieuw te installeren. Maar welke files behalve smb.conf moet ik dan deleten om te voorkomen dat samba de vorige instellingen weer terugpakt.

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: Mijn samba netwerk doet het niet
« Reactie #3 Gepost op: 2009/08/08, 10:34:29 »
Je hoeft hem helemaal niet te uninstalleren ??
Er staan een aantal voor conf files in Samba die je eventueel zo kan overzetten.
Hernoem je huidige smb.conf ff naar smb.conf.OUD en kopieer een andere voorbeeld smb.conf naar die map.
Zorg er nu voor dat die file weer smb.conf heet en verander verder naar wens.

Na veranderingen altijd Samba herstarten.

Om al die file's te vinden open je Terminal en typ je:
locate smb.conf
Je ziet onder meer in "/usr/share/doc/samba-doc/examples/tridge/" een voorbeeld staan van iemand die Trdge heet.
Hij/zij heeft het netjes uitgesplits in 5 files voor de hele Samba configuratie.
Lees de Read me die erbij zit.
enz enz enz...
« Laatst bewerkt op: 2009/08/08, 10:46:25 door Gandyman »
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline eekie1

  • Lid
  • Steunpunt: Nee
Re: Mijn samba netwerk doet het niet
« Reactie #4 Gepost op: 2009/08/08, 14:06:31 »
De smb.conf die ik heb laten zien is gemaakt met gadmin-samba en aangepast op de juiste ip adressen. Kennelijk werkt dit programma niet goed. Ik heb nu de oorspronkelijke smb.conf truggezet. Nu kom ik wel in het windows netwerk, maar alleen de eigen computer wordt gezien en niet de twee andere netwerkcomputers die op windows vista draaien. Met het voorbeeld uit de tritch map kan ik niet veel.

Offline eekie1

  • Lid
  • Steunpunt: Nee
Re: Mijn samba netwerk doet het niet
« Reactie #5 Gepost op: 2009/08/09, 17:00:18 »
Ik heb het probleem opgelost. Het bleek vnl. in de windowsmachine te zitten. Sorry voor de moeite.
Een handige instructie voor dit soort problemen vindt U hier:
http://ubuntuforums.org/showthread.php?t=1169149
« Laatst bewerkt op: 2009/08/09, 17:05:55 door eekie1 »

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: Mijn samba netwerk doet het niet
« Reactie #6 Gepost op: 2009/08/10, 00:23:14 »
Blij dat het nu werkt, en bedankt voor de oplossing.