Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] Canon Pixma mp540 en Xsane  (gelezen 3646 keer)

Offline flyerman

  • Lid
  • Steunpunt: Nee
[Opgelost] Canon Pixma mp540 en Xsane
« Gepost op: 2009/07/24, 20:36:45 »
Ik heb eeb canon mp540, (multifunctioneel apparaat) printer en scanner etc. Ik draai Hardy 64 bits dus de 32 bits van de canon site draaien niet.

Ik heb het voor elkaar gekregen om de printer en scanner te installeren en het werkt ook. Het enige probleem is dat ik de scanner alleen kan benaderen als ik xsane als root opstart.

Zoniet dan krijg ik de melding "kan apparaat pixma xxxxxx: Geen toegang tot apparaat.

Iemand een idee wat ik fout doe of heb gedaan?
« Laatst bewerkt op: 2009/07/25, 10:21:54 door flyerman »
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Canon Pixma mp540
« Reactie #1 Gepost op: 2009/07/24, 20:56:00 »
In der Beschränkung zeigt sich der Meister.

Offline flyerman

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma mp540
« Reactie #2 Gepost op: 2009/07/24, 21:09:03 »
Dat heb ik helemaal gevolgd, ik kan wel scannen, alleen als root
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline hvb

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma mp540 en Xsane
« Reactie #3 Gepost op: 2009/07/24, 23:33:02 »
Ik heb een  vergelijkbaar probleem met een scanner van Agfa (let wel: alleen een scanner), maar misschien heb je er iets aan.
Ik heb deze scanner onder Hardy aan de praat gekregen, na het installeren van de firmware. Alles werkte prima, maar sinds ik op Jaunty zit moet ik ook als root opstarten, waarbij gelijk de scanbestanden ook als root benaderd moeten worden. Ik baalde hier uiteraard flink van, maar heb toch een "oplossing" gevonden waar ik (en misschien jij) mee leven kan.

Ik start xsane op door in de terminal gksudo xsane te typen, waarna na een tijdje xsane opstart (root!). Meteen daarna sluit ik xsane af  en idem de terminal.
Dan ga ik naar toepassingen-grafisch-xsane waarna xsane zonder problemen begint en niet onder root.

Het is een kleine omweg, maar als deze bij jou werkt (ander apparaat) ben je er misschien mee geholpen.

Hans
« Laatst bewerkt op: 2009/07/24, 23:36:07 door hvb »

Offline flyerman

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma mp540 en Xsane
« Reactie #4 Gepost op: 2009/07/25, 09:48:15 »
Helaas, werkt ook niet

Edit: Opgelost door in /etc/udev/rules.d/40-basic-permissions.rules: de permissie te veranderen;

# USB devices (usbfs replacement)
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", MODE="0664"
SUBSYSTEM=="usb_device", MODE="0664"

to:
# USB devices (usbfs replacement)
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", MODE="0666"
SUBSYSTEM=="usb_device", MODE="0666"

Opnieuw opstarten en klaar.

Alleen nog een foutmelding bij afsluiten xsane


Edit: Ook dit is opgelost door in terminal te typen: sudo chown -R $USER:$USER $HOME
« Laatst bewerkt op: 2009/07/25, 10:22:30 door flyerman »
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline Dorlandicus

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Canon Pixma mp540 en Xsane
« Reactie #5 Gepost op: 2009/08/24, 22:30:58 »
Ik heb de 12-stappen methode gebruikt van McGyver om de MP 540 scanner aan de praat te krijgen,
Alleen: na stap 6 wordt er gevraagd naar mijn wachtwoord.
Ik wil dat wachtwoord graag intypen, maar de terminal reageert op geen enkele toetsaanslag.
Wat gaat er verkeerd?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: [Opgelost] Canon Pixma mp540 en Xsane
« Reactie #6 Gepost op: 2009/08/24, 22:38:39 »
Gewoon je wachtwoord intypen, je ziet niets, geen balletjes, sterretjes o.i.d.
erna een ENTER
In der Beschränkung zeigt sich der Meister.

Offline Dorlandicus

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Canon Pixma mp540 en Xsane
« Reactie #7 Gepost op: 2009/08/24, 23:47:02 »
moet ik nu helemaal overnieuw beginnen?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: [Opgelost] Canon Pixma mp540 en Xsane
« Reactie #8 Gepost op: 2009/08/25, 00:04:07 »
Ik denk het niet. Gewoon het commando op nieuw uitvoeren en je wachtwoord invullen.
Tenzij je het terminal venster hebt afgesloten, dan moet je opnieuw beginnen.
Een voordeel de terminal heeft een "geheugen" als je op het pijltje omhoog drukt krijg je het vorige commando, nog een keer het commando ervoor etc. Type maar eens history in de terminal.
In der Beschränkung zeigt sich der Meister.

Offline Dorlandicus

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Canon Pixma mp540 en Xsane
« Reactie #9 Gepost op: 2009/08/25, 01:38:39 »
't Is helemaal gelukt. De scanner werkt.
Wij - pluralis majestatis - danken u allen!