Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: (Opgelost) Geen netwerkshares, draadloos netwerkfunctie te laat beschikbaar?  (gelezen 6308 keer)

Offline eef

  • Lid
  • Steunpunt: Nee
Dag allen,

Als ik via mijn vaste netwerk opstart gaat alles prima en worden mijn twee netwerkshares meteen bij het opstarten getoond op de desktop. In fstab lijkt alles dus prima in orde.
Maar als ik via mijn draadloos netwerk opstart, worden mijn netwerkshares niet getoond. Pas na het commando "sudo mount -a" komen die weer tevoorschijn. (en kunnen ze gebruikt worden).

Vanadium opperde in mijn eerdere topic dat de draadloze netwerkfunctionaliteit misschien nog niet beschikbaar is op het moment dat fstab tijdens het opstartproces uitgevoerd wordt.

Wie weet een oplossing om ofwel de draadloze netwerkfunctionaliteit te laden voordat fstab uitgevoerd wordt, ofwel een manier om fstab later te laden?
Iets met de opstartvolgorde misschien. In sessies kan ik alleen maar iets aan of uitvinken, kennelijk niet de volgorde aanpassen.
Ik gebruik nu versie 9.04
« Laatst bewerkt op: 2009/07/28, 21:00:55 door eef »

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Als je draadloos internet hebt, doe dan eens:
sudo mount -a
Heb je daarna toegang tot je shares?

Offline eef

  • Lid
  • Steunpunt: Nee
Ha Cumulus,

Ja dat is het probleem nu net: met sudo mount -a komen ze bij de draadloze verbinding netjes tevoorschijn, maar na opnieuw opstarten zijn ze weer weg. En ik vind het vervelend om steeds dat commando te moeten geven, terwijl bij mijn vaste verbinding dat niet nodig is.

rarara, hoe komt dat verschil?


Offline masy

  • Lid
  • Steunpunt: Nee
Als je het commando mount -a nog steeds nodig hebt, start er niets automatisch op.
Dan heb je een commando in de opstart vergeten...

 

Offline eef

  • Lid
  • Steunpunt: Nee
Als ik via de vaste ADSL-verbinding opstart werkt alles prima. Heb ik ook geen mount-a commando nodig.
Maar waarom heb ik dat commando dan wel nodig als ik draadloos werk?

Wat is hier nu het verschil tussen draadloos en vast. Waarom heb ik bij de vaste verbinding wel automatische shares op de desktop en bij draadloos niet?

Offline vanadium

  • Lid
  • Steunpunt: Nee
Citaat
waarom heb ik dat commando dan wel nodig als ik draadloos werk?
Omdat hier de netwerkverbinding slechts gelegd wordt per gebruiker na het inloggen.

Offline eef

  • Lid
  • Steunpunt: Nee
Citaat
Omdat hier de netwerkverbinding slechts gelegd wordt per gebruiker na het inloggen.
Dat wist ik niet.
Dus de vaste verbinding via de adsl-kabel is user-onafhankelijk en de draadloze verbinding wordt alleen per user toegestaan?

Enfin, is hier dan iets aan te doen? Masy suggereerde al dat ik een commando in de opstart vergeten was. Enig idee welk commando dat zou moeten zijn en waar die geplaatst moet worden?

Offline tim_vb

  • Lid
  • Steunpunt: Nee
Mount -a  laten uitvoeren vlak,na het opstarten,
Kan je via systeem-voorkeuren-opstart toepassingen en dan toevoegen en bij opdracht mount-a
Volgens mij is je probleem dan opgelost ik heb het wel niet getest.
Mvg. Tim

Offline eef

  • Lid
  • Steunpunt: Nee
Ha Tim,

Bedankt voor je suggestie. Ik had dit al wat eerder al geprobeerd. "Mount -a" invoegen gaf geen verschil. Toen realiseerde ik dat dit een root-commando is. Echter, "sudo mount -a" deed het ook niet.
Misschien omdat het wachtwoord dan niet ingevoerd wordt?

Offline tim_vb

  • Lid
  • Steunpunt: Nee
Probeer eens dit:

Ga naar terminal typ in sudo nano /etc/rc.local
Enter en pasw.
En dan onderaan voor exit 0
mount-a

En dan cntr x en save
Lukt het dan ?
Mvg.tim

Offline eef

  • Lid
  • Steunpunt: Nee
Re: geen netwerkshares, draadloos netwerkfunctionaliteit te laat beschikbaar?
« Reactie #10 Gepost op: 2009/07/24, 17:23:51 »
Leek veelbelovend, maar helaas.

Ook met sudo mount -a gebeurt er niets. In dat laatste geval; waar wordt dan het password voor root gegeven, of is het password voor de sessie dan nog geldig?

rc.local, is dat zoiets als vroeger het autoexec.bat ? (ik ben nog van heel vroeger...)

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: geen netwerkshares, draadloos netwerkfunctionaliteit te laat beschikbaar?
« Reactie #11 Gepost op: 2009/07/24, 19:10:32 »
rc.local kan je inderdaad vergelijken met autoexec.bat. Zoals je ziet, wordt het standaard niet gebruikt. De opstartprocedures zijn heel wat ingewikkelder. Als je zelf ook nog iets wil uitvoeren bij opstart, dan is rc.local wel handig. Je hebt immers geen zin om zelf runlevels aan te passen.

Wat je kan proberen is je netwerkverbindingen aanmelden in /etc/fstab met de opties "noauto,user". Dat betekent dat je de verbinding enkel aanmeldt, maar niet automatisch tijdens de opstart maakt (noauto). "user" betekent dat een gewone gebruiker die verbinding naderhand mag leggen.

Dan voeg je in "Systeem - Voorkeuren - Opstartapplicaties ("Startup programs") het mount commando toe. Dat is eenvoudig "mount <naam_van_je_device>", met <naam_van_je_device> de éérste of tweede ingang in je fstab (aan jou de keuze): alle opties en nodige info staan namelijk reeds in fstab en moet je niet meer aangeven. Wellicht zal je ook een "sleep" commando moeten geven om het mounten even uit te stellen: je wil immers zeker zijn dat de draadloze verbinding reeds gemaakt is als het mount commando uitgevoerd wordt. Het wordt iets als

sleep 3 ; mount <naam_van_je_device>

Zelf zou ik voor een laptop gewoon met een nautilus bookmark werken, denk ik ...


Offline eef

  • Lid
  • Steunpunt: Nee
Re: geen netwerkshares, draadloos netwerkfunctionaliteit te laat beschikbaar?
« Reactie #12 Gepost op: 2009/07/24, 21:33:04 »
Ik had toch echt gedacht dat de procedure van Vanadium zou werken, maar tot op heden nog niet.

Fstab heb ik aangepast, de regels waar het om gaat zijn de volgende:

//px-eh/disk         /media/disk              cifs    user,noauto,rw,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
//px-eh/usbdisk1   /media/usbdisk1           cifs    user,noauto,rw,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

Als ik in de terminal aangeef "mount //px-eh/disk", wordt deze lokatie gelijk gemount en is beschikbaar.

Maar als ik dat commando in rc.local invoer, dan wel in "sessies" (opstarttoepassingen in 9.04) gebeurd er niets. Ook niet als ik bij elk "sleep 30" aangeef

De laatste versie van mijn rc.local ziet er nu zo uit
sleep 60
mount //px-eh/disk
exit 0

Ik heb diverse varianten en combinaties uitgeprobeerd, maar de juiste zit er (nog) niet bij.

Misschien maak ik een grammaticale codefout?

Offline Roel1963

  • Lid
  • Steunpunt: Nee
Re: geen netwerkshares, draadloos netwerkfunctionaliteit te laat beschikbaar?
« Reactie #13 Gepost op: 2009/07/25, 10:27:21 »
Citaat
waarom heb ik dat commando dan wel nodig als ik draadloos werk?
Omdat hier de netwerkverbinding slechts gelegd wordt per gebruiker na het inloggen.

Is het niet zo dat je vanaf 8.10 je wireless settings kan aanmerken als systeeminstelling? Dan wordt volgens mij de netwerkverbinding onafhankelijk van de user ingesteld, en dat zal dus iets eerder gebeuren denk ik.

Volgens mij heet het "modus --> infrastructure" (heb even geen 9.04 computer bij de hand).

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: geen netwerkshares, draadloos netwerkfunctionaliteit te laat beschikbaar?
« Reactie #14 Gepost op: 2009/07/25, 13:48:01 »
Dat dacht ik ook. In het ander draadje had ik aangegeven hoe die instelling te veranderen, maar zelf heb ik dit niet getest.

Offline MartijnB

  • Lid
    • http://www.mbastiaan.nl
  • Steunpunt: Nee
Re: geen netwerkshares, draadloos netwerkfunctionaliteit te laat beschikbaar?
« Reactie #15 Gepost op: 2009/07/25, 17:06:07 »
Hoewel de reden van het probleem in het topic genoemd is, nl het niet system-wide zijn van de draadloze instellingen, zijn de oplossingen die tot nog toe zijn genoemd, niet de goede oplossingen vrees ik.

Wat je moet doen is de draadloze netwerkverbinding beschikbaar maken voor het hele systeem. Dit kan in de netwerkmanager. Je moet hiervoor wél beheerder zijn en er rekening mee houden dat de WPA-sleutel onversleuteld op het systeem wordt opgeslagen.

Als je dat hebt gedaan, moet het goed gaan :)

Offline eef

  • Lid
  • Steunpunt: Nee
Re: geen netwerkshares, draadloos netwerkfunctionaliteit te laat beschikbaar?
« Reactie #16 Gepost op: 2009/07/25, 21:39:42 »
Ha Roel en Vanadium,
Ik had die instelling systeeminstelling al eens opgemerkt in een van de tabbladen van het draadloos netwerk. Hij stond al eens aangevinkt en inmiddels weer uitgevinkt. Toch maar weer eens aangevinkt in de hoop dat de combinatie met de voorgaande maatregelen zou werken. Maar nee.

Soms vraag ik me af of het bestand rc.local wel wordt uitgevoerd, waar ik het vertraagde mount-commando heb neergezzet. Hoe kan ik dat controleren?

Martijn,
Klinkt goed, vooral omdat het zo eenvoudig lijkt. Maar hoe?
In de netwerkmanager waarin ik hierboven al iets heb veranderd vind ik niet direct waar en hoe ik de draadloze verbinding beschikbaar maak voor het gehele systeem. Alleen het tabblad IPv4 instellingen lijkt in de buurt te komen met de keuzeoptie: methode: gedeeld met andere computers. Maar daarmee krijg ik weer geen draadloze verbinding.

Ik heb inmiddels al zoveel mogelijkheden dat er nu exponentieel veel combinaties mogelijk zijn (zou die tip met die tip samen dan werken?). Ik raak inmiddels een beetje moedeloos.



Offline MartijnB

  • Lid
    • http://www.mbastiaan.nl
  • Steunpunt: Nee
Re: geen netwerkshares, draadloos netwerkfunctionaliteit te laat beschikbaar?
« Reactie #17 Gepost op: 2009/07/25, 22:21:00 »
Hey Eef,

Ik heb het even geprobeerd op m'n laptop, maar de optie die beschikbaar is, is 'Netwerk beschikbaar voor alle gebruikers op deze machine' en dus niet wat ik gedacht had :(.

Maar goed, het moet mogelijk zijn wat je wil. Vroegâh moesten we in Linux (draadloze) netwerken namelijk handmatig instellen in een configuratiebestand. Dit configuratiebestand werd dan uitgelezen tijdens de boot en uitgevoerd. Ooit heb ik dit werkbaar gehad met WPA-PSK (toen waren de tools daarvoor net uit). Ik weet het nu op dit moment niet meer.

Ik ga morgen even voor je spitten en je hoort het wel zodra ik iets gevonden heb!

Edit; Ben je van plan met veel draadloze netwerken contact te leggen? Of is het maar één enkel netwerk?
Edit2; Ik stuiter net op een package genaamd 'autofs'. Het zorgt ervoor dat als je een map wil benaderen die nog niet gemount is, automatisch gemount wordt. Is dit een optie voor je? Lees meer hier, hier en hier.
« Laatst bewerkt op: 2009/07/25, 22:28:31 door MartijnB »

Offline masy

  • Lid
  • Steunpunt: Nee
Re: geen netwerkshares, draadloos netwerkfunctionaliteit te laat beschikbaar?
« Reactie #18 Gepost op: 2009/07/26, 00:18:47 »
Hoi Eef,

Als ik het goed begrijp start je als (mogelijk nfs?) cliënt op en log je in op een (nfs?) server in. Wat ik niet goed begrijp is of je met dezelfde machine eerst opstart met de vaste verbinding en vervolgens met dezelfde machine overschakelt naar wireless. Dat kan, maar dan wordt de vaste verbinding met de server ook verbroken én zul je altijd met mount -a onder de wireless-verbinding de netwerkshares moeten herstellen...

Als dit zo is, heeft de vaste verbinding nl. de voorrang. Dan hoef je alleen maar de vaste verbinding uit te schakelen via menu Systeem->Voorkeuren->Netwerkverbindingen. Automatisch verbinden uitvinken. In datzelfde menu zet je bij de Wireless verbinding het vinkje aan.
En opnieuw opstarten. Hierna zal automatisch verbinding naar de wireless worden gezocht en de shares zullen dan ook automatisch plaatsvinden.

Je kunt nl. niet op een machine én via vaste verbinding én via wireless werken. Het is altijd of/of en niet en/en...
Dus zul je een keuze moeten maken tussen vast of wireless.

Als vorenstaande klopt, heb ik maar een advies: Als je in de luxe-positie verkeert om tussen vast- of wireless te kiezen, ga dan altijd voor de vaste verbinding... (Tenzij: je een laptop/notebook hebt,ga dan altijd voor wireless...)

Gr. Masy

 
 

Offline MartijnB

  • Lid
    • http://www.mbastiaan.nl
  • Steunpunt: Nee
Re: geen netwerkshares, draadloos netwerkfunctionaliteit te laat beschikbaar?
« Reactie #19 Gepost op: 2009/07/26, 09:11:21 »
Volgens mij bedoelt Eef dat zij óf haar vaste verbinding óf haar draadloze verbinding gebruikt.

En je kunt wel degelijk twee netwerken door elkaar gebruiken, hoewel het niet altijd praktisch is :P! De netwerkmanager zal dan automatisch het verkeer laten lopen over het netwerk met de laagste latency.

Offline eef

  • Lid
  • Steunpunt: Nee
Re: geen netwerkshares, draadloos netwerkfunctionaliteit te laat beschikbaar?
« Reactie #20 Gepost op: 2009/07/26, 15:37:44 »
Ha Masy,
Ik heb diverse vinkjes aan- en uitgezet in verschillende combinaties. Geen van allen had het gewenste resultaat.
Ik heb het hier overigens over mijn laptop die ik bijna altijd draadloos opstart en draadloos gebruik. Als ik mijn netwerkkabel erin steek, dan werk ik natuurlijk bij voorkeur via de vaste verbinding. Die wordt dan probleemloos gemaakt, inclusief de shares.

Martijn,
op jouw vraag naar hoeveel netwerken ik wil benaderen; ééntje maar, die van "me égah" (heb ook in "dehaag" op school gezeten  =D)
Autofs leek het helemaal te worden (ik dacht eigenlijk dat ik die al geinstalleerd had). Via Synaptic bleek van niet. Heb het geïnstalleerd, maar geeft geen verschil. Jammer.
Ik dacht niet dat daar verder nog iets aan ingesteld moest worden?

Ik blijf een beetje zitten met het idee dat het toch te lang duurt voor het draadloze netwerk gevonden is. Bij het opstarten plopt er direct een lokale share op het buroblad, maar pas een tijd later zie ik het netwerkicoontje oplichten.
Als ik via de terminal de zaak mount (mount //px-eh/disk) gaat dat prima, maar diezelfde regel in de rc.local (voorafgegaan met sleep 60) geeft geen resultaat.

# By default this script does nothing.
sleep 60
mount //px-eh/disk
mount //px-eh/usbdisk1
exit 0

De grammatica ervan lijkt goed te zijn als ik de oplichtende kleurcodes mag geloven.
Hoe weet ik zeker dat rc.local wel wordt uitgevoerd?

Offline MartijnB

  • Lid
    • http://www.mbastiaan.nl
  • Steunpunt: Nee
Re: geen netwerkshares, draadloos netwerkfunctionaliteit te laat beschikbaar?
« Reactie #21 Gepost op: 2009/07/26, 18:13:57 »
Het moet wel ingesteld worden. De documentatie is echter vrij incompleet en bagger. Ik heb nu een uur geprobeerd het aan de praat te krijgen, maar het programma geeft geen kik. Niks in de logboeken, geen output in de terminal. Het enige wat het doet is een bepaald filesystem aanmaken in een bepaalde map..

Maar het is mooi om te lezen dat je maar van één draadloos netwerk gebruik maakt. Lees dit eens.

Je kunt ook nog proberen je eigen script aan te maken, zoals je al gedaan hebt, die wél werkt ;-).
sudo gedit /etc/init.d/nfs-mount-customInhoud daarvan wordt:
#!/bin/bash
if [ "$1" = "start" ]; then
 sleep 60
 mount -a
fi
Opslaan en sluiten. Vervolgens:
sudo chmod +x /etc/init.d/nfs-mount-custom
sudo update-rc.d nfs-mount-custom defaults
En klaar :). Dit zou moeten werken!

Offline eef

  • Lid
  • Steunpunt: Nee
Re: geen netwerkshares, draadloos netwerkfunctionaliteit te laat beschikbaar?
« Reactie #22 Gepost op: 2009/07/26, 19:04:30 »
Ha Martijn,
Bedankt voor je werk, ik zie dat je druk bezig bent om de oplossing te vinden. Dat stel ik op prijs. Jammer voor ons heeft het nog geen gewenst resultaat opgeleverd.

Ik heb de codes gekopieerd en geplakt (heb af en toe een beetje idee wat ik aan het doen ben) en de zaak opnieuw opgestart.
De output van de terminal na het laatste commando is de volgende:

eef@tecra:~$ sudo chmod +x /etc/init.d/nfs-mount-custom
[sudo] password for eef:
eef@tecra:~$ sudo update-rc.d nfs-mount-custom defaults
update-rc.d: warning: /etc/init.d/nfs-mount-custom missing LSB style header
 Adding system startup for /etc/init.d/nfs-mount-custom ...
   /etc/rc0.d/K20nfs-mount-custom -> ../init.d/nfs-mount-custom
   /etc/rc1.d/K20nfs-mount-custom -> ../init.d/nfs-mount-custom
   /etc/rc6.d/K20nfs-mount-custom -> ../init.d/nfs-mount-custom
   /etc/rc2.d/S20nfs-mount-custom -> ../init.d/nfs-mount-custom
   /etc/rc3.d/S20nfs-mount-custom -> ../init.d/nfs-mount-custom
   /etc/rc4.d/S20nfs-mount-custom -> ../init.d/nfs-mount-custom
   /etc/rc5.d/S20nfs-mount-custom -> ../init.d/nfs-mount-custom



Offline MartijnB

  • Lid
    • http://www.mbastiaan.nl
  • Steunpunt: Nee
Re: geen netwerkshares, draadloos netwerkfunctionaliteit te laat beschikbaar?
« Reactie #23 Gepost op: 2009/07/26, 19:17:14 »
Hmm, dat ziet er wel goed uit. Doe eens hetvolgende:
sudo gedit /etc/init.d/nfs-mount-customen plak onderaan:
echo 'OK' > /tmp/testSla het op en herstart de computer. Staat er nu in /tmp een bestandje genaamd 'test'? Zoja, dan start het script wel, maar is waarschijnlijk de wachttijd (nu 60 seconden) te kort. Verander het eens in bijvoorbeeld 200 seconden en wacht. Mount het dan wel (na 200 seconden)?

200 seconden is natuurlijk niet praktisch en, zodra het werkt, zal ik wel even een scriptje voor je schrijven die gewoon test of er een verbinding is en zodra die er is, mount -a uitvoert.

Offline MartijnB

  • Lid
    • http://www.mbastiaan.nl
  • Steunpunt: Nee
Re: geen netwerkshares, draadloos netwerkfunctionaliteit te laat beschikbaar?
« Reactie #24 Gepost op: 2009/07/26, 19:40:13 »
Natuurlijk werkt het niet! Wat dom van me. Het systeem wacht nu eerst 200 seconden tot het script is afgelopen en gaat daarna pas weer verder met booten.

Ik ga nu weg, ik knutsel vannacht / morgen wel even wat voor je in mekaar (zet het maar weer even terug op 1 seconde trouwens, om lange boottijden te voorkomen ;)).