Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Webcam wel in V4L maar niet in V4L2  (gelezen 2346 keer)

Offline Carharttguy

  • Lid
  • Steunpunt: Nee
Webcam wel in V4L maar niet in V4L2
« Gepost op: 2009/07/22, 14:41:51 »
Hoi iedereen,

Ik zit met een probleempje, ik heb een webcam, en als ik die test met gstreamer-properties, werkt die perfect op V4L.
Als ik daarintegen met V4L2 kijk, staat in de dropdownbox "onbekend", klik ik die aan, komt er een driverfout die zegt dat het geen V4L2 driver is, maar misschien een V4L1 driver.

Nu, ik heb een programma (emesene) en die ondersteunt alleen V4L2, is het mogelijk om die compatibel te maken? Of kan ik daar ergens de geupgrade versie van downloaden ofzo?

In cheese enzo werkt mijn webcam perfect.

Ik heb een Logitech QuickCamTM Messenger Webcam
Die ziet er zo uit:

« Laatst bewerkt op: 2009/07/22, 14:43:47 door Carharttguy »

Offline Carharttguy

  • Lid
  • Steunpunt: Nee
Re: Webcam wel in V4L maar niet in V4L2
« Reactie #1 Gepost op: 2009/07/22, 15:14:23 »
Update: ik ben al iets verder:

Ik heb een site gevonden: http://moinejf.free.fr/ Daar kan ik een map vol met drivers downloaden
Op deze site staat dat het status van mijn webcam OK is: http://moinejf.free.fr/webcam.html

Ik heb nu 2 bestanden voor mijn webcam:

zc3xx.c
zc3xx-reg.h

Hoe instaleer ik deze bestanden zodat ze werken?

Alvast beankt!

koma

  • Gast
Re: Webcam wel in V4L maar niet in V4L2
« Reactie #2 Gepost op: 2009/08/17, 12:03:18 »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Webcam wel in V4L maar niet in V4L2
« Reactie #3 Gepost op: 2009/08/17, 22:57:29 »
Zoek in Synaptic op easycam2 installeer de versie met gtk erachter. Na installatie terug te vinden onder Hulpmiddelen. Het programma is in het Frans, beheers je dat mooi, zo niet een woordenboek of vertaalsite, alhoewel het mij ook gelukt is met mijn minimale kennis van het Frans. Trouwens ik heb dezelfde webcam als jij hebt, ik heb alleen een beugeltje aan de onderzijde om de webcam aan de monitor te klemmen.
In der Beschränkung zeigt sich der Meister.

Offline Carharttguy

  • Lid
  • Steunpunt: Nee
Re: Webcam wel in V4L maar niet in V4L2
« Reactie #4 Gepost op: 2009/10/24, 14:48:21 »
Zoek in Synaptic op easycam2 installeer de versie met gtk erachter. Na installatie terug te vinden onder Hulpmiddelen. Het programma is in het Frans, beheers je dat mooi, zo niet een woordenboek of vertaalsite, alhoewel het mij ook gelukt is met mijn minimale kennis van het Frans. Trouwens ik heb dezelfde webcam als jij hebt, ik heb alleen een beugeltje aan de onderzijde om de webcam aan de monitor te klemmen.

Ik heb hier gekeken: https://help.ubuntu.com/community/EasyCam
Heb die links toegevoegd: En update werkt, maar als ik "sudo apt-get install easycam2-gtk" doe, krijg ik dit:

carharttguy@carharttguy-laptop:~$ sudo apt-get install easycam2-gtk
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
Sommige pakketten konden niet ge√Įnstalleerd worden. Dit kan betekenen dat u
een onmogelijke situatie gevraagd hebt of dat u de 'unstable'-distributie
gebruikt en sommige benodigde pakketten nog vastzitten in 'incoming'.
De volgende informatie helpt u mogelijk verder:

De volgende pakketten hebben niet-voldane vereisten:
  easycam2-gtk: Vereisten: python2.4-glade2 maar het is niet installeerbaar
                Vereisten: python2.4-gtk2 maar het is niet installeerbaar
E: Niet-werkende pakketten:

Ps: ik weet dat de softwarebronnen voor hardy zijn, maar als ik er jaunty bij schrijf, werken ze niet..

Offline Glenn nl

  • Lid
  • Steunpunt: Nee
Re: Webcam wel in V4L maar niet in V4L2
« Reactie #5 Gepost op: 2009/10/24, 14:53:20 »
Probeer eerst eens de nieuwste emesene (1.5.1) :

http://www.emesene.org/

Eerst deed mijn cam het niet, nu wel :)