Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: netwerkverbinding alleen nog mogelijk met mount -a  (gelezen 1116 keer)

Offline eef

  • Lid
  • Steunpunt: Nee
netwerkverbinding alleen nog mogelijk met mount -a
« Gepost op: 2009/07/22, 10:44:36 »
Dag allemaal

Op mijn laptop ben ik kortgeleden verhuisd van 8.04 naar 8.10.

Voorafgaand aan de upgrade heb ik volgens mij nog een netwerkschijf toegevoegd (en dus fstab aangepast).
Sindsdien krijg ik na het opstarten geen automatische verbinding meer met mijn netwerklokaties. Pas na het invoeren van sudo mount -a in de terminal, komen de twee netwerkverbindingen weer netjes tevoorschijn.

Fstab:

# /etc/fstab: static file system information.
#
#  -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda6 :
UUID=07fab7f5-95c3-42f1-95f3-800bd6efd8a5 / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/sda5 :
UUID=f6f976d5-cc91-4eac-bbde-655097829af5 /home ext3 relatime 0 2
# Entry for /dev/sda7 :
UUID=c296d7a8-aab2-46d2-8310-adcd9734401a none swap sw 0 0
/dev/scd0       /media/cdrom0    udf,iso9660 user,noauto,exec,utf8 0 0
/dev/sda1       /media/win-c    ntfs-3g defaults,locale=nl_NL.UTF-8 0 0
//px-eh/disk       /media/disk     cifs    guest,rw,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
//px-eh/usbdisk1   /media/usbdisk1 cifs    guest,rw,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

In de map /media zijn alle directories aanwezig.

Op mijn andere machine (8.10 ondertussen, maar op 9.04 werkte het ook) gebruik ik dezelfde strategie met cifs en dezelfde regels in fstab, daar loopt alles vlekkeloos.

Wat kan er gebeurd zijn dat de twee laatste netwerklokaties 'disk' en 'usbdisk1' niet meer automatisch gemount worden bij het opstarten.
Ik vermoed dat er sinds de upgrade een pakket is veranderd of verwijderd wat ik ooit geinstalleerd heb, maar ik zou niet weten welke. Ik heb in synaptic zoveel mogelijk vergeleken aan geïnstalleerde pakketten, maar nog niets gevonden wat ik zou missen.

groeten, Eef
 

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: netwerkverbinding alleen nog mogelijk met mount -a
« Reactie #1 Gepost op: 2009/07/22, 13:50:03 »
Dat het wél lukt na het uitvoeren van het commando "mount -a" laat mij vermoeden dat alle benodigde software wel degelijk geïnstalleerd is. Alleen lijkt de benodigde netwerkfunctionaliteit nog niet beschikbaar op het ogenblik dat fstab tijdens de opstart uitgevoerd wordt. Eigenaardig natuurlijk, dat het op een andere 9.4 machine wel zo werkt.

Als je draadloos netwerk gebruikt, dan wordt dat pas na inloggen geactiveerd. Kan dus niet gaan via /etc/fstab. Wellicht gebruik jij dus géén draadloos, want het ging met Ubuntu 8.4 wel?

Mogelijk werkt het wel als je de verbinding wat in de opstartprocedure doorvoert. Dat kan door de mount commando's uit /etc/fstab te verwijderen en aan /etc/rc.local toe te voegen. Alternatief zou je meteen het commando "mount -a" aan /etc/rc.local kunnen toevoegen.

Anderszijds spreek je hier over een laptop. Op een laptop zou ik persoonlijk geen netwerkschijven via /etc/fstab mounten. De netwerkschijven, of het netwerk, zijn immers niet altijd aanwezig. Dan zou ik gewoon een verbinding configureren via nautilus (Bestand - Verbinden met server). Daar kan je aanklikken dat een bookmark moet aangemaakt worden. Dat verschijnt dan in het linker paneel van nautilus en in het "Plaatsen" menu. Met één klik kan je dan de verbinding maken.


Offline eef

  • Lid
  • Steunpunt: Nee
Re: netwerkverbinding alleen nog mogelijk met mount -a
« Reactie #2 Gepost op: 2009/07/22, 20:49:54 »
Dag Vanadium, bedankt voor je snelle reactie.

De beoogde verbinding is steeds een draadloze, daarop heeft het ook altijd gewerkt. Kort voor de update heb ik echter door een overstap naar eendere provider een tijdje gebruik gemaakt van het netwerk van de buren. Wellicht dat hierdoor iets in het ongerede geraakt is.

Ik had nog niet gedacht om het uit te proberen met het vaste netwerk.
Het blijkt allemaal wel vlekkeloos te werken als ik hem op mijn vaste netwerk opstart. Na uitzetten en netwerkkabel verwijderen, worden de netwerkshares draadloos weer niet weergegeven.

Kennelijk is alles in principe dus oke, maar is (zoals je al opperde) de netwerkfunctionaliteit van het draadloze netwerk nog niet beschikbaar als fstab uitgevoerd wordt.
Je zou zeggen dat de opstartvolgorde gewijzigd moet worden, maar ik weet niet of en hoe dat mogelijk is. Kan de uitvoering van fstab vertraagd worden?

 /etc/rc.local is nieuw voor mij. Er staan nu alleen exit 0 in. Ik probeer het liefst eerst de originele oplossing terug te vinden voordat ik begin aan het omzeilen ervan. Tenzij de rc.local strategie meer voordelen heeft.

groeten, Eef



Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: netwerkverbinding alleen nog mogelijk met mount -a
« Reactie #3 Gepost op: 2009/07/23, 12:22:27 »
Probeer misschien eens (onder 9.04) rechts-klik netwerkicoon, "Edit connections", "Wireless" tab, klik je netwerk, Edit, en dan is er een checkmark "available to all users". Markeer die, en het zou wel kunnen dat op dat ogenblik ook het draadloze netwerk vóór het inloggen wordt opgestart.

Offline eef

  • Lid
  • Steunpunt: Nee
Re: netwerkverbinding alleen nog mogelijk met mount -a
« Reactie #4 Gepost op: 2009/07/23, 12:43:59 »
Nee, helaas. (Ik zit ook nog op 8.10. )
Er zijn onder de draadloos tab wel twee checkboxen, automatisch verbinden (stond aan, blijft aan) en systeeminstelling (stond uit, staat nu ook aan).
Dat heeft niet het verschil gemaakt.

Ik denk dat ik hier maar een nieuw topic over maak, het probleem is nu in ieder geval wel wat duidelijker.

bedankt, Eef

Offline masy

  • Lid
  • Steunpunt: Nee
Re: netwerkverbinding alleen nog mogelijk met mount -a
« Reactie #5 Gepost op: 2009/07/23, 21:21:36 »
De map //px-eh/ is onbekend...

Je kunt daar invullen wat je wilt, dan nog krijg je geen enkel werkende (netwerk)-verbinding...

Gr... Masy