Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Triple screen XGL (2x nvidia)  (gelezen 786 keer)

Gast

  • Gast
Triple screen XGL (2x nvidia)
« Gepost op: 2006/10/23, 14:24:46 »
Na dit topic toch maar besloten een tweede nVidia kaart te kopen om zo XGL werkend te krijgen op drie schermen met 2 nVidia kaarten. Het lukt echter nog steeds niet goed. Ik zal mijn situatie even uitleggen:

In m'n systeem zit een Geforce 7600 PCI-E kaart (waarop 2 schermen zitten) en een Geforce 6200 PCI kaart (met het derde scherm). Ik draai Ubuntu 6.0.6 met Compiz en Beryl. Zonder Compiz en Beryl werkt alles goed: Ik heb 3x 1600x1200, GLX werkt, top. Wanneer ik echter XGL wil gaan draaien met Beryl loopt het zaakje minder voorspoedig.

Het probleem lijkt hem te zitten in de nVidia drivers. Wanneer ik m'n PC opstart (met of zonder XGL) en X wordt geladen, laadt die standaard alleen m'n 2 7600 schermen met de nVidia driver. De 6200 produceert ook beeld, alleen op dit scherm wordt 1 geen nVidia driver geladen (tenminste, ik zie het logo niet verschijnen) en 2 heeft het een hele lage resolutie (640x480 ofzo). GLX support heb ik dan wel op alle drie de schermen maar ik met X echt restarten (crtl-alt-backspace) om de nVidia driver op alle 3 de schermen geladen te krijgen.

Normaal is dit geen probleem: Opstarten, X restarten en gaan. Maar sinds XGL werkt deze methode minder goed. Als ik opstart zonder X te restarten werkt alles goed (op de lage resolutie na) en heb ik zelfs XGL over drie schermen. Als ik echter X restart, zie ik dat alle schermen het nVidia logo laten zien, daarna zie ik heel even de X layout (zwartwit ruitachtergrond, kruisje als cursor) en dan begint die weer met het laden van de nVdia drivers. Dit 3 keer achter elkaar waarna X er de brui aan geeft.

Het vreemde is, als ik maar lang genoeg wacht en werk vanuit de de console, en X weer opstart werkt die weer (alleen geen nVidia driver derde scherm). Als ik te snel X restart laadt die weer alle 3 de drivers en komt die in de loop terecht.

Dus kort omschreven: Met de XGL toevoegingen in m'n gdm.conf-custom krijg ik X niet gestart met 3 schermen in de goede resolutie, zonder de XGL toevoegingen wel (na een herstart van X). Ik heb ik m'n Xorg.conf ook al geprobeerd de Modes van m'n 3de scherm enkel op 1600x1200 te zetten maar dat mocht niet baten. Als ik m'n PCI kaart als primary kaart zit in de BIOS wordt wel gelijk de nVidia driver goed geladen maar dan kom ik toch nog in de loop terecht. Het verwisselen van de PCI kaart naar een ander slot maakt niets uit.

Als ik XGL draai met dual screen (op de 7600) werkt alles perfect. Single screen op de 6200 ook. Alleen het combineren lukt niet. :(

Wat kan ik nog proberen? Gaat die uberhaupt werken of ligt het gewoon aan de nVidia drivers?

Hier nog wat config files: