Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Na installatie iRedMail server rare apache melding (Auth_MySQL_User)  (gelezen 1480 keer)

Offline Riel

  • Lid
    • Rielity
  • Steunpunt: Nee
$ sudo /etc/init.d/apache2 restart

geeft:

Syntax error on line 35 of /etc/apache2/conf.d/awstats.conf:
Invalid command 'Auth_MySQL_User', perhaps misspelled or defined by a module not included in the server configuration

De auth_mysql module is geladen. De awstats.conf:

#
# File generated by iRedMail (2009.07.16.16.41.08):
#
# Version:  0.5.0-rc2
# Project:  http://code.google.com/p/iredmail/
#
# If you deploy iRedMail in product environment, we suggest
# you public your information in 'Success Stories' forum to help us
# promote iRedMail.
#
# Forum: http://www.iredmail.org/forum/
#

# Note: Please refer to /etc/apache2/sites-available/default-ssl for SSL/TLS setting.
#Alias /awstats/icon /usr/share/awstats/icon/
#ScriptAlias /awstats /usr/share/awstats/
#Alias /css /usr/share/awstats/css/
#Alias /js /usr/share/awstats/js/
<Directory /usr/lib/cgi-bin//>
    DirectoryIndex awstats.pl
    Options ExecCGI
    order deny,allow
    allow from all
    #allow from 127.0.0.1

    AuthName "Authorization Required"
    AuthType Basic

    AuthMYSQL on
    AuthBasicAuthoritative Off
    AuthUserFile /dev/null

    # MySQL server, username, password.
    Auth_MySQL_Host localhost
    Auth_MySQL_User vmail
    Auth_MySQL_Password TJiF1ryjsCjmeQXfCIbLhpUTs2NPaM

    # Database related.
    AuthMySQL_DB vmail
    AuthMySQL_Password_Table admin
    Auth_MySQL_Username_Field username
    Auth_MySQL_Password_Field password

    # Password related.
    AuthMySQL_Empty_Passwords off
    AuthMySQL_Encryption_Types Crypt_MD5
    Auth_MySQL_Authoritative On

    Require valid-user
</Directory>

Iemand een idee? Ik zoek me rottig ...
"you don't need to remember anything if you only tell the truth"

Offline tim_vb

  • Lid
  • Steunpunt: Nee
Re: Na installatie iRedMail server rare apache melding (Auth_MySQL_User)
« Reactie #1 Gepost op: 2009/07/16, 16:02:33 »
Mischien kun je die ' Auth... ' in die file veranderen met de uw user naam van mysql
Want ik denk dat hij dat zoekt
Heb je msql geinstalleerd?

Mvg. Tim

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: Na installatie iRedMail server rare apache melding (Auth_MySQL_User)
« Reactie #2 Gepost op: 2009/07/16, 16:49:10 »
Hier staat:
Auth_MySQL_User vmail

Echter de naam van de DB is ook vmail ??

Klopt dat ??
Bij user moet de gebruikersnaam staan toch ?
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline Riel

  • Lid
    • Rielity
  • Steunpunt: Nee
Re: Na installatie iRedMail server rare apache melding (Auth_MySQL_User)
« Reactie #3 Gepost op: 2009/07/17, 10:41:23 »
Auth_MySQL_Host localhost
    Auth_MySQL_User vmail
    Auth_MySQL_Password TJiF1ryjsCjmeQXfCIbLhpUTs2NPaM

veranderd naar AuthMySQL_Host
etc

schijnt zonder foutmelding te gaan ... ?

Bug in programma iRedMail?
"you don't need to remember anything if you only tell the truth"