Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: pc uitschakelen/bios  (gelezen 9687 keer)

Offline crangirl

  • Lid
  • Steunpunt: Nee
pc uitschakelen/bios
« Gepost op: 2009/07/13, 07:04:52 »
Ik heb intussen veel gelezen over de problemen met uitschakelen van de pc met ubuntu en een oude bios, maar nog steeds lukt het me niet om het op te lossen.

Het gaat om de nieuwste versie van Xubuntu, en om een AMD 1000 MHz processor, met 256 MB geheugen (en dus een oude bios).

Heb gelezen (en ben bezig geweest met) acpi=off, acpi=force, etc. Geen succes. Nog steeds de zin '.. halted' en dan moet ik de pc met de hand uitzetten.

Iemand enig idee?

Offline Daniel Trapman

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #1 Gepost op: 2009/07/13, 08:01:43 »
Je kan kijken in de BIOS of je de optie APIC op disabled kan zetten, anders kan je tijdens de installatie kiezen om de optie "noapic" toe te voegen. Zodra je hebt opgestart van de cd, dan kiezen voor installeer Ubuntu en dan nog niet op enter duwen. Druk op F6 en kies voor noapic. Dan komt er een sterretje te staan. Druk op Escape en dan op enter.

Edit: ik had eroverheen gelezen dat je het over uitschakelen hebt.
« Laatst bewerkt op: 2009/07/13, 08:05:21 door Daniel Trapman »



Offline Daniel Trapman

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #2 Gepost op: 2009/07/13, 08:10:38 »
Wat je zou kunnen proberen om in de Terminal het commando

sudo gedit /boot/grub/menu.lst in te geven. Daarna zoek je deze regel kernel /boot/vmlinuz-2.6.28-13-generic root=UUID=9fda3782-94fa-446d-8820-bbe3fea3de45 ro noapic quiet splash
Zoals je ziet staat er bij mij tussen ro en quiet het woord noapic.

Voeg deze toe en sla het bestand op. En herstart dan de computer.

« Laatst bewerkt op: 2009/07/13, 08:12:11 door Daniel Trapman »



Offline crangirl

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #3 Gepost op: 2009/07/13, 08:31:26 »
acpi=force pci=noacpi had ik toegevoegd aan het einde van de regel, maar werkte dus niet. Dit heb ik nu weggehaald (hoop dat dat ok is).

En heb noapic ertussen gezet, zoals je zei. Straks kijken of het werkt.

Offline crangirl

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #4 Gepost op: 2009/07/13, 09:15:38 »
Werkt niet. Nog steeds system halted... (en gepiep).

Misschien dat er ook nog iets achter die regel moet?

Offline Daniel Trapman

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #5 Gepost op: 2009/07/13, 09:28:32 »
Kan je de menu.lst hier eens plaatsen?

Offline crangirl

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #6 Gepost op: 2009/07/13, 09:33:34 »
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 3

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=b5897ec8-855c-44ef-8205-8c749d66108f ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=b5897ec8-855c-44ef-8205-8c749d66108f

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## specify if running in Xen domU or have grub detect automatically
## update-grub will ignore non-xen kernels when running in domU and vice versa
## e.g. indomU=detect
##      indomU=true
##      indomU=false
# indomU=detect

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title Ubuntu 9.04, kernel 2.6.28-13-generic
uuid b5897ec8-855c-44ef-8205-8c749d66108f
kernel /boot/vmlinuz-2.6.28-13-generic root=UUID=b5897ec8-855c-44ef-8205-8c749d66108f ro quiet splash
initrd /boot/initrd.img-2.6.28-13-generic
quiet

title Ubuntu 9.04, kernel 2.6.28-13-generic (recovery mode)
uuid b5897ec8-855c-44ef-8205-8c749d66108f
kernel /boot/vmlinuz-2.6.28-13-generic root=UUID=b5897ec8-855c-44ef-8205-8c749d66108f ro  single
initrd /boot/initrd.img-2.6.28-13-generic

title Ubuntu 9.04, kernel 2.6.28-11-generic
uuid b5897ec8-855c-44ef-8205-8c749d66108f
kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=b5897ec8-855c-44ef-8205-8c749d66108f ro noapic quiet splash
initrd /boot/initrd.img-2.6.28-11-generic
quiet

title Ubuntu 9.04, kernel 2.6.28-11-generic (recovery mode)
uuid b5897ec8-855c-44ef-8205-8c749d66108f
kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=b5897ec8-855c-44ef-8205-8c749d66108f ro  single
initrd /boot/initrd.img-2.6.28-11-generic

title Ubuntu 9.04, memtest86+
uuid b5897ec8-855c-44ef-8205-8c749d66108f
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST


Ik zie nu dat er 2 keer 'quiet splash' staat, moet ik het bij de 1e of 2e toevoegen, of allebei? Of heb ik het op de verkeerde plek toegevoegd?  :-[

Moderator edit: Code tags gezet.
« Laatst bewerkt op: 2009/07/13, 10:30:42 door ex »

Offline Daniel Trapman

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #7 Gepost op: 2009/07/13, 09:46:25 »
Die quiet splash staat goed. Er zijn 2 kernels geinstalleerd. De bovenste "kernel 2.6.28-13-generic" is met een update meegekomen. Ik zie dat je de optie "noapic" bij "kernel 2.6.28.11-generic hebt neergezet. Deze moet je ook even toevoegen bij de bovenste. Het is geen zekerheid of het helpt. Maar niet geschoten is altijd mis.

Offline crangirl

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #8 Gepost op: 2009/07/13, 10:19:20 »
Nog steeds 'system  halted'... Alleen stond er dit keer ook nog iets bij over IDE services, eerder niet..

Offline Daniel Trapman

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #9 Gepost op: 2009/07/13, 10:25:51 »
Ik heb wat gevonden voor je.

In de terminal

sudo gedit /etc/modules
Voeg dan de volgende regel toe.

apm power_off=1

Offline crangirl

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #10 Gepost op: 2009/07/13, 10:31:10 »
Ik heb het helemaal onderaan (nieuwe regel en erboven een witregel) toegevoegd, is dat ok?

Offline Joshua822

  • Documentatieteam
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #11 Gepost op: 2009/07/13, 10:44:23 »
Mag ik erbij zeggen dat het niet "apic" is maar "acpi" ? Probeer eerst weer achter de kernel "noacpi" te plaatsen in /boot/grub/menu.lst/.

Jouw BIOS heeft volgens mij geen volledige ACPI implementatie als je niet kunt afsluiten. Dat is niet zo erg, je kan ook zonder, maar ACPI is, indien correct geïmplementeerd een zeer goede techniek om makkelijk de kernel energie te laten beheren.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #12 Gepost op: 2009/07/13, 10:49:04 »
Apic is wel degelijk goed hoor: http://en.wikipedia.org/wiki/Apic

ACPI wil je juist niet uitschakelen. Dat is het systeem dat verantwoordelijk is voor o.a. het uitgaan van de computer ;)

Offline crangirl

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #13 Gepost op: 2009/07/13, 10:50:16 »
Ik heb wat gevonden voor je.

In de terminal

sudo gedit /etc/modules
Voeg dan de volgende regel toe.

apm power_off=1
Nog steeds system halted. Wel via cd-rom met F6 gewijzigd, maar betwijfel of dit helpt. Bij installeren ook met F6, maar dan acpi=off, hielp niet. Gelezen over acpi=force, maar dat hielp ook niet.



Offline Daniel Trapman

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #14 Gepost op: 2009/07/13, 11:03:58 »
Mag ik erbij zeggen dat het niet "apic" is maar "acpi" ? Probeer eerst weer achter de kernel "noacpi" te plaatsen in /boot/grub/menu.lst/.

Jouw BIOS heeft volgens mij geen volledige ACPI implementatie als je niet kunt afsluiten. Dat is niet zo erg, je kan ook zonder, maar ACPI is, indien correct geïmplementeerd een zeer goede techniek om makkelijk de kernel energie te laten beheren.


Als ik de optie noapic bij mij niet toevoeg, dan start mijn computer niet op. Dan moet ik hem in het BIOS uitschakelen. Maar dan start Windows niet op. En die heb ik nodig om te gamen

En de optie noapic geeft hij ook weer als je vanaf de cd op f6 drukt
« Laatst bewerkt op: 2009/07/13, 11:06:39 door Daniel Trapman »



Offline crangirl

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #15 Gepost op: 2009/07/13, 12:10:31 »
Pc gaat uit! Ik had het eerder wel goed gedaan, alleen moest ik het 2 keer invoeren ipv 1 keer.
acpi=force pci=noacpi


Hij geeft nu wel ineens een icoon van het diskette station aan?? (Terwijl er niets in zit)...
« Laatst bewerkt op: 2009/07/13, 12:16:25 door crangirl »

Offline Daniel Trapman

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #16 Gepost op: 2009/07/13, 12:18:02 »
Blij dat het gelukt is. Nu je printerprobleem nog.

Waarom hij het diskettestation aangeeft weet ik niet.

Offline AptlyNamed

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #17 Gepost op: 2009/07/16, 00:57:02 »
Uit dat gepiep is trouwens af te leiden waar een moederbord op vastloopt, zg beepcodes (kort kort betekent iets anders dan lang kort etc).

Offline crangirl

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #18 Gepost op: 2009/07/16, 08:34:51 »
Het 'gepiep' was alleen toen de computer niet automatisch afsloot.. (nu niet meer dus).

Offline Metal Henkie

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #19 Gepost op: 2009/07/22, 22:12:39 »
Pc gaat uit! Ik had het eerder wel goed gedaan, alleen moest ik het 2 keer invoeren ipv 1 keer.
acpi=force pci=noacpi

Wil je mij precies vertellen welk commando je nu moet invoeren in de terminal? Ik heb namelijk hetzelfde probleem. Ik krijg de volgende melding: [1137.617669] System halted.

Maar als ik de commando's invoer die hierboven worden vermeld, krijg ik de melding: command not found.
Dus ik heb het vermoeden dat ik niet het juiste commando in de terminal invoer.
Ik heb ingevoerd: sudo gedit /etc/modules apm power_off=1

Offline edwinv

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #20 Gepost op: 2009/07/24, 15:37:03 »
Pc gaat uit! Ik had het eerder wel goed gedaan, alleen moest ik het 2 keer invoeren ipv 1 keer.
acpi=force pci=noacpi

Wil je mij precies vertellen welk commando je nu moet invoeren in de terminal? Ik heb namelijk hetzelfde probleem. Ik krijg de volgende melding: [1137.617669] System halted.

Maar als ik de commando's invoer die hierboven worden vermeld, krijg ik de melding: command not found.
Dus ik heb het vermoeden dat ik niet het juiste commando in de terminal invoer.
Ik heb ingevoerd: sudo gedit /etc/modules apm power_off=1


in terminal intypen :

sudo gedit /etc/modules

dit opent een tekstbestandje

hier plaats je de volgende regel in
apm power_off = 1


bestandje opslaan en computer terug opstarten

zou nu moeten werken

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #21 Gepost op: 2009/07/25, 13:53:08 »
thx! Edwinv, nu sluit mijn comp eindelijk volledig af. Had hier met 8.04 geen last van maar met 9.04 en nu met de alpha van 9.10 wel. Dus nogmaals Dank!

Offline Metal Henkie

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #22 Gepost op: 2009/07/27, 13:52:25 »
in terminal intypen :
sudo gedit /etc/modules

Helaas. Als ik dit intyp krijg ik de volgende melding:

sudo: gedit: command not found

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #23 Gepost op: 2009/07/27, 14:26:15 »
Heb je soms Kubuntu geinstalleerd staan, dan werkt dat niet omdat gedit een onderdeel is van gnome. Ik geloof dat je bij kubuntu gebruik moet maken van kate, maar zeker weet ik niet. Even wachten op onze kubuntu-gebruikers.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: pc uitschakelen/bios
« Reactie #24 Gepost op: 2009/07/27, 14:30:21 »
klopt KDE gebruikt Kate
thx voor de bevestiging Arie, wist wel dat Kate gebruikt word maar wist niet zeker of dat onder sudo hetzelfde is.
Wel met kleine letters zeker?, dus: kate