Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] NVIDIA werkt, helaas, niet mee  (gelezen 2293 keer)

Mook

  • Gast
[OPGELOST] NVIDIA werkt, helaas, niet mee
« Gepost op: 2009/07/11, 16:11:39 »
Goedendag!

Na lange tijd met dit probleem te zitten, heb ik toch maar een account aangemaakt in de hoop dat de oplossing zo dichterbij komt. Ik ben nu al zo´n 2 jaar op dit forum en op het internet aan het zoeken naar een oplossing. Elke computer is anders, zodoende ben ik nog geen (werkende) oplossing tegen gekomen. Ik hoop dat jullie mij kunnen helpen.

Mijn computer is een vrij oude Acer Aspire. Het is een AMD Athlon 2600+ met een NVIDA chipset, de grafische chip is een GeForce4 MX.
Ik heb het idee dat de hele hardware-matige configuratie van mijn pc zo gebouwd is dat het probleem wat ik ondervind niet op te lossen is.

Het probleem is dat de resolutie die ik instel niet bewaard blijft, dus elke keer dat ik de computer opstart moet ik de resolutie weer goed zetten.
Ik heb een nieuwe installatie gedaan van Ubuntu 9.04, bij het opstarten was de resolutie 640 bij 480 en het xorg.conf bestand was helemaal leeg. Ik vind dat toch een vrij ouderwetse resolutie, dus besloot ik via ¨Hardwarestuurprogamma´s¨ (restricted drivers) de NVIDIA progammatuur te installeren  ;)
Na het opstarten was de resolutie ongeveer 320 bij 240. Via een onhandige manier weet ik het te presteren om via ¨NVIDIA X Server Settings¨ de resolutie op 1280 bij 1024 te zetten.
In het xorg.conf bestand staat momenteel dit (dus na het installeren van de NVIDIA driver): Section "Screen"
Identifier "Default Screen"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Default Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection
Dit is veel te weinig informatie. In tegenstelling tot wat ik bij NVIDIA X Server Settings te zien krijg, hier word de hardware en de monitor herkend en staan de instellingen goed. Ik weet niet of het relevant is, maar mijn monitor is een Philips 107S CRT.

Wanneer ik in de terminal sudo nvidia-settings type, krijg ik in de terminal de foutmelding VALIDATION ERROR:  Data incomplete in file /etc/X11/xorg.conf.
Undefined Device "(null)" referenced by Screen "Default Screen".

Segmentatiefout
NVIDIA X Server Settings start wel gewoon op.

Als ik in ¨NVIDIA X Server Settings¨ de resolutie wijzig en toegepast heb, klik ik op ¨Save to X Configuration File¨. Vervolgens krijg ik de foutmelding: ¨Failed to parse existing X config file '/etc/X11/xorg.conf'!¨.
Als ik dan de computer opstart ben ik natuurlijk weer bij het begin.

Zo, dat was het ;) Ik bedenk me nu dat het misschien een oplossing is om xorg.conf helemaal handmatig te schrijven, maar ik weet niet hoe dit werkt en of het een juiste oplossing is.
Ik heb al heel heel veel geprobeerd, maar ik hoop dat jullie andere oplossingen kunnen voorstellen. Ik denk dat het probleem zelf niet zo complex is, misschien de oplossing ook niet. Maar om de oplossing te vinden in ieder geval wel ;)
Ik zal niet dreigen dat ik moet overstappen naar Windows als het niet lukt, maar als ik in september weer serieus op m´n pc aan het werk moet..  :rolleyes: Maar, jullie weten vast wel een geniale oplossing. Ik wacht het af!

UPDATE: Ik ben ook tevreden als ik de resolutie 1280 bij 1024 kan houden zonder daarbij de NVIDIA driver te gebruiken, ik hoef niet perse 3D ondersteuning te hebben of Compiz te gebruiken. Maar als het wel kan, is dat het mooist!
« Laatst bewerkt op: 2009/07/12, 14:12:26 door Mook »

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: NVIDIA werkt, helaas, niet mee
« Reactie #1 Gepost op: 2009/07/11, 17:28:20 »
Blijvende instellingen. Alt F2 >   Of Terminalvenster 
gksudo nvidia-settings

GrJ

Mook

  • Gast
Re: NVIDIA werkt, helaas, niet mee
« Reactie #2 Gepost op: 2009/07/11, 17:35:21 »
Dat werkt ook niet, bij het opslaan krijg ik nog steeds dezelfde foutmelding.
Is het mogelijk om NVIDIA X Server Settings te bewerken met de X server uitgeschakeld?
« Laatst bewerkt op: 2009/07/11, 17:38:58 door Mook »

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: NVIDIA werkt, helaas, niet mee
« Reactie #3 Gepost op: 2009/07/11, 17:43:35 »
Je hebt wat meer mogelijkheden om alles goed in te stellen qua beeld, wanneer je Ubuntu 8.04 LTS pakt. Probeer die eens?
http://sites.google.com/site/computertip/geenbeeld
(punt 2)

Ubuntu 8.04 kun je gewoon binnenhalen via de webstek van Ubuntu:
http://www.ubuntulinux.org/getubuntu/download

Branden:
http://sites.google.com/site/computertip/cdbranden

Mook

  • Gast
Re: NVIDIA werkt, helaas, niet mee
« Reactie #4 Gepost op: 2009/07/11, 17:58:26 »
Dat heb ik ook al geprobeerd, maar daar liep ik ook tegen problemen aan waardoor het niet werkte. Daarbij wil ik graag de nieuwste versie van Ubuntu gebruiken.

Bedankt voor de snelle reacties tot nu toe.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: NVIDIA werkt, helaas, niet mee
« Reactie #5 Gepost op: 2009/07/11, 18:03:39 »
Toch denk ik dat het in 8.04 gaat lukken, als je het aanpakt zoals ik heb geadviseerd....

En wat de nieuwste versie betreft: een LTS-versie is van de hoogste kwaliteit, dus eigenlijk sowieso een betere keuze dan 9.04:
http://sites.google.com/site/computertip/versiekeuze
(punt 4)

Mijn werkcomputers gaan beslist niet naar 9.04, die blijven onverstoorbaar doordieselen op 8.04 LTS. Pas medio volgend jaar zet ik die over op de nieuwe LTS, 10.04. Als die een paar maanden oud is (en dus ontdaan van de beginfouten).  :-)

Offline lighthead

  • Lid
  • Steunpunt: Nee
Re: NVIDIA werkt, helaas, niet mee
« Reactie #6 Gepost op: 2009/07/11, 18:04:34 »
@ Mook,

in een ander topic zag ik de volgende tip van MrGee:

typ in terminalvenster: gksudo displayconfig-gtk
dan opent zich een ander venster:

Citaat
Dus klik op op het model balkje, achter Model:. Kies dan via; fabrikant, algemeen een LCD (of CRT)
model met de door jouw gewenste resolutie. ( Of neem het exacte model via fabrikant.)
Daarna zou je meerdere resolutie keuze mogelijkheden moeten hebben, neem de gewenste
sla de zaak op; herstart de machine of herstart de X-server.

Verkeerd gedecteerde displays leveren wel vaker dit soort problemen op en hebben niet noodzakelijkerwijs
te maken met een verkeerd toegepaste/gekozen driver.

Groeten Gerrit

heel misschien, als dit niet helpt kun je in een ander topic van mij kijken of daar voor jou de oplossing ligt.
Voor mij is er nog geen oplossing van vrijwel dezelfde problemen. ik heb 8.04 LTS er weer opgezet, maar ook dat geeft geen soelaas.
ik wacht tot okotber tot 9.10 uitkomt, in de hoop....

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: NVIDIA werkt, helaas, niet mee
« Reactie #7 Gepost op: 2009/07/11, 18:06:49 »
@ lighthead: gksudo displayconfig-gtk gaat dus niet lukken in 9.04, want dat kan alleen in 8.04. Mede daarom raad ik 8.04 aan.  :-)

Offline lighthead

  • Lid
  • Steunpunt: Nee
Re: NVIDIA werkt, helaas, niet mee
« Reactie #8 Gepost op: 2009/07/11, 18:21:42 »
@ Pjotr,

ja, ik las het net op jouw site.

ga nu de door jou aangeggeven stappen proberen om  mijn drivers aan het werk te zetten.

Mook

  • Gast
Re: NVIDIA werkt, helaas, niet mee
« Reactie #9 Gepost op: 2009/07/11, 19:10:32 »
@ Pjotr: Die site heb ik heb ik inderdaad met 8.04 al meerdere keren bezocht, zonder resultaat. Maar ik zie wel dat 8.04 misschien beter gaat werken. Voor nu blijf ik het nog even met 9.04 proberen. Wie weet ;)

@ lighthead: Jou problemen met NVIDIA heb ik gevolgd, maar ook voor mij gaf dit geen oplossing. Succes :)

@ Arie: Met 8.04 heb ik ook niks kunnen bereiken.

Nogmaals de bedankt voor de reacties. Om nu de kracht van de community te ervaren is best kicken  =D

Is het geen optie om ¨gewoon¨ een regel aan het xorg.conf bestand toe te voegen, zodat ik de resolutie kan behouden?
« Laatst bewerkt op: 2009/07/11, 19:17:01 door Mook »

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: NVIDIA werkt, helaas, niet mee
« Reactie #10 Gepost op: 2009/07/11, 20:02:17 »
Ik vermoed, dat het in jouw geval niet aan het stuurprogramma ligt, maar aan de herkenning (of liever gezegd: niet-herkenning) van die ouwe Philips CRT-monitor.

Met gksudo displayconfig-gtk kun je handmatig die monitor selecteren. Klik dan bij "Model" op "Plug 'n' Play", om dat laatste handmatig te zetten op je monitormodel. De Philips 107S staat in de lijst die dan tevoorschijn komt (ik heb het net even gecontroleerd op mijn werkcomputer, die op 8.04 loopt).

Terzijde: als je de aanhalingsteken-toets indrukt, die weer loslaat en daarna op de spatiebalk drukt, krijg je een normaal aanhalingsteken: ". Wat jij nu waarschijnlijk doet is twee keer drukken op de aanhalingsteken-toets, en dan krijg je twee hoge puntjes: ¨. Dat is vermoedelijk niet je bedoeling.... :-)
« Laatst bewerkt op: 2009/07/11, 20:15:54 door Pjotr »

Mook

  • Gast
Re: NVIDIA werkt, helaas, niet mee
« Reactie #11 Gepost op: 2009/07/11, 20:46:49 »
Ik heb laatst wat gelezen over een monitor die ook voor problemen zorgde. Ik zou hier zelf niet zo snel aan denken. Ik ga het proberen met deze niewe insteek, bedankt!

Dat van die haakjes had ik zelf ook al opgemerkt ja. Maar nu je het zo zegt, zie ik inderdaad hoe het werkt ;)

Offline dick123

  • Lid
    • http://www.akker-huis.nl
  • Steunpunt: Nee
Re: NVIDIA werkt, helaas, niet mee
« Reactie #12 Gepost op: 2009/07/12, 12:08:33 »
Goedendag!

Na lange tijd met dit probleem te zitten, heb ik toch maar een account aangemaakt in de hoop dat de oplossing zo dichterbij komt. Ik ben nu al zo´n 2 jaar op dit forum en op het internet aan het zoeken naar een oplossing. Elke computer is anders, zodoende ben ik nog geen (werkende) oplossing tegen gekomen. Ik hoop dat jullie mij kunnen helpen.

Mijn computer is een vrij oude Acer Aspire. Het is een AMD Athlon 2600+ met een NVIDA chipset, de grafische chip is een GeForce4 MX.
Ik heb het idee dat de hele hardware-matige configuratie van mijn pc zo gebouwd is dat het probleem wat ik ondervind niet op te lossen is.

Het probleem is dat de resolutie die ik instel niet bewaard blijft, dus elke keer dat ik de computer opstart moet ik de resolutie weer goed zetten.
Ik heb een nieuwe installatie gedaan van Ubuntu 9.04, bij het opstarten was de resolutie 640 bij 480 en het xorg.conf bestand was helemaal leeg. Ik vind dat toch een vrij ouderwetse resolutie, dus besloot ik via ¨Hardwarestuurprogamma´s¨ (restricted drivers) de NVIDIA progammatuur te installeren  ;)
Na het opstarten was de resolutie ongeveer 320 bij 240. Via een onhandige manier weet ik het te presteren om via ¨NVIDIA X Server Settings¨ de resolutie op 1280 bij 1024 te zetten.
In het xorg.conf bestand staat momenteel dit (dus na het installeren van de NVIDIA driver): Section "Screen"
Identifier "Default Screen"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Default Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection
Dit is veel te weinig informatie. In tegenstelling tot wat ik bij NVIDIA X Server Settings te zien krijg, hier word de hardware en de monitor herkend en staan de instellingen goed. Ik weet niet of het relevant is, maar mijn monitor is een Philips 107S CRT.

Wanneer ik in de terminal sudo nvidia-settings type, krijg ik in de terminal de foutmelding VALIDATION ERROR:  Data incomplete in file /etc/X11/xorg.conf.
Undefined Device "(null)" referenced by Screen "Default Screen".

Segmentatiefout
NVIDIA X Server Settings start wel gewoon op.

Als ik in ¨NVIDIA X Server Settings¨ de resolutie wijzig en toegepast heb, klik ik op ¨Save to X Configuration File¨. Vervolgens krijg ik de foutmelding: ¨Failed to parse existing X config file '/etc/X11/xorg.conf'!¨.
Als ik dan de computer opstart ben ik natuurlijk weer bij het begin.

Zo, dat was het ;) Ik bedenk me nu dat het misschien een oplossing is om xorg.conf helemaal handmatig te schrijven, maar ik weet niet hoe dit werkt en of het een juiste oplossing is.
Ik heb al heel heel veel geprobeerd, maar ik hoop dat jullie andere oplossingen kunnen voorstellen. Ik denk dat het probleem zelf niet zo complex is, misschien de oplossing ook niet. Maar om de oplossing te vinden in ieder geval wel ;)
Ik zal niet dreigen dat ik moet overstappen naar Windows als het niet lukt, maar als ik in september weer serieus op m´n pc aan het werk moet..  :rolleyes: Maar, jullie weten vast wel een geniale oplossing. Ik wacht het af!

UPDATE: Ik ben ook tevreden als ik de resolutie 1280 bij 1024 kan houden zonder daarbij de NVIDIA driver te gebruiken, ik hoef niet perse 3D ondersteuning te hebben of Compiz te gebruiken. Maar als het wel kan, is dat het mooist!

Ik had hetzelfde probleem en heb het opgelost door de volgende regel toe te voegen aan het bestand xorg.conf:

   Option  "metamodes" "1920x1200_60 +0+0; nvidia-auto-select +0+0"


Opdrachtregel: sudo gedit /etc/X11/xorg.conf
regel toevoegen en opslaan

Succes

Mook

  • Gast
Re: NVIDIA werkt, helaas, niet mee
« Reactie #13 Gepost op: 2009/07/12, 14:11:06 »
@ dick123: Ongelofelijk, het werkt gewoon! Eindelijk het probleem opgelost!

Bedankt iedereen voor de bijdrage(s)!