Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu start niet op na RAID instelling  (gelezen 452 keer)

Offline significant

  • Lid
  • Steunpunt: Nee
Ubuntu start niet op na RAID instelling
« Gepost op: 2009/07/08, 14:35:06 »
Hallo!

Wil hier thuis een server klussen, maar het is mijn eerste self-build project. Ofwel nada ervaring en een hoop leren. Gisteren had ik succesvol ubuntu aan de praat en kon ik lekker sudo-en etc.
Echter, mijn systeem bestaat uit drie HDD's. Twee 1Tb-ers en eentje van .5Tb. Eerste twee genoemde wil ik graag in RAID1 (mirroring hebben) via de hardwarematige raid controller. Gisteravond had ik dit pas aan het werk gekregen.
Nu vanochtend werkte mijn ubuntu niet meer, wat ik opzich wel begrijpelijk vond. De installatie CD erin gestopt (ubuntu server 32bit) en opnieuw gedraaid. De set-up geeft keurig aan van wil je raid gebruiken, wat ik bevestig.

Nu echter, krijg ik helemaal geen ubuntu meer, na het opstarten blijft hij hangen op een zwart scherm met een witte underscore. Hoogstwaarschijnlijk heb ik iets met partitioneren niet goed gedaan, want daar snap ik niks van. Ook op het grote WWW kon ik niet echt wijs in hoe dat correct in te stellen.

Ik wil de 500Gb-er gebruiken voor de OS, webmail, ftp en al het overige. De raid dient strict en alleen voor dataopslag. Dit moet ik ook via mijn windows network kunnen accessen.

Wie kan mij vertellen hoe de formattering correct intestellen voor bovenstaande situatie?

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Re: Ubuntu start niet op na RAID instelling
« Reactie #1 Gepost op: 2009/07/08, 21:11:12 »
In principe zou je van een RAID-1 configuratie zonder problemen moeten kunnen starten. Heb je echt "alleen" de hardware RAID gebruikt, m.a.w. de installer bood maar 1 device (weet niet hoe die dan gaat heten) aan van 1Tb? Als dat zo is, dan maak je op dat device in principe je partities aan. Zou je namelijk NIET de hardware RAID gebruiken, maar software RAID, dan moet je zelf de partities voor RAID aanmaken, die "verzamelen" in RAID devices en daar dan pas weer de "normale" (ext3 of ext4) partities in zetten.

Mocht ook dat niet willen booten, dan zou je es kunnen proberen om op elk van de 2 Tb schijven een /boot (ext3 of ext4) aan te maken, tenminste, op de 1e heet-ie gewoon /boot en op de 2e bijv. /boot_2 en nadat alles werkt kopieer de inhoud van /boot naar /boot_2. Vergeet niet om BEIDE partities als "bootable" aan te merken.
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl