Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost] xserver start niet meer op, Radeon driver wordt niet goed geladen  (gelezen 726 keer)

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
Hallo allemaal,

Van de week heb ik de nieuwe fglrx drivers geinstalleerd op Jaunty, normaal heb ik die nodig. Maar wat blijkt, fglrx wordt niet meer ondersteund voor mijn kaart. Stom genoeg heb ik over alle waarschuwingen heen gekeken...  :'(

Nu heb ik direct alle pakketten verwijderd vanuit de recovery mode maar het blijft fout gaan, de xserver wil gewoon niet meer opstarten. Ik krijg slechts een paar vage lijnen.
In de bijlage heb ik de xorg.0.log toegevoegd, ik maak me daarbij zorgen om deze lijn:
(EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM
[dri] Disabling DRI.

Ook wordt er nog steeds iets van fglrx geladen als je kijkt naar deze lijn:
(II) Loading sub module "fglrxdrm"
(II) LoadModule: "fglrxdrm"
(II) Loading /usr/lib/xorg/modules/linux//libfglrxdrm.so
(II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
compiled for 1.4.99.906, module version = 8.62.4

Heeft iemand een idee hoe ik weer terug kan komen in mijn nieuw geinstalleerde Jaunty?  :rolleyes:

Ps. het gaat om een ati radeon mobility x1300
« Laatst bewerkt op: 2009/06/29, 19:38:47 door raggar »

Offline Dooitze de Jong

  • Lid
    • dooitze
    • Dooitze de Jong
  • Steunpunt: Nee
Re: xserver start niet meer op, Radeon driver wordt niet goed geladen
« Reactie #1 Gepost op: 2009/06/29, 15:21:35 »
Probeer in "Recovery Mode" xfix eens

of

Live CD (k)ubby >> Alt+F2 >> gksu nautilus/dolphin >> Bestandssysteem >> Etc >> X11 >> xorg.conf kopieeren naar:

Vaste HDD >> etc >> X11 >> xorg.conf plakken en vervangen

Als het niet lukt meld het maar even
Linux User : 491909
Ubuntu User: 2928
Word geen 100 % Offtopic-spammer, maar help ook eens anderen!
[size=10]Soms plaats ik berichten met mijn pda, dus er kunnen spellingsfouten in zitten[/size]

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
Re: xserver start niet meer op, Radeon driver wordt niet goed geladen
« Reactie #2 Gepost op: 2009/06/29, 15:32:54 »
Hoi Dooitze de Jong, bedankt voor je antwoord. De fix mogelijkheid in de recoverymode had ik al uitgeprobeerd maar haalt niets uit, helaas. En xorg.conf veranderen ook niet.

Verder heb ik geprobeerd:
sudo dpkg-reconfigure -phigh xserver-xorg
alles verwijderen met modprobe -r
alles verwijderen met apt-get --probe remove

Ik ben even zonder idee├źn...  :'(

Zo ie zo valt me op dat xorg.conf zeer minimaal is, heeft dit te maken met het nieuwe bulletproof-x?
Mijn xorg.conf op 9.04 is:

Section "Device"
   Identifier   "Configured Video Device"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
EndSection

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
Re: xserver start niet meer op, Radeon driver wordt niet goed geladen
« Reactie #3 Gepost op: 2009/06/29, 16:54:00 »
Ik ben eruit  :D

Ik had de drivers geïnstalleerd met het standaard script dat ati erbij levert, een automatische install dus. Ik probeerde slechts pakketten te verwijderen die wel bestonden maar niet volledig waren.

Wat ik heb gedaan is in /usr/share/ati het script fglrx-uninstall.sh uitgevoerd als root en dan komt alles weer mooi op zijn plek terecht. Gewoon stom van mij  ;)

Dooitze de Jong, in ieder geval hartelijk dank voor de hulp  :)