Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Bestandsbehherdersvraag  (gelezen 645 keer)

Offline Peter Schallenberg

  • Lid
    • http://www.quup.nl
  • Steunpunt: Nee
Bestandsbehherdersvraag
« Gepost op: 2009/06/22, 10:20:50 »
Als ik in een map files wil selecteren kun je met de ctrl toets meerdere losse files selecteren, en met de shift toets een aaneengeloten rijtje. Als die map nu submappen heeft die ingeklapt zijn, dan selecteer ik de ene keer met de shift een rijtje files, en de andere keer klapt de bestandsbeheerder de bovenliggende map open.
Hoe stel ik nou in dat de shift *alleen* gebruikt kan worden voor het selecteren van een rijtje aangesloten files?
En ik begrijp niet waarom die dat nou niet altijd doet.
Ik heb al zitten zoeken in de voorkeuren, sneltoetsen.
Met de muis zitten schuiven. (misschien dat het afhankelijk van de kolom is waar de cursor instaat?)

alvast dank,
groeten,
Peter
Gemiddeld leeft een mens 28000 dagen.
Eigenlijk ook maar weinig...

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Bestandsbehherdersvraag
« Reactie #1 Gepost op: 2009/06/22, 16:02:35 »
Het gele selectie balkje is altijd aanwezig, dit beweeg ik omhoog of omlaag met de pijltjes toetsen omhoog/naar beneden. Dan met SHIFT ingedrukt selecteer ik de laatste map, de rest er tussen in wordt dan ook geselecteerd. Of ik selecteer een map met de CTRL+linkermuisknop, vervolgens laat ik deze los en selecteer met de SHIFT+linker muisknop de laatste map in de rij. Is dit wat je bedoelt?
In der Beschränkung zeigt sich der Meister.

Offline Peter Schallenberg

  • Lid
    • http://www.quup.nl
  • Steunpunt: Nee
Re: Bestandsbeheerdersvraag
« Reactie #2 Gepost op: 2009/06/22, 17:12:07 »
Dag Gijsbert,

Je kunt het zelf testen.
Maak een map ( bijvoorbeeld /user/test/) aan en zet in die map een serie files.
Maak in die map 1 submap. ( /user/test/nogeentest/ )
Zet daar ook files in.

Als je nu in map /user/test een serie files wil selecteren met behulp van de shift zie je dat het driehoekje bij de submap /user/test/nogeentest/ zwart wordt.
Als je nu klikt om de selectie te bevestigen klapt de submap open ipv de actie voor de selectie.

Hij deed het niet de eerste keer bij mij.
Even dacht ik dat er verschil zat tussen Intrepid, waar ik nu op test, en Jaunty, waar ik het bemerkte.
Maar als je 1maal een keer het driehoekje hebt aangeklikt om de submap te openen, zal deze daarna op ctrl en shift reageren.

Voorts lijkt dit alleen te gebeuren als er maar 1 submap is.
In directories met meerdere submappen heb ik dit gedrag nog niet waargenomen.

lijkt dit een bug of is het een geactiveerde instelling?

groeten,
Peter


Gemiddeld leeft een mens 28000 dagen.
Eigenlijk ook maar weinig...

Offline Floris

  • Lid
  • Steunpunt: Nee
Re: Bestandsbehherdersvraag
« Reactie #3 Gepost op: 2009/06/22, 17:45:42 »
Ik neem aan dat je in de Tree View werkt?

Ik heb even gedaan wat je omschreef.  In het geval dat er maar één submap is zie ik het zwarte driehoekje alleen als ik de cursor op de driehoek plaats, en dan kan ik in de submap selecteren; als ik op de naam van de map klik bijvoorbeeld, dan wordt meteen de hele submap geselecteerd.  Het in- en uitklappen gebeurt dus alleen als je op het driehoekje klikt; dat lijkt mij het gewenste gedrag.

Ik merkte wel dat er in een map met meerdere submappen een – reeds bekende – bug optreedt: bug #373415.
Als je vraag beantwoord is, wees dan zo vriendelijk om de titel van je eerste post met "[OPGELOST]" te beginnen (klik op verander).

Offline eXtreem

  • Lid
  • Steunpunt: Nee
Re: Bestandsbehherdersvraag
« Reactie #4 Gepost op: 2009/06/22, 17:49:21 »
Ik heb het probleem kunnen reproduceren...

Het was best nog wel lastig om de fout te reproduceren, aangezien dit mij alleen voordoet wanneer ik de muis niet beweeg. Dus eerst de muis op de goeie plek zetten, dan de shift indrukken en klikken zonder de muis te verplaatsen. Ook 2 x de shift indrukken lijkt om dit probleem heen te werken. Ik kan niet zeggen of dit nu een bug of een feature is.

Probeer het eens op deze volgorde:

Klik het eerste bestand aan, druk de shift in en beweeg de muis naar de volgende file toe en klik. Direct bij het bewegen wordt het driehoekje weer "normaal" (bij mij in elk geval).
http://ubuntu.zurf.nl    (password ubuntu)
:wq

Offline Peter Schallenberg

  • Lid
    • http://www.quup.nl
  • Steunpunt: Nee
Re: Bestandsbehherdersvraag
« Reactie #5 Gepost op: 2009/06/22, 23:29:03 »
@ Floris,
bug 373415 lijkt inderdaad op dit probleem.
Ik zit in de treeview.

@ eXtreem,
de shift ingedrukt houden bij het verslepen van de muis lijkt te werken, en ook 2 maal de shift indrukken.

Bij mij is het mis op het moment als ik selecteer met de shift, shift loslaat, de muis verplaats en dan weer shift.
Maar ook weer niet altijd.
Ik zie het driehoekje ook aan en uit knipperen bij sommige acties.

Het is volgens mij een bug en geen feature.

inderdaad vervelend.
Sommige handelingen zitten meer in je vingers dan in je hoofd.
Leer ze maar eens af!
dat valt niet mee!

groeten,
Peter
Gemiddeld leeft een mens 28000 dagen.
Eigenlijk ook maar weinig...