Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: (Opgelost!) Geen automatisch internetverbinding na opstarten  (gelezen 3993 keer)

Offline leonux

  • Lid
  • Steunpunt: Nee
(Opgelost!) Geen automatisch internetverbinding na opstarten
« Gepost op: 2009/06/15, 10:14:26 »
Sinds ik 9.04 heb geïnstalleerd wordt er niet meer automatisch verbinding gemaakt met internet. Voorheen in 8.10 was dat geen probleem.

Na installatie heb ik keurig de internetverbinding geconfigureerd mbv. 'sudo pppoeconf' en daarbij aangegeven dat er na het booten automatisch verbinding wordt gemaakt, maar om een of andere reden gebeurd dit niet.
Nu dien ik steeds in de terminal het commando 'sudo pon dsl-provider' te geven (+ wachtwoord) om de verbinding tot stand te brengen. Is dit een 9.04-bug of speelt er iets anders?

Groet,
leonux
« Laatst bewerkt op: 2009/06/22, 10:20:32 door leonux »
Zin en eenvoud!

Offline lizardman

  • Lid
  • Steunpunt: Nee
Re: Geen automatisch internetverbinding na opstarten
« Reactie #1 Gepost op: 2009/06/15, 21:51:20 »
Je zou eens kunnen rondkijken op launchpad of er een bugmeling over is: https://bugs.launchpad.net/ubuntu/+source/network-manager

Als er nog geen bugmelding over is dan kun je er zelf een maken. Wel eerst even een account aanmaken als je die nog niet hebt.  ;-)
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Offline ivo

  • Lid
  • Steunpunt: Nee
Re: Geen automatisch internetverbinding na opstarten
« Reactie #2 Gepost op: 2009/06/15, 22:13:38 »
1) Plaats een bug rapport.
2) Plaats de uit te voeren opdrachtregel in /etc/rc.local. Dit bestand wordt bij elke opstart uitgevoerd.

There are only 10 types of people in the world; those who understand binary and those who don't.

Offline leonux

  • Lid
  • Steunpunt: Nee
Re: Geen automatisch internetverbinding na opstarten
« Reactie #3 Gepost op: 2009/06/16, 10:29:21 »
Citaat
1) Plaats een bug rapport.
2) Plaats de uit te voeren opdrachtregel in /etc/rc.local. Dit bestand wordt bij elke opstart uitgevoerd.

Bedankt!
Hiermee lijkt mijn probleem opgelost te zijn. Ik kijk het nog even een paar dagen aan voor ik het als opgelost geschouw.
Toch vreemd dat dit gebeurd.

Waar moet ik overigens mijn bug rapport plaatsen? En hoe sluit je een topic af als 'opgelost'?
Zin en eenvoud!

Offline lizardman

  • Lid
  • Steunpunt: Nee
Re: Geen automatisch internetverbinding na opstarten
« Reactie #4 Gepost op: 2009/06/16, 11:11:44 »
Op de link die ik gaf zit een knop "report bug".

Opgelost voor je topictitel zetten doe je doormiddel van je eerste bericht in de draad te bewerken.
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Offline jannes

  • Lid
  • Steunpunt: Nee
Re: Geen automatisch internetverbinding na opstarten
« Reactie #5 Gepost op: 2009/06/16, 14:06:48 »
kheb dat ook, kan iemand alle 'sudo' en blabla geven om dit op te lossen...

thx

Offline leonux

  • Lid
  • Steunpunt: Nee
Re: Geen automatisch internetverbinding na opstarten
« Reactie #6 Gepost op: 2009/06/17, 07:44:31 »
Citaat
1) Plaats een bug rapport.
2) Plaats de uit te voeren opdrachtregel in /etc/rc.local. Dit bestand wordt bij elke opstart uitgevoerd.

Dit werkte bij mij prima (met dank aan lizardman). Om rc.local aan te passen heb ik de '/etc'-map geopend als root (even rechtsklikken in map '/etc' en kiezen voor openen als root) en de opdracht 'pon dsl-provider' (uiteraard zonder de ' ') toegevoegd aan rc.local.

Even gechecked of er al een bugreport was op launchpad en toen vond ik het volgende bericht:
Citaat
Can't connect to Internet (Jaunty with DSL)

Rather than upgrade my 8.04 installation (upgraded from 7.10), I installed Jaunty 9.04 via a clean reformat. Upon installation, I ran "sudo pppoeconf" to get online using my wired DSL connection. I even installed WINE. Everything seemed fine.

When I rebooted, I could not get online. I've re-run pppoeconf numerous times since then (accepted all defaults), which ran normally, but no connection when finished. I've tried "pon dsl-provider" (with and without sudo), which likewise results in no connection.

I right-clicked the "Network Connections" icon (upper right of toolbar) and added my info on the DSL tab, but it says "never" after the connection name on the menu, which I assume is the status, but I can't figure out how to change it. (BTW: If I check "All users", everything I typed is forgotten and I must re-enter the info all over again.)

I've tried entering my IP's DNS server numbers in the IPv4 section, which had no effect.

"ifconfig eth0" doesn't give me much useful info, and I can't ping anything from the Networking app. Nor can I install "Wicked" (WICD) from the Synaptic Package Manager (as suggested by an earlier question here) because it wants to download it from the Net.

Help. I'm stumped. Short of reinstalling 9 (or even going back to 8.10), does anyone have any idea of how to get back online? (typing this from XP on same computer).

Setup:
Jaunty v9.04 64bit dualbooting with XP and Win7
wired DSL connection.
Phenom II 920 processor and 2GB ram.
Mugsy323 said on 2009-05-11:

I was able to get my DSL connection working only after reinstalling Jaunty and doing the following:

*******************
Notes:
1) The word "never" that appeared after your connection describes "the last time you were connected". When you are connected, it will change to "Now".)

2) Jaunty now uses the "Network Connections" app to manage your network connections (presumably, you can now have more than one), so if you used "pppoeconf", you've already doomed yourself. Before you go through the pain of reinstalling, try deleting the config file pppoeconf creates before going through the extreme step of reinstalling Ubu9 from scratch. Then set up your DSL the "proper" way via the NC app (on the toolbar). If that works, let us know.
********************

Upon reinstalling Ubu, right-click the "Network Connection" icon and "Edit connection". Click the DSL tab and enter your username and password (I don't know if it matters, but I entered my ISP's .com name on the "Service" line.) Check "Connect automatically" and change the name of the connection to something you'll recognize. Close the app.

Left-click the "Network Connection" icon and the name you gave your connection should be listed. Click it to get online. The icon should change to show two rotating arrows while it tries to connect. Once it does, the icon will change to the standard small "double monitor" connection icon you're familiar with.

I'm typing this from memory, so let me know if I've forgotten/missed anything.

Heb het zelf nog niet geprobeerd, maar wellicht werkt dit ook. Ik hoor het wel.
Zin en eenvoud!

Offline jannes

  • Lid
  • Steunpunt: Nee
Re: Geen automatisch internetverbinding na opstarten
« Reactie #7 Gepost op: 2009/06/17, 11:08:03 »
Probleem nog niet opgelost...

Heb dat gedaan wat u zei.
Herstart en nu moet ik nog altijd eerst wachtwoord geven voordat ubuntu connect met wireless.

En wat door invoeging van uw term is gekomen = nu moet ik zelfs draadloos netwerkt na invoering van het wachtwoord aanduiden...


#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

exit 0
pon dsl-provider

dit staat er in dat rc.local
« Laatst bewerkt op: 2009/06/17, 11:10:07 door jannes »

Offline leonux

  • Lid
  • Steunpunt: Nee
Re: Geen automatisch internetverbinding na opstarten
« Reactie #8 Gepost op: 2009/06/17, 13:02:03 »
Citaat
# Make sure that the script will "exit 0" on success or any other
# value on error.

Betekent dit niet dat het commando "pon dsl-provider" vóór deze zin in het script van rc.local moet staan? Ik ben absolúút geen expert, maar zelf heb ik het wèl zo gedaan en bij mij werkt het prima! Hoef ook geen wachtwoord in te geven. Mijn verbinding loopt trouwens wel via een draad.

Is het misschien dat, omdat het commando bij u achteraan staat, het systeem het ziet als een 'sudo-commando'? Voor de uitvoer daarvan wordt namelijk altijd een wachtwoord gevraagd.
« Laatst bewerkt op: 2009/06/17, 13:04:19 door leonux »
Zin en eenvoud!

Offline jannes

  • Lid
  • Steunpunt: Nee
Re: Geen automatisch internetverbinding na opstarten
« Reactie #9 Gepost op: 2009/06/17, 14:05:00 »
nu staat het voor exit en me pc vraagt nog steeds wachtwoord na booten :)

Offline jannes

  • Lid
  • Steunpunt: Nee
Re: Geen automatisch internetverbinding na opstarten
« Reactie #10 Gepost op: 2009/06/19, 07:40:27 »
Probleem opgelost...

Wat heb ik gedaan:

op draadloze verbinding in de balk bovenin heb ik rechtermuis geklikt...
verbindingen bewerken
menu draadloos aanklikken
de verbinding die daar staat (je eigen verbinding dus bij mij bv Jannes Van Lombergen wireless network) aanklikken en rechts edit duwen.
dan daar onderaan 'avaible to all users' aanvinken.
PW ingeven en aanklikken dat hij dit moet doen voor iedereen.

het werkt...