Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost]Geluid werkt niet HDA ATI SB Sound Card model: SBx00 Azalia onder 9.04  (gelezen 1550 keer)

Offline janvdwerke

  • Lid
    • Oldemarktse Computerclub
  • Steunpunt: Nee
In de vorige versie 8.10 ben ik een tijdje bezig geweest om het geluid op mijn laptop aan de praat te krijgen. Ik kreeg toen prima hulp op dit forum en wilde de toen geboden oplossing uitvoeren door een aantal regels toe te voegen in de alsa database die ik kon opvragen in het terminalvenster door: cat /etc/modprobe.d/alsa-base in te toetsen. Nu wordt gemeld: cat: /etc/modprobe.d/alsa-base: Bestand of map bestaat niet. Is er een manier om om in de nieuwe versie 9.04 deze truc uit te halen? Mijn oude topic staat hier: [Opgelost] Geluid werkt niet met HDA ATI SB Sound Card model: SBx00 Azalia.
« Laatst bewerkt op: 2009/06/13, 12:34:08 door janvdwerke »
Jan van der Werke

Offline mrGee

  • Lid
  • Steunpunt: Nee
Hallo

Zo, ken ik u niet ergens van ?  =D

In 9.04 heet die file; /etc/modprobe.d/alsa-base.conf

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline janvdwerke

  • Lid
    • Oldemarktse Computerclub
  • Steunpunt: Nee
Hallo Gerrit,
Inderdaad we raken al vertrouwd met elkaar zo. Je antwoord heb ik meteen toegepast en warempel het werkt weer. Heel erg bedankt voor je uitstekende hulp.

Nog even resumerend voor lotgenoten:
Wanneer het geluid niet werkt, bestaat er de mogelijkheid om dit op de volgende wijze in te schakelen. De regels die ik heb ingevoerd zijn specifiek voor mijn laptop en het is vaak even uitproberen. Je moet steeds een regel per keer toevoegen in de alsabase en dan de computer herstarten om te testen of het werkt.

Open een terminalvenster en geef het volgende commando:
sudo gedit /etc/modprobe.d/alsa-base.conf

De database wordt dan geopend in een editor. Voeg daarna steeds een regel toe uit de lijst die overigens niet volledig is (misschien kan iemand dat nog toevoegen):
options snd-hda-intel model=toshiba
options snd-hda-intel model=basic
options snd-hda-intel model=auto
options snd-hda-intel model=laptop
options snd-hda-intel model=laptop-eapd
options snd-hda-intel model=3stack
options snd-hda-intel model=uniwill-m31
options snd-hda-intel index=0

Ik had in 8.10 twee regels toegevoegd, maar in 9.04 is alleen de bovenste voldoende:

options snd-hda-intel model=toshiba
options snd-hda-intel position_fix=1 model=lenovo

De eerste zorgt voor geluid en de tweede regel regelde in 8.10 het uitzetten van de speakers wanneer ik een koptelefoon inplugde.

Mijn alsabase in 9.04 ziet er nu zo uit:

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
options snd-hda-intel model=toshiba

# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
« Laatst bewerkt op: 2009/06/13, 02:35:42 door janvdwerke »
Jan van der Werke