Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Debian gerelateerd netwerk probleem (sorry, geen Ubuntu!)  (gelezen 1420 keer)

osc4r

  • Gast
Debian gerelateerd netwerk probleem (sorry, geen Ubuntu!)
« Gepost op: 2006/10/17, 20:43:31 »
He allemaal,

Zoals sommigen zullen weten is DreamLinux (ik geloof tenminste Debian gebaseerd?) echt mijn super OS. Totaal gewoon mijn ding! Op 1 klein dingetje na....

Het netwerk zit te klooien! Ik heb door mijn router een IP laten aanwijzen aan deze pc, en ik kan ook gewoon op internet.. Echter, na ELKE reboot ben ik de sjaak en moet ik heel erg onhandig via Netwerk Tools een beetje gaan klooien met het switchen tussen draadloos (doet het geen eens) en de standaard eth0 verbinding waarna hij hem opeens via DHCP wel pakt.. Wat doe ik verkeerd, en wat is er mis met deze prachtige OS? Nogmaals mijn excuses dat het niet over Ubuntu gaat, maar dat retarded forum daar wat 99/100 in het portugees is irriteert me mateloos!

Hoop dat jullie met al jullie Linux en ex-Linux distributie ervaringen mij verder kunnen helpen!

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Debian gerelateerd netwerk probleem (sorry, geen Ubuntu!)
« Reactie #1 Gepost op: 2006/10/17, 20:50:29 »
Probeer in je router eens de leasetijd op heel lang te zetten (een jaar of eeuwig ....)
Mogelijk dat je steeds een ander IP adres krijgt, maar dat dit ergens niet goed gaat.

Laat het weten,
Ron
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

osc4r

  • Gast
Debian gerelateerd netwerk probleem (sorry, geen Ubuntu!)
« Reactie #2 Gepost op: 2006/10/17, 20:56:37 »
Ok, ik weet dan toevallig hoe ik IN mijn router moet komen dmv 10.0.0.138 in te voeren in mijn URL.. maar iets met de leasetijd heb ik nog nooit van gehoord.. Vertel!

budster

  • Gast
Debian gerelateerd netwerk probleem (sorry, geen Ubuntu!)
« Reactie #3 Gepost op: 2006/10/17, 21:03:45 »
leasetijd is de tijd dat een DHCP adres geldig is,

Als je wilt weten wat er aan de hand is dan zou ik eens in je logs (syslog) gaan snuffelen.

osc4r

  • Gast
Debian gerelateerd netwerk probleem (sorry, geen Ubuntu!)
« Reactie #4 Gepost op: 2006/10/17, 21:42:18 »
En waar kan ik deze vinden? Heb trouwens gemerkt dat als ik ndisgtk invoer in de terminal en naar de netwerk instellingen ga, en ik geef daar ons domein naam aan (lan) en ik activeer de eth0 en eth1 verbindingen (beide via ethernet, rare is echter dat ik maar 1 ethernet poort heb) dan wordt dat allen niet opgeslagen!

Offline woteb

  • Lid
  • Steunpunt: Nee
Debian gerelateerd netwerk probleem (sorry, geen Ubuntu!)
« Reactie #5 Gepost op: 2006/10/17, 21:56:18 »
De meeste routers kun je zo instellen dat een computer een reserved ip-adres kan toewijzen.
Dat betekent dat de computer bij elke (re)boot hetzelfde ip-adres krijgt toegewezen. Het enigste wat je dan moet doen is het mac-adres van de netwerkkaart aan dit ip-adres koppelen. Het mac-adres is een uniek gegeven (vergelijkbaar met een kentekenplaat van een auto). Als de dhcp-server dit mac-adres ziet, wijst het automatisch het hieraan gekoppelde ip-adres toe aan de computer.

Zo heb ik zelf ook een router (Sitecom) die dit doet.

DHCP Leased
DHCP Reseved
Fixed

Het eerste is een ip-adres wat aan een bepaalde duur vast zit.
Het tweede is een ip-adres wat aan het mac-adres is gekoppeld.
Het derde is een statisch ip-adres op de computer zeldf ingesteld. Voor de router betekent dit dat dit adres nooit toegewezen hoeft te worden.

In jouw geval zou ik dus eens gaan kijken of jouw router middels een reserved dhcp-ip-adres toegewezen kan worden. Je mac-adres kun je makkelijk achterhalen. Even in een terminal het commando ifconfig gebruiken, dan zie je bij het hw-adres een serie cijfers en letters staan, vergelijkbaar met een kentekenplaat van een auto.

Even een dump van mijn terminal:

vader@enigma:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:D0:59:2B:A0:75
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:7 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:372 (372.0 b)  TX bytes:372 (372.0 b)

ra0       Link encap:Ethernet  HWaddr 00:17:31:45:DF:26
          inet addr:192.168.0.3  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::217:31ff:fe45:df26/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1492  Metric:1
          RX packets:7931 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6117 errors:3 dropped:3 overruns:0 carrier:0
          collisions:1949 txqueuelen:1000
          RX bytes:4146183 (3.9 MiB)  TX bytes:941239 (919.1 KiB)
          Interrupt:11 Base address:0xc000
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

osc4r

  • Gast
Debian gerelateerd netwerk probleem (sorry, geen Ubuntu!)
« Reactie #6 Gepost op: 2006/10/17, 22:01:50 »
Ik snap het volkomen, ik zie echter alleen waar ik dit zou moeten instellen in mijn router opties, en google helpt mij geen steek verder. Nu heb ik echter wel dit geprobeerd, en verbazingwekkend genoeg werkt dit ook nog eens:

sudo nano /etc/network/interfaces

Hier heb ik de code veranderd in een loopback interface wat er als volgt uitziet:

# Loopback
auto lo
iface lo inet loopback


auto eth0
iface eth0 inet dhcp
Dit werkt kennelijk, en nu heb ik bij het opstarten gewoon internet. Sorry dat ik jullie al die lastige verhalen heb laten typen (weet nu wel weer een stuk meer van routers, bedankt eigenlijk!)

Offline woteb

  • Lid
  • Steunpunt: Nee
Debian gerelateerd netwerk probleem (sorry, geen Ubuntu!)
« Reactie #7 Gepost op: 2006/10/17, 22:17:21 »
Kennis van routers is niet verkeerd.
In mijn geval heb ik al mijn werkstations opvolgende ip-nummers gegeven:

Server: 192.168.0.1 (Fixed, statisch adres)
Enigma: 192.168.0.2 (Reserverd, Ethernetkaart, mijn laptop)
Enigma: 192.168.0.3 (Reserverd, Wireless kaart, mijn laptop)
Werkstation-1: 192.168.0.11 (Reserverd)
Werkstation-2: 122.168.0.12 (Reserverd)
Werkstation-3: 192.168.0.13 (Reserverd)
Laptop-1: 192.168.0.21 (Reserverd)
Laptop-2: 192.168.0.22 (Reserverd)
LAN-Disk: 192.168.0.250 (Fixed, statisch adres)
Router: 192.168.0.253 (Fixed, statisch adres)
Accesspoint: 192.168.0.24 (Fixed, statisch adres)

En systemen die ik thuis repareer of installeer krijgen dan een leased dhcp adres, want dat is toch tijdelijk.
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Gast

  • Gast
Debian gerelateerd netwerk probleem (sorry, geen Ubuntu!)
« Reactie #8 Gepost op: 2006/10/20, 13:04:21 »
Ik heb ook zo'n probleem met internet. Mijn netwerkconfiguratie ziet er ongeveer als volgt uit:
ADSL-modem --> router --> switch --> computer.

Grootste probleem is dat hij op dit moment het internet niet ziet als hij is opgestart. De DHCP lijkt niet te werken. Om internet te krijgen moet ik mijn router aanspreken en internet uit- en aanzetten. Het vervelende is dat als mijn computer opstart (via Ubuntu), hij ook direct de totale internetverbinding eruit gooit. Dit probleem heb ik totaal niet in WinXP. Weet iemand waar dat aan kan liggen?

Als ik ifconfig intik in de console, krijg ik dit:
eth0    Link encap:Ethernet  HWaddr 00:0B:6A:22:86:7D
          inet addr:192.168.2.105  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::20b:6aff:fe22:867d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1879 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2002 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:988511 (965.3 KiB)  TX bytes:219754 (214.6 KiB)
          Interrupt:177 Base address:0xdc00

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:7 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:372 (372.0 b)  TX bytes:372 (372.0 b)

Offline woteb

  • Lid
  • Steunpunt: Nee
Debian gerelateerd netwerk probleem (sorry, geen Ubuntu!)
« Reactie #9 Gepost op: 2006/10/20, 13:21:45 »
En hoe heb je WinXP draaien? Ook via DHCP?
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline crashit

  • Lid
    • Tekstbureau Anderverhaal
  • Steunpunt: Nee
Debian gerelateerd netwerk probleem (sorry, geen Ubuntu!)
« Reactie #10 Gepost op: 2006/10/20, 13:51:36 »
Die draait idd ook via DHCP. Al haalt hij daar niet direct de internetsnelheid die ik normaal heb. Maar daar ga ik strax een proggie overheen gooien die dat probleempje fixt.
"If engineers built buildings the way Microsoft builds operating systems the first woodpecker to come along would bring civilization to its knees."

Offline woteb

  • Lid
  • Steunpunt: Nee
Debian gerelateerd netwerk probleem (sorry, geen Ubuntu!)
« Reactie #11 Gepost op: 2006/10/20, 14:48:54 »
Ik zie bij jouw ifconfig dump het volgende:

inet addr:192.168.2.105  Bcast:192.168.2.255  Mask:255.255.255.0

Dat duidt erop dat je wel een dhcp adres krijgt.

Kun je wel pingen naar je router?
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline crashit

  • Lid
    • Tekstbureau Anderverhaal
  • Steunpunt: Nee
Debian gerelateerd netwerk probleem (sorry, geen Ubuntu!)
« Reactie #12 Gepost op: 2007/08/24, 23:48:15 »
Met de komst van Feisty was het probleem opgelost :)
"If engineers built buildings the way Microsoft builds operating systems the first woodpecker to come along would bring civilization to its knees."