Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: 403 error bij cgi-bin/test.pl  (gelezen 3783 keer)

Bloodcrave

  • Gast
403 error bij cgi-bin/test.pl
« Gepost op: 2009/05/16, 15:13:21 »
Hi,

Ik probeer perl scripts uit te voeren op mijn server maar elke keer als ik naar mijnsite.com/cgi-bin/test.pl ga krijg ik een 403 error.
Kortom ik heb geen toestemming om dat bestand uit te voeren.

In mijn 000-default configuratie file heb ik deze code staan voor cgi / perl
ScriptAlias /cgi-bin/ /var/www/cgi-bin/
<Directory "/var/www/cgi-bin">
Options ExecCGI
AddHandler cgi-script cgi pl
</Directory>

De cgi-bin folder is gechmod naar 755 en het bestand test.pl ook naar 755
Beide zijn owned by brian (mijn gebruikers account)

Heb ik iets verkeerds gedaan of ben ik iets vergeten ?
Hopelijk kunnen jullie me verder helpen.

-Brian

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: 403 error bij cgi-bin/test.pl
« Reactie #1 Gepost op: 2009/05/16, 15:45:25 »
Krijg je die foutmelding ook als je de eigenaar verandert in www-data?

Bloodcrave

  • Gast
Re: 403 error bij cgi-bin/test.pl
« Reactie #2 Gepost op: 2009/05/16, 16:08:54 »
Krijg je die foutmelding ook als je de eigenaar verandert in www-data?

Helaas wel.
Heb ook al geprobeerd om de groep www-data en owner brian maar dat werkt ook niet, blijf die 403 houden.

Bloodcrave

  • Gast
Re: 403 error bij cgi-bin/test.pl
« Reactie #3 Gepost op: 2009/05/17, 21:00:13 »
iemand die me verder kan helpen ?

Bloodcrave

  • Gast
Re: 403 error bij cgi-bin/test.pl
« Reactie #4 Gepost op: 2009/05/19, 13:00:56 »
Ik heb de eigenaar op brian gezet en de groep www-data vervolgens de map cgi-bin chmodded naar 755 en het bestand test.pl ook en nog werkt het niet  ???

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Re: 403 error bij cgi-bin/test.pl
« Reactie #5 Gepost op: 2009/06/16, 16:03:53 »
Volgens mij moet het trouwens zijn: +ExecCGI

En verder zou ik zeker even kijken in de apache log file (hoe die heet staat ook in dezelfde conf als de ExecCGI), want vaak krijg je daar de EXACTE meldingen te zien.
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl