Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: (opgelost) Krijg Grub niet te zien tijdens opstarten op multiboot systeem  (gelezen 1123 keer)

Offline Draadtrekker

  • Lid
  • Steunpunt: Nee
Hello,

Ik heb Windows 7 geinstalleerd op mijn systeem,  daarna ubuntu 9 en nu krijg ik Grub niet meer te zien bij het opstarten.
situatie: schijf 1 met daarop Windows Vista en Ubuntu, schijf 2 met Windows 7
ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x181d660b

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        9730    78148608    7  HPFS/NTFS

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xc9bcc9bc

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1        8211    65954826    7  HPFS/NTFS
/dev/sdb2            8212       11907    29688120   83  Linux
/dev/sdb3           11908       16708    38564032+   f  W95 Ext'd (LBA)
/dev/sdb4           16709       19457    22081342+   7  HPFS/NTFS
/dev/sdb5           11908       16360    35768659+  83  Linux
/dev/sdb6           16361       16708     2795278+  82  Linux swap / Solaris
ubuntu@ubuntu:~$


Hoe krijg ik Grub terug bij het opstarten met daarin de keuze tussen de 3 besturingssystemen?

thx

« Laatst bewerkt op: 2009/05/11, 16:24:56 door Draadtrekker »

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Krijg Grub niet te zien tijdens opstarten op multiboot systeem
« Reactie #1 Gepost op: 2009/05/11, 15:25:37 »
Ubuntu start wel gewoon op? Even op escape rammen.

Offline Draadtrekker

  • Lid
  • Steunpunt: Nee
Re: Krijg Grub niet te zien tijdens opstarten op multiboot systeem
« Reactie #2 Gepost op: 2009/05/11, 15:30:49 »
Hello,

ubuntu start helemaal niet op,  ik ben nu met de live cd aan het werk.
ik krijg het opstartmenu van windows te zien (keuze tussen vista en 7)

mvg

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Krijg Grub niet te zien tijdens opstarten op multiboot systeem
« Reactie #3 Gepost op: 2009/05/11, 15:31:18 »
Even grub herstellen dan maar?

Offline Draadtrekker

  • Lid
  • Steunpunt: Nee
Re: Krijg Grub niet te zien tijdens opstarten op multiboot systeem
« Reactie #4 Gepost op: 2009/05/11, 15:35:02 »
Ja,  maar ik weet niet precies hoe (heb wel het artikel gelezen over grub herstellen)
maar ik zou hulp kunnen gebruiken met de schijfverwijzingen

Mvg

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Krijg Grub niet te zien tijdens opstarten op multiboot systeem
« Reactie #5 Gepost op: 2009/05/11, 15:40:11 »
Reparatie van grub: Start de Ubuntu live cd op. Open een terminal en type in sudo grub Nu krijg je de commando lijn van grub, grub> type nu find /boot/grub/stage1
Nu krijg je een of meerdere mogelijkheden te zien, bijv (hd0,3) type nu in
root (hdx,x) voor x het getal invullen wat jij hebt gevonden, let op er staat een spatie tussen root en (hdx,x) Nu type je in setup (hd0) let op de spatie.
Type nu in quit Sluit af en start opnieuw op.
Kan je nu wel gewoon opstarten?

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Draadtrekker

  • Lid
  • Steunpunt: Nee
Re: Krijg Grub niet te zien tijdens opstarten op multiboot systeem
« Reactie #6 Gepost op: 2009/05/11, 15:50:59 »
Gijsbert,

ik kreeg als uitkomst hd 1/1 en heb het in die zin aangepast maar Windows boot manager geeft het nog niet op, ik krijg Grub nog steeds niet te zien.

mvg

Offline Mark81

  • Lid
  • Steunpunt: Nee
Re: Krijg Grub niet te zien tijdens opstarten op multiboot systeem
« Reactie #7 Gepost op: 2009/05/11, 15:52:37 »
Waarschijnlijk is wat Gijsbert aanraad idd voldoende om de grub te herstellen. Wat betreft je vraag naar hulp bij schijfverwijzingen:

de eerste harddisk van een computer wordt (hd0) genoemd. De eerste partitie op die schijf geef je aan dmv (hd0,0). De tweede partitie als (hd0,1) etc. De tweede harddisk (hd1) en de eerste partitie van die schijf is dus hd(1,0) etc. Dit is de basis.
Jouw Grub zul je dus terugvinden op (hd1,1), namelijk de 2e partitie van de 2e harddisk (sdb). Dmv de commando's die Gijsbert heeft laten zien, zul je de MBR van je computer laten weten dat Grub zich bevind op de tweede schijf op de tweede partitie.

Is dit wat duidelijker? Of maak ik het onnodig gecompliceerd   :-[
Hoe dan ook, succes!

Offline Mark81

  • Lid
  • Steunpunt: Nee
Re: Krijg Grub niet te zien tijdens opstarten op multiboot systeem
« Reactie #8 Gepost op: 2009/05/11, 15:55:13 »
Oeps, te laat... sorry.

Ik heb er niet superveel verstand van, maar kun je via de live CD wel browsen naar je Ubuntu partitie? Zo ja, kijk eens in /boot. Staat daar een folder grub? En zo ja, staan er een aantal bestanden waaronder stage1? Als deze namelijk allemaal ontbreken is er uberhaupt geen goede install van Grub geweest en moet je denk ik opnieuw installeren...

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Krijg Grub niet te zien tijdens opstarten op multiboot systeem
« Reactie #9 Gepost op: 2009/05/11, 16:01:51 »
Gijsbert,

ik kreeg als uitkomst hd 1/1 en heb het in die zin aangepast maar Windows boot manager geeft het nog niet op, ik krijg Grub nog steeds niet te zien.

mvg
Ik denk dat net zoals bij mij Grub door 9.04 in de MBR van  je andere HD geschreven is.
Dit kan je zo controlleren, bij het opstarten van de PC op DEL of F2 drukken, komt meestal in het begin scherm te staan welke toets je moet indrukken voor de setup. Verander nu de boot volgorde zodat je andere schijf als eerste boot. Lukt het nu wel?
In der Beschränkung zeigt sich der Meister.

Offline Draadtrekker

  • Lid
  • Steunpunt: Nee
Re: Krijg Grub niet te zien tijdens opstarten op multiboot systeem
« Reactie #10 Gepost op: 2009/05/11, 16:23:01 »
Gijsbert,

idd switchen van schijf in het bios is idd de oplossing


thx