Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Driver geluidskaart  (gelezen 3762 keer)

Offline JacobK

  • Lid
  • Steunpunt: Nee
Driver geluidskaart
« Gepost op: 2009/05/04, 14:10:07 »
Ik probeer via deze handleiding m'n geluidskaart die sinds de upgrade naar 9.04 niet meer werkt weer aan de praat te krijgen, maar op een gegeven moment loop ik vast.

De laatste stappen bij het kopje "Is ALSA using the correct model?" snap ik niet helemaal. Je moet de ALSA-base oproepen in de terminal, dat lukt. Maar vervolgens moet je weer nieuwe commandos intypen, maar waar dan? Ik snap er niks meer van.

(Mocht het nog relevant zijn, hier staat alle info over m'n geluidskaart: http://www.alsa-project.org/db/?f=0c8c3817663021ab30d673598dc9a399647723b7 )

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Driver geluidskaart
« Reactie #1 Gepost op: 2009/05/05, 00:18:45 »
Zover ik het kan zien moet je allerlei gegevens opzoeken in een database en vergelijken met de gegevens die jij hebt gevonden. Pas bij dit This is the steps that were necessary to get a Dell Dimension E520 with Intel HDA and SigmaTel STAC9227 Codec to work after upgrading to Ubuntu 9.04: sudo nano /etc/modprobe.d/alsa-base.conf moet je weer in de terminal invoeren.
Heb je dit al geprobeerd: http://ubuntuforums.org/showthread.php?t=205449
In der Beschränkung zeigt sich der Meister.

Offline JacobK

  • Lid
  • Steunpunt: Nee
Re: Driver geluidskaart
« Reactie #2 Gepost op: 2009/05/05, 10:05:11 »
Ja dat weet ik, maar bij die stap was ik ook al. Ik wil dus eerst even proberen deze methode af te maken, ik heb deze bijna klaar, maar dan loop ik dus bij die stap vast.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Driver geluidskaart
« Reactie #3 Gepost op: 2009/05/05, 11:59:22 »
Oke, je voert dit in de terminal  sudo nano /etc/modprobe.d/alsa-base.conf  of je kan ook opstarten met gedit sudo gedit /etc/modprobe.d/alsa-base.conf nu opent een venster van gedit met je alsa-base.conf tekst. Nu zet je de regel erin options snd-hda-intel model=5stack( Natuurlijk vervangen door de gegevens die je gevonden hebt in Configuration.txt voor jouw kaart op de website, bijv model=6stack). Sla het bestand op en type in de terminal sudo alsa force-reload Dan ben je klaar, wat er onder staat is als je toch nog problemen tegen komt.
In der Beschränkung zeigt sich der Meister.

Offline JacobK

  • Lid
  • Steunpunt: Nee
Re: Driver geluidskaart
« Reactie #4 Gepost op: 2009/05/05, 13:08:32 »
In de configuration staat bij mij bij model dit:

model : <NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>
Wat betekent dat?

En waar moet je die tekst in de configuration plaatsen? Of maakt dat niet uit?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Driver geluidskaart
« Reactie #5 Gepost op: 2009/05/05, 13:29:21 »
De eerste regel zegt mij zo niets, ik denk dat er normaal het model van je kaart komt te staan als de driver geïnstalleerd is, bij mij staat deze regel er niet in. Je kan er voorlopig een # voorzetten, hierdoor wordt de regel niet uitgevoerd in de configuratie. Na het opnieuw opstarten kan je altijd nog deze # weghalen. Dan daarna wel eerst het laatste commando uitvoeren sudo alsa force-reload
Dit is mijn alsa-base:
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
#   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
#   non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
Zoals je ziet staan de options onderaan. Daar kan je jou regel onderaan toevoegen.
In der Beschränkung zeigt sich der Meister.

Offline JacobK

  • Lid
  • Steunpunt: Nee
Re: Driver geluidskaart
« Reactie #6 Gepost op: 2009/05/05, 13:37:03 »
Okee, dan deed ik het net goed, maar toch gaat er iets fout:
jacob@jacob-laptop:~$ sudo alsa force-reload
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/jacob/.gvfs
      Output information may be incomplete.
Terminating processes: 3033 3224lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/jacob/.gvfs
      Output information may be incomplete.
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/jacob/.gvfs
      Output information may be incomplete.
.
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/jacob/.gvfs
      Output information may be incomplete.
Unloading ALSA sound driver modules: snd-hda-intel snd-pcm-oss snd-mixer-oss snd-pcm snd-seq-dummy snd-seq-oss snd-seq-midi snd-rawmidi snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc.
Loading ALSA sound driver modules: snd-hda-intel snd-pcm-oss snd-mixer-oss snd-pcm snd-seq-dummy snd-seq-oss snd-seq-midi snd-rawmidi snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-allocWARNING: All config files need .conf: /etc/modprobe.d/alsa-base.conf.save, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/alsa-base.conf.save, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/alsa-base.conf.save, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/alsa-base.conf.save, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/alsa-base.conf.save, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/alsa-base.conf.save, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/alsa-base.conf.save, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/alsa-base.conf.save, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/alsa-base.conf.save, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/alsa-base.conf.save, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/alsa-base.conf.save, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/alsa-base.conf.save, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/alsa-base.conf.save, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/alsa-base.conf.save, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/alsa-base.conf.save, it will be ignored in a future release.

Offline JacobK

  • Lid
  • Steunpunt: Nee
Re: Driver geluidskaart
« Reactie #7 Gepost op: 2009/05/05, 13:50:16 »
Hmm, redelijk bizar: ik heb bij system-preferences-sound alles van autodetect naar HDA sis966 ALC268 Analog (OSS) gezet, en als ik daar test doe dan hoor ik weer wat. Maar als ik dan een youtubefilmpje oid open, dan hoor ik weer niks. Wat is hier aan de hand?

EDIT: als ik geluid open op de computer dan doetie het ook gewoon, maar als ik iets op internet open dus niet.
« Laatst bewerkt op: 2009/05/05, 13:52:24 door JacobK »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Driver geluidskaart
« Reactie #8 Gepost op: 2009/05/05, 14:17:33 »
Die waarschuwingen zijn er alleen voor, dat bij een nieuwere versie van alsa de veranderingen genegeerd worden. Je hebt het script gedraaid met en zonder #? Bij mij heet het script alleen alsa-base, dus geen conf erachter. Ik heb de zelfde chipset er op zitten als jij, de
HDA SIS 966, jij hebt alleen de toevoeging ALC268 en ik ALC861VD
OSS is de voorloper van ALSA die weer de voorloper is van PulseAudio. Staan alle regelaars open?Vooral de PCM Zo ziet het bij mij eruit
[img=http://img16.imageshack.us/img16/6633/schermafdrukvolumeregel.th.png]
Rechts onder kan je op Voorkeuren klikken en andere kanalen verwijderen of toevoegen.
In der Beschränkung zeigt sich der Meister.

Offline JacobK

  • Lid
  • Steunpunt: Nee
Re: Driver geluidskaart
« Reactie #9 Gepost op: 2009/05/05, 14:21:04 »
Jep, staan allemaal open. Bij OSS zijn het er maar 3, maar toch.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Driver geluidskaart
« Reactie #10 Gepost op: 2009/05/05, 14:32:58 »
Kan je, je huidige alsa-base.conf hier plaatsen?
In der Beschränkung zeigt sich der Meister.

Offline JacobK

  • Lid
  • Steunpunt: Nee
Re: Driver geluidskaart
« Reactie #11 Gepost op: 2009/05/05, 14:44:13 »
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Driver geluidskaart
« Reactie #12 Gepost op: 2009/05/05, 15:49:40 »
Volg dit eens als eerste http://sites.google.com/site/computertip/geengeluid
Mocht dit niet werken bij jou, kopieer dan mijn alsa-base en sla deze op als een gewoon plat tekst document, dus alsa-base, wel je alsa.base.conf veranderen in bijv. lsa.base.conf. Hierna een herstart van de computer.
In der Beschränkung zeigt sich der Meister.

Offline JacobK

  • Lid
  • Steunpunt: Nee
Re: Driver geluidskaart
« Reactie #13 Gepost op: 2009/05/05, 16:21:02 »
En waar opslaan dan? In modeprobe.d kan niet, want die is beveiligd.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Driver geluidskaart
« Reactie #14 Gepost op: 2009/05/05, 17:05:56 »
In modprobe.d,maar wel als root, open nautilus in de root mode door in de terminal te typen gksudo nautilus.
Nu mag je alles veranderen zo in de root mode. Navigeer nu naar de map /etc/modprobe.d
Klik met de rechtermuis in het witte vlak>Kies in het menu Document aanmaken, plak de gekopieerde tekst in het lege document, sla het document op als alsa-base.Vergeet niet het ander document te hernoemen, alsa-base.conf dus.
In der Beschränkung zeigt sich der Meister.

Offline JacobK

  • Lid
  • Steunpunt: Nee
Re: Driver geluidskaart
« Reactie #15 Gepost op: 2009/05/06, 14:24:08 »
Zelfs dit mag niet baten. Ik begin inmiddels echt wanhopig te worden  ???

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Driver geluidskaart
« Reactie #16 Gepost op: 2009/05/06, 16:12:17 »
Niet wanhopig worden de oplossing komt er echt wel.
Ik zag dat je een BT chip op de kaart hebt. Open nautilus in de root mode, gksudo nautilus in de terminal. Navigeer nu naar de map /etc scroll naar beneden tot het bestand modules. Dubbel klik hier op nu opend gedit dit bestand. Zet je cursor achter het laatste woord en geef een ENTER, nu staat je cursor aan het begin van de nieuwe regel. Type nu de volgende zinnen, elk op een aparte regel zoals hier onder staat:
-r bt878 bttv
snd_bt87x
bt878

Sla het op en sluit gedit en start de computer opnieuw op.
Heb je nu wel geluid?
In der Beschränkung zeigt sich der Meister.

Offline JacobK

  • Lid
  • Steunpunt: Nee
Re: Driver geluidskaart
« Reactie #17 Gepost op: 2009/05/06, 17:10:14 »
Helaas, het mocht niet baten.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Driver geluidskaart
« Reactie #18 Gepost op: 2009/05/06, 21:43:11 »
Dan maar bij het begin beginnen, volg de stappen uit deze link https://help.ubuntu.com/community/SoundTroubleshooting?action=show&redirect=DebuggingSoundProblems
Mocht je een stap tegen komen die niet werkt of waar je van denkt hoe moet dat precies, post dat dan.
In der Beschränkung zeigt sich der Meister.

Offline JacobK

  • Lid
  • Steunpunt: Nee
Re: Driver geluidskaart
« Reactie #19 Gepost op: 2009/05/13, 17:50:52 »
Erg late reactie, maar was de laatste tijd te druk om met ubuntu te lopen klooien. Die stappen heb ik al eerder genomen, zonder resultaat.

Nog even voor de duidelijkheid: mijn geluidskaart werkt dus inmiddels wel, alleen op internet doetie het niet.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Driver geluidskaart
« Reactie #20 Gepost op: 2009/05/13, 18:37:15 »
Heb je al onder voorkeuren>Tabblad toepassingen gekeken of er een afspeel apparaat staat voor de diverse geluidsbestanden? Misschien moet je nog wel een plugin installeren. Zie foto.
Kan je een schermafdruk van je audiomixer hier plaatsen?
En hoe heb je weer geluid gekregen?

[verwijderd door de beheerder]
« Laatst bewerkt op: 2009/05/13, 18:46:09 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline JacobK

  • Lid
  • Steunpunt: Nee
Re: Driver geluidskaart
« Reactie #21 Gepost op: 2009/05/13, 19:13:05 »
Jep, heb de VLC plugin gewoon aanstaan daar.

Hoe ik em aan de praat kreeg staat hier:

Hmm, redelijk bizar: ik heb bij system-preferences-sound alles van autodetect naar HDA sis966 ALC268 Analog (OSS) gezet, en als ik daar test doe dan hoor ik weer wat. Maar als ik dan een youtubefilmpje oid open, dan hoor ik weer niks. Wat is hier aan de hand?

EDIT: als ik geluid open op de computer dan doetie het ook gewoon, maar als ik iets op internet open dus niet.

En zie de bijlage voor soundmixer.

[verwijderd door de beheerder]

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Driver geluidskaart
« Reactie #22 Gepost op: 2009/05/13, 21:20:51 »
Tjee, wat weinig schuifjes.  ;) Ik zie wel een PCM-2, waar is PCM-1?
Als je op de knop "Preferences" drukt kan je dan niet meer schuifjes aanvinken?
Ik zie ook dat je de OSS gebruikt, kan je niet kiezen voor ALSA of PULSE? Niet dat het moet, ik vroeg het me even af.
In der Beschränkung zeigt sich der Meister.

Offline JacobK

  • Lid
  • Steunpunt: Nee
Re: Driver geluidskaart
« Reactie #23 Gepost op: 2009/05/13, 21:32:14 »
Nope, alle schuifjes staan aangevinkt. En dit was ook de enige waar ik geluid onder hoorde, dus ik vond OSS wel prima.

Raar nu: bij sound preferences staat nu achter HDA sis etc. dit "(not connected)"

En ik hoor ook helemaal geen geluid meer, ook niet van iets anders dan internet. Voor zo ver ik weet heb ik niks bijzonders gedaan.

Voor de zekerheid ga ik maar even rebooten.

Offline JacobK

  • Lid
  • Steunpunt: Nee
Re: Driver geluidskaart
« Reactie #24 Gepost op: 2009/05/13, 21:48:23 »
Dat laatste probleem is opgelost. Waarschijnlijk lag het aan een update van eerder vanavond, die vast liep, en die ik forceerde af te sluiten. Daarna waren er een paar rare dingen: dat geluid bijvoorbeeld, en als ik afsloot waren suspend en hibernate verdwenen, raar allemaal. Na de reboot was ook de hele layout verneukt. Toen heb ik de update nog een keer gedaan, en gereboot, en hij doet het nu weer als nooit te voren.

Blijft alleen het zelfde probleem: geen geluid op internet.