Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost][Jaunty / 9.04] Foutmelding bij installatie MySQL Server 5.0  (gelezen 945 keer)

Offline Djeba

  • Lid
  • Steunpunt: Nee
Ik kan in 9.04 wel MySQL 5.1 gebruiken. Maar programma's als Drupal of phpMyAdmin verwachten nog versie 5.0. Wanneer ik dus MySQL Server 5.0 installeer om met die programma's te kunnen werken krijg ik steeds de foutmelding: 

E: /var/cache/apt/archives/mysql-server-5.0_5.1.30really5.0.75-0ubuntu10_i386.deb: subprocess pre-installation script returned error exit status 1

Iemand enig idee wat ik nu kan doen? Want 5.0 is dus nodig.
« Laatst bewerkt op: 2009/05/06, 12:22:52 door Djeba »
De waarheid is altijd het sterkste argument.

Offline xpired

  • Lid
  • Steunpunt: Nee
Re: [Jaunty / 9.04] Foutmelding bij installatie MySQL Server 5.0
« Reactie #1 Gepost op: 2009/05/03, 16:19:06 »
Heb je de mysql-server die je NIET wilt gebruiken er af gehaald?
Zo ja, zal ik daar als eerste mee beginnen. Eventueel met de --purge opties.

apt-get autoremove
apt-get --purge remove mysql-server
apt-get update
apt-get install mysql-server-5.0

Misschien dat de 5.1 installatie nog in de weg zit.

Overigens heb ik phpMyAdmin en Drupal prima werken op MySQL Server 5.1 op diverse servers.



Offline Djeba

  • Lid
  • Steunpunt: Nee
Re: [Jaunty / 9.04] Foutmelding bij installatie MySQL Server 5.0
« Reactie #2 Gepost op: 2009/05/03, 16:54:15 »
Heb je de mysql-server die je NIET wilt gebruiken er af gehaald?
Zo ja, zal ik daar als eerste mee beginnen. Eventueel met de --purge opties.

apt-get autoremove
apt-get --purge remove mysql-server
apt-get update
apt-get install mysql-server-5.0

Misschien dat de 5.1 installatie nog in de weg zit.

Overigens heb ik phpMyAdmin en Drupal prima werken op MySQL Server 5.1 op diverse servers.


Via Synaptic deed ik wel een volledige deïnstallatie. Maar dat zegt natuurlijk ook niet alles. Ik zal deze commando's eens intypen :-)

Ik heb Joomla ook goed draaien onder MySQL 5.1. Maar dat CMS wordt niet via de repositories geïnstalleerd. Drupal en phpMyAdmin via de repo's (via Synaptic dus in mijn geval) heeft gewoon die 'dependencies' en via die weg kom je er niet omheen om MySQL 5.1 er af te halen. Ik kan natuurlijk buiten de repo's om werken, zoals jij dan denk ik ook gedaan hebt om het werkend te krijgen. Toch?
De waarheid is altijd het sterkste argument.

Offline xpired

  • Lid
  • Steunpunt: Nee
Re: [Jaunty / 9.04] Foutmelding bij installatie MySQL Server 5.0
« Reactie #3 Gepost op: 2009/05/03, 17:17:18 »
Ja.... sites zoals drupal installeer ik eigenlijk nooit via de Ubuntu repositories.
Vooral omdat in zelf in de hand wil houden wanneer en hoe snel ik updated.
Meestal update ik overigens een drupal website eerder dan dat hij in een repo is.

Offline Djeba

  • Lid
  • Steunpunt: Nee
Re: [Jaunty / 9.04] Foutmelding bij installatie MySQL Server 5.0
« Reactie #4 Gepost op: 2009/05/06, 12:22:10 »
Ik heb vanochtend een compleet schone installatie gedaan van 9.04. En deze keer heel goed opgelet bij alles wat MySQL betreft:
--Apache2 wil en installeert: mysql-common
--phpMyAdmin wil en installeert: mysql-client5.0
Dan is er nog steeds geen mysql-server geïnstalleerd. Deze keer was er geen enkel probleem om mysql-server5.0 te installeren.

Waarschijnlijk had ik al een keer meer gewisseld van 5.1 naar versie 5.0 en was er ergens een lock-bestandje blijven staan of wat ook. De commando's van Sebastan zouden het wel opgelost hebben, denk ik dus.
De waarheid is altijd het sterkste argument.